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Understanding the Concepts

In this tutorial, you learn the fundamental concepts of Autodesk® Revit® Structure 4. You learn how

Revit Structure works, the terms used when working with the product, and how to navigate the user

interface.

In the lesson that follows, you learn many of the important features in Revit Structure that contribute

to a user-friendly design environment, enhanced productivity, and faster construction documents. You

begin with the fundamental concepts that Revit Structure is built upon. You learn the terminology, the

hierarchy of elements, and how to navigate the user interface.

1

1



Understanding the Basics
In this lesson, you learn what Revit Structure is and how its parametric change engine benefits you and your work.

What is Autodesk Revit Structure?

The Revit Structure platform for building information modeling is a design and documentation system that supports
the design, drawings, and schedules required for a building project. Building information modeling (BIM) delivers
information about project design, scope, quantities, and phases when you need it.

In the Revit Structure model, every drawing sheet, 2D and 3D view, and schedule is a presentation of information from
the same underlying building model database. As you work in drawing and schedule views, Revit Structure collects
information about the building project and coordinates this information across all other representations of the project.
The Revit Structure parametric change engine automatically coordinates changes made anywhere—in model views,
drawing sheets, schedules, sections, and plans.

What is meant by parametric?

The term parametric refers to the relationships among all elements of the model that enable the coordination and
change management that Revit Structure provides. These relationships are created either automatically by the software
or by you as you work. In mathematics and mechanical CAD, the numbers or characteristics that define these kinds of
relationships are called parameters; hence, the operation of the software is parametric. This concept is important because
it is this capability that delivers the fundamental coordination and productivity benefits of Revit Structure: change
anything at any time anywhere in the project, and Revit Structure coordinates that change through the entire project.

The following are examples of these element relationships:

■ Pilasters are spaced equally across a given elevation. If the length of the elevation is changed, the relationship of
equal spacing is maintained. In this case, the parameter is not a number but a proportional characteristic.

■ The edge of a roof is related to the exterior wall such that when the exterior wall is moved, the roof remains
connected. In this case, the parameter is one of association or connection.

How does Revit Structure keep things updated?

A fundamental characteristic of a building information modeling application is the ability to coordinate changes and
maintain consistency at all times. You do not have to intervene to update drawings or links. When you change
something, Revit Structure immediately determines what is affected by the change and reflects that change to any
affected elements.

Revit Structure uses 2 key concepts that make it especially powerful and easy to use. The first is the capturing of
relationships while the designer works. The second is its approach to propagating structural changes. The result of these
concepts is software that works like you do, without requiring entry of data that is unimportant to your design.

Element behavior in a parametric modeler

Revit Structure uses 5 software element classes: host, component, annotation, view, and datum elements. This
implementation provides flexibility for designers. Revit Structure elements are designed to be created and modified by
you directly; programming is not required. If you can draw, you can define new parametric elements in Revit Structure.

Hosts include slabs, walls, and roofs. Components include beams, columns, and braces. Annotations are 2D, view-specific
elements that help you produce your documentation. Views are dynamic representations of the model and are always
up-to-date. Datum elements are non-physical items used to establish project context.

In Revit Structure, behavior of elements is largely governed by their context in the structure. The context is determined
by how you draw the component and the constraint relationships that are established with other components. Often,
you do nothing to establish these relationships; they are implied by what you do and how you draw. In other cases,
you can explicitly control them, by locking a dimension or aligning two walls, for example.

Understanding Revit Structure terms

Most of the terms used to identify objects in Revit Structure are common, industry-standard terms familiar to most
engineers. However, there are some terms that are unique to Revit Structure, and understanding them is crucial to
understanding the software. This section defines the basic terms used in Revit Structure.
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In Revit Structure, the term “project” refers to the single database of information for your design—the building
information model. The project file contains all the information for your structural design, from geometry to construction
data. This information includes components used to design the model, views of the project, and drawings of the design.
By using a single project file, Revit Structure makes it easy for you to alter your design and have changes reflected in
all associated areas (plan views, elevation views, section views, schedules, and so forth). Having only one file to track
also makes it easier to manage the project.

Another important term to understand is “level”. Levels are infinite horizontal planes that act as a reference for
level-hosted elements, such as roofs, slabs, beams, footings, etc. Most often, you use levels to define a vertical height
or story within a building. You create a level for each known story or other needed reference of the building; for example,
first floor, top of wall, or bottom of foundation. To place levels, you must be in a section or elevation view.

South Elevation View of Structure

When creating your project, you add Revit Structure parametric building elements to the design. All elements are
considered categories. Revit Structure classifies elements by model component elements and annotation elements. A
model component element, such as a beam, brace, or roof, represents the actual 3D geometry of the building. An
annotation structural element, such as a text note, loaded tag, or symbol, helps document the model.

Families are classes of elements in a category that group elements with a common set of parameters (properties), identical
use, and similar graphical representation. Different elements in a family may have different values for some or all
properties, but the set of properties—their names and meaning—is the same. For example, a truss could be considered
one family, although the web supports that compose the family come in different sizes and materials.

Most families are component family files, which means you can load them into your project and create them from
family templates. You can determine the set of properties and the graphical representation of the family. Other families
are called system families. These families, which include slabs, dimensions, roofs, levels, etc., are not available for
loading or creating as separate files.

Revit Structure predefines the set of properties and the graphical representation of system families. You can use the
predefined types to generate new types that belong to this family within the project. Each family can have different
types. A type can be a specific size of a family, such as a 30 X 42 title block.

A type can also be a style, such as default aligned or default angular style for dimensions. A family can have several
types. For example, a column could come in several different sizes. Each different size would be a new type within the
same family. Instances are the actual items that are placed in the project and have specific locations in the building
(model instances) or on a drawing sheet (annotation instances).
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Revit Structure terms

Navigating the Revit Structure User Interface

One of the advantages of Revit Structure is its ease of use, specifically its clear user interface. The Revit Structure window
is arranged to make navigation easy. Even the toolbar buttons are labeled, making it easy to understand what each
button represents. Revit Structure uses standard Microsoft® Windows® conventions. If you have used any other product
that follows these conventions, you will soon feel comfortable learning this interface.

In the steps that follow, you navigate and become familiar with the Revit Structure user interface.

Start a new project

1 On the Standard toolbar, click  .

This creates a new project based on the default template.

The Title Bar

2 Place your cursor at the top of the user interface and notice the Title Bar contains the name of the project
and the view that is currently open.

By default, new projects are numbered consecutively until saved with a new name. In addition, the Level
2 structural plan view is the default open view.

TIP The project template determines which view is opened and the view names as well.

The Menu Bar

3 Click View menu  ➤ Zoom.
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The Menu Bar across the top of the window includes standard menu names such as File, Edit, and View.
You can choose commands by placing the cursor over the menu name and clicking. You then click the
command name to run the command. Many of the commands also have shortcut keys to speed up the
design process. These shortcut keys are listed next to the command on the menu.

TIP For example, the shortcut key for Zoom To Fit is ZF.

While working in the drawing area, you simply type the required keystrokes to run the command. Another
timesaving tool for selecting commands is to place the cursor in the drawing area and right-click. The
context menu changes depending on the function you are performing and what is currently selected.

The Toolbar

4 On the Window menu, click Toolbar.

There are 6 toolbars across the top of the window just beneath the Menu Bar. The buttons on the toolbar
represent some of the more common commands. You can control the visibility of the toolbars and turn
the toolbar text labels on or off within the Window ➤ Toolbar menu. You can use the toolbar grips to
resize and move each toolbar.

The Options Bar

5 On the Basics tab of the Design Bar, click Structural Wall.

Notice the bar beneath the toolbars contains design options used to draw the structural wall.
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The Options Bar is context-sensitive and varies depending on the tool or selected component.

6 On the Design Bar, click Beam.

Notice the design options available on the Options Bar are now applicable to beams. On the left side of
the Options Bar, notice a beam type is specified.

The Type Selector

7 The drop-down list on the left side of the Options Bar is called the Type Selector. Select the drop-down list
to view the list of beams.

The Type Selector is a context-sensitive drop-down list. If you select the Beam tool, the Type Selector
displays a list of beams available within the project. The list of components in the Type Selector is identical
to the components listed in the Families branch of the Project Browser under the respective category.

8 On the Basics tab of the Design Bar, click Structural Column.

9 In the Type Selector, notice the list of columns that are available.

You use the Type Selector in 2 ways. First, you can select a component type before you add it to the building
model. For example, if you intend to add a beam, the beam type active in the Type Selector is the beam
type that is added when you insert it into the building model. You can also use the Type Selector to change
a component type after it has been added to the building model. Within the drawing area, you can select
any component and then change the type using the Type Selector.

The Design Bar

10 On the Window menu, click Design Bars.

The Show Design Bars dialog box is displayed.
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The Design Bar is located on the left side of the interface, immediately below the Type Selector. There are
9 tabs in the Design Bar, containing buttons grouped by function. You can control which tabs display by
selecting them in the Show Design Bars dialog box.

11 Click OK.

Each tab contains frequently used commands that are also available from the Menu Bar.

■ Basics tab—includes commands for creating most basic structural model components

■ View tab—commands for creating different views in the project

■ Architectural tab—commands for adding architectural components to your project

■ Drafting tab—commands for both adding annotation symbols and creating the sheet details for the
project construction documents

■ Rendering tab—commands for creating rendered 3D images

■ Site tab—commands for adding site components and producing site plans

■ Massing tab—commands for executing conceptual massing commands

■ Modelling tab—all the commands to create structural model elements

■ Construction tab—includes commands for creating construction industry information

To access the commands within a tab, click the tab, and the respective commands are displayed on the
Design Bar.

TIP You can turn the visibility of each tab on and off by right-clicking on the Design Bar and selecting the tab
from the context menu.
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The Project Browser

12 To the right of the Design Bar is the Project Browser. In the Project Browser, select Views (all).

You can use the Project Browser to quickly manage the views, schedules, sheets, reports, families, and
groups of your current project. You can right-click in the browser to add, delete, and rename views, families,
and groups. The browser is conveniently organized by view type (structural plans, elevations, 3D), family
category (beams, columns, walls), and group name. You can expand or compress the browser list by clicking
the + or - sign next to the name. To open a view, double-click the name. You can also drag and drop from
the browser into the drawing area, making it easy to add a family or group to the project or add a view to
a sheet. The browser is also dockable, so you can position it wherever you want by dragging the Project
Browser title bar to a new location.

13 In the Type Selector, scroll through the sorting available for the Project Browser.

14 On the Settings menu, click Browser Organization.
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You can create and modify Project Browser organization schemes for both views and sheets. After you
create a browser organization scheme, you can instantly change the sorting within the Project Browser by
selecting the scheme in the Type Selector.

15 In the Browser Organization dialog box, click Cancel.

The Status Bar

16 On the Basics tab of the Design Bar, click Structural Wall.

The cursor is displayed as a pencil.

17 Place the cursor near the center of the drawing area. Do not click.

In the bottom left corner of the window, notice the Status Bar provides information regarding what you
should do next. In this case, it tells you to "Click to enter wall start point."

TIP The cursor tooltip that displays is identical to the note on the Status Bar.

18 On the Design Bar, click Modify.

You can turn the Status Bar visibility on or off from the Window menu. The Status Bar also provides
information, in conjunction with tooltips, regarding selected components within a view. When you place
the cursor over a component, it highlights and the status bar displays the component name.
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TIP When attempting to select a specific component in a crowded or detailed view, use the Tab key to alternate
between nearby components.

19 Place the cursor over the elevation symbol at the bottom of the drawing area.

The elevation symbol consists of two parts, the main symbol and the elevation directional arrows. Make
sure you place the cursor over the arrow portion of the symbol so that it is highlighted.

In the Status Bar, notice that the name of the preselected component is Views: Elevation: Building Elevation.

20 Press TAB, and notice that the preselected component switches to the main elevation symbol.

Revit Structure Help

21 Click Help menu  ➤ Autodesk Revit Help.

Help is available online at all times during a Revit Structure session. You can use this tri-pane, HTML help
window to search for information and quickly display it to read or print. There are several tools that help
you find information. You can select a topic on the Contents tab, find a keyword on the Index tab, search
for all instances of a word or phrase on the Search tab, or save commonly used pages on the Favorites tab.
Context-sensitive help is also available to provide instant help on any menu command.

You can access Help in the following ways:

■ Dialogs: Dialog include Help buttons. Click the Help button, and the topic specific to the dialog opens.
If there is no Help button displayed, press F1 to get help on that dialog.

■ Windows: From any window, press F1 to get the topic associated with the window.

■ Toolbar: From the Toolbar, click  , and then click on a specific menu command or command
button for Help. You can also press SHIFT+F1. Be sure to have the Standard toolbar displayed.

■ Tooltips: To see tooltips, rest the cursor over the Toolbar button until the tooltip displays.

TIP You can control the level of tooltip assistance from the Settings  ➤ Options menu.

22 Close the Revit Structure Help window.
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Modifying Project and System
Settings

In this tutorial, you learn how to modify your Autodesk® Revit® Structure 4 working environment. In

the first lesson, you modify the system environment, which is independent of the project settings. In

the second lesson, you modify project settings to control the appearance of the components and

subcomponents within that project. Finally, you create an office template, and set it as your default

template.

2

11



Modifying System Settings
In this lesson, you learn how to control the system settings within Revit Structure. System settings are local to each
computer and applied to all projects; they are not saved to project or template files.

Modifying General System Options

In this exercise, you modify the settings that control your local Revit Structure working environment. These settings
control the graphics, selection default options, notification preferences, journal cleanup options, and your username
when using worksets.

Set graphics settings

1 Open Revit Structure.

2 Click File menu ➤  Close to close all open projects.

3 Click Settings menu ➤ Options.

4 In the Options dialog, click the Graphics tab.

5 Under Colors, select Invert background color, and click OK.

6 Click File menu ➤ New ➤ Project to open a new Revit Structure project.

7 In the New Project dialog, under Template file, click Browse.

8 In the left pane of the Choose Template dialog, click Training Files.

9 Select i_Tutorial_Default.rte in the Imperial folder, and click Open.

10 In the New Project dialog, click OK.

Notice that the drawing area is black.

11 Click Settings menu ➤ Options.

12 In the Options dialog, click the Graphics tab.

13 Under Colors, click the value for Selection Color.

14 In the Color dialog, select yellow, and click OK.

NOTE You can also specify the Alert Color. When an error occurs, the elements causing the error display using
this color.

15 Click the General tab.

16 Under Notifications, specify the following options:

■ For Save Reminder interval, select One hour.

■ For Save to Central Reminder Interval, select One hour.

■ For Tooltip Assistance, select None.

17 Click OK.

18 On the Modelling tab of the Design Bar, click Structural Wall.

19 Sketch a simple straight horizontal wall in the center of the drawing area.

20 On the Design Bar, click Modify, and select the wall.
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Notice the selected wall is yellow rather than the default red.

21 On the Design Bar, click Modify.

22 Place the cursor over the wall but do not select it.

Notice that a tooltip is not displayed.

23 Place the cursor over any of the icons on the toolbars.

Notice that a tooltip is displayed even though you set Tooltip Assistance to None. This setting controls
only the tooltips that display within the drawing area.

24 Click File menu ➤ Close.

25 When prompted to save, click No.

Setting Options

26 Click File menu ➤ Open.

27 In the left pane of the Open dialog, click the Training Files icon.

28 Open the i_RST_Settings.rvt file located in the Imperial folder.

Notice that the system settings apply to this project.

29 Click Settings menu ➤ Options.

30 In the Options dialog, click the Graphics tab and make the following changes:

■ Under Graphics, clear Invert background color.

■ For Selection Color, select Red.

31 Click the General tab and make the following changes:

■ Under Notifications, select your preferred Save Reminder interval, and select Normal for Tooltip
Assistance.

■ Under Windows Username, enter the name you want to use during worksharing. Your login name
displays by default.

■ Under Journal File Cleanup, select values for When number of journals exceeds and Delete journals
older than (days).

Journal files are deleted automatically after their number exceeds the value you specify. Journal files
are text documents that record each step during your Revit Structure sessions. These files are used
primarily in the software support process. Journals can be run in order to detect a problem or recreate
lost steps or files. They are saved at the termination of each Revit Structure session.
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NOTE Revit Structure Journal files are normally found in C:\Program Files\Autodesk Revit Structure\Journals.
The path may vary depending on your operating system or where you installed Revit Structure.

32 Click OK.

Notice that the drawing area background colors are no longer inverted and that tooltips display when you
place the cursor over any building component.

33 Click File menu ➤ Close. If prompted, do not save the changes.

34 Proceed to the next exercise, “Specifying File Locations” on page 14.

Specifying File Locations

In this exercise, you specify your default file locations. These settings control location of important Revit Structure files
such as your default project template, and the family template files, the family libraries, as well as the material and
rendering libraries.

Set file locations

1 Click Settings menu ➤ Options.

2 In the Options dialog, click the File Locations tab.

3 Under Default template file, click Browse.

Notice that there are industry-specific templates that you can set as your default template.

TIP To view a template, you can start a new project with that template. Click File menu  ➤ New  ➤  Project,
and click Browse to select a template.

4 Click Cancel.

5 Under Default path for user files, click Browse.

6 In the Browse for Folder dialog, select the folder to save your files to by default, and click OK.

7 In the Options dialog, under Default path for family template files, click Browse.

This path is set automatically during the installation process. These are the family templates that you use
to create new families. It is unlikely that you would ever want to modify this path. However, there are
some circumstances where you may need to modify the path, such as in a large, centralized, structural firm
where customized templates reside on a network drive.

8 Click Cancel.

Specify library settings and create a new library

9 In the Options dialog, under Libraries, notice the list of library names.

The list is dependent on the options that you selected during installation. Each library path points Revit
Structure to a folder of families or training files. You can modify the existing library names and path, and
you can create new libraries. An icon for each library displays in the left pane of all Revit Structure Open,
Save, Load, and Import dialogs.
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When you are opening, saving, or loading a Revit Structure file, you can click on the library folder located
in the left pane of the dialog. In the following illustration, notice that the libraries display as icons in the
left pane.

10 Under Libraries, click  .

11 Click in the Library Name field of the new library, and change the name to My Library.

12 Click in the Library Path column for My Library, and click the arrow that displays on the right side of the
field.

13 Navigate to C:\My Documents or any other folder where you want to create a personal library of Revit
Structure projects, templates, or families, and click OK.

TIP You may want to create a new folder first, and select it as the library path.

The new library displays in the left pane of all Revit Structure Open, Save, Load, and Import dialogs.

TIP The library icons display in the order that they are listed in the Options dialog.

14 Under Library Name, click My Library.

15 Click  until My Library is at the top of the list, and click OK.

16 Click File menu ➤ Open.

17 In the left pane of the Open dialog, click the My Library icon.

Notice that Revit Structure navigates directly to the library path. If you work in a large office, you may
want to set up an office library on a network path in order to increase productivity and maintain office
standards.

18 Click Cancel.

19 Click Settings menu ➤ Options.

20 Click the File Locations tab.
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21 Under Libraries, select My Library.

22 Click  to delete the library.

Specify rendering settings

23 Click the Rendering tab.

24 Under AccuRender resource location, view the current path.

This path specifies the location of the AccuRender® texture library. This path is determined during
installation. If you want to relocate this path, specify the new location here.

25 Click OK.

26 Proceed to the next exercise, “Specifying Spelling Options” on page 16.

Specifying Spelling Options

In this exercise, you modify the spelling settings and the custom dictionaries for Revit Structure.

Modify spelling settings

1 Click Settings menu ➤ Options.

2 In the Options dialog, click the Spelling tab.

3 Under Settings, select Ignore words in UPPERCASE.

4 Under Personal dictionary, click Edit.

The custom dictionary opens in your default text editor.

5 In the text editor, enter sheetmtl-Cu.

6 Click File menu ➤ Save.

7 Click File menu ➤ Exit.

Notice that there is also a building industry dictionary.

8 Under Building industry dictionary, click Edit.

9 In the text editor, scroll down the list of building industry terms.

10 Click File menu ➤ Exit.

11 In the Options dialog, click OK.

12 On the Standard toolbar, click  to open a new Revit Structure project using the default template.

13 On the Basics tab of the Design Bar, click Text.

14 Click in the drawing area, and enter This is sheetmtl-Cu and SHTMTL-CU

15 On the Basics tab of the Design Bar, click Modify.

16 Click Tools menu ➤ Spelling.

Notice that the spell checker allowed sheetmtl-Cu because you added it to the custom dictionary. It allowed
SHTMTL-CU because you set the spelling options to ignore words in uppercase.

17 Click OK.

18 Click Settings menu ➤ Options.

19 In the Options dialog, click the Spelling tab.

20 Under Settings, click Restore Defaults.

This resets the spelling settings to their original configuration.

21 Under Personal dictionary, click Edit.
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The custom dictionary opens in your default text editor.

22 In the text editor, do the following:

■ Delete sheetmtl-CU.

■ Click File menu ➤ Save.

■ Click File menu ➤ Exit.

23 In the Options dialog, click OK.

24 Click File menu ➤ Close. If prompted, do not save the changes.

25 Proceed to the next exercise, “Modifying Snap Settings” on page 17.

Modifying Snap Settings

In this exercise, you modify snap settings. Snap settings are system settings that are applied to all projects and not
saved within a project file. You can turn snap settings on and off, or use the shortcut keys to force a particular snap
method. In this exercise, you modify snap increments, work with snapping turned off, and use shortcut keys to control
snapping on an instance basis.

Modify snap increments

1 Click File menu ➤ New ➤ Project to open a new Revit Structure project.

2 In the New Project dialog, under Template file, click Browse.

3 In the left pane of the Choose Template dialog, click Training Files.

4 Select i_Tutorial_Default.rte in the Imperial folder, and click Open.

5 In the New Project dialog, click OK.

6 Click Settings menu ➤ Snaps.

Notice that you can modify both length and angular snap increments. As you zoom in and out within a
view, Revit Structure uses the largest increment that represents less than 2 mm in the drawing area. You
can add an increment by entering the value with a semicolon after it.

7 Under Dimension Snaps, click in the Length dimension snap increments box following the value 4' ; and
enter 1; .

8 Under Object Snaps, notice the 2-letter acronyms next to each object snap option.
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These are shortcut keys that you can use at any time when working on the design. For example, if you
want to snap an object to a wall midpoint, enter SM and only midpoint snaps are recognized until you
perform an action. After you click to place the object at the midpoint, snapping reverts to the system default
settings.

9 In the Snaps dialog, click OK.

10 On the Modelling tab of the Design Bar, click Structural Wall.

11 Click in the center of the drawing area, and move the cursor to the right.

Notice that the dimension snaps at 4' increments. If it does not, zoom out until it does so.

This kind of dimension is called a listening dimension; it refers specifically to the dimension that appears
while you are in the act of sketching. The listening dimension reacts to the movement of your cursor and
to numerical keyboard entries.

TIP To zoom while in the act of sketching, use the wheel button on your mouse. If you do not have a wheel
button, you can right-click and select a zoom option from the context menu. While sketching, you can also use
the zoom shortcut keys such as ZO to zoom out.

12 While sketching a generic straight wall, zoom in until the listening dimension snap increment shifts to 1'
.

This is the increment that you added previously.

Sketch without snapping

13 While sketching the wall, enter the shortcut key SO to turn snaps off.

Notice that when snapping is turned off completely, the listening dimension reflects the exact length of
the wall as you move the cursor to the left or right.

14 Click to set the wall endpoint.

15 Click in the drawing area to start a second wall, and move the cursor to the right. Do not set the wall end
point.

Notice that snapping is once again active. When you use shortcut keys to control snapping, the command
is only active for one click of the mouse.
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Use snapping shortcut keys

16 On the Design Bar, click Modify, and click Wall.

17 Place the cursor over the horizontal wall you added previously.

Notice that the cursor snaps to various points on the wall. If you move the cursor along the wall, it will
snap to the endpoints, the midpoint, and the wall edges.

18 Enter SM.

This is the snap shortcut key that restricts all snapping to midpoints.

19 Notice that the cursor now snaps only to the midpoint of the wall.

20 Click to start the wall at the midpoint.

21 Move the cursor downward, and specify the wall endpoint.

22 Click Settings menu ➤ Snaps.

23 Under Dimension Snaps, click in the Length dimension snap increments box, and delete the value 1"; .

Make sure you also delete the semicolon.

24 Click OK.

25 Click File menu ➤ Close, and do not save the file.

26 Proceed to the next lesson, “Modifying Project Settings” on page 19.

Modifying Project Settings
In this lesson, you learn how to control the project environment by using the options available on the Settings menu.
Using these options, you modify the appearance of components and their subcomponents within a project. You create
and modify materials, annotations, lines, fill patterns, and object styles. Finally, you modify the way the Project Browser
organizes the project.

The exercises in this lesson should be done sequentially using the same project file. If you cannot complete the exercises
in their entirety, save the project file with a unique name, and use it to complete the exercises.

Creating and Applying Materials

In this exercise, you create a new material and apply it to a model component. When you apply a material to a
component, it defines the appearance of that component in shaded and rendered views. Well designed materials provide
the foundation for photorealistic renderings.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_Proj_Settings.rvt located in the Imperial folder.

Create a new material

1 Click Settings menu ➤ Materials.

Notice the materials listed on the left side of the dialog. This list includes all materials available for use on
model components. When a model component is loaded into a project, all materials that are part of that
component family are also loaded into the project.

2 Scroll down, and select Concrete - Precast Concrete for Name.

3 Click Duplicate.
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This creates a new material using the selected material settings as the starting point.

4 In the New Material dialog, enter Concrete - Precast, and click OK.

You have created a new material that can be applied to any model component in this project. Notice that
the material settings have not changed from the material that you duplicated. In the steps that follow, you
modify the material so that it displays correctly in a shaded or rendered view.

Modify material settings

5 Under AccuRender, click  to select a texture.

6 Navigate to AccuRender\Concrete\Exposed Aggregate, Tan.

7 In the Material Library dialog, on the Material menu, select New ➤ Use Current Material as Template.

8 In the Material Editor dialog, click the Orientation tab.

9 Under Offset, enter 0.75 for X and Y, and click OK.

By offsetting the X and Y values of the image map, you help prevent the appearance of repetitive patterns
within the rendering.

10 In the Save Material As dialog, enter Concrete - Tan for the name, select user from the list of libraries, and
click OK.

The AccuRender texture Concrete - Tan is now part of your AccuRender User library.

11 In the Material Library dialog, click OK.

Apply the new material

12 In the Project Browser, expand Views (all) ➤ Floor Plans, and double-click T.O. Fnd. Wall.

13 Select the lower exterior wall, and click  .

14 In the Element Properties dialog, click Edit/New.

15 Click Duplicate.

16 Enter the new wall name, Foundation - Custom, and click OK.

17 In the Value field for Structure, click Edit.

18 Click in the Material field for Finish 2.

Layer #2 is the exterior finish of the wall. It is currently assigned the material Concrete Cast-in-place
concrete .
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19 On the right side of the Material field, click  .

20 In the Materials dialog, select Concrete-Precast for Name, and click OK.

This is the material you created previously.

21 Click OK 3 times.

The lower wall now uses the Concrete AccuRender texture when you render it.

22 Select the left foundation wall.

23 Press TAB to select the remaining exterior walls.

24 In the Type Selector, select Basic Wall: Foundation-Custom.

All of the exterior walls of this project are now Foundation-Custom.

25 On the View Toolbar, click  .

Notice that the foundation walls are no longer gray and there is no material pattern applied in this view.
This is because a surface pattern was not selected when the material was defined. In the following exercise,
“Creating and Applying Fill Patterns” on page 22, you create a pattern and apply it to this material.

26 On the Rendering tab of the Design Bar, click Region Raytrace.

TIP If the Rendering tab is not available on the Design Bar, right-click the Design Bar, and select Rendering.

27 In the drawing area, drag a rectangle around the entire 3D image.

28 In the Scene Selection dialog, select Exterior for type, and click OK.
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After you draw the rectangle around the 3D model, the rendering process begins. When it is finished, the
material that you created is displayed.

NOTE If you want to see the material in greater detail, click Display Model on the Rendering tab of the Design
Bar. Zoom into the model, select Region Raytrace, and drag a rectangle around the area you want to render.

29 On the Rendering tab of the Design Bar, click Display Model.

TIP On the View Control bar, click Model Graphics Style, and click Hidden Line to return to the previous view.

30 Click File menu ➤ Save As.

31 Navigate to a folder of your preference, and save the file as i_Settings-in progress.rvt .

32 Proceed to the next exercise, “Creating and Applying Fill Patterns” on page 22.

Creating and Applying Fill Patterns

In this exercise, you create a new pattern and apply it to the material you created in the previous exercise.

There are 2 types of fill patterns: model and drafting. Model patterns represent actual element appearance on a building,
such as brick coursing or ceramic tile on a wall. Model patterns are fixed and scale with the model. Drafting patterns
represent material in symbolic form, such as steel, which consists of a double-diagonal hatching pattern. Drafting
pattern density is fixed. Both pattern types are created and applied in a similar way.

TIP Drafting patterns represent materials in symbolic form. Model patterns represent actual element appearance on a structure.
You can align, rotate, and move model patterns. You can also dimension to model pattern lines.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_Settings-in progress.rvt .

Create a new fill pattern

1 In the Project Browser, expand Elevations, and double-click West.

Notice that no model surface pattern displays on the wall.

2 Click Settings menu ➤ Fill Patterns.

3 Under Pattern Type, choose Model.

4 Scroll down the list of patterns.

Notice that a concrete surface model pattern is not available.

5 Click New.

6 In the Add Surface Pattern dialog, click Custom.

7 Under Custom, click Import.
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8 Navigate to the training folders installed with your Revit Structure software.

TIP Typically, your training files can be found on C:\Documents and Settings\All Users\Application
Data\Autodesk\Revit Structure\Training. The location of these files can vary depending on the path you set
during installation.

9 Select Concrete_Surface.pat from the Common folder, and click Open.

10 Under Custom, select Concrete and enter 30 for Import scale.

11 Enter Concrete Surface for Name, and click OK.

The new model pattern is available in the Name list in the Fill Patterns dialog.

12 Click OK.

Apply the concrete surface pattern

13 In the Project Browser, expand Elevations, and double-click West.

14 On the View Control Bar, select Model Graphics Style: Wireframe.

15 Select the wall.

16 On the Options Bar, click  .

17 In the Element Properties dialog, click Edit/New.

18 In the Value field for Structure, click Edit.

19 In the Edit Assembly dialog, click in the Material field for Finish 2.

Finish 2 is the exterior finish of the wall. It is currently assigned the material Concrete-Precast.

20 On the right side of the Materials field, click  .

21 Under Surface Pattern, click  , to select a fill pattern.

22 In the Fill Patterns dialog, under Pattern Type, select Model.

23 Select the Concrete Surface model pattern, and click OK.

24 In the Materials dialog, click OK.

25 Click OK 3 times.

The west wall of the building displays as solid fill.

26 On the Design Bar, click Modify.

27 On the View Toolbar, click  .
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TIP If the pattern does not display, adjust your zoom settings as needed.

28 Zoom into the model until the fill pattern appears.

29 Click File menu ➤ Save.

30 Proceed to the next exercise, “Controlling Object Styles” on page 24.

Controlling Object Styles

You can use object styles to control the appearance of components and subcomponents. Object styles are applied in
every view and can be overridden in a particular view by modifying the Visibility/Graphics settings. Object styles allow
you to control the appearance of multiple components of the same type.

For example, there are often multiple trusses within a project. Rather than continually modify the type properties of
each truss, you can change the type properties center chase width of one truss and then apply the change to all trusses.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_Settings-in progress.rvt .

Apply object styles

1 In the Project Browser, expand 3D Views, and double-click 3D.

2 On the keyboard, use the shortcut keys ZF (Zoom to Fit) so the entire model fits in the drawing area.
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3 On the View Control Bar, click Model Graphics Style, and click Hidden Line.

4 Click Settings menu ➤ Object Styles.

5 In the Object Styles dialog, click Show categories from all disciplines.

6 Under Category, expand Walls.

7 Under the Walls category, double-click the Line Color field.

8 In the Color dialog, under Custom Colors, select Blue, and click OK.

9 In the Object Styles dialog, click OK.

Notice the line color is applied to the wall.

10 Click File menu ➤ Save.

11 Proceed to the next exercise, “Modifying Line Patterns and Styles” on page 26.
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Modifying Line Patterns and Styles

In this exercise, you create a new line pattern and apply it to the truss in plan view. You then create a new line style
to represent underslab drainage.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_Settings-in progress.rvt .

Create a new line pattern

1 Verify that the project from the previous exercise, i_Settings-in progress.rvt , is open with the 3D view active.

2 Click Settings menu ➤ Line Patterns.

3 In the Line Patterns dialog, click New.

4 In the Line Pattern Properties dialog, enter Truss for Name.

5 Enter the Types and Values shown in the following illustration:

6 Click OK twice.

You have created a new line pattern; now you must apply it. There are 2 ways to apply the line style to the
truss. You can use the Visibility/Graphics settings to modify the truss appearance in a specific view, (example:
plan view), or you can use Object Styles to apply the change to all views.

Apply the new line pattern

7 In the Project Browser, under Floor Plans, double-click T.O. Fnd. Wall.

8 On the View Control Bar, click Model Graphics Style, and click Hidden Line.

9 Click Settings menu ➤ Object Styles.

10 In the Object Styles dialog:

■ Under Category, expand Structural Framing, and select Web Joist.

■ Under Line Pattern, select Truss.

■ Click OK.

26 | Chapter 2   Modifying Project and System Settings



11 Click View menu ➤ Visibility/Graphics.

12 Click the Model Categories tab, expand Structural Framing, and select Web Joist for Visibility.

13 Click Override for Line Style Projection.

This overrides the appearance of the truss only in the current view.

14 In the Select Line Style dialog, select Override and specify the following options:

■ Select 2 for Line Weight.

■ Select Blue for Line Color.

■ Select Truss for Line Pattern.

15 Click OK twice.

Create a new line style

16 In the Project Browser, under Floor Plans, double-click T.O. Slab.

17 Click Settings menu ➤ Line Styles.

18 In the Line Styles dialog, under Modify Subcategories, click New.
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19 Enter Underslab Drainage for Name, and click OK.

20 For the Underslab Drainage category, specify the following values:

■ Select 6 for Line Weight Projection.

■ Select Red for Line Color.

■ Select Double Dash 5/8" for Line Pattern.

■ Click OK.

21 On the Modelling Tab of the Design Bar, click Lines.

22 In the Type Selector, select Underslab Drainage.

23 In the Options Bar, specify the following:

■ Click  .

■ Enter 2' 0" for Offset.

■ Click  .

24 Click outside the upper-left corner of the slab to begin the rectangle, move the cursor to the bottom-right
corner of the slab, and click to set the rectangle endpoint.

25 In the Options Bar, specify the following:

■ Click  .

■ Click  .

26 Draw 3 vertical lines, equally spaced as shown below.
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27 On the View Toolbar, click  .

Notice the underslab drainage lines appear in this view.

28 Click View menu ➤ Visibility/Graphics.

29 On the Model Categories tab, expand Lines, and clear Underslab Drainage.

This turns off the visibility of the underslab drainage lines only in this view.

30 Click OK.

31 In the Project Browser, under Floor Plans, double-click Level 1.

32 Click View menu ➤ Visibility/Graphics.

33 On the Model Categories tab, expand Lines, and clear Underslab Drainage.

34 Click OK.

35 Click File menu ➤ Save.

36 Proceed to the next exercise, “Modifying Annotations” on page 29.

Modifying Annotations

In this exercise, you create a new dimension style using units of measurement that differ from the project settings. You
also load a new beam annotation symbol and apply it to show the beam instance number rather than the beam type
number.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_Settings-in progress.rvt .

Create a new dimension style

1 Verify that the project from the previous exercise, i_Settings-in progress.rvt , is open with the 3D View active.

2 Click Settings menu ➤ Annotations ➤ Dimensions ➤ Linear.

3 In the Type Properties dialog, click Duplicate.

4 Enter the name Linear - Imperial and click OK.

5 Under Text, click the default value for Units Format.
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6 In the Format dialog:

■ Clear Use project settings.

■ Select Feet and fractional inches for Units.

7 Click OK twice.

You have created a new dimension style.

8 On the Basics tab of the Design Bar, click Dimension.

In the Type Selector, notice that there is a Linear - Imperial dimension available.

9 On the Basics tab of the Design Bar, click Modify.

Load a new beam tag

10 In the Project Browser, under Floor Plans, double-click T.O. Fnd. Wall.

11 Click Settings menu ➤ Annotations ➤ Loaded Tags.

12 Click Load.

13 In the Open dialog, navigate to the Annotations/Structural folder of the Imperial Library, and select Structural
Framing Tag .

In the preview image, notice that the label displays 1i. This indicates this tag is designed to display the
beam instance value rather than the type value.

14 Click Open.

15 In the Tags dialog, scroll to Structural Framing Tag and notice that Structural Framing Tag is now the
assigned tag.

This tag is used when tagging using the Beams By Category option.

16 Under Loaded Tags, click Structural Framing Tag , and select the drop-down arrow that displays.

Notice that you can choose between the 2 beam tag types loaded into this project.

17 Click OK.

18 On the Drafting tab of the Design Bar, click Tag.

19 Click By Category.

20 On the Options Bar, clear Leader.

21 Click a beam.
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A beam instance tag displays on the selected beam.

22 On the Design Bar, click Tag All Not Tagged.

Under Category, notice the structural framing tag appears twice. Each tag category has a different loaded
tag: one displays the type value, the other displays the instance value.

23 Select the structural framing tag category with the loaded tag, Structural Framing Tag .

24 Under Leader, verify that Create is clear, and click OK.

The remaining untagged beams are tagged.

25 On the View Toolbar, click  .

26 Click File menu ➤ Save.

27 Proceed to the next exercise, “Specifying Units of Measurement, Temporary Dimensions, and Detail Level
Options” on page 31.

Specifying Units of Measurement,Temporary Dimensions, and Detail Level
Options

In this exercise, you modify 3 settings that have a broad impact on the project. In the first section, you specify the
project units of measurement - unless there is an override, dimension values display using this setting. In the second
section, you modify the temporary dimension settings. In the final section, you modify the detail level assignments.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_Settings-in progress.rvt .

Set units of measurement

1 Click Settings menu ➤ Project Units.

2 In the Project Units dialog, under Length, click the default value for Format.

3 In the Format dialog, select To the nearest 1/16" for Rounding, and click OK.

4 In the Project Units dialog, under Area, click the default value for Format.

5 In the Format dialog, select 0 decimal places for Rounding, select SF for Unit suffix, and click OK.

Modifications to area rounding are displayed in schedules and area tags.

6 Click OK.

Unless there is an override, dimensions use these project settings.

Specify temporary dimension properties

7 Click Settings menu ➤ Temporary Dimensions.

8 Under Walls, select Centerlines
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9 Under Doors and Windows, select Openings, and click OK.

In this project, temporary dimensions now snap to the centerline faces and to the openings.

Specify detail levels

10 Click Settings menu ➤ Detail Level.

When you create a new view and specify its view scale, the detail level is specified automatically according
to the arrangement in the table.

TIP You can override the detail level at any time by specifying the Detail Level parameter in the View Properties
dialog.

In this table, you use the arrows between the columns to move view scales from one detail level to another.
You do not select a view scale to move it. The view scale moves either from the bottom or the top of the
column based on the direction.

11 Between the columns Coarse and Medium, click  .

Notice the 1/4" = 1' 0" view scale moved to the Medium column. Any new view created using this scale is
automatically assigned the detail level Medium.

12 Click OK.

13 Click File menu ➤ Save.

14 Click File menu ➤ Close.

15 Proceed to the next exercise, “Modifying Project Browser Organization” on page 32.

Modifying Project Browser Organization

In a typical project, you often produce multiple packages of related drawings. These drawings and sheets can become
so numerous that navigating the lengthy Project Browser list is cumbersome. In order to organize the views and sheets
into sets of deliverables, you can use the Project Browser settings to instantly modify how the Project Browser groups
and sorts.

In this exercise, you modify the Project Browser organization and create new methods of grouping and sorting the
views and sheets.

NOTE In this exercise, you open a project that was created using Autodesk® Revit® Building to better demonstrate different
phases of construction. Revit Structure project files do not include ceiling plans.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open c_Project_Browser.rvt from the Common folder.

Organize the Project Browser by views

1 In the Project Browser, expand Views (all) ➤ 3D Views, and double-click Completed Project.

32 | Chapter 2   Modifying Project and System Settings



2 In the Project Browser, expand Sheets (all).

Notice that the sheets are listed alphanumerically based on the sheet number.

3 Open each of the 3D views in the following order, and notice the progression of each view:

■ Main Bldg - Phase 1-Structure

■ East Wing - Phase 2-Structure

■ West Wing - Phase 3-Structure

■ Completed Project-Structure

■ Completed Structure w/ Roof&Floors

■ Completed Project

Each of the 3D views varies by phase and discipline.

4 Click Settings menu ➤ Browser Organization.

5 On the Views tab, select Discipline, and click OK.

On the Project Browser, notice that Views are divided into Architectural and Structural disciplines.

6 In the Project Browser, expand both the Architectural and Structural category of views.

7 Click Settings menu ➤ Browser Organization.

8 Select Phase, and click Apply.

In the Project Browser, notice that views are grouped based on phase.

9 In the Browser Organization dialog, select Type/Discipline, and click OK.

10 In the Project Browser, expand each view type, and notice that each is grouped by discipline.
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Organize Project Browser by sheets

11 Click Settings menu ➤ Browser Organization.

12 Click the Sheets tab.

13 Select Sheet Prefix, and click OK.

14 In the Project Browser, under Sheets, expand each sheet set.

Create a new browser organization name

15 Click Settings menu ➤ Browser Organization.

16 Click the Views tab, and click New.

17 Enter Phase/Type/Discipline, and click OK.

18 In the Browser Organization Properties dialog, click the Folders tab, and specify the following:

■ Group by: Phase

■ Then by: Family and Type

■ Then by: Discipline

19 Click OK.

20 In the Browser Organization dialog, select Phase/Type/Discipline as the current browser organization, and
click OK.

21 In the Project Browser, under Views, expand Complete ➤ 3D Views and then expand Architectural and
Structural.

Notice that the Project Browser has reorganized all the views within this project according to Phase, View
Type (Family and Type), and Discipline.

22 Click File menu ➤ Close.

If you want to save this file, navigate to your preferred directory, enter a unique file name, and click OK.

In this lesson, you modified various project settings that affect project appearance and organization. All the settings
that you changed in this lesson are saved with the project. You can also save these settings in a template file. By saving
these settings as a template and using it throughout the office, you maintain consistent standards and reduce the
amount of repetitive work. In the lesson that follows, you create an office template.

Creating a Structural Template
In this lesson, you create a Revit Structure template file and set it as your default template. When you create new
projects, the project template is used to provide the initial project settings such as materials, dimensions styles, levels,
preloaded families, and view names. You can save Project Browser organization schemes, named print settings, and
rendered scenes in a template. Although Revit Structure provides many templates to choose from, you may decide to
modify one or more of these templates to the specific needs of your company. A well designed template will ensure
office standards are maintained and will reduce repetitive work.

This lesson is intended to provide you with a blueprint of how to create your structural template. It is mostly conceptual
and is designed as a road map with options for your consideration. The lesson begins with choosing the right base
template and progresses through many of the most common modifications that you would consider in order to make
a template unique to your situation.

Choosing the Base Template

In this exercise, you select the starting point for your structural template.

Whenever you create a new project or template, a group of settings are used to specify the project environment. For
example, when you create a new project, you can select an existing template or begin the project with no template.
Even if you choose not to base that project on a template, certain baseline settings are still assigned to the new project.
When you create a new template based on an existing template, the same rules apply. You can use an existing template
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as the baseline or use no template at all. Depending on your needs, choose the option that will help you develop the
best template with the least amount of work.

Review existing templates

1 Click File menu ➤ New ➤ Project.

2 Under Template File, click Browse.

Notice there are a number of different templates to choose from. The template selection may vary depending
on your installation. Other than the default template, each is modified in a way to make it useful to a
particular industry, such as structural or construction.

The first step in creating your structural template is deciding which template to use as your starting point.
If your work requires a variety of templates, you can modify one template and use Transfer Project Standards
to copy the changes to other templates.

3 Select the Structural Analysis-Default.rte template, and click Open.

4 In the New Project dialog, select Project for Create new.

5 Click OK.

6 In the Project Browser, expand Views ➤ Elevations, and double-click Building Elevation.

7 Click View menu ➤ Zoom ➤ Zoom in Region and, in the drawing area, drag a zoom region around the
level heads.

Notice that there are more predefined levels than you normally see in the default template.

8 In the Project Browser, navigate throughout the various views and schedules.

Notice that the structural analysis template is more complex than the default template. Other templates,
such as the structural template, are simple in respect to the predefined views and schedules, but the view
properties have been modified to maximize the use of the structural tools.

9 Click File menu ➤ Close.

If you have additional projects open, close them.

10 Click File menu ➤ New ➤ Project.

11 Under Template File, click Browse.

12 Select a default template.

TIP This template is the starting point for your new template. If you want to use a template other than the
default, you can select it now.

13 Click Open.

14 Under Create New, select Project Template, and click OK.

15 Proceed to the next exercise, “Modifying Project Settings” on page 35.

Modifying Project Settings

In this exercise, you modify the project settings for your new template. These settings control the appearance of
components and their subcomponents within a project. In order to maintain office standards and reduce rework, you
can establish the settings that are common to most projects. For example, you can create the materials commonly used
in most projects. When you create the material, you can dictate its appearance in all views and renderings.

In this exercise, you modify the following:

■ Materials

■ Fill patterns

■ Object styles
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■ Line styles, weights, and patterns

■ Annotations

■ Project units

■ Temporary dimensions

■ Detail levels

■ Project Browser organization

■ View direction

In addition to the list above, there are additional commands on the Settings menu that allow modifications that can
be saved in a template. The specifics regarding each of these are addressed at the end of this exercise.

During this exercise, specific modifications are not dictated. You are merely pointed to each area where you can adapt
the template to your needs. For more details on modifying these settings, see the previous lesson, “Modifying System
Settings” on page 12, or refer to the Help documentation.

Create and modify materials

1 Click Settings menu ➤ Materials.

2 Scroll down the Name list.

Observe the materials that are already defined. You may want to rename or modify some of the existing
materials. If there are materials that are commonly used within your office or industry, create and modify
them as needed.

If you create or modify new materials, you may want to specify their appearance when rendered. You can
do this by setting the AccuRender Texture.

3 Under AccuRender, click  to access the AccuRender Material Library.

If there are custom AccuRender materials that you want to add to the template, you can do so by going to
the Material menu and selecting New. Choose the appropriate option, and create the AccuRender material.

RELATED See “Modifying System Settings” on page 12 for more information on creating new AccuRender
materials.

When you save a new AccuRender material designed to be used in an office template, be aware that access
to the original material library may be necessary at some point. You may want to save the material to a
library located on a network path.

4 Click OK twice to close the Material Library and Materials dialogs.

Create and modify fill patterns

5 Click Settings menu ➤ Fill Patterns.

6 Scroll through the list of model and drafting patterns.

TIP Drafting patterns represent materials in symbolic form. Model patterns represent actual element appearance
on a structure. You can align, rotate, and move model patterns.

7 Create new fill patterns as needed, or modify existing patterns.

RELATED See “Modifying Project Settings” on page 19 for more information on creating new fill patterns.

8 Click OK when finished.

Specify object styles

9 Click Settings menu ➤ Object Styles.
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In the Object Styles dialog, you can set line weights, line colors, line patterns, and materials for different
categories and subcategories of components or imported objects.

TIP When the material of a component is set to by category, it adopts the material assigned to its object styles
category.

10 Click the Model Objects tab, and scroll through the list of categories.

11 Modify the properties of any existing categories as needed.

12 If necessary, create new subcategories.

13 Click the Annotation Objects tab.

14 Modify categories, and create new subcategories as needed.

15 Click OK to close the Object Styles dialog.

Modify line weights

16 Click Settings menu ➤ Line Weights.

The Line Weights command controls the display of line widths for each scale of a view. You can add and
delete view scales.

In the dialog, there are 3 tabs: one for model component line styles, one for perspective model line styles,
and one for annotation symbol line styles.

The Model Line Weights tab controls the line width of structural components, such as beams and columns
in orthographic views. The widths are dependent on the scale of the design. You can define the widths of
16 different pens for 6 different drawing scales.

The Perspective Line Weights tab controls the line width of objects in perspective views.

The Annotation Line Weights tab controls the line width of annotation symbols, such as section lines and
dimension lines. Annotation line widths are independent of the view scale.

17 Click the Model Line Weights tab.

18 Modify existing line weights as needed.

19 Add and delete view scales as needed.

20 Click the Perspective Line Weights tab.

21 Modify existing line weights as needed.

22 Click the Annotation Line Weights tab.

23 Modify existing line weights as needed.

24 Click OK.

Modify line patterns

25 Click Settings menu ➤ Line Patterns.

26 Scroll through the list of line patterns.

27 To modify a line pattern, select it, and click Edit.

28 Add and delete line patterns as needed.

29 Click OK.

Modify line styles

30 Click Settings menu ➤ Line Styles.

31 For existing line categories, modify the line weight, line color, or line pattern as needed.

32 If necessary, create new line subcategories using line weights and line patterns previously modified or
created.
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33 Click OK.

Modify arrowheads

34 Click Settings menu ➤ Annotations ➤ Arrowheads.

The arrowheads configured within this dialog can be applied to text notes, tags, and dimensions.

35 Select the Type drop-down list, and notice the list of existing arrowhead styles.

To see the details of a particular style, select it from this list.

36 Modify the properties of existing arrowhead styles if necessary.

37 Click Rename if you want to rename an existing arrowhead.

38 If you need to create a new arrowhead style, click Duplicate, name the style, and specify the properties.

39 Click OK.

Modify Dimension Styles

40 Click Settings menu ➤ Annotations ➤ Dimensions ➤ Linear.

Linear, angular, and radial dimensions are modified separately.

41 Select the Type drop-down list, and notice the list of existing linear dimension styles.

To see the details of a particular style, select it from this list.

42 Modify the properties of existing linear dimension styles if necessary.

43 Click Rename if you want to rename an existing style.

44 If you need to create a new linear dimension style, click Duplicate, name the style, and specify the properties.

45 Click OK.

46 Repeat the previous 5 steps for angular and radial dimensions.

■ Click Settings menu ➤ Annotations ➤ Dimensions ➤ Angular.

■ Click Settings menu ➤ Annotations ➤ Dimensions ➤ Radial.

Modify loaded tags

47 Click Settings menu ➤ Annotations ➤ Loaded Tags.

The tag assignments in this dialog dictate the default tag for each category. For example, when you add a
structural framing tag with the tag option selected, the beam is tagged using the tag assigned to the structural
framing category in this dialog. You can override tag assignment using the Type Selector.

48 Scroll through the list of loaded tags.

Notice many categories do not have loaded tags. You can have multiple tags loaded for any category. When
more than one tag has been loaded for a category, the last loaded tag becomes the default tag. In the Tags
dialog, you can override the assignment by selecting a different tag from the drop-down list.

49 To load new annotation tags, click Load.

50 After you have loaded the necessary tags, make sure each category is assigned the desired tag, and click
OK.

Specify project units

51 Click Settings menu ➤ Project Units.

52 Under Length, click Format.

53 Modify the unit settings if necessary.

54 Click OK.

55 Repeat the previous 2 steps for the Area, Volume, and Angle settings.
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56 Specify the Slope option, and choose a decimal symbol.

57 Click OK.

Specify temporary dimensions

58 Click Settings menu ➤ Temporary Dimensions.

59 Under Walls, specify where you want the temporary dimensions to measure from by default.

TIP In the drawing area, you can modify the location of temporary dimension witness lines.

60 Under Doors and Windows, specify the default location for temporary dimensions.

61 Click OK.

Specify detail levels

62 Click Settings menu ➤ Detail Level.

When you create a new view, the detail level of that view is automatically assigned using this table. The
detail level is based on view scale. You can override the detail level at any time by specifying the Detail
Level parameter in the View Properties command.

View scales are organized under the detail level headings Coarse, Medium, or Fine. Using the arrows between
the columns, you can move view scales from one detail level to another.

63 Review the table, and move view scales as needed.

NOTE You cannot select specific scales in this dialog. To move the view scales, click the arrows between columns.
The view scales move from the lower-left to the upper-right and vice-versa.

64 Click OK.

Modify project browser organization

65 Click Settings menu ➤ Browser Organization.

In a typical project, you often produce multiple packages of related drawings. These drawings and sheets
can become so numerous that navigating the lengthy Project Browser list is cumbersome. In order to
organize the views and sheets into sets of deliverables, you can use the Project Browser settings to instantly
modify how the Project Browser groups and sorts.

66 In the Browser Organization dialog, click the Views tab.

67 Delete, Rename, or Edit existing organization types.

68 If necessary, create new browser organization types.

69 Click the Sheets tab.

70 Delete, Rename, or Edit existing organization types.

71 If necessary, create new browser organization types.

72 Click OK.

Setting View Direction

73 In the Project Browser, right-click - any plan view of the Structural Plan Family, and select Properties.

In certain projects, engineers view plans using different orientations in different countries. This parameter
makes it possible for you to select a different view direction. For example, you can view the project from
the slab looking up (up direction), or from the roof looking down (down direction).

74 In the Element Properties dialog, click Edit/New.

75 In the Type Properties dialog, click View Direction.
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76 Use the down arrow to change the parameters to Up or Down.

77 Click OK to exit the dialogs.

Additional project settings

78 On the Settings menu, there are several additional commands that control the project environment.
Although these settings can be saved within a template, you should consider each carefully before applying
changes to a template.

For example, you can save rendered scene settings to a template. However, you may only want to add
generically named settings that would be applicable to most projects. In such a case, you must decide if
the time investment is offset later by the reduction in repetitive work.

Each of these areas is covered later in this lesson or in other tutorials. Use the table below as a checklist,
and make modifications in each area as necessary. Links to associated tutorials are provided. You can find
additional information in Help. Each command is available on the Settings menu.

ConsiderationsAssociated TutorialSettings Menu
Command

If necessary, you can add project (and shared)
parameters to a template. This could be useful for
things such as title blocks, and framing tags.

This command is covered in an exercise
later in this lesson. See “Setting up Shared
and Project Parameters” on page 47.

Project Parameters

Create and modify the view templates to control the
appearance of default views.

This command is covered in an exercise
later in this lesson. See “Modifying Views
and View Templates” on page 42.

View Templates

If necessary, you can set the symbolic representation
settings for cutback distance, brace symbols, and
column symbols.

“Modifying Structural Settings” on page
45

Structural Settings

79 Proceed to the next exercise, “Loading and Modifying Families and Groups” on page 41.
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Loading and Modifying Families and Groups

In this exercise, you load and modify families or groups into the template started in the previous exercise. If you have
not completed the previous exercise, do so before starting this exercise. Depending on the intended use of this template,
you may want to load families into the template to save time later or ensure consistency throughout the office. You
can load any family or group into a template. Obviously, you should only load components that tend to be used in
every project and are not likely to change. For example, you could load detail components, titleblocks, and beams. You
may want to modify slab types to add a more diverse selection within the template. Although the options are endless,
there are some important thoughts to consider.

It is important to understand that you should not load every conceivable family into a template file. Although this is
possible, it is not recommended because it would increase the file size significantly before the first component was
added to the project. In addition, each component loaded will add to the length of the relative Type Selector list. For
example, if you loaded every beam type you could find, you would have to scroll through a lengthy list of beams every
time you changed a beam within a project. This would be cumbersome and counterproductive. You should think very
carefully about what families or groups to load and modify within a template.

Load and modify families

1 Use the project started in the previous exercise, and on the Modelling tab of the Design Bar, click Beam.

2 In the Type Selector, notice the list of beams is already loaded.

If this selection is satisfactory, you can move onto the next component type. However, you may want to
delete, modify, or add to this selection. You can do this in several ways: select a component type and click
Properties to modify or add a new type, or use the Project Browser to delete an existing type. In the steps
that follow, you do both.

3 To modify, create, or load a new beam type, click  on the Options Bar.

Use the instructions in the table below to perform these steps.

Steps:Goal:

In the Element Properties dialog, select Load. Navigate to the directory containing the
beam type, select it, and click Open.

Load new beam type

In the Element Properties dialog, select Edit/New. Make modifications, and click OK.Modify beam type

In the Element Properties dialog, select Edit/New. Click Duplicate, enter a name, and
click OK. Modify type properties, and click OK.

Create new beam type

4 Click OK.

5 Repeat the process for any component type that you want to modify.

You may want to open other Design Bar tabs and make modifications to components not available on this
tab. You can also load families and groups from the File menu.

6 Click File menu ➤ Load from Library.

Notice that you have the option to Load Family or Load Group. Loading from the library is quickest when
you know exactly what families you want to load. Press ESC twice to return to the template.

Use Project Browser to modify families

7 In the Project Browser, expand Families.
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Notice that each family category is listed. You can use the Project Browser to modify family types.

8 Expand Annotation Symbols.

Notice that there is a titleblock symbol loaded. (The titleblock name may vary depending on the template
you started with.)

9 Expand the titleblock, and select the titleblock type.

10 In the Type Properties dialog, click Preview.

This titleblock is currently part of the template. Notice it has Revit in the upper-right corner. You may
want to load a titleblock applicable to your office and then delete this titleblock.

11 To load a titleblock, click Load.

12 Click OK.

You can use the Project Browser to delete a component from the project/template. To do so, right-click the
component, and click Delete.

13 Using any of the techniques learned in previous steps, load, create, or modify any component families or
groups as necessary.

14 Proceed to the next exercise, “Modifying Views and View Templates” on page 42.

Modifying Views and View Templates

At the beginning of this lesson, you created new projects using different templates, and you noticed that each template
had a unique set of predefined views. In this exercise, you create the views required for your template. In addition, you
create and apply the underlying view templates that control the initial appearance of the views.

View templates help standardize the look of all views by providing the initial settings for a view. You can also apply a
template to an existing view at any time using the Apply View Template command. The view inherits view properties
such as View Scale, View Range, Discipline, Detail Level, and the visibility settings of categories and subcategories. In
this exercise, you will first modify view templates, and then create new views that will automatically use those templates.

Create and modify view templates

1 Click Settings menu ➤ View Templates.

2 For Name, select Structural Framing Plan.

These settings are applied when you create a new plan view by adding a new level. At any time, you can
apply a view template to any view. These values represent the starting point for each plan view.

By modifying the view templates according to your specific needs, you save time and increase consistency.
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3 Specify each value as needed. Keep in mind that these settings are the default settings for this view type.

4 If necessary, rename or duplicate the view template, and make modifications.

5 Repeat the steps above for each of the view templates in the Name drop-down list.

6 Click OK.

Apply view templates

7 In the Project Browser, expand Views ➤ Structural Plans, and double-click Level 1.

8 Click View menu ➤ Apply View Template.

TIP To select the view template directly from the Project Browser: select the view, right-click, and select Apply
View Template.

Applying a view template to a view is a one-time action. When the view template is applied the view
properties of the target view are instantly reset to match those of the template. After the template is applied,
the view is not linked to the template in any way. Subsequent modifications to the view template do not
affect any current views unless you reapply the view template. There is no limit to the number of times
you can apply a view template to a view, nor is there a limit to the number of view templates that you can
apply.

TIP To apply the template to multiple views, select the view in the Project Browser, and press Ctrl while selecting
additional views. Then right-click and select Apply View Template.

9 Select the Structural Framing Plan template.

10 Select Apply automatically to new views of same type.

This option means that every time a new plan view is created, this view template will be used to set the
initial view properties.

11 Click Apply, and click OK.

12 In the Project Browser, under Floor Plans, double-click Level 2.

13 Click View menu ➤ Apply View Template.

14 Select the Structural Plan template, click Apply, and click OK.

15 If you modified any other view templates, open the view from the Project Browser, and apply the appropriate
template.

Create and modify views

16 In the Project Browser, under Elevations, double-click Building Elevation.
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Notice the level names have blue titles for the associated plan views. Black levels have no associated views.

17 In the Project Browser, under Structural Plans, review the existing floor plans.

18 In the Project Browser, under Structural Plans, right-click Level 1, and notice the context menu includes
options to rename, duplicate, or delete this view.

You can rename this view, if desired. You can also duplicate or delete the view.

19 In the Project Browser, review the Structural plans and elevations. Rename, duplicate, or delete them as
needed.

20 To add additional levels to the template, click Level on the Basics tab of the Design Bar.

Make sure you are still in the Level 2 view.

21 In the Options Bar, select Make Plan View.

22 Add the new level within the elevation view.

The associated floor plan will use the Structural Plan view template to set its initial view properties.

23 Rename and reposition the level as needed.

24 Create additional levels as needed.

Create 3D views

25 To add 3D views to the template, click  on the View toolbar.

26 In the Project Browser, expand 3D Views.

27 In the Project Browser, under 3D Views, right-click {3D}, and select Rename.

28 Rename the 3D View.

If necessary, you may want to modify the view properties of any new views. To do so, go to the View menu
 ➤  View Properties.

29 To create additional 3D views, click  on the View toolbar.

30 On the View toolbar, click  .

You can use this tool, Dynamically Modify View, to orient and save the view.

31 Click the arrow on the right side of the Dynamic View dialog.

32 You can use Orient to a Direction or Orient to a View to set the camera location and target.

33 To save the view, click  , supply a view name, and click OK.

The view is listed in the Project Browser under Views ➤ 3D Views.

Create and modify schedules

34 On the View tab of the Design Bar, click Schedule/Quantities.
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You may want to add schedules to a template. You may want to consider adding the schedules that you
use most often, and modify their properties accordingly. This can save time and ensure office standards
are maintained.

35 If you want to add schedules to your template, select the category type, and click OK.

36 In the Schedule Properties dialog, make the following modifications as needed:

■ On the Fields tab, select and order required fields.

■ On the Filter tab, assign filters.

■ On the Sorting/Grouping tab, modify settings.

■ On the Formatting tab, modify settings.

■ On the Appearance tab, modify settings.

37 Click OK.

38 Repeat the steps above for each schedule type you add to the template.

Add sheets to the template

39 On the View tab of the Design Bar, click Sheet.

You are prompted to select a titleblock. If you have already loaded your titleblocks into the template, select
one, and click OK.

TIP You can add sheets to the template and delete the titleblock. To do so, select the default titleblock, and
click OK. After the sheet is created, select the titleblock and delete it. You can still add views to the sheet. To
later add a titleblock to a sheet, click View menu ➤ New ➤ Place Titleblock.

40 Add views to the sheet by selecting Add View from the View tab of the Design Bar.

TIP You can drag and drop views directly from the Project Browser onto the sheet.

41 To rename or renumber the sheet, right-click the sheet in the Project Browser, and click Rename, or on the
sheet itself, double-click the sheet number.

42 Create new sheets as needed.

Subsequent sheets are numbered consecutively based on the previous sheet.

43 Proceed to the next exercise, “Modifying Structural Settings” on page 45.

Modifying Structural Settings

You can create custom cutback distances for braces, beams, and columns. You can also create custom brace symbols
for use in plan views and for parallel line offset distances. You may want to add symbolic settings to a template. You
may want to consider adding the settings that you use most often, and modify their properties accordingly. This can
save time and ensure office standards are maintained.

Create custom symbolic representations

1 Click Settings menu ➤ Structural Settings.

2 In the Structural Settings dialog, click the Symbolic Representation Settings tab.
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3 Under General, enter the desired values for the following cutback distances:

■ Symbolic brace/beam cutback distance: Sets the distance from the center of the brace/beam to the
center of the adjoining beam.

■ Symbolic column cutback distance: Sets the distance from the center of the column to the beam
endpoint.

4 Under Brace Symbols, specify the desired line representation and offset as follows:

■ Plan representation: Select the desired symbolic line type for plan representation (Line or Line with
Angle.)

■ Parallel line offset: Enter the symbolic distance for the parallel line offset.

5 Click OK.

6 Proceed to the next exercise, “Modifying Import/Export Settings” on page 46.

Modifying Import/Export Settings

In this exercise, you modify the export layer settings for DWG/DXF and DGN. You then set the import line weights
for DWG/DXF. When you import a DWG or DXF file, each layer in the file is assigned a line weight based on the pen
number/line weight settings you created.

Modify export layers for DWG and DXF

1 Click File menu ➤ Import/Export Settings ➤ Export Layers DWG/DXF.

The Export Layers command maps Revit Structure categories and subcategories to specific layer names that
are available after exporting to other CAD programs. Revit Structure presets the layer names to American
Institute of Architects (AIA) industry standards. The layer names are stored in a text file (exportlayers.txt),
and are exported along with your project into the appropriate CAD program. The layer mapping files reside
in the Data folder of the Revit Structure program installation directory.

2 For each category, specify the following:

■ Projection Layer Name and Color ID

■ Cut Layer Name and Color ID
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3 If you modified the settings in this dialog, select Save As, name the file, and click Save.

Modify export layers for DGN

4 Click File menu ➤ Import/Export Settings ➤ Export Layers DGN.

The layer names are stored in a text file (exportlayersdgn.txt) for MicroStation, and then are exported along
with your project into the appropriate CAD program. The layer mapping files reside in the Data folder of
the Revit Structure program installation directory.

5 For each category, specify the following:

■ Projection Level Number and Color ID

■ Cut Level Number and Color ID

6 If you modified the settings in this dialog, select Save As, name the file, and click Save.

Modify import line weights

7 Click File menu ➤ Import/Export Settings ➤ Import Line Weights DWG/DXF.

You can import pen numbers from a DWG or DXF file and map them to a Revit Structure line weight.
When you save these mappings to a text file, they become the set mappings for the project. These settings
are retained within the project template; therefore, you do not need to worry about where the text file is
saved.

8 In the dialog, match the pen (DWG/DXF Color Number) to the appropriate line weight (values from 1 -
16); for example, Pen Number 1 to Line Weight Number 1, Pen Number 2 to Line Weight Number 2, and
so on. Set as many pen-line weight mappings as desired.

9 Select Save As, name the file, and click Save.

When you import a DWG or DXF file, each layer in the file is assigned a line weight based on the pen
number/line weight settings you created.

10 Proceed to the next exercise, “Setting up Shared and Project Parameters” on page 47.

Setting up Shared and Project Parameters

In this exercise, you refine the template further by setting up shared parameters, project parameters, and related
multi-category tags and schedules.

Using shared parameters, you can define additional parameters that are not included in either the pre-defined instance
and type parameters within family components or within the project template. You can add these shared parameters
to any family regardless of category. Their definitions are stored in an external file ensuring consistency across families
and projects. Their values may also be aggregated and reported using multi-category schedules. For example, you could
use shared parameters to add specific parameters to an existing family component for scheduling and tagging when
those parameters are not initially present by default.

Project parameters are those parameters (either instance or type) that are used within a single project for the purposes
of scheduling information specific to that project. They cannot be shared with other projects, and unlike shared
parameters, they cannot be used to tag objects.

Multi-Category Tags employ shared parameters to permit tagging of any family component regardless of category.
When scheduling, you normally schedule a single category: rooms, doors, windows, and so on. When you create a
multi-category schedule, it lists components regardless of category by using an external parameter as a filter.

In this exercise, detailed instructions are not supplied because each office has a unique set of needs. If you do not need
to make changes to shared or project parameters, you can skip this exercise and move on to the last exercise of this
lesson, Creating Named Print Settings.

Set up shared parameters

1 Click File menu ➤ Shared Parameters.
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NOTE This procedure is for creating a new shared parameter file. If a file already exists, you can browse to that
file and modify it as needed.

2 Click Create.

This allows you to name the external parameter file. If this template will be used by multiple people within
an office, you may want to save the file to a network location.

3 Name and save the file.

After the file is named, you can begin creating parameter groups.

4 In the Edit Shared Parameters dialog, under Groups, click New.

5 Enter the group name, and click OK.

6 Create as many groups as needed.

For each parameter group, you can create a list of parameters.

7 Under Parameter group, select a group to which you want to add parameters.

8 Under Parameters, click New.

9 Name the parameter, and specify the Type.

10 Click OK.

11 For each parameter group, add required parameters.

12 Click OK when you have finished creating shared parameters.

Set up project parameters

13 Click Settings menu ➤ Project Parameters.

14 Click Add.

15 In the Parameter Properties dialog, select Project parameter.

16 Under Name, enter a parameter name.

17 Under Discipline, select a parameter discipline type.

18 Under Type, select a parameter value type.

19 Specify whether the parameter is stored by instance or type.

20 Select the element categories to which this parameter applies.

21 Click OK.

22 Add project parameters as needed.

23 To add a shared project parameter, click Add, and select Shared Parameter.

24 Click Select, and select a shared parameter.

25 Click OK.

26 Specify whether you want the shared parameter to be an instance or a type parameter, and specify the
categories to which this parameter applies.

27 Click OK.

28 Add shared project parameters as needed, and click OK when finished.

Create and load multi-category tags

29 Create required multi-category tags in the Family Editor.

For information on creating multi-category tags, see the tutorial referenced in the introduction of this
exercise, or consult the Help documentation.
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After you have created the multi-category tags within the Family Editor, you can load them into the
template.

30 Click File menu ➤ Load from Library ➤ Load Family.

31 Navigate to the directory that contains the tag you want to load, select the tag, and click Open.

The tag is now part of the template.

Create multi-category schedules

32 On the View tab of the Design Bar, click Schedule/Quantities.

33 Select <Multi-Category> for Category.

34 Under Name, enter a name for the schedule, and click OK.

35 Create the schedule as you did in the previous exercise.

Notice that the shared parameters created in previous steps are included under Available fields.

36 When you have completed the schedule, click OK.

37 Create additional multi-category schedules as needed.

38 Proceed to the final exercise, “Creating Named Print Settings” on page 49.

Creating Named Print Settings

In this exercise, you create named print settings, and add them to your default template file. This can be beneficial if
you have numerous printers in a large networked office. For each printer, you can set options such as sheet sizes, paper
placement, and the percent of actual size. You can also create named settings for printing to a DWF writer. By creating
named settings within the template, you need only select a setting, make minor modifications if necessary, and print.

Create named print settings

1 Click File menu ➤ Print.

2 Under Name, select the first printer for which you want to create named settings.

3 Under Settings, click Setup.

4 Click Save As.
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5 In the New dialog, enter a name for the print setting and click OK.

6 Modify the printer settings.

7 If you want to have multiple settings for this printer, click New, and create additional settings as needed.

8 Click OK when you have finished creating named settings for this printer.

9 In the Print dialog, select a different printer, click Setup, and create new settings for this printer.

10 Repeat these steps as needed.

TIP You can also create named settings for your DWF writer.

11 Click OK when finished.

Your template is complete. The only remaining task is to save it.

Save the template

12 Click File menu ➤ Save.

13 Navigate to the directory where you want to save the template.

If you need to share this file with others, you should save it to a network path.

14 Under Save as type, select Template Files (*.rte).

15 Name the template, and click Save.

Use the template

16 To use the template, click File menu ➤ New ➤ Project.

17 Select Browse, and navigate to the location where you saved the template.

18 Select the template, and click Open.

19 Click OK.

The changes you made to the template are now the starting point for this project.

You can also set this template as your default template.
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Set the template as your default template file

20 Click Settings menu ➤ Options.

21 Click the File Locations tab.

22 Next to Default template file, click Browse.

23 Navigate to the template location, select it, and click Open.

24 Click OK.

TIP Another way to create a template is to delete all model geometries from an existing project, and save it as
a template file. This can provide a good starting point for a template. In addition, you can use the Transfer Project
Standards tool to move standards from one project to another.

In this lesson, you modified settings, loaded components, and saved them to a template. By investing the time to
individualize your template, you help ensure the office standards are maintained and reduce repetitive work that would
be done by each employee for each project.
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Starting a New Project

In this tutorial you begin your structural model in Autodesk® Revit® Structure 4, by importing or linking

an existing Autodesk® architectural project created in AutoCAD®, Architectural Desktop™, and Revit®

Building.

3
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Importing/Linking Drawing Files
In this lesson, you learn how to import or link to files from different drawing programs. The imported file is used as a
background template for creating the structural elements of the model.

Importing/Linking a 2D AutoCAD File

In this lesson, you learn how to import or link a 2-dimensional (2D) drawing created in AutoCAD for use as a background.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog box, click the Training Files icon.

■ Open i_RST_CSM_1.rvt located in the Imperial folder.

NOTE For training purposes, some structural columns were added to the model at off-grid locations in conjunction with
architectural columns. In the next tutorial “Creating a Structural Model” on page 65, you use these columns to complete
the structural framing.

1 In the Project Browser ➤ Views (all) ➤ Structural Plans.

Notice that Level 2 is bold. This is the active view that displays in the drawing area.

2 Click File menu ➤ Import/Link ➤ CAD Formats.

3 In the left pane of the Import/Link dialog, click the Training Files icon, and select i_STR_CSM_Level2.dwg
located in the Imperial folder.

4 In the Import/Link dialog;

■ Under Import or Link, select both Link (instead of import) and Current View Only.

NOTE Selecting Current View Only prevents the DWG file from appearing in all views. The file becomes
view specific and will behave like an annotation. Selecting Link (instead of import) allows you to view, drag,
copy, paste, and rotate the view as one object. However, you cannot select individual elements in the linked
model.

■ Under Layer/Level Colors, select Black and White.

■ Under Positioning, select Automatically place and Center-to-center.

■ Click Open.
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Exterior facade outlines, stairs and elevator opening symbols, and a few basic interior walls and doors
display in the view.

5 In the drawing area, click the imported/linked file.

6 On the Options toolbar, click  to pin the drawing so that it cannot be moved within the drawing area.

7 Click View menu ➤ Visibility/Graphics.
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8 In the Visibility/Graphic dialog, select the Imported Categories tab.

9 Select Halftone for value of i_STR_CSM_Level2.dwg , and click OK.

The halftone of the imported drawing is used as a background for placing columns.

10 Click File menu ➤ Close.

You can save the open file if you wish. In the next tutorial, “Creating a Structural Model” on page 65, a
new dataset is supplied.

Importing /Linking an Architectural Desktop File

In this lesson, you learn how to import a 3-dimensional (3D) drawing created in Architectural Desktop for use as a
background. Before exporting the file from Architectural Desktop, the file should be prepared as follows;

■ Proxy graphics should be enabled by setting the system variable to 1.

■ Bind all external reference files (xrefs) to make the architectural data visible to the engineer after export. In the
Xref Manager dialog, select each file and select Insert for Bind Type.

■ On the File menu, select Export to AutoCAD, and select the latest available format.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog box, click the Training Files icon.

■ Open i_RST_CSM_1.rvt located in the Imperial folder.

NOTE For training purposes, some structural columns were added to the model at off-grid locations in conjunction with
architectural columns. In the next tutorial, “Creating a Structural Model” on page 65, you use these columns to complete
the structural framing.

1 In the Project Browser, expand Views (all), and expand Structural Plans.

Notice that Level 2 is bold. This is the active view that displays in the drawing area.

2 Click File menu  ➤ Import/Link ➤ CAD Formats

3 In the left pane of the Import/Link dialog, click the Training Files icon, and select i_RST_Import_ADT.dwg
located in the Imperial folder.

4 In the Import/Link dialog;

■ Under Layer/Level Colors, select Invert Colors.
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■ Under Positioning, select both Automatically Place and Origin-to-Origin.

■ Click Open.

Exterior facade outlines, stairs, and elevator opening symbols, and a few basic interior walls and doors
display in the view.

5 In the drawing area, click the imported/linked file.

6 On the Options toolbar, click  to pin the drawing so that it cannot be moved within the Revit Structure
drawing area.
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7 Click View menu ➤ Visibility/Graphics.

8 In the Visibility/Graphic dialog, click the Imported Categories tab.

9 Select Halftone for value of i_RST_Import_ADT.dwg , and click OK.

The halftone of the imported drawing is used as a background for placing columns.

10 On the View toolbar, click  .

11 In the drawing area, click the linked file.

12 On the Options toolbar, click Partial Explode.
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13 Select any column, and on the Option Bar, click  .

14 In the Element Properties dialog, do the following:

■ Under Constraints, enter - 1' 0" for Base Offset.

■ Click OK.

Notice the column adjusts to the change.

15 Close the Element Properties dialog.

16 Click File menu ➤ Close.

You can save the open file if desired. In the next tutorial, “Creating a Structural Model” on page 65, a new
dataset is supplied.

Linking a Revit Building File

In this exercise, you learn how to link to a 3-dimensional (3D) drawing created in Revit Building for use as a background.
You also learn how to use the Copy/Monitor feature to provide project coordination between architects and structural
engineers. You can copy grids, levels, columns, walls, and floors from the original design and monitor any changes
made to those elements.

Open a new project

1 Click File menu ➤ New ➤ Project.

2 In the New Project dialog, select a template file, select Project under Create New, and click OK.
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Notice that Level 2 is bold. This is the active view that displays in the drawing area.

Linking a Revit Building file

3 Click File menu ➤ Import/Link ➤ Revit.

4 In the left pane of the Import/Link dialog, click the Training Files icon, and select i_STR_CSM_Revit.rvt
located in the Imperial folder.

5 In the Add Link dialog, under Positioning, select Automatically Place and Origin-to-Origin.

6 Click Open.

Exterior facade outlines, stairs and elevator opening symbols, and a few basic interior walls and doors
display in the view.

7 Enter ZF. This is the keyboard shortcut for Zoom to Fit.

8 In the drawing area, click the linked file.

9 On the Options toolbar, click  to pin the drawing so that it cannot be moved within the Revit Structure
drawing area.
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10 Click Tools menu ➤ Copy/Monitor ➤ Select Link.

11 Click the imported Revit drawing. The Design Bar changes to Copy/Monitor mode

Setting options

12 On the Design Bar, click Options.

The Copy/Monitor Options dialog opens. Elements available for monitoring are separated into 5 categories
(Levels, Grids, Columns, Walls, and Floors). On each tab the Original Type column identifies the type for
the Revit Building file, and the New Type for the corresponding element available in the template selected.
Each tab provides various parameters that can be set for that specific element. Also, you can exclude element
types you do not want to copy.

13 In the Copy/Monitor Options dialog, click the Columns tab.

NOTE Architectural columns typically extend through multiple layers of a model. A column may span from level
1 to level 10 of a structure and may present a problem when the analytical model is generated. Therefore,
columns need to be split at each level.

14 In the Columns dialog, under Additional Copy Parameters, select Split Columns by Levels.

15 Set the other parameter as desired. When finished, click OK to close the Copy/Monitor Options Dialog.

Copying grids

16 In the Project Browser, under Structural Plans, select Level 2.

17 On the Copy/Monitor Design Bar, click Copy.

18 Click the grid to be copied/monitored.

To select more than one grid, click Multiple on the Options toolbar, press Ctrl, while making selections.
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NOTE If you are prompted that the element type already exists in the project, and that the type from the new
project will be used, click OK.

After you select the grid, an eyeball symbol is displayed to indicate a relationship with the original element.

NOTE A warning message may indicate that the loaded type has been renamed. The warning can be ignored.

Copying levels

19 In the Project Browser, under Elevations (Building Elevation), double-click Building Elevation.

20 On the Copy/Monitor Design Bar, click Copy.

21 Click the level to be copied/monitored.

To select more than one level, click Multiple on the Options toolbar, press Ctrl, and select each level.

NOTE If you are prompted that the element type already exists in the project, and that the type from the new
project will be used, click OK.
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After you select each level, an eyeball symbol is displayed to indicate a relationship with the original
element.

NOTE A warning message may indicate that the loaded type has been renamed. The warning can be ignored.

Copying structural walls, floors, and columns

22 In the Project Browser, under Structural Plans, select Level 1.

23 On the Copy/Monitor Design Bar, click Copy.

24 Click the structural elements to be copied/monitored.

To select more than one element, click Multiple on the Options toolbar, press Ctrl, and select each element.

NOTE If you are prompted that the element type already exists in the project, and that the type from the new
project will be used, click OK.

After selecting each element, an eyeball symbol is displayed to indicate a relationship with the original
element.

NOTE A warning message may indicate that the loaded type has been renamed. The warning can be ignored.

25 On the Design bar, Click Finish Mode.

Change the structural usage of the copied elements

26 Select a structural wall to be copied/monitored, and on the Option Bar, click  .

27 In the Element Properties dialog, select Bearing for Structural Usage, and click OK.
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28 Select a floor to be copied/monitored, and on the Option Bar, click  .

29 In the Element Properties dialog, check the value for Structural, and click OK.

NOTE For all copied/monitored structural walls, columns, and floors, the structural usage parameter must be
changed in the Element Properties dialog, so that Revit Structure will enable the analytical projection plane
feature for those elements.

30 Click File menu ➤ Close.

NOTE All copied elements are monitored for possible changes. In a later tutorial, “Project Coordination” on
page 273, the updated Revit Building file is reloaded into Revit Structure. The coordination monitor function
provides notification that updates have occurred.

You can save the open file if you wish. In the next tutorial, a new dataset is supplied.

31 Proceed to the next tutorial, “Creating a Structural Model” on page 65.
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Creating a Structural Model
In this lesson, you create the structural model using the tools available in Autodesk® Revit® Structure 4. You begin by
adding columns from Ground Level to Level 2. You copy columns and use the paste-align command to add structure
to other levels. You also learn how to splice the columns. After you copy columns, you add horizontal framing to an
area of Level 2, and then copy this framing to other levels.

Completed model

Adding Grid Lines to the Imported Drawing

In this exercise, the imported drawing is a halftone, that you use as a background drawing for placing columns.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_CSM_Grids.rvt located in the Imperial folder.

1 On the View toolbar, click  , and draw a zoom box around the upper-left corner of the structural
model as shown.
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2 On the Drafting tab of the Design Bar, click Grid.

3 On the Options Bar, click  .

4 Select the left vertical grid line.

Notice the grid line is highlighted with a blue value within the grid head.

5 Click the value in the grid head, and enter A.

As you select subsequent grid lines, they are labelled in alphabetical sequence.

6 Select the next vertical grid line to the right of grid line A.

Notice it is labeled B.

7 Select the remaining vertical grid lines moving from left to right. Zoom in and out as needed.
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8 When you get to grid I, change the value to J. The last vertical grid is K.

9 On the View toolbar, click  , and select Zoom in Region.

10 Draw a zoom region around the upper-right corner of the structural model.

11 Select the upper horizontal grid line.

Notice it is grid L.

12 Click the blue value within the grid line L head, and enter 1 for the new value.

13 Select the next grid line below grid 1.

Notice that the sequencing has adjusted from alphabetical to numeric.

14 Select the remaining 3 horizontal grids. The bottom grid should be grid 5.

68 | Chapter 4   Creating a Structural Model



15 On the Design Bar, click Modify.

16 Click File menu ➤ Save As.

17 Navigate to a folder of your preference, and save the file as i_CSM-in-progress.rvt .

18 Proceed to the next exercise, “Adding Structural Columns” on page 69.

Adding Structural Columns

In this exercise, you load a new column type from the Revit Structure Library and add columns at each grid intersection.
These columns extend from an elevation to a splice elevation just above Level 2.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_CSM-in-progress.rvt

Place columns at grid intersections

1 On the keyboard, enter ZF.

This is the shortcut key for Zoom to Fit.

Level 2 plan view

2 On the Modelling tab of the Design Bar, click Structural Column.

NOTE If the Modelling tab of the Design Bar does not display, right-click in the Design Bar, and click Modelling.

3 In the Type Selector, selectW-Wide Flange-Column: W10x33 .

4 In the Options Bar, click  .

NOTE When you use the Grid Intersection tool to place columns, Revit Structure places the tops of the columns
at the current level, and the bases of the columns at the level below.

5 Select the entire grid by drawing a pick box around it.
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6 On the Options Bar, click Finish.

7 Press ESC or Modify to finish the placing the columns.

Notice that columns are placed at each grid intersection. In addition, there are a few extraneous columns
on grid line intersections that are exterior to the structure.

8 Select the columns that are outside of the structure footprint, and press DEL. The exact list of columns to
delete is listed:

■ G1, H1, J1, K1

■ G2, H2, J2, K2

■ G5, H5, J5, K5

■ K3

■ A5, B5, C5

Specify base and top of column elevations, and splicing.

9 Right-click the column located at C2, and click Select All Instances.

TIP You may have to zoom into the grid intersection to right-click one of the columns.

10 On the Options Bar, click  .

11 In the Element Properties dialog, do the following:

■ Under Constraints, enter 0' 0" for the Base Offset value.

■ Under Constraints, enter 2' 0" for the Top Offset value.

■ Under Graphics, select Welded Connection.

A welded connection graphically adds a splice symbol to the columns. In a coarse detail view, the
welded connection is visible as 2 vertical lines at the splice location.

■ Click OK.

12 On the Design Bar, click Modify.
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Create new levels

13 In the Project Browser, expand Elevations (Building Elevation), and double-click South Elevation.

14 On the Drafting tab of the Design Bar, click Level.

15 Draw a new level: drawing from left to right, start the level line 10' 0" above Level 2, and align the endpoint
with the level heads of the existing elevations.

NOTE If necessary, you can adjust the height by clicking the temporary dimension and modifying the level
elevation. Level 3 should be 10' 0" above Level 2.

Notice the new level is named Level 3. A new structural plan view by the same name is also created and
listed within the Project Browser.

16 Repeat this procedure to create Level 4.

Level 4 should be 10' 0" above Level 3 with an elevation of 30' 0" .

17 On the Design Bar, click Modify.

Adjust location of the grid

18 Select grid head A.

19 Adjust the zoom settings so you can select the grid control below the grid head.

20 Drag the grid control above Level 4 as shown.

Copy the columns to new levels

21 In the Project Browser, under Structural Plans, double-click Level 2.

22 Draw a pick box around the entire structural model.

23 On the Options Bar, click  .

24 In the Filter dialog, click Check None, select Structural Columns, and click OK.

All of the structural columns in the model remain selected.

25 Click Edit menu ➤ Copy to Clipboard.

26 Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.
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27 In the Select Levels dialog, select Level 3 and Level 4, and click OK.

TIP Press and hold CTRL when making multiple selections.

28 On the Design Bar, click Modify.

29 In the Project Browser, under Elevations (Building Elevation), double-click South Elevation.

Spliced columns display from Ground Level to Level 4

30 Click File menu ➤ Save.

31 Proceed to the next exercise, “Add Horizontal Framing to the Levels” on page 72.

Add Horizontal Framing to the Levels

In this exercise, you frame 4 bays of Level 2 by adding horizontal members and a steel deck.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_CSM-in-progress.rvt

Specify beam type

1 In the Project Browser, under Structural Plans, double-click Level 2.

2 On the Modelling tab of the Design Bar, click Beam.

3 In the Type Selector, selectW-Wide Flange: W18x40 .

Add girders

4 On the View Toolbar, click  , and draw a zoom box around the east area of the structure as shown.
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5 On the Options Bar:

■ Specify Level 2 for Plane.

■ Specify Girder for Usage.

■ Click Grid.

6 Press CTRL and select grid lines H and J.

TIP Place the cursor over a grid and the tooltip displays the grid name.

7 On the Options Bar, click Finish.

8 On the Design Bar, click Modify.

9 On grids H and J, delete the two small beam sections between grid lines 4 and 5.

10 On the Modelling tab of the Design Bar, click Beam.

11 On the Options Bar:

■ Specify Level 2 for Plane.

■ Specify Girder for Usage.

12 Select a column center, and draw a girder from column to column, framing the bays with girders.
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NOTE In the following image, framing tag visibility was turned off and the beam visibility increased for training
purposes.

13 On the Design Bar, click Modify.

Set top of steel

14 Right-click the girder between H3 and J3, and click Select All Instances.

15 On the Options Bar, click  .

16 In the Element Properties dialog, under Constraints, enter -0' 7" for Geometry Offset, and click OK.

Copy the girders to levels above

17 On the Edit menu, click Copy to Clipboard.

18 On the Edit menu, click Paste Aligned ➤ Select Levels by Name.

19 In the Select Levels dialog, select Level 3 and Level 4.

20 Click OK.

21 In the Project Browser, expand 3D Views, and double-click East Section - Perspective.

NOTE If necessary, you can select the crop region and drag the extents to adjust the extents of the view.

Notice the copied beams on levels 3 and 4.
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Sketch a beam system

22 In the Project Browser, under Structural Plans, double-click Level 2.

23 Zoom in on the east side of the structure where you previously added the beams.

24 On the Modelling tab of the Design Bar, click Beam System.

25 On the Options Bar, click  .

26 On the Design Bar, click Structural Beam System Properties.

27 In the Element Properties dialog, specify the following parameter values:

■ Under Constraints, enter -0' 7" for Elevation.

■ Under Pattern, select Fixed Distance for Layout Rule.

■ For Spacing, enter 6' 0" .

■ For Justification, select Center.

■ For Beam Type, select W-Wide Flange: W14x22 .

28 Click OK.

29 On the Design Bar, click Pick Supports.

30 Select the girder between H3 and J3. Then select the 3 girders that surround the upper-left bay as shown.

NOTE The 2 short lines adjacent to the H3-J3 girder represent the beam system direction. The longitudinal axis
of the beam system members will be placed parallel to these lines. In the next step you edit the beam direction.

31 On the Design Bar, click Beam Direction.

32 Select the vertical girder between J2 and J3 as shown.
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33 On the Design Bar, click Finish Sketch.

NOTE In the image above and all subsequent images, the framing tag visibility has been turned off for training
purposes. In your dataset, the framing tags display.

34 Repeat the beam system process for the bay to the right using the following beam system property values
in the Element Properties dialog:

■ Under Constraints, enter -0' 7" for Elevation.

■ Under Pattern, select Fixed Number for Layout Rule.
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■ For Number of Lines, specify 2.

■ For Beam Type, select W-Wide Flange: W14x22 .

35 When specifying the beam direction, select the girder between J2 and J3 as shown.

36 On the Design Bar, click Finish Sketch.

Automatically create a beam system

37 In the Project Browser, under Structural Plans, double-click Level 2.

38 Zoom in on the east side of the structure where you previously added the beams.

39 On the Modelling tab of the Design Bar, click Beam System.

40 On the Options Bar, click  .
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41 In the Element Properties dialog, do the following:

■ Under Constraints, enter -0' 7" for Elevation.

■ Under Pattern, select Fixed Number for Layout Rule.

■ For Number of Lines, specify 3.

■ For Beam Type, select W-Wide Flange: W14x22 .

■ Click OK.

42 Select the top girder in the lower-left bay as shown.

43 Click to place the beam system.

44 Select the top girder in the lower-right bay as shown.
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45 Click to place the beam system.

46 On the Design Bar, click Modify.

Copy the beam systems to levels above

47 Hold the cursor over grid line H of the lower-left beam system, and press TAB until the beam system
highlights.

NOTE A beam system displays with dashed lines as shown. Be sure that you have selected a beam system (not
just a beam) when copying elements to other levels. You will need to cycle through some of the elements in
your model by pressing TAB as explained above.

Beam system displays with dashed lines

48 Right-click on the beam system, and click Select All Instances.
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49 Click Edit menu ➤ Copy to Clipboard.

50 Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

51 In the Select Levels dialog, select Level 3 and Level 4.

52 Click OK.

53 In the Project Browser, under 3D Views, double-click East Sections - Perspective.

Notice the copied beam systems.

Add composite deck

54 In the Project Browser, under Structural Plans, double-click Level 2.

55 On the Modelling tab of the Design Bar, click Slab.

56 On the Design Bar, click Floor Properties.

57 In the Element Properties dialog, do the following:

■ For Type, select 3" LW Concrete on 2" Metal Deck .

■ Under Constraints, specify -0' 2" for Height Offset from Level.

58 Click OK.

59 On the Design Bar, click Lines.
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60 Sketch lines along the structure perimeter using the interior-most model lines of the glazing as snap points,
and then sketch along the girders as shown.

61 On the Design Bar, click Finish Sketch.

Revit Structure provides a deck span direction symbol when the deck is placed. The filled half-arrows of
this symbol represent the span of the deck.

Rotate the span direction

62 Select the span direction symbol.

The span direction arrows are parallel and just beneath grid line 3.

63 On the Edit menu, click Rotate.

64 On the Options Bar, enter -90 for angle, and press Enter.

Notice the span direction arrows have rotated 90 degrees and are now vertical.

Copy the slab to other levels

65 Select the slab.

66 Click Edit menu ➤ Copy to Clipboard.

67 Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

68 In the dialog, select Level 3 and Level 4, and click OK.

69 On the Design Bar, click Modify.
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70 In the Project Browser, under 3D Views, double-click East Section - Perspective.

71 Click File menu ➤ Save.

72 Proceed to the next exercise, “Add Bracing” on page 82.

Add Bracing

In this exercise, you add vertical bracing to a bay.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_CSM-in-progress.rvt

Create the framing elevation

1 In the Project Browser, under Structural Plans, double-click Level 2.

2 On the View tab of the Design Bar, click Framing Elevation.

3 Place a framing elevation symbol between 4H and 4J in the direction shown.
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When you position the framing elevation near grid line 4, click when the grid line highlights.

4 In the Project Browser, under Elevations (Interior Elevations), double-click Elevation 1-a.

5 On the Modelling tab of the Design Bar, click Brace.

6 In the Type Selector, select L-Angle: L8x6x5/8 .

7 Add a brace from Level 2 to Level 3:

■ Enter SE on the keyboard and snap the cursor to the left endpoint of the Level 2 beam for the start
point. Use the Status Bar to see the snap point.

■ Enter SM on the keyboard, and select the midpoint of the beam at Level 3 for the endpoint.

NOTE If necessary, you can select the crop region and adjust the left/right extents to see the columns on grids
H and J.
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8 Repeat this step for the opposite brace.

9 Repeat these steps to add bracing from Level 3 to Level 4.

10 In the Project Browser, under 3D Views, double-click East Section - Perspective.

Notice the braces in the back/right of the structural model.

11 Click File menu ➤ Save.

12 Proceed to the next exercise, “Adding Shear Walls” on page 85.
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Adding Shear Walls

In this exercise, you create shear walls that surround one of the stairwells.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_CSM-in-progress.rvt

1 In the Project Browser, under Structural Plans, double-click Level 2.

2 Zoom in on the east stair within the quadrant F3-G4.

3 On the Modelling tab of the Design Bar, click Structural Wall.

4 In the Type Selector, select Basic Wall: Exterior - 10" Concrete .

5 On the Options Bar, specify the following:

■ Select Chain.

■ Specify Ground Level for Depth.

6 Sketch 4 walls as shown.
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When sketching, trace over the centerline of the walls in the imported drawing file.

TIP After sketching the walls, you can select a wall and use the arrow keys on your keyboard to nudge the wall
to a particular location.

7 Press ESC twice to finish placing walls.

8 Select all 4 walls.

TIP During selection, you can use the TAB key to toggle to the wall chain and select it with one click.

9 On the Options Bar, click  .

10 In the Element Properties dialog, under Constraints, specify Up to level: Level 4 for Top Constraint, and
click OK.

11 Click File menu ➤ Save.

12 Proceed to the next exercise, “Adding Isolated Foundations” on page 86.

Adding Isolated Foundations

In this exercise, you add isolated foundations to column locations.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_CSM-in-progress.rvt

Place isolated foundations

1 Within the Level 2 Structural Plan, right-click the W10x33 column at H4, and click Select All Instances.
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2 On the Options Bar, click  .

3 In the Element Properties dialog, under Structural Analysis, verify the following:

■ For Analytical Projection Plane Top, select Level 2.

■ For Analytical Projection Plane Bottom, select Ground Level.

■ Click OK.

4 On the Design Bar, click Modify.

5 In the Project Browser, under Structural Plans, double-click Ground Level.

6 On the Modelling tab of the Design Bar, click Foundation ➤ Isolated.

7 In the Type Selector, select Footing-Rectangular: 72"x48"x18" .

8 In the drawing area, snap the cursor to the midpoint of the columns where you have added horizontal
framing to place an isolated footing at each location.

NOTE In the following image, the curtain wall visibility was altered for training purposes. In your dataset, the
imported DWG file does not display in this view.

By default, the footing is placed at Ground Level.

9 On the Design Bar, click Modify.
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10 In the Project Browser, under 3D Views, double-click East Section - Perspective.

11 Click File menu ➤ Save.

12 Proceed to the next exercise, “Completing the Structural Model” on page 88.

Completing the Structural Model
In previous lessons, you have added columns and horizontal framing to your model. In the exercises that follow, you
complete the structural model, adding horizontal framing, bracing, openings, foundation, and concrete wall framing.

Complete the Steel Framing of Level 2

In this exercise, you complete the horizontal framing of Level 2 by adding girders and beam systems, as well as cantilevers
and outriggers.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_CSM_2.rvt located in the Imperial folder.

Add girders using the grid tool

1 In the Project Browser, under Structural Plans, double-click Level 2.

2 On the Modelling tab of the Design Bar, click Beam.

3 In the Type Selector, select W-Wide Flange: W18x40 .

4 On the Options Bar:

■ Specify Level 2 for Plane.

■ Specify Girder for Usage.

■ Click Grid.

NOTE Although you previously added girders to the structural model, using the grid tool does not duplicate
girders at these locations.

5 Draw a pick box around all the grids.
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TIP You can also press CTRL and select all grid lines manually.

6 On the Options Bar, click Finish.

7 On the Design Bar, click Modify.

Manually add additional beams

8 Zoom around the bay in the upper-left corner of the model.

9 Select the framing tag between A1 and A2.

10 On the View Control Bar, click the Hide/Isolate control, and click Hide Category.

Notice that framing tags no longer display within this view. This is a temporary setting that you can turn
off by selecting Reset Temporary Hide/Isolate from the Hide/Isolate control.

11 Using the framing skills you have learned in previous steps, complete the framing of this bay as shown.
Use the W-Wide Flange: W18x40 beam type for the 3 new beams.

12 Add girders between the perimeter columns that were not captured by the grid tool.

Zoom in and out as needed. Add the beam chains to the following locations:

■ Above grid line 1 between B and E.

■ Around the perimeter of the rotunda.

■ Between the column below the midpoint of H2-H3 and the corner of the stairwell shear walls.

■ Between the column just above K4 and over to F5.

■ Between the lower-left corner between A4 and D5.

Specify the top of steel

13 Zoom around the bay in the upper-left corner of the model.

14 Right-click the girder between A2 and B2, and click Select All Instances.

15 On the Options Bar click  .

16 In the Element Properties dialog, under Constraints, specify -0' 7" for Geometry Offset, and click OK.

Frame the remaining bays

17 On the Modelling tab of the Design Bar, click Beam System.

18 On the Design Bar, click Structural Beam System Properties.

19 In the Element Properties dialog, specify the following parameter values:

■ Under Constraints, enter -0' 7" for Elevation.
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■ Under Pattern, select Fixed Number for Layout Rule.

■ Specify 3 for Number of Lines.

■ Select W-Wide Flange: W14x22 for Beam Type.

■ Click OK.

20 On the Design Bar, click Pick Supports.

21 In the bay adjacent to the upper-left stairwell, select the 4 girders as shown.

TIP Use the Trim tool to clean up gaps in the loop or overlapping intersections.

NOTE Make sure the beam direction is horizontal. Use the Beam Direction tool to make adjustments.

22 On the Sketch tab, click Finish Sketch.

23 Using the same beam system properties, use the Pick Support tool to create the beam system boundary as
shown.

TIP Use the Trim tool to trim the lower beam and properly place the beam direction.

24 On the Sketch tab, click Finish Sketch.

25 Select the beam that spans the middle of the stairwell and delete it.

If a warning appears indicating that pinned objects were deleted, ignore it.
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26 On the File menu, click Close.

NOTE You can save the open file if you wish. Rather than add beam systems to the dozens of bays within this
model, a new dataset is provided in the next step with the beam systems added as shown.

Open new dataset

27 Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.
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■ Open i_RST_CSM_3.rvt located in the Imperial folder.

In this new dataset, beam systems have been added to all bays. The visibility of structural framing tags has
been turned off in the Level 2 plan view. In addition, the structural framing on levels 3 and 4 that you
built in the first lesson of this tutorial have been deleted for training purposes. Lastly, the base offset of
the structural columns on the lower level has been set to zero so they will attach to the footings.

Add cantilevered members and outriggers

28 In the Project Browser, under Structural Plans, double-click Level 2.

29 Zoom into the upper-left corner of the model.

30 On the Modelling tab of the Design Bar, click Beam.

31 On the Options Bar, click  .

32 In the Element Properties dialog, under Constraints, enter -0' 7" for Geometry Offset, and click OK.

Add cantilevers at columns

33 Select column A1 as the beam start point.
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34 Move the cursor to the left and select a perpendicular point on the inside face of the exterior glazing as
the endpoint.

35 Repeat these steps to add a cantilever beginning at column A2.

Add an outrigger

36 Add an outrigger using a W-Wide Flange: W18x40 beam type.

■ Select the left endpoint of the cantilever at A1 as start point of the outrigger.

■ Select the left endpoint of the adjacent cantilever at A2 as the end point of the outrigger.

Add intermediate cantilevers

37 Sketch intermediate beams between the outrigger and the beam between A1 and A2 as shown.
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38 On the File menu, click Close.

You can save the open file if you wish. In the next exercise, a new dataset is supplied.

39 Proceed to the next exercise, “Adding a Steel Deck” on page 94.

Adding a Steel Deck

In this exercise, you add a steel deck to the model.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_CSM_4.rvt located in the Imperial folder.

In this dataset, additional cantilever beams and outriggers were added to the model. In addition, the following new
levels were added: 5, 6, 7, Roof, Garage Level-1, and Foundation. The pre-existing columns were paste-aligned to the
roof level.

1 In the Project Browser, under Structural Plans, double-click Level 2.

2 On the Modelling tab of the Design Bar, click Slab.
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3 On the Design Bar, click Floor Properties.

4 In the Element Properties dialog, do the following:

■ For Floor Type, select 3" LW Concrete on 2" Metal Deck .

■ For Height Offset from Level, specify -0' 2" .

■ Click OK.

5 On the Design Bar, click Lines.

6 Sketch lines along the structure perimeter using the interior lines of the glazing as snap points.

When sketching this deck, you can use a combination of lines including; sketched, picked, straight, and
arced. Use Trim/Extend to clean up line intersections and close gaps.

TIP To sketch lines along the lower arced wall, select Chain on the Options Bar, and sketch a chain of continuous
line segments.

7 Click Finish Sketch.

8 On the View toolbar, click  .

9 Enter SD. This is the keyboard shortcut for Shading with Edges.

10 Navigate to a folder of your preference, and save the file as i_CSM4-in-progress.rvt
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11 Proceed to the next exercise, “Adding Shafts” on page 96.

Adding Shafts

In this exercise, you add elevator and stair openings to Level 2.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_CSM4-in-progress.rvt

1 In the Project Browser, under Structural Plans, double-click Level 2.

NOTE Make sure this view is using the Wireframe model graphics display style. If it is not, use the View Control
Bar to make the change.

2 Enter WF. This is the keyboard shortcut for wireframe.

3 Zoom around the stairway in quadrant F3-G4.

4 On the Modelling tab of the Design Bar, click Opening.

5 In the Opening Placement Options dialog, select Create shaft opening, and click OK.

The Design Bar changes to Sketch mode.

6 On the Design Bar, click Pick Walls.

7 Select the 4 walls surrounding the stairwell as shown.

8 On the Design Bar, click Properties.

9 In the Element Properties dialog, do the following:

■ For Top Constraint, select Roof.

■ For Base Constraint, select Foundation.

■ For Top Offset, enter -1' 0" .

■ For Base Offset, enter 1' 0" .

■ These settings ensure that the shaft extends through the structure without penetrating the roof or the
foundation.

■ Click OK.

10 On the Design Bar, click Finish Sketch.

11 Repeat these steps for the stairwell and the elevator opening in quadrants A1-B2 and B2-C3.
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For both of these shafts, specify a Top Offset of 1' 0" .

TIP When sketching the shafts, use the Lines tool in combination with the pick option and select the external
face of the walls imported with the DWG file. Use the Trim tool to clean up gaps and intersections.

12 On the View toolbar, click  .

Shafts in Level 2 deck

13 Click File menu ➤ Save.

14 Proceed to the next exercise, “Duplicating Framing” on page 97.

Duplicating Framing

In this exercise, you copy Level 2 framing to other levels.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_CSM4-in-progress.rvt

Copy Level 2 framing and deck

1 In the Project Browser, under Structural Plans, double-click Level 2.

2 Zoom to Fit, and draw a pick box around the entire model.

3 On the Options Bar, click  .

4 In the Filter dialog, click Check None, select Structural Framing, Structural Beam Systems, and Floors, and
then click OK.

5 Click Edit menu ➤ Copy to Clipboard.

6 Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

7 In the Select Levels dialog, select Level 4, Level 5, and Roof, and then click OK.
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8 On the View toolbar, click  .

Copied levels with stair and elevator openings

Modify roof and framing

9 In the Project Browser, under Structural Plans, double-click Roof.

10 Select the floor.

11 On the Options Bar, click Edit.

12 Delete the atrium arc and use the Trim tool to close the gap as shown.

NOTE In the image shown above, the weight of the sketch lines was increased for training purposes.

13 On the Design Bar, click Finish Sketch.

14 Zoom in around the former atrium area, and select all framing and columns as shown.

NOTE Hold the CTRL key down as you make multiple selections.
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15 Press Delete on the keyboard.

Ignore the warning that pinned objects were deleted.

Add cantilever beams and outriggers

16 Zoom in on the former atrium area as shown.

17 On the Modelling tab of the Design Bar, click Beam.

18 On the Options Bar, specify Girder for Usage.

19 Add cantilever beams and outriggers as shown to complete the new corner.

Copy roof framing and slab to levels 6 and 7

20 Zoom out until you can see the entire model within the drawing area.

21 Draw a pick box around the entire model.
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22 On the Options Bar, click  .

23 In the Filter dialog, click Check None, select Structural Framing, Structural Beam Systems, and Floors, and
then click OK.

24 Click Edit menu ➤ Copy to Clipboard.

25 Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

26 In the Select Levels dialog, select Level 6, and Level 7, and click OK.

27 On the View toolbar, click  .

Notice the atrium columns on levels 6 and 7 need to be deleted. This is done for you in the next dataset.

28 Click File menu ➤ Close.

You can save the open file if you wish. In the next exercise, a new dataset is supplied.

29 Proceed to the next exercise, “Adding a Roof” on page 100.

Adding a Roof

In this exercise, you create a roof above level 7.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_CSM_5.rvt located in the Imperial folder.
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1 In the Project Browser, under Structural Plans, double-click Roof.

2 On the View menu, click View Properties.

3 In the Element Properties dialog, under Instance Parameters, select Level 7 for Underlay Value.

NOTE Level 7 is selected so you can see the footprint of the slab.

4 Click OK.

5 On the Architectural tab of the Design Bar, click Roof ➤ Roof by Footprint.

NOTE The Roof command does not provide analytical properties. If the roof is required to provide these properties
for analysis, select the Slab command under the Modelling tab of the Design Bar.

6 On the Architectural tab of the Design Bar, click Lines.

7 On the Options Bar, click  .

Trace the outline for the roof

8 Select the exterior edge of the steel deck, using the following illustration for guidance.

NOTE Verify that the deck is selected and not the structural framing
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Trace the outline of 2 shaft openings

9 On the Toolbar, click  , and draw a zoom box around the upper-left corner of the model.

10 Select the walls that outline both shaft openings as shown.

11 On the Design Bar, click Finish Roof.

12 Click View menu ➤ View Properties.

13 In the Element Properties dialog, under Instance Parameters, select None for Underlay Value.

14 Click OK.

15 Click File menu ➤ Save As.

16 Navigate to a folder of your preference, and save the file as i_CSM5-in-progress.rvt

17 Proceed to the next exercise, “Adding an Opening ” on page 102.

Adding an Opening

In this exercise, you add an opening (doorway) to the structural walls of the emergency stairway. The opening is then
copied to each level.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_CSM5-in-progress.rvt

1 In the Project Browser, under Structural Plans, double-click Ground Level.

2 On the Toolbar, click  , and draw a zoom box around the emergency stairway as shown.
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3 On the Architectural tab of the Design Bar, click Door.

4 Place the door opening approximately as shown.

5 Select the door opening.

6 Click Edit menu ➤ Copy to Clipboard.

7 Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

8 On the Select Levels dialog, select Level 2.

9 Press SHIFT and select Level 7.
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NOTE Levels 2 through 7 should be highlighted.

10 Click OK.

11 In the Project Browser, under 3D Views, select 3D - Atrium.

12 On the Toolbar, click  , and draw a zoom box around the opening created in the emergency stairway
as shown.

13 Click File menu ➤ Save.

14 Proceed to the next exercise, “Adding an Opening in a Beam” on page 104.

Adding an Opening in a Beam

In this exercise, you add an opening in selected beams by modifying the beam type in the Family Editor, and importing
the revised beam into the project.
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NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_CSM5-in-progress.rvt

1 On the Toolbar, click  , and draw a zoom box around the beams for the lower floors as shown.

2 Click on the beam located on the corner of level 2. This is the beam type that requires the opening.

3 On the Options Bar, click Edit Family.

4 In the Revit dialog, click Yes to open the W-Wide Flange beam type for editing.

The beam is displayed in a new window.

5 In the Family Project Browser, expand Views (all) ➤ Elevations (Elevation 1), and double-click Front.

The Front elevation of the beam is displayed.

6 On the Toolbar, click  , and draw a zoom box around the center line of the beam.

7 On the Family Design Bar, click Void Form ➤ Void Extrusion.

8 On the Work Plane dialog, under Select a New Work Plane, click Name, and select Reference Plane: Center
(Front/Back).

9 On the Work Plane dialog, click OK
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10 On the Options Bar, click  .

11 Click on the centerline of the beam, and draw a circle approximately as shown.

12 Press the ESC key.

13 On the Family Design Bar, click Modify.

14 Select the circle, and on the Options Bar, click  .

15 In the Element Properties dialog, select the Center Mark Visible parameter, and click OK.

The centerline of the circle is now visible.

16 On the Options Bar, click  .

17 Select the vertical centerline reference plane, and select the centerline of the circle.

18 Click the lock to lock the reference plane to the centerline of the circle.

19 Press the ESC key.

20 On the Options Bar, click  .

21 Select the horizontal centerline reference plane, and select the centerline of the circle.

22 Click the lock to lock the reference plane to the centerline of the circle.

23 On the Design Bar, click Finish Sketch.

NOTE Aligning and locking the centerline of the circle to the reference plane ensures the circle will remain in
the center of the beam, regardless of the length.

24 On the View Toolbar, click  .
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25 Click the circle on the beam.

The extrusion is displayed as a cylinder.

26 On the View Control toolbar, select Model Graphic Style: Shading w/Edges.

27 Click the right directional arrow, and slide the cylinder to the right so the extrusion passes through the
beam as shown.

28 Click File menu ➤ Save As.

29 Navigate to a folder of your preference, and save the revised beam family file as W-Wide Flange with
Opening.rfa .

30 On the Family tab of the Design Bar, click Load into Projects.

31 In the Load into Projects dialog, click the box next to the file i_CSM5-in-progress.rvt located in the Imperial
project file, and click OK.

The project file reopens.

32 On the keyboard, enter ZF.
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This is the keyboard shortcut for Zoom to Fit.

33 On the Toolbar, click  , and draw a zoom box around the beams for the lower floors as shown.

34 Click on the lowest beam located on the corner of level 2.

35 Press and hold the CTRL key, while selecting the beams for levels 2 through 4 as shown.

36 On the Type Selector, select the modified beam type W-Wide Flange with Opening: W18X40.rfa .

37 Click in the drawing area.
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The modified beams with openings are displayed as shown.

38 Click File menu ➤ Close.

You can save the open file if you wish. In the next exercise, a new dataset is supplied.

39 Continue with the next exercise, “Adding Foundation Walls” on page 109.

Adding Foundation Walls

In this exercise, you add structural walls. You add these walls using the Ground Level view, and walls are generated
downward to the Foundation.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_CSM_6.rvt located in the Imperial folder.

In this new dataset, the atrium columns on levels 6 and 7 have been deleted. In addition, modified structural framing
and slabs have been copied to levels 2 and 3 to accommodate the front lobby and atrium. Transfer beams were added

Adding Foundation Walls | 109



to Level 4. A roof has been added over Level 7. Openings have been added to both the stairway, and a structural beam.
Lastly, the footings added at the beginning of the tutorial were deleted to make way for piers.

Sketch the atrium walls

1 In the Project Browser, under Structural Plans, double-click Ground Level.

The imported DWG file was copied and paste-aligned to this level for you.

2 On the Modelling tab of the Design Bar, click Structural Wall.

3 In the Type Selector, select Basic Wall: Foundation - 12" Concrete.

4 On the Options Bar, do the following:

■ Specify Foundation for the depth value.

■ For Loc Line, select Wall Centerline

■ Click  .

■ In the Element Properties dialog, under Constraints, enter -0' 6" for Top Offset, and click OK.

5 On the Options Bar, click  .

6 Click the arc line of the imported DWG file.

A foundation wall is added and aligned with the wall centerline.

Sketch the remaining foundation walls

7 On the Options Bar, click  , and select Chain.

8 Use the sketching tools available on the Options Bar to add foundation walls to the remaining perimeter
of the model. Use the center of the curtain wall lines in the DWG file as an underlay to trace over.

On portions of the south wall, you can use an arc or a chain of small wall segments.

9 Press ESC twice to finish the wall sketch.
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10 In the Project Browser, under 3D Views, double-click 3D Atrium.

11 Navigate to a folder of your preference, and save the file as i_CSM6-in-progress.rvt .

12 Proceed to the next exercise, “Adding Piers or Pilasters” on page 111.

Adding Piers or Pilasters

In this exercise, you add piers or pilasters and concrete columns at each steel column location.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_CSM6-in-progress.rvt

Add concrete piers

1 In the Project Browser, under Structural Plans, double-click Ground Level.

2 On the Modelling tab of the Design Bar, click Structural Column.

3 In the Type Selector, select Concrete-Square-Column: 18x18 .

4 In the Options Bar, select Foundation for Depth.

5 Within the perimeter of the structure model, add a concrete column centered on each steel column location.

TIP You can use the Grid Intersection tool to speed up this process. If you select all the grid lines and add columns
to all intersections, make sure you delete the columns outside the structure perimeter. In addition, you will still
need to manually add piers to the locations that are not on a grid line, such as the atrium.

Concrete pier centered on steel column

6 On the Design Bar, click Modify.

7 In the Project Browser, under 3D Views, double-click 3D - Atrium.
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8 Place the cursor over one of the foundation walls, press TAB, and select the foundation wall chain.

9 On the View Control Bar, click the Hide/Isolate control, and click Hide Object.

This provides a better view of the new below-grade piers.

10 Click File menu ➤ Close.

You can save the open file if you wish. In the next exercise, a new dataset is supplied.

11 Proceed to the next exercise, “Frame Ground Level and Parking Garage Level” on page 112.

Frame Ground Level and Parking Garage Level

In this exercise, you frame the garage and ground levels by adding slabs, sloped slabs, and concrete beam framing.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_CSM_7.rvt located in the Imperial folder.

1 In the Project Browser, under Structural Plans, double-click Ground Level.

2 On the Modelling tab of the Design Bar, click Slab.

3 On the Design Bar, click Floor Properties.

4 In the Element Properties dialog, specify the following:

■ Select 6" Concrete for Type.

■ For Height Offset From Level, enter 0.

■ Click OK.

5 On the Design Bar, click Pick Walls.

6 Select the exterior face of the foundation walls. If necessary, use the flip controls to toggle to the exterior
face.
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TIP Press Tab to select the wall chain.

7 Click Finish Sketch.

NOTE When prompted whether you want to attach the walls beneath the slab to the bottom of the slab. Click
Yes.

WARNING If an error dialog displays regarding the span direction component, click Delete Type.

8 In the Project Browser, under 3D Views, double-click 3D - Atrium.

9 In the Project Browser, under Structural Plans, double-click Ground Level.

Frame concrete girders

10 On the Modelling tab of the Design Bar, click Beam.

11 In the Type Selector, select Concrete-Rectangular Beam:16x32 .

12 On the Options Bar, click Grid.

13 Select all grid lines.

14 Remove grid line G from the selection by holding the SHIFT key down and selecting grid line G.

This prevents a beam being added between the atrium at G1 and G3.

15 On the Options Bar, click Finish.

NOTE If you are warned of a problem with keeping elements joined, expand the warning and select the framing
element. It will display as selected in the drawing area. It is most likely a segment that can be deleted or unjoined.
Resolve the problem by clicking the appropriate solution.

16 Manually add a beam between G3 and G4, and another between G4 and G5.

17 On the Design Bar, click Modify.
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Copy the framing and slab to Garage Level -1

18 Drag a pick box around the entire model.

19 On the Options Bar, click  .

20 In the Filter dialog, click Check None, select Structural Framing and Floors, and then click OK.

21 Click Edit menu ➤ Copy to Clipboard.

22 Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.

23 In the Select Levels dialog, select Garage Level -1, and click OK.

24 In the Project Browser, under 3D Views, double-click 3D - Atrium.

Notice the copied elements are selected.

25 On the Design Bar, click Modify.

Add the garage entrance exit ramp

26 In the Project Browser, under Structural Plans, double-click Garage Level -1.

27 On the View Control Bar, click the Model Graphics Style control, and click Hidden Line.

28 Zoom in around the lower-left corner of the model.

29 On the Modelling tab of the Design Bar, click Slab.
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30 On the Design Bar, click Lines.

31 Sketch the slab in the southwest exterior corner of the structure as shown.

32 On the Design Bar, click Slope Arrow.

33 Sketch a slope arrow from left to right as shown.

34 Right-click the slope arrow, and select Properties.

35 In the Element Properties dialog, specify the following:

■ Under Constraints, select Ground Level for Level at Tail.

■ For Height Offset at Tail, enter 0.

■ For Height Offset at Head, enter 0.

■ For Level at Head, select Garage Level-1.

■ Click OK.

36 On the Design Bar, click Finish Sketch.

37 In the Project Browser, under Elevations (Building Elevation), double-click South Elevation.

38 On the View Control Bar, click the Model Graphics Style control, and click Hidden Line.

39 Zoom in on the lower-left corner to see the ramp.
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Completed ramp

Add a sloped beam system under the ramp

40 In the Project Browser, under 3D Views, double-click 3D - Atrium.

41 On the Toolbar, click  , and draw a zoom box around the ramp as shown.

42 On the Modelling Tab of the Design Bar, click Beam System.

43 On the Design Bar, click Set Work Plane.

44 In the Work Plane Dialog, under Specify a new Work Plane, select Pick a plane, and click OK.

45 Select the underside face of the existing ramp.

46 On the Design Bar, select Structural Beam System Properties.

47 In the Element Properties dialog, do the following:

■ Under Beam Type, select Concrete-Rectangular Beam: 16 X 32 .

■ Under Pattern, select Fixed Number for Layout Rule Value.

■ Under Number of Lines, enter 5 for Value.

■ Click OK.

48 In the Project Browser, under Structural Views, select Ground Level.

49 On the Toolbar, click  , and zoom in on the ramp.

50 On the Design Bar, click Lines.

51 Draw an outline of the ramp as shown.
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52 On the Design Bar, click Finish Sketch.

NOTE Ignore the warning regarding the analytical point of the beam and slab.

53 On the View Toolbar, click  .

54 On the View Toolbar, click  , and zoom in on the beam system.

55 Click on one of the beams to select it, hold the CTRL key, and select the remaining 4 beams.

56 On the Options Bar, click  .

57 In the Element Properties dialog, do the following:

■ For Geometry Offset, enter -0' 4 1/4" .

■ For Angle, enter 9.85.

■ Click OK.

58 On the Toolbar, click  , and zoom in on the ramp as shown.

Add a wall opening at the garage entrance

59 On the View Toolbar, click  , and zoom in on the wall that faces the end of the new ramp.

60 On the Modelling tab of the Design Bar, click Opening.

61 In the Opening Placement Options dialog, select Pick a wall to be cut by an opening, and click OK.

62 Select the foundation wall that faces the short edge of the new ramp.

When you are adding a wall opening, there are no drawing tools to select. You can immediately draw the
rectangular opening.

63 Sketch the opening, corner to corner as shown.
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NOTE Depending on where you draw the opening, you may get a warning message that elements cannot
remain joined. In this case, click Unjoin Elements, and continue with the next step.

64 On the Design Bar, click Modify.

65 On the View Toolbar, click  .

66 On the View Toolbar, click  .

67 Zoom in on the model until the garage opening is displayed, and select it.

Notice that you can adjust the opening extents using the controls.

68 On the File menu, click Save.

69 Proceed to the final exercise, “Placing a Wall Foundation” on page 118.

Placing a Wall Foundation

In this exercise, you add a continuous foundation beneath the exterior walls of the structural model. In addition, you
add an isolated foundation beneath the piers.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_CSM7-in-progress.rvt

Sketch the continuous foundation

1 In the Project Browser, under Structural Plans, double-click Foundation.

2 On the Modelling tab of the Design Bar, click Foundation ➤ Wall.

3 Place the cursor over one of the foundation walls, press Tab until the chain of walls is offered as a selection
option, and click to select the foundation wall chain.
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A continuous foundation is added.

4 On the Design Bar, click Modify.

Edit foundation properties

5 Right-click one of the foundation walls.

6 On the Options Bar, click  .

7 In the Element Properties dialog, click Edit/New.

8 In the Type Properties dialog, under Dimensions, edit the following:

■ For Toe length, enter 1' 6" .

■ For Heel length, enter 1' 6" .

■ For Foundation Thickness, enter 1' 6" .

■ Click OK.

9 In the Element Properties dialog, click OK.

Place isolated foundation

10 In the Project Browser, Under Structural Plans, double-click Foundation.

11 On the View menu, click Visibility/Graphics.

12 In the Visibility/Graphics dialog, under Visibility, clear Structural Framing, and click OK.

13 On the Modelling tab of the Design Bar, click Foundation ➤ Isolated.

14 In the Type Selector, select Footing-Rectangular: 72"x48"x18" .

15 Click the midpoint of each of the concrete columns to place an isolated foundation at each location as
shown.
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16 On the Design Bar, click Modify.

17 On the Project Browser, under 3D Views, double-click Atrium.

18 On the File menu, click Save.

You have completed the Creating a Structural Model tutorial. You can save the open file if you wish. In
the next tutorial a new dataset is supplied.

19 Proceed to the next tutorial, “Precast Concrete” on page 121.
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Precast Concrete

In this tutorial, you work with precast concrete components using the tools available in Autodesk® Revit®

Structure 4. In the first lesson, you add a precast concrete beam system to an existing project. You then

modify the precast beam type within the Revit Structure family editor.

5
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Creating a Precast Beam System
In this lesson, you add a precast concrete beam system to an existing structure.

Adding a Beam System to the Structure

In this exercise, you add a precast beam system to the roof of an existing structure.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_Precast_Concrete.rvt located in the Imperial folder.

1 In the Project Browser, under Structural Plans, double-click Roof.

2 On the Modelling tab of the Design Bar, click Beam System.

3 On the Options Bar, click  .

4 In the Element Properties dialog, under Pattern, do the following:

■ For Layout Rule, select Clear Spacing.

■ For Clear Spacing, enter 0' 1" .

■ For Justification, select Center.

■ For Beam Type, select Precast-Double Tee: 8' x 20" .

■ Click OK.

5 Select the top girder on the north side of the structure as shown.
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6 Click to place the beam system.

NOTE The dotted lines represent the beam system direction. The longitudinal axis of the beam system members
will be placed parallel to these lines.

7 In the Project Browser, under 3D Views, double-click 3D.

The beam system is displayed.

8 Navigate to a folder of your preference, and save the project file as i_RST_Precast-in progress.rvt

9 Proceed to the next exercise, “Changing the Beam System Properties” on page 123.

Changing the Beam System Properties

In this exercise, you change the construction properties so the beam system will extend to the concrete support beam.

Dataset

■ Use the project file that you saved at the end of the previous exercise, i_RST_Precast-in progress.rvt .

1 On the View Toolbar, click  , and draw a zoom box around the edge of the beam system as shown.
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Notice the gap between the edge of the beam system and the concrete beam.

2 Click one of the precast beams as shown.

3 Right-click the selected beam, and click Select All Instances.

4 On the Options Bar, click  .

5 In the Element Properties dialog, under Construction, for Start and End Extension, enter 0' 5" , and click
OK.
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The beam system now extends to the concrete support beam.

6 Click File menu ➤ Save.

7 Proceed to the next exercise, “Changing the Beam System Clear Spacing” on page 125.

Changing the Beam System Clear Spacing

In this exercise, you change clear spacing of the beam system to adjust the gap between each beam.

Dataset

■ Use the project file that you saved at the end of the previous exercise, i_RST_Precast-in progress.rvt .

1 In the Project Browser, under Sections (Building Section), double-click Section 1.

Notice the spacing between each precast beam.

2 In the Project Browser, under Structural Plans, double-click Roof.

3 Select the beam system.
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4 On the Options Bar, click  .

5 In the Element Properties dialog, under Construction, for Clear Spacing, enter 0' 0" , and click OK.

6 In the Project Browser, under Sections (Building Section), double-click Section 1.

Notice the clear spacing between each precast beam is removed.

7 Click File menu ➤ Save.

8 Proceed to the next lesson, “Modifying the Precast Beam Family” on page 126.

Modifying the Precast Beam Family
In this lesson, you add a chamfer to the existing double-tee beam family.

Adding a Chamfer to the Beam

In this exercise, you open the precast beam within the family editor and add a chamfer to both beam supports. You
then import the revised beam back into the project.

Dataset

■ Use the project file that you saved at the end of the previous exercise, i_RST_Precast-in progress.rvt .

Open the beam type for editing

1 Click one of the precast beams as shown.

126 | Chapter 5   Precast Concrete



2 On the Options Bar, click Edit Family.

3 In the Revit dialog, click Yes to open the Precast-Double Tee Family for editing.

The beam is displayed in a new window.

4 In the Family Project Browser, expand Views (all) ➤ Elevations (Elevation 1), and double-click Left.

5 Select the beam.

Open the beam profile

6 In the Family Project Browser, expand Families ➤ Profiles ➤ Double Tee-Profile.

7 Right-click Double Tee-Profile, and click Edit.

8 In the Revit dialog, click Yes to open the Double Tee-Profile for editing.

9 Click View menu ➤ Visibility Graphics.

10 In the Visibility/Graphic Overrides dialog, click the Annotations Categories tab.

■ Under Visibility, click Dimensions and Reference Planes.
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■ Click Apply, and then click OK.

The reference planes and dimensions are now visible.

Zoom in on the left tee of the beam

11 On the View Toolbar, click  , and draw a zoom box around the left tee of the beam.

NOTE The dimensions should be visible under normal circumstances but are purposely hidden for this demo.

12 Select each of the dimensions representing the slope length, and drag them above the top horizontal surface
of the beam profile as shown.

Draw horizontal reference plane

13 On the Design bar, click Ref Plane.

14 Draw a horizontal reference plane below the existing plane, and click Modify.

15 Click the reference plane dimension and enter 0' 2" .
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16 Press ESC.

17 Select the horizontal reference plane.

18 On the Options Bar, click  .

19 In the Element Properties dialog, under Options, for Is Reference, select Not a Reference, and click OK.

Draw vertical reference planes

20 On the Design Bar, click Ref Plane.

21 Draw a vertical reference plane to the left of the center line as shown.

22 Press ESC.

23 Click the reference plane dimension and enter 0' 2" .

24 Press ESC.

25 Use the same technique to draw a vertical reference plane to the right of center as shown.
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26 Press CTRL, and select both vertical reference planes.

27 On the Options Bar, click  .

28 In the Element Properties dialog, under Options, for Is Reference, select Not a Reference, and click OK.

Add dimensions to each reference plane

29 On the Design Bar, click Dimension.

30 Add a dimension for the left vertical reference plane, and click the lock symbol next to the dimension to
lock the distance.

31 Repeat for the vertical reference plane on the opposite side as shown.

32 Add a dimension for the horizontal reference plane as shown.

130 | Chapter 5   Precast Concrete



NOTE Make sure the top dimension line snaps to the horizontal reference plane and not the horizontal line of
the beam.

33 Click the lock symbol next to the dimension to lock the distance.

34 Press ESC.

Align the bottom horizontal surface of the beam

35 On the View Toolbar, click  , and draw a zoom box around the left tee of the beam.

36 Click the bottom horizontal line of the beam, and drag the end point away from the angled line as shown.

37 Enter AL (this is the keyboard shortcut for Align).

38 For the align-to point, select the vertical reference plane as shown.

39 Select the line representing the bottom surface of the beam as shown.
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Press the TAB key to make sure you are selecting the end point of the line and not the reference plane.

40 Click the lock symbol to lock the alignment.

41 Press ESC.

42 Repeat this technique for the inside of the same tee.

Sketch new profile

43 Select the angled line as shown.

44 Press DELETE.

45 On the Design bar, click Lines.

46 Sketch the new profile for the beam as follows:

■ Snap to the end point of the lower horizontal plane.

■ Snap to the intersection of the horizontal and vertical reference planes.
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■ Snap to the end of the top horizontal line.

47 Press ESC.

48 Repeat this technique for the opposite side of the beam.

Modify the right tee of the beam

49 Enter ZF (this is the keyboard shortcut for Zoom to Fit).

50 Click the horizontal reference plane and drag it beyond the right tee of the beam as shown.

51 On the View Toolbar, click  , and draw a zoom box around the right tee of the beam.
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52 Repeat the following techniques for the right tee of the beam.

■ Draw vertical reference planes.

■ Add dimensions to each reference plane.

■ Align the bottom horizontal surface.

■ Sketch the new profile.

Flex the design

53 On the Design bar, click Family Types.

54 In the Family Types dialog, specify the following:

■ For Tee Width, enter 6' 0" .

■ For Width, enter 10' 0" .

■ Click Apply, and then click OK.

The beam should adapt to all changes. If it does not, fix any problems with alignment or constraints.

55 Click Edit menu ➤ Undo Family Type to undo the dimension changes.

Reload the family into the project

56 On the Design Bar, click Load into Projects.

57 In the Reload Family dialog, select Override parameter values of existing types, and click Yes.

Notice the project file becomes active and the beam updates with the latest changes.

58 Proceed to the next tutorial, “Creating Drawings” on page 135.
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Creating Drawings

In this tutorial, you learn how to create drawings from a building information model using Autodesk®

Revit® Structure 4. To create a printed or plotted set of drawings from the views in your structural model,

begin by first creating sheets, which are a type of view in a project. Sheets are defined by borders, usually

contain a title block, and are accessible from the Project Browser. Depending on the type of drawing that

you want to create, you can add different views of the model directly to the sheet. The model views that

you can add to sheets include plan, section, elevation, and three-dimensional (3D) views.
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Creating Drawing Sheets in a Project
In this lesson, you learn how to create sheets within a Revit Structure project, how to add views to the sheets, and how
to create new views from a model. The project used in the following exercises is the same one used in the previous
lesson.

Creating a Drawing Sheet

In this exercise, you create a drawing sheet that includes a plan view, 3D view, and section views. Sheet views update
automatically when you modify your model.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog box, click the Training Files icon.

■ Open i_RST_Drawings.rvt located in the Imperial  folder.

Enter the project information to display in the title block of the drawing sheet

1 Click Settings menu ➤ Project Information.

2 In the Element Properties dialog box, click Edit for Project Address.

3 In the Edit Text dialog box, enter the following address: 123 Main Street, Anytown, MA 12345.

4 Click OK.

5 Specify the remaining instance parameters:

■ For Project Issue Date, enter 31 March 2006.

■ For Project Status, enter Initial Draft.

■ For Client Name, enter J. Smith.

■ For Project Name, enter Office Structure.

■ For Project Number, enter 2006-01.

6 Click OK.

Create a sheet

7 On the View tab of the Design Bar, click Sheet.
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TIP If the View tab is not displayed in the Design Bar, right-click, and click View.

8 In the Select a Title block dialog box, select E1 30 x 42 Horizontal: E1 30x42 Horizontal , and click OK.

A title block and drawing borders are displayed on the drawing sheet.

The title block that you selected is a family that has already been loaded into the project. The text fields
in the title block family (shown below) contain labels that automatically display the corresponding project
information that you entered.

NOTE The Project Path parameter in the lower-right corner of the sheet view automatically updates every time
the project file is saved.

9 In the Project Browser, expand Sheets (all).

The new sheet is displayed in the Project Browser with the name S-2 - Unnamed.

Change the sheet name and number in the title block

10 On the Design Bar, click Modify, and select the title block.

11 When the title block highlights, on the Options Bar, click  .
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12 In the Element Properties dialog, do the following:

■ Under Identity Data ➤ Sheet name, enter Plans and Elevations.

■ Under Identity Data ➤ Sheet number, enter S-1.

13 Click OK.

The sheet name and number are displayed in the title block and in the Project Browser.

Add a plan view to the sheet

14 On the View tab of the Design Bar, click Add View.

15 In the Views dialog box, select Structural Plan: Level 2, and click Add View to Sheet.

16 Move the cursor to the center of the sheet, and click to place the view.

17 With the view selected, right-click, and click Properties.

18 In the Element Properties dialog box, under Graphics, specify1/16" = 1'- 0" for View Scale, and click OK.

The scale of the view on the sheet changes. If you were to open the Structural Plan: Level 2, right-click,
and click View Properties, you would see that the scale plan view is now 1/16" = 1'- 0" .

19 Drag the view to the upper-left corner of the sheet.

20 Adjust the length of the title line by dragging the right end control until it fits under the view.

NOTE If necessary, you can select the view title separately and move it to a new position.
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Add an elevation to the sheet

21 On the View tab of the Design Bar, click Add View.

22 In the Views dialog box, select Elevation: South Elevation, and click Add View to Sheet.

23 Click on the lower half of the sheet to place the view.

24 With the view selected, right-click, and click Properties.

25 In the Element Properties dialog, do the following:

■ Under Graphics, specify 1/16" = 1'- 0" for View Scale.

■ Under Extents, clear Crop Region.

■ Click OK.

26 Position the view below the Structural Plan: level 2.

27 Drag the title line under the elevation view.

28 Adjust the length of the title line by dragging the right end control until it fits under the view.

NOTE If necessary, you can select the view title separately and move it to a new position.

Add a 3D view to the sheet

29 On the View tab of the Design Bar, click Add View.

30 In the Views dialog box, select 3D View: East Section - Perspective, and click Add View to Sheet.

31 Click on the upper-right corner of the sheet to place the view.

32 Drag the title line under the elevation view.

33 Adjust the length of the title line by dragging the right end control until it fits under the view.
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NOTE If necessary, you can select the view title separately and move it to a new position.

34 On the File menu, click Save As.

35 Navigate to a folder of your preference, and save the file asi_RST_Drawings-in progress.rvt

36 Proceed to the next exercise, “Adding a Sheet to the Project” on page 140.

Adding a Sheet to the Project

In this exercise, you add a new sheet to the project, add a section view, and adjust the scale of the view.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_RST_Drawings-in progress.rvt .

Add a new sheet to the project

1 On the View tab of the Design Bar, click Sheet.

2 In the Select a Title block dialog box, select E1 30 x 42 Horizontal: E1 30x42 Horizontal , and click OK.

3 Select the title block, and on the Options Bar, click  .

4 In the Element Properties dialog box, under Identity Data, enter Section Views for Sheet Name, and click
OK.
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Section Views is displayed in the title block as the sheet name.

The new sheet, incrementally named S-2 Section Views, is displayed in the Project Browser, under Sheets
(all).

5 On the File menu, click Save.

6 Proceed to the next exercise, “Creating New Views to Add to Sheets” on page 141.

Creating New Views to Add to Sheets

In this exercise, you learn how to create a new section view and a new callout view, and then add them to a new
drawing sheet.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_RST_Drawings-in progress.rvt .

Create a section view of Level 2, and add it to the sheet

1 In the Project Browser under Structural Plans, double-click Level 2.

2 On the View Toolbar, click  , and zoom in on the east area of the structure as shown.
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3 On the View tab of the Design Bar, click Section.

4 In the Options Bar, select 1/16" = 1'- 0" for Scale.

5 Add a section line that cuts through the right side of the building:

■ Click between grid lines G and H to place the start point of the section line and the section head
(section tag).

■ Move the cursor to the right and click between grid lines J and K to place the section tail and complete
the section line.

6 In the Project Browser under Sheets (all), double-click S-2 Section Views.

7 On the View tab of the Design Bar, click Add View.

8 In the Views dialog box, select Section: Section 1, and click Add View to Sheet.

9 Click on the upper-left corner of the sheet to place the view.

10 With the view selected, right-click, and click Properties.

11 In the Element Properties dialog box, under Graphics, specify 3/16" = 1' - 0" for View Scale.

12 Drag the title line under the elevation view, and click OK.

13 Adjust the length of the title line by dragging the right end control until it fits under the view.
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NOTE If necessary, you can select the view title separately and move it to a new position.

Create a callout view, and add it to the sheet

14 In the Project Browser under Sections (Building Sections), double click Section 1.

15 On the View Toolbar, click  , and zoom in on the lower floors of the structure.

16 On the View tab of the Design Bar, click Callout.

17 Draw a box around the column of Garage Level 1, as shown.

18 Select the drag bar attached to the callout balloon, and position it approximately as shown.

19 In the Project Browser under Sheets (all), double-click S-2 Section Views.

20 On the Project Browser under Sections (Building Sections), click Callout of section 1, and drag the view
onto the sheet.

21 With the view selected, right-click, and click Properties.

22 In the Element Properties dialog box, under Graphics, specify3/4" = 1'- 0" for View Scale, and click OK.
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23 Drag the title line under the elevation view.

24 Adjust the length of the title line by dragging the right end control until it fits under the view.

NOTE If necessary, you can select the view title separately and move it to a new position.

25 On the File menu, click Save.

26 Proceed to the next exercise, “Using Legends” on page 144.

Using Legends
Legends provide a way to display a list of the various structural components and annotations used in a project. The
two most common types of legends produced for construction documents are annotation legends and building
component legends.

Annotation legends are made up of components such as section markers which are paired with text that identifies
them. On construction documents, annotation legends are often referred to as symbol legends.

Legends list and identify components such as weld symbols and rebar tags. On construction documents, component
legends are often called schedules (beam schedule, concrete schedule, and so on).

Creating a Symbol Legend

In this exercise, you create a legend view and add symbols and text to it, using a text type you create by duplicating
an existing text type and modifying the type properties. Finally, you add the completed symbol legend to a sheet for
the construction documents.
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NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_RST_Drawings-in progress.rvt .

Create a legend view

1 Click View menu ➤ New ➤ Legend.

2 In the Project Browser, expand Legends.

3 Right-click Legend 1, and click Rename.

4 In the Rename View dialog box, enter Symbol Legend for Name, and click OK.

Add symbols to the legend

5 On the Drafting tab of the Design Bar, click Symbol.

6 Add the following symbols to the legend view, selecting each from the Type Selector and placing it in the
drawing area as shown.

■ Section Head - Filled

■ Span Direction Fixed: 1/2”

■ Rebar Tag

■ Weld Symbol: Both

■ Weld Symbol - Spacer: Spacer

■ Weld Symbol-w-Preparation: Melt Thru
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Create a text type

7 Because the text size for the symbol legend is not available in the Type Selector, you create a text type with
the necessary size. You do this by duplicating an existing text type and modifying the type properties.

On the Design Bar, click Text.

8 In the Type Selector, select Text: 1/4" Ariel text .

9 On the Options bar, click  .

10 In the Element Properties dialog box, click Edit/New.

11 In the Type Properties dialog box, click Duplicate, enter 1/8" text for Name, and click OK.

12 Under Text, enter 1/8" for Text Size, and click OK twice.

Add text to the legend

13 In the Type Selector, verify that Text: 1/8" text is selected, and click to the right of the first symbol to specify
the text start point.

14 Enter Level Marker (Level Name/Elevation) or the text note.
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15 Working from the top down, enter the following text for the remaining symbols in the legend:

■ Span Direction Fixed: 1/2”

■ Rebar Tag (Tag#)

■ Weld Symbol

■ Weld Symbol - Spacer

■ Weld Symbol - Melt thru

Place the symbol legend on a sheet

16 In the Project Browser, expand Sheets (all), and double-click S-1 - Plans and Elevations to open it in the
drawing area.

17 In the Project Browser, click Symbol Legend, drag it to the lower-right corner of the sheet, and click to
place it.

18 On the Design Bar, click Modify to end the command.

The symbol legend is added to the sheet.

19 Click File menu ➤ Close.

20 You can save the open file is you wish. In the next tutorial, a new dataset is supplied.
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21 Proceed to the next tutorial, “Scheduling” on page 149.
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Scheduling

In this tutorial, you learn how to create a customized schedule of structural framing elements in your

Autodesk® Revit® Structure 4 projects.

7
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Creating a Beam Schedule
In this lesson, you learn how to create a beam schedule for the structural model as shown below. When you schedule
structural components in Revit Structure, you can list each component as a separate line item (an instance schedule),
or you can group components of the same type into a single line item (a type schedule).

Creating Shared Parameters

In this exercise you learn how to use shared parameters to define additional elements that are usually not included in
the beam schedule when it is created within the project template. Shared parameters can be added to any family,
regardless of category, and are defined and stored in an external file, ensuring consistency across families and projects.
Their values may also be aggregated and reported within Revit Structure multi-category schedules.

An example of the use of shared parameters is the need to add width and height information to a beam family component
originally defined as a family parameter. The following exercise demonstrates the solution for this situation and covers
the process of setting up shared parameters and adding them to a family.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_Schedules.rvt located in the Imperial folder.

Editing the family parameters

1 In the Project Browser, Under Structural Plans, double-click Ground Level.

NOTE Some beams have been added to this view to better demonstrate the scheduling tool.

2 Select one of the beams as shown.
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3 On the Options Bar, click Edit Family.

4 Click Yes when prompted about opening the beam for editing.

NOTE You are now in the Family Editor. The selected beam family is displayed in the drawing area.

5 On the Family design bar, click Family Types.

6 In the Family Types dialog, under Dimensions, select the b parameter, and click Modify.

7 In the Parameter Properties dialog, select Shared Parameter, and click Select.

8 When asked if you want to specify a shared parameter file, click Yes.

9 In the Edit Shared Parameters dialog, click Create.

10 In the Save As dialog, specify a location for the file and enter Project Shared Parameters for name. Click
Save.

11 In the Edit Shared Parameters dialog, under Groups, click New.

12 In the New Parameter Group dialog, enter Dimensions for name, click OK.

13 In the Edit Shared Parameters dialog, under Parameters, click New.
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14 In the Parameter Properties dialog, do the following:

■ Under Name, enter b.

■ Under Type, select Length.

■ Click OK.

15 In the Edit Shared Parameters dialog, under Parameters, click New.

16 In the Parameter Properties dialog, do the following:

■ Under Name, enter h.

■ Under Type, select Length.

■ Click OK.

17 In the Edit Shared Parameters dialog, click OK.

18 In the Shared Parameter dialog, select the b parameter, and click OK.

19 In the Parameter Properties dialog, click OK.

20 In the Family Types dialog, under Dimensions, select the h parameter, and click Modify.

21 In the Parameter Properties dialog, select Shared Parameter, and click Select.

22 In the Shared Parameter dialog, select the h parameter, and click OK.

23 In the Parameter Properties dialog, click OK.

24 In the Family Types dialog, click OK.

NOTE The b and h parameters, which were originally family parameters, are now shared parameters. They will
appear in the structural framing schedule field once they are reloaded into the project file.

25 On the Family design bar, click Load into Project.

26 Select the active file, and click OK.

27 When prompted to overwrite the existing version of the family, click yes.

28 Proceed to the next exercise, “Creating a Structural Framing Schedule” on page 152

Creating a Structural Framing Schedule

In this exercise, you learn how to create a structural framing concrete beam schedule.

Create the schedule

1 In the Project Browser, Under Structural Plans, double-click Ground Level.

2 On the View tab of the Design Bar, click Schedule/Quantities.

TIP If the View tab of the Design Bar is not active, right-click in the Design Bar, and click View.

3 In the New Schedule dialog, under Category, select Structural Framing, and click OK.

Define the fields to display as columns in the beam schedule

4 In the Schedule Properties dialog, click the Fields tab.

5 Under Available fields, select Mark, and click Add.

The Mark field is moved under Scheduled fields.

152 | Chapter 7   Scheduling



6 Using the same process, add the following fields to the schedule:

■ Comments

■ b

■ h

■ Structural Usage

■ Reference Level

7 In the Schedule Properties dialog, click Add Parameter.

8 In the Parameter Properties dialog, do the following:

■ Under Parameter Data, enter Rebar for Name.

■ Under Type, select Text.

■ Click OK.

NOTE Rebar is now a project parameter that can also be found in the properties of any structural framing
component.

9 Under Scheduled fields, order the fields as shown by selecting them and clicking Move Up or Move Down.

10 Click OK.

A schedule is created that includes all structural framing elements in the project.
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11 Proceed to the next exercise, “Customizing the Schedule” on page 154.

Customizing the Schedule

In this exercise, you learn how to customize the new beam schedule.

Modifying the table elements

1 Modify the schedule headings as follows:

■ Select Mark, and enter MARK.

■ Select b, and enter W.

■ Select h, and enter D.

■ Select Comments, and enter REMARKS.

■ Select the title, and enter GROUND LEVEL CONCRETE BEAM SCHEDULE.

NOTE Under the Project Browser, click Schedules/Quantities. Notice that the schedule name has changed.

2 Select headings W and D.

3 On the Options bar, click Group.

A new blank cell is created above columns W and D.

4 Click the new heading, and enter SIZE.

Selecting a filter

5 Right-click the open area next to the schedule, and select View Properties.

6 In the Element Properties dialog, under Filter, click Edit for Value.

7 In the Schedule Properties dialog, click the Filter tab, select the Reference Level for Filter by, select Ground
Level, and click OK.

8 In the Element Properties dialog, click OK.

Notice the schedule is filtered and shows only the structural framing elements of the ground level.

Sorting/grouping the schedule by structural usage

9 Right-click the open area next to the schedule, and select View Properties.

10 In the Element Properties dialog, under Sorting/Grouping, click Edit for Value.
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11 In the Schedule Properties dialog ➤ Sorting/Grouping tab, do the following:

■ Under Sort by, select Structural Usage.

■ Select Header.

■ Select Footer

■ Select Blank Line.

■ Click OK.

12 On the Element Properties dialog, click OK.

The schedule is updated to provide both a header and footer for each type, sorted by structural usage.

13 Proceed to the next exercise, “Formatting Units” on page 155.

Formatting Units

In this exercise, you change the format for displaying units in the beam schedule.

1 Right-click the open area next to the schedule, and click View Properties.

2 In the Element Properties dialog, under Formatting, click Edit for Value.

3 In the Schedule Properties dialog, click the Formatting tab.

4 Under Fields, click b, and click Field Format.

5 In the Field Format dialog, do the following:

■ Clear Use Project Settings.

■ Under Rounding, select To the nearest 1/8" .

■ Under Units, select Fractional inches .
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■ Click OK.

6 Under Fields, select h, and click Field Format.

7 Repeat step 5.

8 On the Schedule Properties dialog, click OK.

9 On the Element Properties dialog, click OK.

Columns W and D now display fractional inches .

10 Proceed to the next exercise, “Entering Marks and Rebar Data” on page 156.

Entering Marks and Rebar Data

In this exercise, the schedule is modified to include the mark value assigned to each beam element as well as specific
rebar data.

1 In the Project Browser, under Structural Plans, double-click Ground Level.

2 On the Window menu, click Tile.

The screen is split into two separate windows, showing both the beam schedule and Ground Level view.

NOTE Close any additional views that may be opened. If prompted to save the changes to the beam family,
click Yes, and provide a location for the new family file.

3 On the schedule window, scroll down until the Joists section of the schedule is visible.

4 Click in the Ground Level window, and on the Toolbar, click  , and zoom in on the joists.

5 In the Schedule window, enter the following information for the first joist in the schedule:

■ Under MARK, enter 1B21.

NOTE Notice the joist is highlighted (red) in the Ground Level view.

■ Under Rebar, enter 2-#8 X 9' - 0" Bot .

6 Click the Rebar column to highlight the joist in the Ground Level view.
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7 Click the highlighted joist, and on the Options bar, click  .

8 In the Element Properties dialog, under Identity Data, notice the Value field for the Mark parameter reflects
the data entered on the schedule, as does the value for the Rebar parameter.

9 Press and hold the Ctrl key while selecting multiple joists on the Ground Level window.

10 On the Options bar, click  .

11 In the Element Properties dialog, do the following:

■ Under Identity Data, enter 1B21 for Mark Value.

■ Under Other, select 2-#8x9'-0" Bot for Rebar value.

■ Click OK.

NOTE Ignore the warning regarding elements having duplicate Mark values.

The schedule is updated with the joist information.

12 On the File menu, click Save as.

13 Navigate to a folder of your preference, and save the file as i_RST_Schedules-in-progress.rvt .

14 Proceed to the next exercise, “Calculating Values” on page 157.

Calculating Values

In this exercise , you create a formula to calculate the unit cost for each individual girder and joist as well, as the total
cost of all structural items for the ground level of the structure.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_RST_Schedules-in-progress.rvt .

1 Right-click the open area next to the schedule, and click View Properties.

2 In the Element Properties dialog, under the Fields parameter, click Edit for Value.

3 In the Schedule Properties dialog, do the following:

■ Under Available Fields, select Cost, and click Add.

■ Under Available Fields, select Length, and click Add.

■ Click Calculated Value.
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4 In the Calculated Value dialog, do the following:

■ Enter Total Cost for Name.

■ Select Number for Type.

■ Enter Length*Cost/1' for Formula.

Note that the formula will calculate the total cost based on a length unit of 1' .

■ Click OK.

5 In the Schedule Properties dialog, click OK.

6 In the Element Properties dialog, click OK.

7 Scroll to the first girder on the schedule, enter 3 for Cost, and press Enter.

Beacause cost is a type parameter, the value will be applied to all elements of the same type. When the
notification box is displayed, cick OK to accept the change. The schedule will calculate the total cost for
all girders.

NOTE The cost value represents a random value chosen for demonstration purposes only. Also notice that the
Total Cost parameter does not have a unit value assigned. In Revit Structure, the number type cannot be assigned
a dollar value.

8 Scroll to the first joist on the schedule, and enter 1.5 for Cost.

Because cost is a type parameter, the value will be applied to all elements of the same type. When the
notification box is displayed, click OK to accept the change. The schedule will calculate the total cost for
the joists.

9 Right-click the open area next to the schedule, and click View Properties.

10 In the Element Properties dialog, under Formatting, click Edit for Value.

11 In the Schedule Properties dialog, do the following:

■ Click the Formatting tab.

■ Under Fields, select Total Cost.

■ Under Field Formatting, select Calculate totals.

■ Click OK.

12 In the Element Properties dialog, click OK.

The schedule now includes the sum for Total Cost.

13 Proceed to the next exercise, “Resorting the Schedule” on page 158.

Resorting the Schedule

In this exercise, you group the beams by similar instances, and then resort by the beam mark.

1 Maximize the schedule window.

2 Right-click the open area next to the schedule, and select View Properties.

3 In the Element Properties dialog, under Sorting/Grouping, click Edit for Value.

4 In the Schedule Properties dialog, do the following:

■ Clear Itemize every instance.

■ Under Then by, select Mark.
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■ Click OK.

5 In the Element Properties dialog, click OK.

Notice the schedule is not itemized and does not show each beam, but instead groups all the beams of the
same mark in a single row.

6 Proceed to the next exercise, “Hiding /Unhiding Columns” on page 159.

Hiding /Unhiding Columns

In this exercise, you learn how to hide specific columns on the schedule so the information will not be visible on
printed outputs.

1 On the schedule, click the Cost column.

2 Right-click the open area next to the schedule, and click View Properties.

3 In the Element Properties dialog, under Formatting, click Edit for Value.

4 In the Schedule Properties dialog, do the following:

■ Under Fields, select Total Cost.

■ Under Field Formatting, select Hidden field.

■ Click OK.

5 In the Element Properties dialog, click OK.

The Total Cost column is now hidden.

6 You can also hide columns by doing the following:

■ In the Element Properties dialog, click OK.
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■ On the schedule, select the Cost and Length columns.

■ Right-click, and select Hide Column(s).

7 The columns are now hidden.

NOTE To show all hidden columns, right-click the open area next to the schedule, click Unhide All Columns.

8 Proceed to the next exercise, “Creating a Graphical Column Schedule” on page 160.

Creating a Graphical Column Schedule
In this lesson, you learn how to create a graphical column schedule for the current project.

Hiding Levels /Creating the Schedule

In this exercise you learn how to select which levels in the project are to be included in the schedule.

1 On the Settings menu, click Structural Settings.

2 In the Structural Settings dialog, click the Symbolic Representation Settings tab.

3 Click Levels Hidden in Graphical Column Schedules.

4 In the Levels Hidden dialog, select Foundation, Garage Level - 1, and Ground Level, and click OK.
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NOTE These levels will not appear on the graphical column schedule.

5 In the Structural Settings dialog, click OK.

6 On the View tab of the Design Bar, click Graphical Column Schedule.

The schedule is created. Notice that the first level on the schedule is Level 2.

Change the Schedule Appearance

In this exercise, you learn how to add a title to the schedule and how to customize text and graphic appearance.

1 Right-click the schedule, and select View Properties.

2 In the Element Properties dialog, under Text Appearance, click Edit for Value.

3 In the Graphical Column Schedule Properties dialog, do the following:

■ For Title text, select Courier New from the drop-down list, and then select Bold and Italic.

■ For Level text, select Ariel Black from the drop-down list, and then select Bold.
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4 Click the Grid Appearance tab.

5 Under Horizontal Widths:

■ Enter 2" for Column Locations,

■ Enter 2" for Level Names.

6 Click OK.

7 In the Element Properties dialog, under Identity Data, enter Steel Column Schedule for Title.

8 Click OK.

9 Click File menu ➤ Save.
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10 Proceed to the next exercise, “Tagging the Columns” on page 163.

Tagging the Columns

In this exercise, you learn how to tag each steel column in the schedule.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_RST_Schedules-in-progress.rvt .

1 On the Drafting tab of the Design Bar, click Tag ➤ By Category.

2 On the Options bar, click Vertical, and clear Leader.

3 Click the column on Level 7 to place the tag.

4 On the Drafting tab of the Design Bar, click Tag All Not Tagged.

5 In the Tag dialog, do the following:

■ Under Category, select Structural Column Tag .

■ Under Orientation, select Vertical.

■ Click Apply.

■ Click OK.

6 Enter ZF to fit the entire column schedule in the drawing area.

7 Draw a pick box around the entire schedule.

8 On the Options bar, click  .

9 In the Filter dialog, clear Structural Columns, and click OK.
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10 On the Toolbar, click  , and zoom in on one of the column tags.

11 On the Toolbar, click  , and move the tags until they are positioned approximately as shown.

12 Proceed to the next exercise, “Splitting the Columns into Segments” on page 164.

Splitting the Columns into Segments

In this exercise, you split the column schedule horizontally to create multiple segments.

1 Right-click the schedule, and select View Properties.

2 In the Element Properties dialog, do the following;

■ Under View Scale, enter 1' = 20' - 0"

■ Under Column Locations per Segment, enter 10.

3 Click OK.

The schedule is split into 4 segments with 10 column locations per segment.

4 Proceed to the next exercise, “Creating Multiple Sheets for the Graphical Column Schedule” on page 165.
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Creating Multiple Sheets for the Graphical Column Schedule

In this exercise, you create multiple sheets for the graphical column schedule.

1 On the View tab of the Design Bar, click Sheet.

2 In the Select a Titleblock dialog, select E1 30 x 42 Horizontal: E1 30x42 Horizontal , click OK.

A titleblock and drawing borders are displayed on the drawing sheet.

3 In the Project Browser, expand Sheets (all).

The new sheet is displayed in the Project Browser.

Change the sheet name and number

4 On the Design Bar, click Modify, and select the titleblock.

5 In the Options bar, click  .

6 In the Element Properties dialog, do the following:

■ Under Identity Data ➤ Sheet Name, enter Steel Column Schedule.

■ Under Sheet Number, enter S-3.

■ Click OK.

The sheet name and number are displayed in the titleblock and in the Project Browser.

Add the column schedule to the sheet

7 On the View tab of the Design bar, click Add View.

8 In the Views dialog, select Graphical Column Schedule, and click Add View to Sheet.

9 Move the cursor to the center of the sheet, and click to place the view.

10 Select the schedule, and on the Options Bar, click  .

11 In the Element Properties dialog, under Extents, enter 1 for Segments in Viewport.

The first segment will be placed on Sheet S-3.
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Add additional sheets

12 On the View tab of the Design Bar, click Sheet.

13 In the Select a Titleblock dialog, select E1 30 x 42 Horizontal: E1 30x42 Horizontal , click OK.

14 On the Design Bar, click Modify, and select the titleblock.

15 On the Options bar, click  .

16 In the Element Properties dialog, do the following:

■ Under Identity Data ➤ Sheet Name, enter Steel Column Schedule.

■ Under Sheet Number, enter S-4.

■ Click OK.

17 Repeat previous steps to add 2 additional sheets.

Enter Steel Column Schedule for name, and enter S-5 and S-6 for sheet numbers.

Place remaining views

18 On the Project Browser, expand Sheets (all), and click Sheet S-4.

19 On the Project Browser, under Graphical Column Schedule, click Graphical Column Schedule 1, and drag
it onto the sheet.

20 Move the cursor to the center of the sheet, and click to place the view.

21 Position the schedule as necessary.

22 On the Project Browser, expand Sheets (all), and click Sheet S-5

23 On the Project Browser, under Graphical Column Schedule, click Graphical Column Schedule 1, and drag
it onto the sheet.

24 Move the cursor to the center of the sheet, and click to place the view.

25 On the Project Browser, expand Sheets (all), and click Sheet S-6.

26 On the Project Browser, under Graphical Column Schedule, click Graphical Column Schedule 1, and drag
it onto the sheet.

27 Move the cursor to the center of the sheet, and click to place the view.

28 Click File menu ➤ Save.

29 Proceed to the next exercise, “Exporting Schedule Information to Microsoft Access” on page 166.

Exporting Project Information with ODBC
In this lesson, you learn how to export project information to an ODBC (Open DataBase Connectivity) - compliant
database.

Exporting Schedule Information to Microsoft Access

In this exercise, you learn how to export project information into a Microsoft® Access 2000 database. The process that
you use to export the database is similar for any other ODBC-compliant database.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_RST_Schedules-in-progress.rvt .

1 On the File menu, click Export ➤ ODBC Database.

2 In the Select Data Source dialog, click the File Data Source tab.
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3 Click New.

4 In the Create New Data Source dialog, select the Microsoft Access driver (*mdb), and click Next.

5 Enter RevitDSN for the name of the DSN, and click Next.

6 Click Finish.

7 In the ODBC Microsoft Access Setup dialog, under Database, click Create.

8 In the New Database dialog, under Database Name, enter Revit_Project.mdb for Database Name.

9 Under Directories, select a location for the database file, and click OK to create the database.

10 When the confirmation message displays, click OK.

11 In the OBDC Microsoft Access Setup dialog, click OK.

12 Click OK in the remaining dialogs, and then open the database in Microsoft Access.

Revit Structure creates 2 tables: one that lists all of the element instances in a project, and one that lists all
of the element types in a project (see below).

A unique element ID is used to identify exported elements, so that each table of elements includes an ID
column. Elements IDs are also used to establish relationships between elements in different tables. For
example, instance tables include a TypeId column containing the ID of the instance’s type, and some
instance tables include a RoomId column containing the ID of the room that the instance is in.

13 Close the exercise file.

14 Proceed to the next tutorial, “Steel Details” on page 169.
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Steel Details

In this tutorial, you learn how to use Autodesk® Revit® Structure 4 to create steel details from the structural

model (model-based), and how to create a drafting detail using the tools provided (drafting-detail). Detail

drawings describe how particular pieces of the structure go together and are typically created in the

middle to later portion of the design process after the general building shape and structural elements

have been decided upon. This tutorial comprises the following model-based steel detail exercises:

■ Welded Brace Connection

■ Bolted Angle Connection

■ Glazing Support Connection

8
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Setting Up Section Views on Sheets
In this lesson, you begin with a framed model as the basis of your details. You cut a section in plan, revise an existing
elevation view, revise a callout view, and add these views to a sheet.

Cut Sections and Add Views to Sheets

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_DET.rvt located in the Imperial folder.

Prepare the welded brace elevation view

1 In the Project Browser, expand Views (all), Structural Plans, and double-click Level 4.

2 Select  , and draw a zoom box around the northwest stair opening as shown.

3 Double-click the elevation bubble to open the elevation view.

4 In the elevation view, select the crop region and drag the controls to resize such that only the Level 4 area
is visible.

5 On the View Control Bar:

■ Click Scale control, and select 3/4" =1' - 0" .

■ Click Detail Level ➤ Fine.

■ Click Model Graphics Style ➤ Shading with Edges.
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Create the section view

6 In the Project Browser, under Structural Plans, double-click Level 4.

7 Select  , and draw a zoom box around grid line intersection 1-E.

8 On the View tab of the Design Bar, click Section.

9 Draw a section as shown.

10 On the Design Bar, click Modify.

11 Double-click the section bubble to open the section view.

12 Select the crop region, and drag the crop region controls so that only Level 4 is visible.

13 On the View Control Bar:

■ Click Scale control, and select 1/2" =1' - 0" .

■ Click Detail Level ➤ Fine.

■ Click Model Graphics Style ➤ Shading with Edges.
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Revise the callout view

14 In the Project Browser, under Elevations (Building Elevation), double-click West Elevation.

A callout symbol is located in this view at the south wall.

15 Select  , and zoom in on the south wall at Level 4.

16 Double-click on the callout head to open the view.

17 On the View Control Bar:

■ Click Scale control, and select 3/4" =1' - 0" .

■ Click Detail Level ➤ Fine.

■ Click Model Graphics Style ➤ Shading with Edges.

Create a sheet and place the section, elevation, and callout views on the sheet.

18 Click View menu ➤ New ➤ Sheet.

19 In the Select a Title block dialog, select E1 30x42 Horizontal , and click OK.
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20 In the Project Browser, expand Sheets (all).

21 Right-click S-6 Unnamed, and click Rename.

22 In the Sheet Title dialog, enter Steel Details for Name, and click OK.

23 In the Project Browser, right-click S-6 - Steel Details, and click Add View.

24 In the Views dialog, select Section: Section 1, and click Add View to Sheet.

25 Move the cursor onto the sheet, and click to place the view.

26 In the Project Browser, right-click S-6 - Steel Details, and click Add View.

27 In the Views dialog, select Elevation: Elevation 1-a, and click Add View to Sheet.

28 Move the cursor onto the sheet, and click to place the view.

29 In the Project Browser, right-click S-6 - Steel Details, and click Add View.

30 In the Views dialog, select Elevation: Callout of West Elevation, and click Add View to Sheet.

31 Move the cursor onto the sheet, and click to place the view.

32 Click File menu ➤ Save As, and save the model to a location of your choice using the following filename:
i_RST_DET-in progress.rvt .

33 Proceed to the next lesson, “Detailing Steel” on page 173.

Detailing Steel
In this lesson, you add a welded bracing detail, a bolted angle detail, and a facade support detail to the model.

Welded Bracing Detail

Dataset
Continue to use the dataset you saved in the previous exercise, i_RST_DET-in progress.rvt .

The first part of the exercise involves adding a plate to the underside of a beam to support the bracing. You will sketch
the lines in a model view.

Sketch line work

1 In the Project Browser, under Elevations (Interior Elevation), double click Elevation 1-a.

Detailing Steel | 173



2 On the Toolbar, click  , and draw a zoom box around the midpoint of the beam where the braces
meet at Level 4.

3 Select the left brace, and drag the shape handle (two small triangles at the brace end) to move the brace
so it is not touching the beam flange.

4 On the Drafting tab of the Design Bar, click Detail Lines.

5 Place the cursor near the bottom flange of the beam, and enter SM to snap to the midpoint.

6 Sketch a vertical line down 1' -1 3/8" from the bottom flange as shown.

TIP After establishing the line direction, enter the value.
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Next, you create 2 detail lines that are offset from this vertical line.

7 On the Options Bar, click Offset.

8 On the Options Bar, select Numerical, enter 2' 6" for Offset, and select Copy.

9 Place the cursor near the vertical line to highlight it.

A line displays that is offset from the highlighted line.

10 Click to place this line.

11 Repeat the same steps to place a vertical line on the opposite side.

12 On the Drafting tab of the Design Bar, click Detail Lines.

13 On the Options Bar, click  , and enter 1' 8" for the Offset value.

14 Place the cursor on the bottom flange of the beam as shown, and click to place the detail line.
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15 On the Design Bar, click Modify and select the horizontal detail line.

16 Enter 3' 9" for the temporary dimension value as shown.

17 On the Drafting tab of the Design Bar, click Detail Lines, and sketch 2 detail lines to connect the horizontal
line to the vertical lines as shown.

18 Select the middle vertical line that you used as a reference line, and press DELETE to delete this element.
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Add weld symbols

19 In the Project Browser, expand Families ➤ Annotation Symbols ➤ Weld Symbol ➤ select Both, drag it into
the view as shown, and click to place it.

The weld symbol has 4 numerical parameters that are currently set to 0.

20 Click Modify.

21 Select the weld symbol, click the left top weld annotation, and enter 3/8 . Repeat for the left bottom value.

22 Click the right top weld annotation, and enter a period. Repeat for the right bottom value.

23 On the Design Bar, click Modify, and select the weld symbol.

24 On the Options Bar, click Add a Leader.

25 Drag the leader arrowhead to the position as shown.

26 Use the same technique to add another weld symbol as shown.
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27 Right-click the new weld symbol, and click Properties.

28 In the Element Properties dialog, do the following:

■ Under Structural, select Weld All Around

■ Under Graphics, select Weld Contour-Empty for Top Symbol

■ Click OK.

Label the angles and the plate

29 On the Drafting tab of the Design Bar, click Text.

30 On the Options Bar, click  .

31 Draw a text leader to the plate, and enter 3/8" PL for text.

32 On the Drafting tab of the Design Bar, click Text.

33 On the Options Bar, click  .

34 Draw a leader to the brace and enter L8x8 TYPICAL for text as shown.
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35 Click File menu ➤ Save.

36 Proceed to the next exercise, “Bolted Angle Detail” on page 179.

Bolted Angle Detail

Dataset
Continue to use the dataset you saved in the previous exercise, i_RST_DET-in progress.rvt .

In the first part of the exercise, you add 2 angles to the model using an angle family that has been loaded into the
project. Then, you add some annotations.

1 In the Project Browser, under Sections, double-click Section 1.

2 In the Project Browser, under Families ➤ Detail Items ➤ L-Angle-Bolted Connection Section, select L4x4x5/16
.

3 Drag the family onto the grid line in the view as shown.

Add annotations

4 On the Drafting tab of the Design Bar, click Detail Lines.
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5 Sketch a vertical line through the center of the left set of bolts as shown.

6 On the Drafting tab of the Design Bar, click Text.

7 On the Options Bar, click  .

8 Enter the text notes as shown.

9 Click File menu ➤ Save.

10 Proceed to the next exercise, “Facade Support Detail” on page 180.

Facade Support Detail

Dataset
Continue to use the dataset you saved in the previous exercise, i_RST_DET-in progress.rvt .
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In this exercise, you add members to support exterior wall glazing.

1 In the Project Browser, under Elevations (Building Elevation), double-click West Elevation.

2 On the Toolbar, click  , and draw a zoom box around the callout at the intersection on Level 4 at
grid 4.

3 Double-click the callout head to open Callout of West Elevation.

On the right side of the view is an imported symbol that represents a curtain wall. You will attach a channel
in section to the outrigger for use as a member of the facade support system.

4 In the Project Browser, expand Families ➤ Detail Items ➤ C-Channel Section , select C5x6.7 .

5 Drag the channel onto the drawing area.

6 Click Modify and select the channel.

7 Press the spacebar to rotate the channel twice, move it to the position shown, and click to place it.
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8 On the Edit toolbar, click  , and select the left side of the column as shown.

9 Next, select the back of the channel as shown.

10 Continue to use the align tool to align the channel to the bottom of the outrigger as shown.

11 In the Project Browser, expand Families ➤ Detail Items ➤ Bolt-Section, select bolt, and drag it onto the
outrigger and channel as shown.
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Add annotations

12 On the Drafting tab of the Design Bar, click Text.

13 Click the open area outside of the channel and enter C5x6.7 .

14 Click near the bolt and enter 3/4" DIA. A325 BOLT .

15 Press ESC twice to exit the Text tool.

16 In the Project Browser, under Sheets, double-click S-6 Steel Detail to view the results of your work in the
sheet view.

17 Click File menu ➤ Close.

You can save the open file if you wish. In the next lesson, a new dataset is supplied.

18 Proceed to the next lesson, “Creating a Drafting View Detail” on page 183.

Creating a Drafting View Detail
In this lesson, you learn how to create a drafting view detail for a deck span transition using the drafting tools provided
in Revit Structure.

Creating a Deck Span Transition Detail

Dataset

■ Click File menu ➤ Open.
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■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_Deck_Span_Detail.rvt located in the Imperial folder.

Create the drafting view

1 On the View tab of the Design Bar, click Drafting View.

2 In the New Drafting dialog, do the following:

■ Under Name, enter Typical Detail- Deck Span Transition.

■ Under Scale, select 1 1/2" = 1' - 0" .

■ Click OK.

3 In the Project Browser, expand Drafting Views, and double-click Typical Detail - Deck Span Transition.

Load detail components

4 On the Drafting tab of the Design Bar, select Detail Component.

5 In the Type Selector, select AISC Wide Flange Shapes - Section: W18x35 .

6 Click the drawing area to place the component.

7 On the Design bar, click Modify.

8 On the Drafting tab of the Design Bar, select Detail Component.

9 In the Type Selector, select K-Series Bar Joist - Side: 14K3 .

10 Position the joist on the right side of the beam.

Align the bottom of the joist seat with the top of the beam as shown.

11 On the Design bar, click Modify.

12 On the Drafting tab of the Design Bar, select Repeating Detail.

13 In the Type Selector, select Metal Deck .

14 Click the end of the joist.

15 Move the pointer to the right to begin placing the deck.
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16 Press the SPACEBAR to rotate the orientation of the deck, and continue to move the pointer to the right
until the deck is drawn as shown.

17 On the Design bar, click Modify.

18 On the Drafting tab of the Design Bar, select Detail Component.

19 In the Type Selector, select AISC Tube Shapes - Section: HSS2-1/2x2-1/2x.125 .

20 Place the tube on the top flange of the steel beam directly next to the end of the joist seat as shown.

21 On the Design bar, click Modify.

22 On the Drafting tab of the Design Bar, select Detail Component.

23 In the Type Selector, select Roof Decking-Side: 1.5 WR 22 .

24 Align the bottom of the decking with the top of the joist and move the deck to the left approximately as
shown.
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25 On the Design bar, click Modify.

26 On the Drafting tab of the Design Bar, select Detail Component.

27 In the Type Selector, select K-Series Bar Joist-Section: 14K3 .

28 Place the joist to the left of the beam, and align the top of the joist with the bottom of the deck as shown.

29 On the Design bar, click Modify.

Add weld symbols

30 In the Project Browser, expand Families ➤ Annotation Symbols ➤ Weld Symbol ➤ select Bottom, drag it
into the view as shown, and click to place it.

31 On the Design Bar, click Modify.

32 Select the weld symbol, and on the Options Bar, click  .

33 In the Element Properties dialog, change the following instance parameters:

■ Under Structural, select Field Weld.

■ Enter 3/16 for Bottom Weld Size.

■ Enter 2 @ 12 for Bottom Weld Length.

■ Under Other, clear Symbol Left, and select Symbol Right.

■ Click OK.

34 On the Design Bar, click Modify, and select the weld symbol.

35 On the Options Bar, click Add a Leader.

36 Drag the leader arrowhead to the position as shown.
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Add text to the detail view

37 On the Drafting tab of the Design Bar, click Text.

38 On the Options Bar, click  .

39 Draw a text leader to the steel deck and enter STL DECK SEE PLAN for text.

40 On the Design bar, click Modify.

41 On the Drafting tab of the Design Bar, click Text.

42 Repeat the previous steps to add the remaining text and leader to the detail view as shown.

43 Click File menu ➤ Save As, and navigate to a folder location of your choice.

44 Proceed to the next tutorial, “Concrete Details” on page 189.
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Concrete Details

In this tutorial, you learn how to use Autodesk® Revit® Structure 4 to create concrete details from the

structural model (model-based), how to create a detail library for multiple users, and how to import the

library into an existing project. Detail drawings show how particular pieces of the structure go together

and are typically created in the middle to later portion of the design process after the general building

shape and structural elements have been decided upon. This tutorial comprises the following model-based

concrete detail exercises:

■ Footing Detail

■ Wall Detail

■ Area Reinforcement - Wall

■ Area Reinforcement - Slab

■ Path Reinforcement - Opening

9
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Setting Up Section Views on Sheets
In this lesson, you begin with a framed model as the basis of your details. You cut 2 sections in plan, revise an existing
elevation view, revise a callout view, and add these views to a drawing sheet.

Cut Sections and Add Views to Sheets

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_Concrete_Details.rvt located in the Imperial folder.

Cut a section through the foundation wall

1 In the Project Browser, expand Views (all) ➤ Structural Plans, and double-click Ground Level to open the
view.

2 On the Toolbar, click  , and draw a zoom box around the southwest corner at grid line A and between
grid lines 3 and 4.

3 On the View tab of the Design Bar, click Section.

4 Draw the section as shown: click to the left of the wall, move the cursor to the right, and then click to the
right of the wall.

5 On the Design Bar, click Modify.

6 Double-click the section bubble to open the section view.
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7 In the section view, select the crop region, and drag the controls to resize the crop region such that only
the foundation wall is shown.
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Resized view

8 On the View Control Bar:

■ Click Scale control, and select 3/4" = 1'- 0" .

■ Click Detail Level ➤ Fine.

■ Click Model Graphics Style ➤ Shading with Edges.

Create a sheet and place the section view on the sheet

9 Click View menu ➤ New ➤ Sheet.

10 In the Select a Title Block dialog, select E1 30x42 Horizontal , and click OK.

11 In the Project Browser, under Sheets, right-click the sheet S-6 Unnamed, and click Rename.

12 In the Sheet Title dialog, enter S-4 for Number, enter Concrete Details for Name, and click OK.

13 In the Project Browser, under Sheets, right-click the S-4 sheet, and click Add View.

14 In the Views dialog, select Section: Section 1, and click Add View to Sheet.

15 Place the view on the sheet as shown.
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16 Click File menu ➤ Save As.

17 Navigate to a folder of your preference, and save the file as: i_RST_Concrete_Details-in progress.rvt .

18 Proceed to the next lesson, “Model Based Concrete Detail Examples” on page 193.

Model Based Concrete Detail Examples
In this lesson, you sketch rebar on a footing detail, and add area reinforcement to a wall and a concrete slab using the
Revit Structure drafting tools and the area reinforcement tool.

Footing Detail

Dataset
Continue to use the dataset you saved in the previous exercise, i_RST_Concrete_Details-in progress.rvt .

1 In the Project Browser, under Structural Plans, double-click Ground Level.

NOTE The line weights in your file may differ from the examples shown. Some of the rebar line weights were
increased in the illustrations for training purposes.

2 On the Toolbar, click  , draw a pick box, and zoom in on the southwest corner of the structure.

3 Click the section line, and position the upper drag bar as shown.

4 Press ESC.

5 Double-click the section bubble.
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The Section 1 view opens.

Add wall keys at the bottom of wall

6 On the Toolbar, click  , and draw a zoom box around the wall footing as shown.

7 Click Tools menu ➤ Edit Cut Profile.

8 On the Options Bar, select Boundary between faces.

9 Select the boundary between the wall and footing.
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10 On the Design Bar, click  , select Chain, and click  . Sketch 3 lines as shown.

11 On the Design Bar, click Finish Sketch.

Add straight bar to footing

12 On the Modelling tab of the Design Bar, click Rebar ➤ Sketch Rebar.

13 Select the continuous footing as the host element.

The Design Bar changes to sketch mode.

Footing Detail | 195



14 Sketch a straight bar by clicking inside the footing first and then moving the cursor to the right as shown.

15 On the Sketch tab, click Finish Sketch.

Add hooked bars to footing

16 On the Modelling tab of the Design Bar, click Rebar ➤ Sketch Rebar.

17 Select the continuous footing as the host element.

18 Sketch a rebar by clicking inside the footing first and then moving the cursor into the wall as shown.

NOTE Be sure to sketch from the footing to the wall.

19 On the Sketch tab, click Finish Sketch.

20 Right-click the rebar you added in the previous steps, and click Properties.

21 In the Element Properties dialog, under Construction, select Rebar Hook 1 for Hook at Start.

22 Click OK.
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23 Repeat the same steps to place a rebar on the other face of the wall.

24 Select the second rebar, and click the hook orientation control  to reverse the direction of the hook.

25 On the Modelling tab of the Design Bar, click Rebar ➤ Place Rebar.

26 Select the end of the straight bar, and place the pointer between the hooked and straight bars approximately
as shown.

Footing Detail | 197



Notice the rebar tool snaps to the end of the straight bar.

27 Click to place the first rebar as shown.

28 On the Design Bar, click Modify.

Place rebar set

29 Select the single rebar.

30 On the Options Bar, do the following:

■ For Rebar Set Layout Rule, select Number with Spacing.

■ For Quantity, enter 6.
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■ For Spacing, enter 6" .

31 On the Design Bar, click Modify.

Check rebar spacing

32 On the Drafting tab of the Design Bar, click Dimension.

33 Move the cursor over the first rebar in the array.

The vertical snapping plane of the bar is highlighted.

34 Click to select this plane, and move the cursor to the edge of the footing as shown.
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35 Click to select this plane and place the dimension.

NOTE The dimension is placed to check the distance from the concrete face to the rebar array. Delete the
dimension after verifying the clearance requirements have been met.

36 Click File menu ➤ Save.

37 Proceed to the next exercise, “Wall Detail” on page 200

Wall Detail

Dataset
Continue to use the dataset you saved in the previous exercise, i_RST_Concrete_Details-in progress.rvt .

1 In the Project Browser, under Structural Plans, double-click Garage Level - 1.

NOTE The line weights in your file may differ from the examples shown. Some of the rebar line weights were
increased in the illustrations for training purposes.

2 On the Toolbar, click  , draw a pick box, and zoom in on the southwest corner of the structure.

3 On the View tab of the Design Bar, click Section.

4 Click inside the wall between grid lines B and C, move the cursor down, and click the outside wall to place
the section as shown.
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5 On the Design Bar, click Modify.

6 Click the section line, and position the drag bar as shown.

7 Press ESC.

8 Double-click the section bubble.

The Section 2 view opens.

9 In the section view, select the crop region, and drag the controls to resize the crop region such that only
the foundation wall is shown.

10 On the View Control Bar:

■ Click Scale control, and select 3/4" = 1'- 0" .

■ Click Detail Level ➤ Fine.
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■ Click Model Graphics Style ➤ Shading with Edges.

Place horizontal rebar

11 On the Modelling tab of the Design Bar, click Rebar ➤ Place Rebar.

12 Place the rebar at the base of the wall approximately as shown.

13 On the Design Bar, click Modify.

14 Select the rebar, and on the Options Bar, do the following:

■ For Rebar Set Layout Rule, select Fixed Number.
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■ For Quantity, enter 3.

Rotate the rebar

15 Select the rebar.

Notice all 3 instances of rebar are grouped as a single element.

16 On the Edit toolbar, click  .

The rotation center control is positioned over the left bar.

17 Click and drag the rotation center control to the left rebar as shown.

18 Move the cursor to the left to set the rotation control angle, and rotate the rebar set as shown.

19 Click to place the rebar array.
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Set maximum spacing

20 Select the rebar, and on the Options Bar, do the following:

■ For Rebar Set Layout Rule, select Maximum Spacing.

■ For Spacing, enter 1' 6" .

21 Drag the rebar shape handle to the top of the wall.

Additional rebar will be placed at the specified distance.

Mirror the rebar set

22 On the Edit toolbar, click  .

23 Move the cursor to the right until the center line reference plane of the wall appears as shown.
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24 Click to place the rebar.

Place vertical rebar

25 Right-click in an empty part of the drawing area, and click Zoom to Fit.

26 On the Toolbar, click  , and draw a zoom box around the lower half of the wall.

27 On the Modelling tab of the Design Bar, click Rebar ➤ Sketch Rebar.

28 Select the concrete wall to be the rebar host.

You are now in sketch mode.

29 Click the top rebar.
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Notice the cursor snaps to the rebar to establish the sketch endpoint.

30 Drag the sketch line towards the bottom of the wall as shown.

31 On the Design Bar, click Modify.

32 On the Design Bar, click Finish Sketch.

Mirror the rebar

33 Click the vertical rebar.

34 On the Edit toolbar, click  .

35 Move the cursor over the wall until the center line reference plane appears.
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36 Click to place the rebar.

Rebar visibility

37 Select the outside vertical rebar, and on the Options Bar, click  .

38 In the Element Properties dialog, under Graphics, click Edit for View Visibility States.

39 In the Rebar Element View Visibility States dialog, for 3D View, select Visibility, and click OK.
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40 In the Element Properties dialog, click OK.

41 In the Project Browser, under 3D Views, double-click 3D.

42 On the Toolbar, click  .

43 Rotate the model to view the garage ramp side of the structure.

44 On the Toolbar, click  , and draw a zoom box around the garage ramp.

Notice the single vertical rebar is visible.

Extend the vertical rebar for the garage wall

45 Select the single rebar, and on the Options Bar, do the following:

■ Select Maximum Spacing for Rebar Set Layout Rule.

■ Enter 1' 6" for Spacing.

46 Drag the shape handles to extend the rebar to the left and right edges of the garage wall as shown.
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Additional rebar will be placed at the specified distance.

47 With the rebar array still selected, on the Options Bar, click  .

48 In the Rebar Element View Visibility States dialog, clear Visibility for 3D View.

The rebar array is no longer visible in the 3D View.

49 Click File menu ➤ Save.

50 Proceed to the next exercise, “Area Reinforcement Wall Detail” on page 209

Area Reinforcement Wall Detail

Dataset
Continue to use the dataset you saved in the previous exercise, i_RST_Concrete_Details-in progress.rvt .

Create a section view

1 In the Project Browser, under Structural Plans, double-click Garage Level-1.

NOTE The line weights in your file may differ from the examples shown. Some of the rebar line weights were
increased in the illustrations for training purposes.

2 On the Toolbar, click  , and draw a zoom box around the upper north wall of the structure.

3 On the View tab of the Design Bar, click Section.

4 Add a section line that cuts through the north wall of the structure as shown.

5 Double-click the section bubble to open the section view.
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6 On the Options Bar, select 3/4" = 1' - 0" for Scale.

7 In the section view, select the crop region, and drag the controls to resize the crop region such that only
the foundation wall is shown.

Sketch the area reinforcement

8 Select the foundation wall.

9 In the Project Browser, under 3D Views, double-click 3D.

10 On the Toolbar, click  .
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11 Rotate the model to view the atrium side of the structure.

The foundation wall is highlighted.

12 On the Options Bar, click  to enter sketch mode.

13 On the Design Bar, click Lines, and trace the outline of the foundation wall as shown.
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NOTE The 2 short lines adjacent to the vertical line of the outline represent the rebar major direction. Bars will
be placed parallel to the major direction near both wall faces. Minor bars will be placed perpendicular to the
major bars, adjacent to the major bars. To change the major direction, on the Design Bar, click Major Direction
Edge, and select one of the horizontal lines of the outline.

14 On the Design Bar, click Finish Sketch.

The area reinforcement is automatically applied to the selected foundation wall, and is indicated on the
3D view with an X as shown.

15 In the Project Browser, under Sections (Building Sections), double-click Section 3.

The area reinforcement for the foundation wall is displayed.

Remove the major bars

16 Select the area reinforcement rebar, and on the Options Bar, click  .
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17 In the Element Properties dialog, under Layers, clear the values for Exterior Major Direction and Interior
Major Direction, and click OK.

Notice the rebar for the major span direction of the foundation wall is no longer present.

Reselect Interior Major Direction and Exterior Major Direction, and click OK.

Change the number of bars

18 In the Element Properties dialog, do the following:

■ For Value, under Construction, select Fixed Number.

■ For Exterior Minor Number of Lines, under Layers, enter 30.

■ For Interior Minor Number of Lines, under Layers, enter 30.

■ Click OK.
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Notice that more bars are displayed in the section view.
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Add annotation

19 On the Drafting tab of the Design Bar, click Tag ➤ By Category.

20 Click the area reinforcement rebar to place the tag.

21 On the Design Bar, click Modify.

22 Using the drag control, move the rebar tag approximately as shown.

23 Click File menu ➤ Save.

24 Proceed to the next exercise, “Area Reinforcement Slab Detail” on page 215.

Area Reinforcement Slab Detail

Dataset
Continue to use the dataset you saved in the previous exercise, i_RST_Concrete_Details-in progress.rvt .
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Create a section view

1 In the Project Browser, under Structural Plans, double-click Garage Level-1.

NOTE The line weights in your file may differ from the examples shown. Some of the rebar line weights were
increased in the illustrations for training purposes.

2 On the Toolbar, click  , and draw a zoom box around the circular foundation on the north side of
the structure as shown.

3 On the View tab of the Design Bar, click Section.

4 Add a section line that cuts through the circular foundation as shown.

5 Double-click the section head to open the section view.

6 On the View Control Bar, do the following:

■ For Scale, select 1/4" = 1' - 0" .

■ For Detail Level, select Fine.

■ For Model Graphics Style, select Shading w/Edges.

7 In the section view, select the crop region, and drag the controls to resize the crop region such that only
the concrete slab on Garage Level-1 is shown.
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Sketch the area reinforcement

8 In the Project Browser, under Structural Plans, double-click Garage Level -1.

9 Select the concrete slab as shown.

10 On the Options Bar, click  to enter sketch mode.

11 Using the line tool, draw an area reinforcement box as shown.
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12 On the Design Bar, click Finish Sketch.

13 In the Project Browser, under Sections (Building Sections), double-click Section 4.

The area reinforcement for the slab is displayed.

Change the rebar properties

14 Select the area reinforcement rebar, and on the Options Bar, click  .

15 In the Element Properties dialog, do the following:

■ Under Layers, clear Top Major Direction.

■ For Bottom Major Hook Type, under Layers, select None.

Add annotation

16 On the Drafting tab of the Design Bar, click Tag ➤ By Category.

17 Click the area reinforcement rebar to place the tag.
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18 On the Design Bar, click Modify.

19 Select the rebar tag, and on the Options Bar, select Free End.

20 Using the drag control, move the rebar tag approximately as shown.

21 Click File menu ➤ Save.

22 Proceed to the next exercise, “Path Reinforcement Detail” on page 219.

Path Reinforcement Detail

Dataset
Continue to use the dataset you saved in the previous exercise, i_RST_Concrete_Details-in progress.rvt .

Sketch the path reinforcement

1 In the Project Browser, under Structural Plans, double-click Level 3.

2 On the Toolbar, click  , and draw a zoom box around the slab opening on the north side of the
structure as shown.

3 On the Modelling tab of the Design Bar, click Rebar ➤ Sketch Path Reinforcement.

4 Select the slab opening.

You are now in sketch mode.
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5 On the Options Bar, click  , and enter 1' 0" for Offset.

6 Draw a path reinforcement box approximately as shown.

NOTE The lines you sketch for the path reinforcement box cannot intersect and must not form a closed loop.

7 On the Design Bar, click Finish Sketch.

The path reinforcement for the slab opening is displayed. Using the drag control, move the rebar tag
approximately as shown.

Create a section view

8 On the View tab of the Design Bar, click Section.

9 Add a section line that cuts through the slab opening as shown.
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10 On the Design Bar, click Modify.

11 Double-click the section head to open the section view.

12 On the View Control Bar, do the following:

■ For Scale, select 1/4" = 1' - 0" .

■ For Detail Level, select Fine.

■ For Model Graphics Style, select Shading w/Edges.

13 In the section view, select the crop region, and drag the controls to resize the crop region such that only
the edge of the opening in the slab and the path reinforcement on Level 3 is shown.

NOTE The line weights in your file may differ from the examples shown. Some of the rebar line weights were
increased in the illustrations for training purposes.

Change rebar properties

14 On the Toolbar, click  , and draw a zoom box around the edge of the slab opening.

15 Select the rebar.
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Notice the rebar toggle control icon appears.

16 Click the toggle control to change the rebar hook type as shown.

17 Click File menu ➤ Close.

You can save the open file if you wish. In the next lesson, a new dataset is supplied.

18 Proceed to the next lesson, “Creating a Detail Library” on page 222.

Creating a Detail Library
In this lesson, you begin by opening a project that contains common drafting view details. Instead of having to draw
these details for every project, you will learn how to save both the individual views and complete detail sheets as a new
detail library and then import these details into a different project.

Creating a Drafting View Detail Library

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_Save_Detail.rvt located in the Imperial folder.

Save a group of views to the library

1 In the Project Browser, expand Sheets (all), and double-click S.1 - TYPICAL DETAILS.
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Notice there are 3 typical detail views on this sheet.

2 Click File menu ➤ Save to Library ➤ Save Views.

3 In the Save Views dialog, select Drawing Sheet: S.1 - TYPICAL DETAILS, and click OK.

4 In the Save As dialog:

■ Locate a common drive that can be accessed by all team members.

■ Click the icon to the right of Save In to create a new Folder.

■ Enter Detail Library for the folder name.

■ Open the new folder.

■ Under File name, enter TYPICAL COLUMN BEAM AND GIRDER DETAILS.

■ Click Save.
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Save individual views to the library

5 Click File menu ➤ Save to Library ➤ Save Views.

6 In the Save Views dialog, do the following:

■ In the list of views, clear Drawing Sheet: S.1 - TYPICAL DETAILS.

■ Under Views, select Show drafting views only.

Only the drafting views will be displayed.

■ Select both Footing Section views.

■ Click OK.

7 In the Save As dialog, do the following:

■ Under Save in, navigate to the Detail Library folder created in step 4.

■ For File name, enter FOOTING SECTION.

■ Click Save.

NOTE When you save your file, Revit Structure will save views that contain 3D objects; however, when you insert
these views into a new project, only the 2D elements will be inserted.

8 Click File menu ➤ Close.

9 Proceed to the next exercise, “Importing Details from the Library” on page 224.

Importing Details from the Library

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_Insert_Detail.rvt located in the Imperial folder.
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NOTE This exercise requires the completion of the previous exercise, “Creating a Drafting View Detail Library” on page
222 before proceeding.

Insert drawing sheet from the library

1 Click File menu ➤ Insert from File ➤ Views.

2 In the Open dialog:

■ For Look in, select the Detail Library folder you created in the previous exercise.

■ Select the file TYPICAL COLUMN BEAM AND GIRDER DETAILS.rvt.

■ Click Open.

3 In the Insert Views dialog:

■ Select Drawing Sheet: S.1 - TYPICAL DETAILS.

■ Click OK.

Because you are importing element types that may already exist in the project, a duplicate types dialog
displays. Click OK.

4 Once the drawing sheet opens, close the warning dialog that appears.
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5 In the Project Browser, expand Sheets (all), and double-click S.1 - TYPICAL DETAILS.

Insert separate footing sections from the library

6 Click File menu ➤ Insert from File ➤ Views.

7 In the Open dialog, do the following:

■ For Look in, select the folder Detail Library you created in the previous exercise.

■ Select the file FOOTING SECTION.rvt.

■ Click Open.

8 In the Insert Views dialog:

■ Under Views, select Drafting View: FOOTING SECTION.
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■ Click OK.

Because you are importing element types that may already exist in the project, a duplicate types dialog
appears. Click OK.

9 Click File menu ➤ Insert from File ➤ Views.
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10 In the Open dialog:

■ For Look in, select the folder Detail Library you created in the previous exercise.

■ Select the file Footing Sections.rvt.

■ Click Open.

11 In the Insert Views dialog:

■ Under Views, select Drafting View: Footing Section 2.

■ Click OK.

Because you are importing element types that may already exist in the project, a duplicate types dialog
appears. Click OK.
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12 Click File menu ➤ Close.

You have created a library of common drafting details that can be shared by each member of the structural
team. You have also imported both individual detail views as well as the entire detail sheet into an existing
project.

13 Proceed to the next tutorial, “Annotating and Dimensioning” on page 231.
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Annotating and Dimensioning

In this tutorial, you learn how to annotate and dimension your Autodesk® Revit® Structure 4 projects.

10
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Dimensioning
In this lesson, you learn how to create permanent dimensions to control and document your designs. In Revit Structure,
there are 2 types of dimensions: temporary and permanent. Temporary dimensions display automatically when you
create and insert components. Permanent dimensions must be explicitly created, except when you sketch profiles to
create families. In this case, permanent dimensions are created automatically, although you must turn on their visibility
to view them.

Creating Dimensions

In this exercise, you learn how to create and modify different types of permanent dimensions that you can add to your
drawings. The dimension types include aligned, linear, multi-segmented, radial, and angular.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_Dimensioning.rvt located in the Imperial folder.

Create permanent dimensions

1 In the Project Browser, expand Views (all) ➤ Floor Plans, and double-click Floor.

2 On the Basics tab of the Design Bar, click Dimension.

The default dimensioning options display on the Options Bar. By default, dimensions are aligned and snap
to wall centerlines.

3 Without making any changes on the Options Bar, move the cursor over the north wall of the proposed
North Building.

4 When the centerline of the wall highlights, select it.

5 Move the cursor toward the south wall and when the centerline of the wall highlights, select it.
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6 Move the cursor to the left, toward the empty space outside the wall, and click to place the dimension.

The dimension displays in the drawing. A lock symbol that is unlocked displays next to it, indicating that
the dimension can be modified.

7 Click the lock.

The lock displays as locked, indicating that you cannot change the distance between the referenced walls
without first unlocking the dimension. Only aligned and angular permanent dimensions can be constrained
in this way.

8 On the Design Bar, click Modify.

9 Select the north wall and move it upward.

Notice that the south wall moves with the north wall, and the distance between them does not change
because the dimension is constrained.

10 Click  .

11 Select the dimension, click the lock to unlock it, and press DELETE.

Create a multi-segmented dimension

12 On the Design Bar, click Dimension.

13 On the Options Bar, select Wall centerlines for Prefer.

14 Select the north and south walls of the North Building.
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15 On the Options Bar, select Wall faces for Prefer.

16 Select the exterior faces of the top and bottom walls of the South Building.

17 Move the cursor to the left of the South Building, and click to set the dimension location.

An unlocked lock symbol displays next to each dimension segment. In addition, an equal symbol with a
slash through it is displayed, indicating that the dimension segments are not equal in length.

Create a radial dimension

18 On the Design Bar, click Dimension.

19 On the Options Bar, click  , and select Wall centerlines for Prefer.

20 Dimension a curved wall of the North Building:

■ Select the southwest corner wall to display the radial dimension.

■ Move the cursor to the inside of the curved wall, and click to place the dimension.

21 Click View menu ➤  Zoom ➤ Zoom in Region, and draw a zoom box around the curved wall.
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The dimension is snapped to the wall centerline, the default dimension option.

22 On the Design Bar, click Modify, select the dimension line of the radial dimension, and press DELETE.

23 On the Design Bar, click Dimension.

24 On the Options Bar, click  , and select Wall faces for Prefer.

25 Dimension the curved wall again:

■ Move your cursor over the inside face of the wall until it highlights.

■ Select the inside face of the wall, and place the dimension as shown.

26 Adjust the zoom settings so that you can add a dimension to the upper-left portion of the North Building.

Create an angular dimension

27 On the Options Bar, click  , and verify that Wall faces is selected for Prefer.

28 Dimension the angled wall at the top left of the North Building:

■ Select the inside face of the angled wall below the opening, and then select the inside face of the
vertical wall below it.

■ Move your cursor to the right to size the dimension arc, as shown, and click to place the dimension.

Create a linear dimension

29 On the Options Bar, click  .
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Notice that the Prefer and Pick options are no longer available on the Options Bar. The linear dimension
tool has a more restricted selection filter so that you can select only points. The dimension is always
constrained to either the horizontal or vertical axis, and depends on the cursor tracking behavior. You can
override the cursor tracking by pressing the SPACEBAR.

30 Dimension interior walls in the South Building:

■ In the top room on the left side of the building, select a point at the interior corner of the top left wall
join.

■ Select the interior corner of the bottom left wall join of the room.

■ Move your cursor to the right, and click to place the dimension.

31 On the Design Bar, click Modify.

32 Click File menu ➤ Save As, and save the model to a location of your choice using the following filename:
i_RST_Dimensioning-in progress.rvt .

33 Proceed to the next exercise, “Controlling Witness Line Location” on page 236.

Controlling Witness Line Location

In this exercise, you learn to add, delete, and change the origin of dimension witness lines. When you place dimensions,
you specify their origin on the Options Bar. However, in some cases, you may need to override their settings on an
instance basis. For example, for a multi-segmented dimension, you may want to locate the 2 outermost witness lines
on the exterior face of each wall, whereas the witness lines referring to interior walls would be located on the centerline
of each wall.

Dataset
Continue to use the dataset you used in the previous exercise, i_RST_Dimensioning-in progress.rvt

Override dimension defaults

1 Delete the multi-segmented vertical dimension that you placed along the left side of the building model
in the previous exercise.

2 On the Basics tab of the Design Bar, click Dimension.

3 On the Options Bar, verify that Wall faces is selected for Prefer.

4 Move the cursor over the north wall of the North Building, but do not select anything.

5 Alternate the cursor position over the inner and outer wall face.

Notice that only the wall faces highlight when you move the cursor over them, because the Prefer wall
faces option is selected instead of the Prefer wall centerline option.

6 Position the cursor over the wall, and press TAB repeatedly.

Each time you press TAB, a different wall selection choice highlights, including the wall centerline.

7 When the exterior face of the wall highlights, select it.
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8 Move the cursor over the south wall of the North Building, press TAB until the wall centerline highlights,
and select it.

9 Move the cursor to the top horizontal wall of the South Building, and select the exterior face.

10 Move the cursor to the south wall of the South Building, and select the exterior face.

11 Place the dimension as shown.

Edit dimension witness lines

12 On the Design Bar, click Modify.

13 Select the dimension that you just placed.

The dimension highlights, and control boxes display on each witness line.
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14 Click twice on the control box on the witness line that references the south wall of the North Building.

The witness line moves to interior wall face.

15 Click the control box again.

The witness line moves to the wall centerline.

16 Move the cursor to the control box on the witness line that references the north wall of the South Building,
but do not select it.

17 Right-click the control box, and click Delete Witness Line.

The witness line is deleted.
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18 Right-click the dimension line that references the face of the south wall of the North Building, and click
Edit Witness Lines.

IMPORTANT Be careful to right-click the witness line and not the control box on the witness line. If you right-click
the control box, a context menu with different options is displayed.

19 Select the outside face of the north wall of the South Building.

The full dimension string is displayed.

20 To end the editing command, click in the drawing area away from the floor plan.

21 Click File menu ➤ Save.

22 Proceed to the next exercise, “Modifying Dimension Properties” on page 239.

Modifying Dimension Properties

In this exercise, you learn to modify the type parameters of dimensions.

Dataset
Continue to use the dataset you used in the previous exercise, i_RST_Dimensioning-in progress.rvt .

Change the type parameters of the floor plan dimensions

1 On the Basics tab of the Design Bar, click Modify, and select the multi-segmented dimension that you
modified in the previous exercise.

2 On the Options Bar, click  .

3 In the Element Properties dialog, click Edit/New.

4 In the Type Properties dialog, change the following type parameter values:

■ Under Text, enter 3/16” for the Text Size.

■ Under Text, select Right, then Up for Read Convention.

5 Click OK twice.

6 On the Design Bar, click Modify.

The dimension updates as shown.
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7 Click File menu ➤ Save. In the next exercise, a new dataset is provided.

8 Proceed to the next exercise, “Working with Alignments and Constraints” on page 240.

Working with Alignments and Constraints

In this exercise, you learn to align components and lock their alignment to better work with them in your drawings.
Aligning components is similar to dimensioning components with a value of zero. A locked alignment is a constraint
that is maintained if any of the aligned components are moved or modified. As you create components, alignments
can be made and locked with minimal effort. For example, when sketching walls, if 2 or more walls are colinear, a lock
symbol immediately displays, allowing you to lock the alignment of the walls.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_Alignment.rvt located in the Imperial folder.

Align the 2 uppermost horizontal walls in the floor plan

1 On the Tools toolbar, click  .

The cursor displays 2 arrows at its tip, indicating that the Align command is active.

2 Align the walls:

■ Select the exterior face of the uppermost horizontal wall.

■ Select the exterior face of the shorter horizontal wall on the left.

The shorter horizontal wall on the left moves to align with the upper horizontal wall. When you align 2
components, the first component that you select is the target and remains fixed in position, while the
second component moves to complete the alignment. The lock symbol displays as unlocked, indicating
the 2 walls are not constrained to each other.
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3 Click the lock.

The symbol changes to a closed lock, indicating that the alignment of the 2 walls is now locked.

Align the 3 short horizontal walls

4 On the Options Bar, select Multiple Alignment, and select Wall centerlines for Prefer.

5 Select the lower center wall to define it as the target fixed wall to which the other walls will align.

6 Select the short wall to the left.

7 Click the lock to lock the alignment of the walls.

8 Select the short horizontal wall on the right.
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Do not lock this segment of the alignment.

9 On the Design Bar, click Modify.

10 Select the middle horizontal wall, and drag it downward.

The wall on the left moves with the middle wall when you drag it, but the wall on the right does not
because the alignment between the 2 walls is not constrained (locked).

11 On the toolbar, click  once to undo the move.

12 Click the right wall, and then click the lock to align the wall with the middle wall.

Move the walls to verify the alignment.
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Align the windows on the floor plan

13 On the Tools toolbar, click  .

14 On the Options Bar, clear Multiple Alignment.

15 Select the window in the upper horizontal wall on the left side of the floor plan.

16 Select the window on the far left in the lower wall.

The 2 windows align.

17 Select the far right window in the bottom wall.

18 Select the far right window in the top wall.

The second window does not align because it is already constrained by a locked dimension.

19 To view the constraint, on the Design Bar, click Modify, and select the dimension between the second
window and the right wall. A lock is displayed, indicating the constraint.

20 Click the lock to unlock it.

21 On the Tools toolbar, click  , and align the windows.
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22 Align the remaining windows, as shown.

23 Click File menu ➤ Save As, and save the model to a location of your choice using the following filename:
i_RST_Alignment-in progress.rvt .

24 Proceed to the next exercise, “Creating Automatic Linear Wall Dimensions” on page 244.

Creating Automatic Linear Wall Dimensions

In this exercise, you learn how to automatically dimension a linear wall with openings (windows) by selecting the wall,
instead of selecting the wall and all the openings as dimension references.

Dataset
Continue to use the dataset you used in the previous exercise, i_RST_Alignment-in progress.rvt .

1 View the south wall, and notice that it includes 5 openings.
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You want to dimension the wall so that the width of each opening displays in the dimension string.

2 On the Design Bar, click Dimension.

3 On the Options Bar, do the following:

■ Click  .

■ Verify Wall centerlines is selected for Prefer.

■ Select Entire Walls for Pick.

■ Click Options.

4 In the Auto Dimension Options dialog, select Openings and Widths.

These options ensure that the wall dimension includes the openings (in this case, the windows), and that
the window widths are referenced in the overall dimension string.

5 Click OK.

6 Select the south wall.

The 2 vertical walls highlight, indicating the start and end of the dimension string.

7 Move your cursor below the south wall, and click to add the dimension.

8 On the Design Bar, click Modify.
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9 Click File menu ➤ Save. In the next lesson, a new dataset is provided.

10 Proceed to the next lesson, “Annotating” on page 246.

Annotating
In this lesson, you learn how to use some of the annotation features included in Revit Structure. You learn how to:

■ Tag a single beam

■ Tag a beam system

■ Tag beams by category

■ Create a custom type mark in place of the beam tag.

Tagging Beams

In this exercise, you learn how to place beam tags. You learn how to add a beam tag, tag all the beams that are not
tagged, and create a custom mark in place of the beam tag.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_Annotations.rvt located in the Imperial folder.

Add a beam tag

1 In the Project Browser, expand Structural Plans, and double-click Level 2.

2 On the Drafting tab of the Design Bar, click Tag ➤ By Category.

Move the cursor over the beams in the drawing area, and notice the tag for the specific beam is displayed.

3 Click any beam to place the tag.

Tag all beams in the structural plan

4 On the Drafting tab of the Design Bar, click Tag All Not Tagged.
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5 In the Tag All Not Tagged dialog, do the following:

■ Under Category, select Structural Framing Tag: Standard.

■ Click Apply.

Notice the tags are loaded in the structural view.

■ Click OK.

Create a custom type mark tag

6 Right-click the open area above the model, and click Zoom ➤ Zoom in Region.

7 Draw a zoom box that surrounds the upper beams between grids C and D as shown.
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8 Click one of the W18 X 40 beams, and on the Options Bar, click  .

9 In the Element Properties dialog, click Edit/New.

10 In the Type Properties dialog, under Type Mark, enter W18 , click Apply and OK.

11 In the Element Properties dialog, click OK.

12 Click one of the W14 X 22 beams, and on the Options Bar, click  .

13 In the Element Properties dialog, click Edit/New.

14 In the Type Properties dialog, under Type Mark, enter W14 , click Apply and OK.

15 In the Element Properties dialog, click OK.

Edit the beam tag family

16 Click one of the W18 X 40 beam tags, and on the Options Bar, click Edit Family.

When prompted to open the Structural Framing Tag for editing, click Yes. You are now in the Family Editor.

17 Click the structural label, and on the Options bar, click  .

18 In the Element Properties dialog, under Label, select Type Mark, and click OK.
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19 Click File menu ➤ Save As.

20 In the Save As dialog, do the following:

■ Select a folder location.

■ Enter Structural Framing Tag - by Type Mark for File name.

■ Click Save.

21 On the Family Design Bar, click Load into Projects.

22 In the Load into Projects dialog, select the active file, and click OK.

Apply the new type mark tag to all beams

23 In the plan view, click the W18 X 40 beam tag, hold the Ctrlkey, and select the W14 X 22 beam tag.

24 In the Type Selector, select Structural Framing Tag - by Type Mark: Standard.

The new beam tag is applied to the selected beams.

25 Enter ZF, and draw a pick box around the entire model as shown.
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26 On the Options bar, click  .

27 In the Filter dialog;

■ Click Check None.

All items will be cleared.

■ Select Structural Framing Tags.

■ Click OK.

28 In the Type Selector, select Structural Framing Tag - by Type Mark: Standard.

The new beam tag is applied to all beams.
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29 If you want to save your changes, on the File menu, click Save As, and save the exercise file with a unique
name, or close the exercise file without saving your changes.

Tag the beam system

30 Click View menu ➤  Zoom ➤ Zoom in Region, and draw a zoom box around the beam system as shown.

The existing beam tags have been removed for this step.

31 On the Drafting tab of the Design Bar, click Beam System Tag.

Move the cursor over the beams in the drawing area, and notice the tag for the specific beam system is
displayed.

32 Click any beam within the beam system to place the tag.

33 Click File ➤ Save As, and save the completed project in a folder location of your preference.
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Worksets

On many building projects, engineers commonly work in teams with each person assigned to a specific

functional task. This involves simultaneously working on and saving different portions of the project.

In Autodesk® Revit® Structure 4, this collection of building elements (such as roofs, slabs, beams, etc.)

is called a Workset. In this tutorial, you learn how to use Worksharing to divide a project into worksets

so multiple users can access the project, to allow visibility control and ownership for each assigned

element, and to have all the elements coordinated by Revit Structure.

You can enable Worksharing for any project. Only one user can edit each workset at a given time. All

other team members can view this workset; however, they cannot make changes to it. This prevents

possible conflicts within the project. If you need to modify an element that belongs to a workset that

someone else is actively working on, you can borrow that element without requiring the workset owner

to relinquish control of the entire workset.

Using Worksharing, team members adding and changing elements in worksets can save their work to a

local file on the network to their own hard drive, and they can publish work to a central file whenever

they choose. They can also update their local files at any time in order to see the changes other team

members have published.
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Using Worksharing in a Project
In this lesson, you learn the fundamentals of Worksharing. This includes how to plan and execute the use of worksets
in a project in order to maximize project and team performance. You begin by enabling Worksharing within a project
and setting up the initial workset environment. In the next exercise, you learn how to work as an individual with the
central and local project files. You then learn how to work within a Worksharing-enabled project with multiple users
and how to borrow particular elements from other users.

Enabling Worksharing and Setting Up Worksets

In this exercise, you enable Worksharing within an existing project. You subdivide the project into worksets and save
the project as the central file.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open the i_RST_Worksets.rvt file located in the Imperial folder.

Enable Worksharing

1 On the Options Bar, click  .

NOTE You can also access the Worksets dialog by clicking File menu ➤ Worksets.

2 Click OK to accept the default workset names.

The Worksets dialog is displayed.

Notice that all worksets are open and editable by you, and User1 is displayed as the present owner.

3 TIP The initial owner name is assigned by the operating system of your computer. For training purposes, the
username was changed in the Options dialog (accessible from the Settings menu). You cannot change your
username with an unsaved Worksharing-enabled project open.

4 In the Worksets dialog, under Show, select:

■ Families
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■ Project Standards

■ Views

5 Scroll down the list of workset names, and notice all are editable by you.

6 Under Show, clear Families, Project Standards, and Views.

Only User-Created worksets should display.

In this simple training project, a small number of team members are working on the structural model. For
training purposes, imagine 5 users including yourself. The project is subdivided in such a way as to reflect
the tasks of each user. In this case, one team member is assigned to the slabs, a second user is assigned the
roof, a third is assigned all beams and columns, a fourth is assigned the foundation and garage ramp, a
fifth is assigned to the elevator shafts, and all team members must have access to all linked or imported
DWG or RVT files.

Therefore, you must create worksets that allow each team member to work independently.

Creating new worksets

7 In the Worksets dialog, click New.

8 For the new workset name, enter Beams and Columns.

9 Verify that Visible by default in all views box is selected.

10 Click OK.

11 In the Worksets dialog, click New.

12 For Enter new workset name, enter Elevator Shafts.

13 Verify that Visible by default in all views box is selected.

14 Click OK.

15 In the Worksets dialog, click New.

16 For Enter new workset name, enter Foundation.

17 Because the foundation should only be visible in specific views, clear Visible by default in all views. This
improves performance because fewer components need to be generated in each view.

18 Click OK.

19 In the Worksets dialog, click New.

20 For Enter new workset name, enter Slabs.

21 Verify that Visible by default in all views box is selected.

22 Click OK.

23 In the Worksets dialog, click New.

24 For Enter new workset name, enter Roof.

25 Because the roof should only be visible in specific views, clear Visible by default in all views. Again, this
improves performance.

26 Click OK.

27 In the Worksets dialog, click New.

28 For Enter new workset name, enter Garage Ramp.

29 Because the garage ramp should only be visible in specific views, clear Visible by default in all views.

30 Click OK.

31 In the Worksets dialog, click New.

32 For Enter new workset name, enter Linked or imported DWG or RVT files.

33 Verify that the Visible by default in all views box is selected.

34 Click OK.
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You have created the required worksets for each team member working on this project. The next step is to
create the central file.

35 In the Worksets dialog, click OK

Create the central file

36 Click File menu ➤ Save As.

The central file is created automatically the first time you save the project after enabling worksets.

Navigate to a location on a network drive that all team members have access to, but be sure not to save
the file in the training files location. This is imperative if you and another user intend to complete the
multi-user exercise later in this tutorial. If you do not have access to a network and still want to complete
that exercise, this can be accomplished by saving the central file to your hard drive and changing your
user name before accessing the project.

37 In the Save As dialog, for file name, enter Worsksets Project - Central.

38 Click Save.

Now that you have created the central file, you must relinquish workset editability so that other users can
have access to the worksets they need.

NOTE Continue using the central file for the following steps.

Checking in the worksets

39 On the Options Bar, click  .

NOTE You can also access the Worksets dialog by clicking File menu ➤ Worksets.

40 In the Worksets dialog, under Show, select:

■ User-Created

■ Families

■ Project Standards

■ Views

41 Select all the worksets by pressing CTRL + A.
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42 On the right side of the dialog, click Non Editable.

Notice that your name has been removed as the owner of the worksets and that all Editable values are set
to No.

43 In the Worksets dialog, click OK.

44 Click File menu ➤ Save to Central.

45 In the Save to Central dialog, under Comments, enter Initial Central File Setup, and click OK.

46 After the file is saved, click File menu ➤ Close.

Creating a local file

47 Click File menu ➤ Open.

Navigate to the location of the central file Worksets Project - Central on the network drive.

48 Select the file, and click Open.

49 Click File menu ➤ Save As.

50 In the Save As dialog, navigate to a folder on your local computer.

51 Enter Worksets Project_Local-User 1 for File name, and click Save.

52 Proceed to the next exercise, “Making Elements Editable ” on page 258.

In this exercise, you enabled Worksharing on a project, and created new worksets to accommodate each team member.
You then created the central file, checked in all worksets, and created a local file. This project is now ready for individuals
to access it and check out their required worksets.
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Making Elements Editable

In this exercise, you change the status for the structural columns workset and assign them to User1.

NOTE Continue using the local file Worksets Project_Local-User 1 for the following exercise.

1 On the Options Bar, click  .

In the Worksets dialog, notice that all worksets are available for editing.

2 Click Cancel.

3 Click one of the structural columns as shown.

4 On the Options Bar, click  .

5 In the Element Properties dialog, scroll down to Identity Data.

Notice the value for Workset is grayed out. This indicates that the column element is non-editable by the
current user.

6 Click Cancel.

7 Right-click the highlighted column, and click Make Elements Editable.

8 On the Options Bar, click  .

9 In the Element Properties dialog, for Workset, select Beams and Columns.

10 Click OK.

11 Click the highlighted column to deselect it, and on the Options Bar, click  .
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The Worksets dialog, under Borrowers for Workset1, notice that User1 is listed.

12 Click Cancel.

Assign the structural columns

13 Draw a pick box around the entire model to select all elements.

14 On the Options Bar, click  .

15 In the Filter dialog, click Check None.

16 Select Structural Columns, and click OK.
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All structural columns in the model are highlighted, and a workset puzzle-piece icon displays next to each
column indicating it can be changed to editable.

17 Right-click one of the columns, and click Make Elements Editable.

The puzzle-piece icons disappear, but the columns remain highlighted.

18 On the Options Bar, click  .

19 In the Element Properties dialog, for Workset, select Beams and Columns.

20 Click OK.

The columns and beams elements are now assigned for Workset1.
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21 Click File menu ➤ Save to Central.

22 In the Save to Central dialog, under After save relinguish editable, clear Borrowed Elements.

23 Click File menu ➤ Save, to save the local file.

24 Proceed to the next exercise, “Making the Entire Workset Editable” on page 261.

Making the Entire Workset Editable

In this exercise, you make the entire workset editable and assign individual elements to specific users.

1 Click File menu ➤ Open.

Navigate to the location of the central file Worsksets Project-Central on the network drive.

2 Click Open.

3 On the Options Bar, click  .

In the Worksets dialog, notice User1 is listed under Borrowers for Beams and Columns.

4 In the Worksets dialog, select Workset1, and click the Editable on the right-side of the dialog.
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User1 is now listed as the Owner of Workset1.

5 Click OK.

Assign the floor workset

6 Draw a pick box around the entire model to select all elements.

7 On the Options Bar, click  .

8 In the Filter dialog, click Check None, and select Floors.

9 Click OK.
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All floors are highlighted.

10 On the Options Bar, click  .

11 In the Element Properties dialog, for Workset, select Slabs.

12 Click OK.

The slabs are now assigned for Workset1.

Assign the roof workset

13 Select the roof as shown.
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14 On the Options Bar, click  .

15 In the Element Properties dialog, for Workset, select Roof.

16 Click OK.

The roof is now assigned for Workset1.

Using the steps described in the previous procedure, assign the remaining worksets for the elevator shafts,
foundation, and the garage ramp.

Turn visibility on/off

17 Click elsewhere in the drawing area to deselect the roof.

18 Enter VV. This is the keyboard shortcut for Visibility/Graphic override.

19 In the Visibility/Graphic Overrides dialog, click the Worksets tab.

20 Clear Beams and Columns, Roof, and Slabs, and then click Apply and OK.
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21 The elements are now hidden from the view. To turn off additional elements, clear the box next to the
desired element.

22 Enter VV, and on the Visibility/Graphic Overrides dialog, click the Worksets tab.

23 Check Beams and Columns, Roof, and Slabs, and then click Apply and OK.

The elements are now visible in the view.

Save to central file

24 Click File menu ➤ Save to Central.

25 In the Save to Central dialog, select:

■ User-created Worksets

■ Borrowed Elements

26 After the file is saved, click File menu ➤ Save to save a local copy.

27 Under Comment, enter Reassigning elements to their own worksets.

28 Click OK.

29 Proceed to the next exercise, “Using Worksets with Multiple Users” on page 265.

Using Worksets with Multiple Users

In this exercise, two users access the central file through a network connection. For training purposes, they are referred
to as User 1 and User 2. Each modifies the structural model within their local file and publishes it back to the central
file where the other user can see the changes. Throughout the process, each user must check out worksets, make elements
editable, and reload the latest changes.

This exercise requires the completion of the previous workset exercises and access to the resulting local and central
files. If you have not yet completed these exercises, please do so before continuing.

Although this exercise is designed specifically for two separate users with network access to the central file, a single
user can complete this exercise by opening up an additional session of Revit Structure and setting the username to User
2. In the following section of this exercise, instructions are provided on how to accomplish this.

NOTE If you are working with a second user (User 2), skip the following section, and proceed to Creating a local copy.
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Using a second Revit Structure session to mimic User 2

1 Minimize the current Revit Structure window.

2 Start a new Revit Structure session by double-clicking the Revit Structure icon on the desktop or by selecting
it from the Start menu.

3 On the Settings menu, click Options.

4 Click the General Tab and, under Username, enter User 2, and click OK.

WARNING After completing this tutorial and closing the project file, return to the Settings dialog, and reset the
Username to your computer login name. This is a system setting.

Creating a local copy

5 In this exercise, two users work on the structural model residing in the central file you created and saved
in a previous exercise. If both users have completed the previous worksets exercises and created central
files on the network, select one of those central files to be used in this exercise.

Regardless of which central file you choose to use, one user has already created a local file. For training
purposes, consider that person to be User 1. The user who has not yet created a local file for the chosen
central file is User 2. The next series of steps create a local file for User 2. Throughout the remainder of this
exercise, instructions are staggered, specifically sequenced, and refer explicitly to User 1 and User 2.

User 2: Create a local file, and check out worksets

6 Click File menu ➤ Open, and navigate to the location where you saved the central file named Worksets
project-Central.rvt.

7 In the Open dialog, select the central file and, under Open Worksets, select Specify.

8 Click Open.

Using selective open allows you to choose which worksets you want to open. Only the worksets you select
and any worksets already editable by you are opened. In addition, any referenced workset is opened but
hidden. This reduces the amount of time required to open very large project files and increases performance
while you work.

9 In the Opening Worksets dialog, select all the User-Created worksets, and click OK.

10 Click File menu ➤ Save As.

11 In the Save As dialog, click Options.

12 In the File Save Options dialog, verify that Make this the Central location after save is not selected, and
click OK.

13 Navigate to your preferred location on the hard drive, name the file Worksets Project_Local-User 2, and
click Save.

You now have a local copy of the project. This file is for your use only.

14 Click File menu ➤ Worksets.

15 Select the Foundation workset, and select Yes for Editable.

You are now the owner of that workset.

16 Click OK.

User 1: Check out worksets, modify the structural model, and publish changes

17 User 1 should still have the local file open. If it is not open, open it now.

18 Click File menu ➤ Worksets.

Notice that the Foundation workset is checked out by User 2.

19 Try to change the Editable status for Foundation to Yes.
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A warning is displayed informing you that you cannot check out this workset because it is already checked
out by another user.

20 Click OK to return to the Worksets dialog.

21 Select the Beams and Columns workset, and select Yes for Editable.

Notice that you own this workset and the active workset is now Beams and Columns. If you only have one
workset checked out, it becomes the active workset.

22 Click OK.

23 In the Project Browser, expand 3D Views, and double-click 3D-Atrium.

24 Select any column on the foundation level as shown in the following illustration, and move it.

A warning is displayed informing you that a conflict exists.

25 Click anywhere in the empty drawing area to ignore the warning.

26 Click File menu ➤ Save to Central.

27 In the Save to Central dialog, select the option to save the local file after the central file is saved.

28 Click OK.

User 2: Modify the building model and publish changes

29 In the Project Browser, expand 3D Views, and double-click 3D-Atrium.

Notice that the changes made by User 1 do not immediately display in the local file of User 2. That is
because changes made to the central file display in local files only when the worksets are explicitly updated.

30 Using the following illustration as a guide, select a footing, and move it.
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31 Click File menu ➤ Save to Central.

User 1: Reload latest worksets, and check out additional worksets

32 Click File menu ➤ Reload Latest.

The changes User 2 made are apparent.

33 Click File menu ➤ Worksets.

34 Select Roof, select Yes for Editable, and click OK.

Because you now have more than one workset checked out, you are asked if you want to make the Roof
workset the active workset. Click Yes.

Even though the Roof workset is active, you still have complete access to the elements belonging to the
Roof workset. However, any elements added to the structure are automatically assigned to the active workset.

35 On the Project Browser, under Structural Plans, double-click Roof.

36 On the Modelling tab of the Design Bar, click Slab.

37 In the Design Bar, click Pick Supports, and sketch a new roof between any four beams.

A message displays informing you that the component you are trying to place is not visible in that view.
This is because when the Roof workset was created, the Visible by default option was not selected. Therefore,
the visibility of the workset is not turned on even though it is checked out and is the active workset. You
should turn on the visibility before adding a roof.

38 On the Design Bar, click Modify.

39 On the View menu, click Visibility/Graphics.

40 In the Visibility/Graphics dialog, click the Worksets tab, select Roof to turn on its visibility, and click OK.

41 Notice that the roof you added previously now displays.
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42 Click File menu ➤ Save to Central.

43 In the Save to Central dialog, select the option to save the local file after the central file is saved.

44 Click OK.

If you intend to complete the final portion of this tutorial by proceeding to the Element Borrowing exercise,
leave this file open in its current state.

In this exercise, two users worked on the same structure using worksets. Each user checked out worksets, modified the
structure and published their changes back to the central file.

In the final exercise of this tutorial, you learn how to borrow elements from worksets that other users are actively
working on.

If you intend to complete the final exercise of this tutorial, “Borrowing Elements from the Worksets of Other Users”
on page 269, leave this file open in its current state. This exercise also requires two users and you can skip the first
sections of the exercise and proceed directly to the section, Checking out worksets.

Borrowing Elements from the Worksets of Other Users

In this exercise, two users are working on the same project with separate local files. As each of you work, you must
borrow elements that belong to worksets that the other user has checked out. You learn how to make borrowing requests
and how to grant them.

This exercise requires two users and, throughout this training, they are referred to as User 1 and User 2. There are specific
instructions for each user. Each user must have network access to the central file.

Although this exercise is designed specifically for two separate users with network access to the central file, a single
user can complete this exercise by opening up an additional session of Revit Structure and setting the username to User
2. At the appropriate point in this exercise, instructions are provided on how to accomplish this.

If you have not completed the previous workset exercises, you need to set up your central and local files. Only one user
needs to open the dataset and save the central file to a network location.

NOTE When you open the training dataset for this tutorial, you may receive a message informing you that the central file
has been relocated. Click OK to this message and subsequent messages. These messages are a result of the central file being
relocated (to your PC). In subsequent steps, you save the dataset as a central file, and these problems are rectified.

User 1: Check out worksets

1 Click File menu ➤ Worksets.

2 In the Worksets dialog, if any User-Created worksets are not open, select them, and click Open.

3 Select the Foundation workset, and select Yes for Editable.

You are now the owner of that workset.

4 Under Active Workset, select Foundation, and click OK.
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User 2: Check out worksets

5 Click File menu ➤ Worksets.

6 In the Worksets dialog, select the Beams and Columns workset, and select Yes for Editable.

You are now the owner of that workset.

7 Under Active Workset, select Beams and Columns, and click OK.

User 2: Borrow an element from User 1

8 In the Project Browser, expand 3D Views, and double-click 3D-Atrium.

9 On the Options Bar, verify that Editable Only is cleared.

This allows you to select elements that belong to worksets that you do not own.

10 Using the following illustration as a guide, select a footing.

A symbol appears letting you know that it belongs to a workset you do not own.

11 Move the footing.

A warning message informs you that you must obtain permission from User 1.

12 Click Place Request to ask User 1 for permission to move the footing.

After you submit the request, a message informs you that you are waiting for permission from User 1.

At this point, you should inform User 1 that you are waiting for permission to edit a borrowed element.
Leave this dialog open until User 1 grants permission.

User 1: Grant User 2 permission to borrow element

13 When User 2 contacts you and informs you that a borrowing request is pending your authorization, click
File menu ➤ Editing Requests.
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14 In the Editing Requests dialog, select the request submitted by User 2.

15 Click Grant.

16 Click Close.

User 2: Check for editability grant

17 In the Check Editability Grants dialog, click Check Now.

A message informs you that your request has been granted.

18 Click OK, and notice the footing is in the new location.

User 1 and 2: Save to Central, to Local, and close

19 Click File menu ➤ Save to Central.

20 In the Save to Central dialog, select the following, and click OK.

■ User-created Worksets

■ Borrowed Elements (User 2 only)

■ Save the local file after “Save to Central” completes successfully

21 Click File menu ➤ Close.

In this multi-user exercise, you learned how to borrow elements from another workset even though that workset was
actively being edited by another user. In this case, you requested permission to edit the element, and the other user
granted it.
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Project Coordination

You have received the latest model from the architect and changes have been made to the design. In

this tutorial, the structural engineer imports the modified Autodesk® Revit® Building model, reviews

each change individually, and determines the impact of each modification on the structure. This task is

accomplished using the copy monitor feature that was activated when the project was started. Once each

change has been reviewed, an interference check is run on the model to correct the placement of any

architectural elements (door, or window) that might interfere with elements in the Autodesk® Revit®

Structure 4 model. Finally, all changes are documented using the Revit Structure revision system feature.
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Coordination Review
In this lesson, you begin by opening the Revit Structure file that contains the modified Revit Building file. In the tutorial,
“Starting a New Project” on page 53, the architect’s file was imported into Revit Structure, and the copy monitor feature
was activated. This feature enabled the engineer to monitor the project grids, levels, floors, walls, and columns for any
future modifications. When the modified file is brought back into Revit Structure, the copy monitor feature automatically
notifies you of the changes, which can be accepted, rejected, or postponed, depending on the impact to the design.
Finally, you run an interference check to verify that the changes do not interfere with structural elements of the model.

Opening the Modified Revit Building File

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_Coordination.rvt located in the Imperial folder.

NOTE Because some of the changes from the architect involve elements that are monitored by the copy monitor feature of
Revit Structure, a warning is displayed. Click OK to open the file.

1 In the Project Browser, under Structural Plans, double-click Level 3.

2 Click View menu ➤ Visibility Graphics.

3 In the Visibility/Graphic Overrides dialog, select the Revit Links tab.

4 Select the linked file i_RBD_After.rvt , click Apply, and then click OK.
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The modified Revit Building file will now be visible along with the Revit Structure file. Click  , and
draw a zoom box around the upper-left corner of the building at grid line B, and notice the duplicate grid
lines and the relocation of the stairway.

5 Click View menu ➤ View Properties.

6 In the Element Properties dialog, under Graphics, select Coordination for Discipline, and click OK.

Selecting this discipline allows the architectural walls to be visible.

7 Enter ZF.

This is the keyboard shortcut for Zoom to Fit.

8 On the View Toolbar, click  .

9 On the View Toolbar, click  .

Spin the model until the elevator shaft is visible.

10 On the Toolbar, click  , and draw a zoom box around the lower levels of the elevator shaft as shown.
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11 Click Window menu ➤ Tile.

The Level 3 Plan view and the 3D view are displayed in separate windows. Close all additional views that
may have been opened accidentally.

12 In the Structural Plan: Level 3 window:

■ Select  , and draw a zoom box around the elevator shaft.

■ On the View Control Bar, click the Model Graphics Style control, and click Wireframe.

■ Click between grid lines A and B until the Revit Links box is displayed. Click to select the linked file.

The Revit Building file is highlighted, and the Coordination Review icon displays on the Options Bar.

13 On the Options Bar, click  .

The Coordination Review lists all messages that require some type of action. These messages identify
elements that were deleted, moved, or changed in some way from the architect’s file. The structural engineer
should address each message individually and take some form of action to resolve the conflict. Actions
include: Postpone, Reject, Accept Difference, and a custom message that pertains to each New/Unresolved
category.

14 Click the 3D Views: 3D window to deselect the plan view.
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Review change to Floor Sketch

15 Position the Coordination Review dialog so the 3D window is visible.

16 In the Coordination Review dialog, do the following:

■ Expand New/Unresolved ➤ Floors ➤ expand Monitor Floor Sketches.

■ Display the review message for any individual floor by expanding Sketches are Different.

■ Click the message Floor: Floor: 6" Concrete .

The selected floor from the structural model is highlighted in the 3D window.

■ Click the first message under Monitor Floor Sketches, then press SHIFT while selecting the remaining
messages.

Notice each floor is highlighted on the 3D view.

■ In the Action column, select Copy Sketch to Floor: 6" Concrete , and click Apply.

The concrete floor sketches for all levels of the structure will be adjusted to accommodate the architect’s
floor sketch change.

Review location of grid B

17 Position the Coordination Review dialog so the plan view is visible.
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18 In the Coordination Review dialog, do the following:

■ Expand New/Unresolved ➤ Grids ➤ Maintain relative position of Grids ➤ Grid moved.

■ Click the message i_RBD_After.rvt: Grids: Grid:B .

Grid B from the architect’s model is highlighted on the Level 3 window.

■ For Action, select Modify Grid B, and click Apply.

The grid line is adjusted to accommodate the architect’s change.

Review location of elevator walls

19 On the Toolbar, click  , and draw a zoom box around the elevator shaft in the plan view.

20 In the Coordination Review dialog, do the following:

■ Under New/Unresolved ➤ Walls ➤ expand Maintain wall position.

There are 4 changes involving the elevator shaft walls. Select one of the messages and notice the wall
is highlighted on the Structural Plan: Level 3 plan view.
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■ Click the first message under Wall centerlines are different, then press SHIFT while selecting the remaining
messages.

Notice each wall is highlighted on the Level 3 plan view.

■ For Action, select Modify Wall Basic Wall: Generic 8" Masonry , and click Apply.

The elevator walls on the structural model will be adjusted to accommodate the architect’s change.

Review wall modifications

21 Position the Coordination Review dialog so the lower floors of the 3D View are visible.

22 In the Coordination Review dialog, do the following:

■ Expand New/Unresolved ➤ Walls ➤ Missing Wall Sketches ➤ Sketch is missing.

■ Click the message Walls: Basic Wall: Foundation - 12" Concrete .

The missing sketch line is highlighted in the plan view.

■ Select Postpone for Action.

The structural engineer will discuss this change with the architect before proceeding.

■ Click the Add Comment field.
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■ In the Edit Comment dialog, enter Need to discuss with architect.

■ Click OK.

■ Click the message Walls: Basic Wall: Generic - 8" Masonry .

The missing sketch line is highlighted on the Structural Plan: Level 3 plan view.

■ Select Postpone for Action.

■ Click the Add Comment field.

■ In the Edit Comment dialog, enter Need to discuss with architect.

■ Click OK.

■ In the Coordination Review dialog, click Apply, and OK.

23 Click File menu ➤ Save As, and save the model to a location of your choice using the following filename:
i_RST_Coordination-in progress.rvt .

24 Proceed to the next exercise, “Interference Check” on page 280.

Interference Check

In this exercise, you use the interference tool in Revit Structure to check on 2 potential problems with the stairway.
The first is the possible interference between the stairs and a relocated structural column, and the second is a structural
brace that interferes with a door opening in the stairway.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_RST_Coordination-in progress.rvt

1 Click Tools menu ➤ Interference Check ➤ Run Check.
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The default table compares elements within the same project. The next step is to select the architect’s file
so it can be checked against the structural project.

2 On the right-side of the Interference Check dialog, select i_RBD_After.rvt for Categories from.

Notice the categories for the architect’s file differ from the current Revit Structure project.
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Run interference check on columns and stairs

3 In the list for the current project, select Structural Columns, and Stairs for the Revit Building project.

4 Click OK.

A report is generated showing all instances of interference between columns in the structural project and
the upper-left stairway in the Revit Building project.

5 In the Interference Report dialog, do the following:

■ Under Structural Columns, expand the message for Level 3 Stairs as shown.

There are 7 instances of interference between structural columns and the upper-left stairway. Each
representing a different level.
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■ Select i_RBD_After.rvt: Stairs: Stair: 7" max riser 11" tread .

Notice the stairway of the architect’s model is highlighted on the Structural Plan: Level 3 window

■ Select Structural Columns: W-Wide Flange Column: W10X33 .

Notice the column of the structural model is highlighted on the Structural Plan: Level 3 window, and
that it interferes with the stairway.

■ Click Export to generate an interference report.

Export the Column interference report

6 In the Export dialog:

■ Under Save in, select a folder location on your local computer.

■ Under File name, enter Columns vs. Stair Check.

■ Under Save as type, select Revit Interference Report (*.html).

■ Click Save.

The report provides detail on the interference and should be used to discuss the problem with the architect.

7 In the Interference Report dialog, click Close.

Run interference check on vertical bracing

8 Click Tools menu ➤ Interference Check ➤ Run Check.

9 In the Interference Check dialog, select i_RBD_After.rvt for Categories from.

10 Select Structural Framing ➤ Vertical Bracing for Current Project, and Doors for the Revit Building project.
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11 Click OK.

There is 1 instance of interference between structural bracing and the door for the upper-left stairway.

12 In the Interference Report dialog, do the following:

■ Under Structural Framing ➤ expand Doors.

■ Select i_RBD_After.rvt: Doors: Door Single .

Notice the door from the architect’s model is highlighted on both the 3D View and Structural Plan
view windows.

■ Select Structural Framing: L-Angle: L4X4X3/4
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.

Notice the brace from the structural model is highlighted on both the 3D view and Structural Plan
view windows, also the brace interferes with the opening.

■ Click Export to generate an interference report.

Export the Brace and Door interference report

13 In the Export dialog:

■ Under Save in, select a folder location on your local computer.

■ Under File name, enter Brace vs. Door opening.

■ Under Save as type, select Revit Interference Report (*.html).

■ Click Save.

14 Click File menu ➤ Save and save the file in a folder of your preference. In the next lesson, a new dataset
is provided.

15 In the Interference Report dialog, click Close.

The report provides detail on the interference and should be used to discuss the problem with the architect.

16 Proceed to the next lesson, “Using Revision Tracking” on page 285.

Using Revision Tracking
Revit Structure provides tools that enable you to track revisions to your project. You can create a sequence of revisions,
and you can draw revision clouds around elements in your project that have changed. You can use revision tags to
notate the revision clouds, and can then display the revisions in schedules that appear in the title block of each project
sheet.

Setting Up a Revision Table

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.
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■ Open i_RST_Revision.rvt located in the Imperial folder.

Specify a revision numbering method

1 On the Settings menu, click Revisions.

2 In the Revisions dialog, verify that By Sheet is selected for Numbering Method.

When you use this option, the revisions are numbered according to the sequence in which they are added
to a sheet. If you select By Project, the revisions are numbered according to the sequence of revisions in
the Revisions dialog. For example, if the active revision is number 1, all tags and schedules display the
numeral 1.

Add a revision for grid B

3 Click on the value for Release Date, and enter 2/15/06.

This is the date the revisions were identified.

4 Click on the value for Description, and enter Moved Grid B west by 2' .

In general, revision descriptions should be comprehensive, yet as concise as possible.

5 Verify that Issued is cleared.

When Issued is selected, the revision is locked and issued to the field.

6 Verify that Visible is selected.

If Visible is not selected, any revision cloud you draw to indicate this particular revision is not visible in
the view in which you create it. In most instances, you would turn off visibility only after a revision was
issued.

7 Click Apply, and OK.

8 Proceed to the next exercise, “Sketching Revision Clouds” on page 286.

Sketching Revision Clouds

In this exercise, you indicate the changes made by the architect graphically with a revision cloud. Revision clouds have
read-only properties, including revision number and revision date, which are inherited from the revision table you
created for the project.

You can sketch revision clouds in all views except 3D model views. However, you can add a revision cloud to the 3D
view once it is placed on a sheet. Each cloud is visible only in the view in which it is sketched. You can draw multiple
revision clouds for each revision.
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Add a revision cloud for grid B

1 In the Project Browser, under Sheets (all), double-click S.1 - Level 3 Framing Plan.

2 On the Drafting tab of the Design Bar, click Revision Cloud.

Revit Structure is now in sketch mode.

3 Right-click the view on the sheet, and select Activate View.

The Activate View command activates a viewport on the sheet, allowing you to edit the model directly
from the sheet.

4 In the drawing area, click near grid line B, and move the cursor clockwise to create a segment of the revision
cloud.

5 Click to end that segment and begin a new segment.

6 Continue adding segments until the cloud encompasses the area that you changed.

7 On the Design Bar, click Finish Sketch.

The revision cloud is displayed around the modified grid line.

NOTE At this point, the revision for grid line B should be issued to the field to prevent any changes to the revision
cloud. In this tutorial, the revisions to the project will be issued after all the revision clouds have been drawn.

8 Click File menu ➤ Save As, and save the model to a location of your choice using the following filename:
i_RST_Revision-in progress.rvt .

9 Proceed to the next exercise, “Add Remaining Revisions” on page 287.

Add Remaining Revisions

In this exercise, the remaining revisions for the project are documented.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_RST_Revision-in progress.rvt

Add a revision for the elevator stairs

1 On the Settings menu, click Revisions.

2 In the Revisions dialog, click Add: New.

A new row is added below the existing row in the revision table.

3 Click on the value for Release Date, and enter 2/20/06.

This is the date the revisions were sent out for review.

4 Click on the value for Description, and enter Moved Stair exit 2' west .

In general, revision descriptions should be comprehensive, yet as concise as possible.
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5 Verify that Issued is cleared.

When Issued is selected, the revision is locked and issued to the field.

6 Verify that Visible is selected.

If Visible is not selected, any revision cloud you draw to indicate this particular revision is not visible in
the view in which you create it. In most instances, you would turn off visibility only after a revision was
issued.

Add a revision cloud for the elevator stairs

7 On the Drafting tab of the Design Bar, click Revision Cloud.

Revit Structure is now in sketch mode.

8 In the drawing area, click above the elevator shaft, and move the cursor clockwise to create a segment of
the revision cloud.

9 Click to end that segment and begin a new segment.

10 Continue adding segments until the cloud encompasses the area that you changed.

11 On the Design Bar, click Finish Sketch.

The revision cloud is displayed around the modified stairs. You can change the appearance of the cloud
from the Settings menu.

Add a revision for the brace interference

12 In the Revisions dialog, click Add: New.

A new row is added below the existing row in the revision table.

13 Click on the value for Release Date, and enter 2/21/06.

This is the date the revisions were sent out for review.
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14 Click on the value for Description, and enter Research brace.

In general, revision descriptions should be comprehensive, yet as concise as possible.

15 Verify that Issued is cleared.

When Issued is selected, the revision is locked and issued to the field.

16 Verify that Visible is selected.

If Visible is not selected, any revision cloud you draw to indicate this particular revision is not visible in
the view in which you create it. In most instances, you would turn off visibility only after a revision was
issued.

Add a revision cloud for the brace interference

17 In the Project Browser, under Sheets (all), double-click S.2 - Stair Shafts Sections.

18 Right-click the center view on the sheet, and select Activate View.

The Activate View command activates a viewport on the sheet, allowing you to edit the model directly
from the sheet.

19 On the Drafting tab of the Design Bar, click Revision Cloud.

Revit Structure is now in sketch mode.

20 In the drawing area, click above the brace, and move the cursor clockwise to create a segment of the revision
cloud.

21 Click to end that segment and begin a new segment.

22 Continue adding segments until the cloud encompasses the area that you changed.
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23 On the Design Bar, click Finish Sketch.

The revision cloud is displayed around the brace. You can change the appearance of the cloud from the
Settings menu.

Add a revision for the door interference

24 In the Revisions dialog, click Add: New.

A new row is added below the existing row in the revision table.

25 Click on the value for Release Date, and enter 2/22/06.

This is the date the revisions were sent out for review.

26 Click on the value for Description, and enter Research door.

In general, revision descriptions should be comprehensive, yet as concise as possible.

27 Verify that Issued is cleared.

When Issued is selected, the revision is locked and issued to the field.

28 Verify that Visible is selected.

If Visible is not selected, any revision cloud you draw to indicate this particular revision is not visible in
the view in which you create it. In most instances, you would turn off visibility only after a revision was
issued.
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Add a revision cloud for the door interference

29 In the Project Browser, under Sheets (all), double-click S.2 - Stair Shafts Sections.

30 Right-click the right view on the sheet, and select Activate View.

The Activate View command activates a viewport on the sheet, allowing you to edit the model directly
from the sheet.

31 On the Drafting tab of the Design Bar, click Revision Cloud.

Revit Structure is now in sketch mode.

32 In the drawing area, click above the door, and move the cursor clockwise to create a segment of the revision
cloud.

33 Click to end that segment and begin a new segment.

34 Continue adding segments until the cloud encompasses the area that you changed.

35 On the Design Bar, click Finish Sketch.

The revision cloud is displayed around the door. You can change the appearance of the cloud from the
Settings menu.

36 Click File menu ➤ Save.

37 Proceed to the next exercise, “Tagging Revision Clouds” on page 291.

Tagging Revision Clouds

In this exercise, you apply a revision tag to the revision cloud in the current drawing. The tag number that is displayed
in the drawing is based on the numbering method you specified when you set up the revision table in a previous
exercise.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_RST_Revision-in progress.rvt

Place a revision tag

1 In the Project Browser, under Sheets (all), double-click S.1 - Level 3 Framing Plan.

2 Right-click the view on the sheet, and select Activate View.

The Activate View command activates a viewport on the sheet, allowing you to edit the model directly
from the sheet.

3 On the Drafting tab of the Design Bar, click Tag ➤ Tag By Category.
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4 On the Options Bar, clear Leader.

5 In the drawing area, position the cursor just outside the revision cloud for grid line B.

If the cursor is just inside the cloud, the tag is displayed inside the cloud.

6 Click to place the tag.

The tag displays the revision number of the cloud. The number is based on the numbering method you
specified when you set up the revision table. Because you chose to number by sheet, and because the
revision is the first in the project, the cloud is tagged as number 1.

7 Repeat steps 2 through 5 to add revision tags for all remaining revision clouds.

8 On the File menu, click Save.

9 Proceed to the next exercise, “Working with Revisions” on page 292.

Working with Revisions

In this exercise, you first view the revisions that were created in the previous exercise, and then issue the revisions to
create a record, and lock it from further changes.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_RST_Revision-in progress.rvt

View the revisions

1 In the Project Browser, under Sheets (all), double-click S.1 - Level 3 Framing Plan.

2 Select  , and draw a zoom box around the title block as shown.
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3 In the Project Browser, under Sheets (all), double-click S.2 - Stair Shafts Sections.

4 Select  , and draw a zoom box around the title block as shown.

Issue a revision

5 After you make the necessary changes to the project and add the revised views to a sheet, you prevent
further changes to the revision. You do this by issuing the revision.

On the Settings menu, click Revisions.

6 Select Issued for each revision entry, and click OK.

NOTE After you issue a revision, you can no longer modify it. You cannot add revision clouds to the revision in
the drawing area, nor can you edit the sketch of the existing clouds.

7 On the File menu, click Close. Click Yes when prompted to save the drawing.
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Structural Analytical Modelling

In this tutorial, you learn some basic concepts of the Autodesk® Revit® Structure 4 analytical model and

how to prepare the model to be analyzed by a 3rd party analysis software.

13
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Applying the Analytical Model to the Design Process
Revit Structure combines 2 models. The physical model that is used for documentation, quantity take off, interaction
with steel detailers and fabricators and also the analytical model that can be consumed by multiple 3rd party analysis
software. The analytical model consists of structural components, component properties, material properties, geometry,
loads and load combinations. As you create objects and the physical model, the analytical model is created automatically
based on engineering rules and logical relationships between the structural objects.

When working with the analytical model, Revit Structure View Templates provide initial conditions for a view. You
can apply a template to an existing or new view. You can also apply an existing view’s view properties using the Apply
View Template command. The view inherits view properties such as View Scale, Discipline, Detail level, and the visibility
settings of categories and subcategories. View Templates help standardize the look of all views.

Views and View Templates are not linked. All views created with that template are not automatically updated. To update
a view, you can reapply the modified template.

NOTE Reapplying a view template overrides previous view property modifications and View templates can only be applied
to geometric views.

Because each view in Revit Structure consists of different properties, the View Template saves and applies only common
properties. You can save the View Template from one type of view and apply those same properties to any other
geometric view.

For example, if you save a template from a plan view, you can apply that same template to a 3D view. Though the View
Range property applies only to plan views, the template is still applied to the 3D view. Revit Structure applies only the
properties applicable to both.

Analytical Checks

In this exercise, you learn how to check member supports, and run an analytical consistency check on the analytical
model shown below. Analytical checks should be run at different phases of the project and the model adjusted
accordingly.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_SAM_Analytical_Checks.rvt located in the Imperial folder.
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Applying the view template

1 Click View menu ➤ Apply View Template.

2 In the Select View Template dialog, select Structural Analytical Normal or Structural Analytical Stick.

The Structural Analytical Normal view template will present structural components in this new analytical
plan view with both the analytical model and the physical model displayed as shown.

The Structural Analytical Stick view template will present structural components in this new analytical
plan with only the analytical model displayed as shown.

NOTE If the visibility of loads is tuned off in the view, applying either the stick or normal analytical view template
to the view will cause loads to be displayed.

Analytical settings

1 Click Settings menu ➤ Structural Settings.

2 In the Structural Settings dialog, select the Analytical Model Settings tab.

This tutorial will run both the Member Supports Check and Analytical/Physical Model Consistency Check
for all elements selected from the Settings menu ➤ Structural Settings dialog, under the Analytical Model
Settings tab.

Check member supports

3 Click Tools menu ➤ Analytical Model ➤ Check Member Supports.
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Revit Structure checks for instances where a structural element (column) is missing a foundation support
(slab, wall, or isolated). A Warning dialog appears notifying you that there are structural elements that may
not be supported properly.

4 In the Warning dialog click  , to view each warning.

Notice that the structural element is highlighted on the model as each warning is selected.

5 Close the Warning dialog.

Review support warnings

6 Click Tools menu ➤ Review Warnings.

7 In the Warning dialog:

■ Expand Structural Element may not be supported ➤ Warning 1.

■ Click Structural Columns: W-Wide Flange-Column: W10X33

■ Click Show.

■ Click OK in the Viewing Tips dialog.
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The unsupported element is highlighted and displayed in the drawing area.

Notice the column is not supported by an isolated footing.

Review circular reference warnings

8 Click Tools menu ➤ Review Warnings.

9 In the Warning dialog:

■ Expand Circular Support Chain Detected ➤ First Warning

■ Click Structural Framing: W-Wide Flange-Column: W18X40

■ Click Show.

■ Click OK in the Viewing Tips dialog.
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Notice the highlighted beam requires an adjacent beam for support on one end.

10 In the Warning dialog, click Close.

Correct member supports

11 In the Project Browser, under Structural Plans, double-click Ground Level.

Notice that there are missing isolated footings at specific grid locations.

12 On the Modelling tab of the Design Bar, click Foundation ➤ Isolated.

13 Place an isolated footing at each of the following grid locations: E-1, E-3, D-2, D-4, H-3, and H-4.

14 On the Design bar, click Modify.

Correct circular reference

15 In the Project Browser, under Structural Plans, double-click Level 2.

16 Correct the placement of the structural beams as shown.

300 | Chapter 13   Structural Analytical Modelling



Run a consistency check

1 In the Project Browser, expand 3D Views, and double-click 3D.

2 Click Tools menu ➤ Analytical Model ➤ Analytical / Physical Model Consistency Check.

Revit Structure checks for consistency between the analytical and physical models. A Warning dialog
appears notifying you that there are model elements that have a zero-length. This indicates the specific
element has a physical length but no analytical length.

3 In the Warning dialog click  , to view each warning.

Notice that the structural element is highlighted on the model as each warning is selected.

4 Close the Warning dialog.

Review warnings

5 Click Tools menu ➤ Review Warnings.

6 In the Warning dialog:

■ Expand Zero-length Analytical Model Detected ➤ first Warning.

■ Click Structural Columns: W-Wide Flange-Column: W10X49
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■ Click Show.

■ Click OK in the Viewing Tips dialog.

The Zero-length element is highlighted and displayed in the drawing area.

7 In the Warning dialog, click Close.

8 Select the column that was previously highlighted, and on the Options Bar, click  .

In the Element Properties dialog, notice that Ground Level is selected as the value for Analytical Projection
Plane Top.
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9 In the Element Properties dialog, click OK.

Correct zero-length elements

10 On the keyboard, enter ZF.

This is the shortcut for Zoom to Fit.

11 On the View Toolbar, click  .

12 Spin the model to view the atrium side of the structure.

13 Hold the Ctrl key, and select the 3 outermost columns identified in the warning dialog as shown.

Analytical Checks | 303



14 On the Options Bar, click  .

15 Under Analytical Projection Plane Top, select Top of Column.

16 In the Element Properties dialog, click OK.

17 Click Tools menu ➤ Analytical Model ➤ Analytical / Physical Model Consistency Check.

The Warning dialog does not appear. This indicates the zero-length warnings have been fixed.

18 Click File menu ➤ Close.

You can save the open file if you wish. In the next exercise, a new dataset is provided.

19 Proceed to the next exercise, “Load Cases” on page 304.

Load Cases

In the Structural Settings dialog, you edit and add load cases. The following illustration shows the Structural Settings
dialog with the Load Cases tab selected.
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The first table is the Load Cases table. Revit Structure provides several default load case types that you can use to generate
loads in you model. In this table, you add, edit, or delete load cases.

The second table is the Load Natures table. In this table, you add or delete load natures.

In this exercise, you learn how to add new load cases.

NOTE This tutorial uses the word Dataset when referring any required training file.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_SAM3.rvt located in the Imperial folder.

Adding a Load Case

1 Click Settings menu ➤ Structural Settings.

2 In the Structural Settings dialog, select the Load Cases tab.

3 Click Add.

A new load case is added to the bottom of the table, and the Add button changes to Duplicate.

4 Click in the name cell of the new load case, and rename it to Roof Hung.

NOTE The Case Number column of the table is read-only. Revit Structure provides a default number.

5 Under Category, select Dead Loads.

NOTE You can also create a new load case with the Duplicate command. Select an existing load case record in
the table, then click Duplicate. The selected load case is copied in the table.

Adding a load nature

1 Click in the Load Natures table.

2 Click Add.
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A new load nature record is added to the bottom of the table.

3 Click in the cell of the new load nature, and enter an appropriate name.

NOTE The new load nature is now available under the Nature column of the Load Cases table.

4 Click OK to close the Structural Settings dialog.

5 Proceed to the next exercise, “Add Loads to the Model” on page 306.

Add Loads to the Model

Loads are added to the model using a coordinate system. Revit Structure has several coordinate systems for loads:

Coordinate systems for loads

■ project coordinate system

■ current work plane

■ host work plane

The project coordinate system displays in the view when you click Loads on the Modelling tab of the Design Bar. The
orientation of the project coordination is as illustrated:

A view has a work plane that can be used for object placement. Loads are placed perpendicular to the view’s current
work plane.

A host for a load has its own work plane, and loads can be placed by default, perpendicular to the host’s work plane.
Hosts include slabs and beams.

In this exercise, you will be adding dead loads, live loads, and wind loads to the model, using the project coordinate
system. Then you create load combinations for use by analysis and design software.

Change the coordinate system orientation

1 In the Project Browser, expand Views (all), expand 3D Views, and double-click View 1 - Analytical.
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2 On the View Control Bar, click the Model Graphics Style control, and click Hidden Line.

3 On the View Toolbar, click  .

4 In the Dynamic View dialog box, click Spin [Shift].

5 Move the cursor to rotate the model so the garage sloped slab is visible.

6 Select  , draw a zoom box around the garage sloped slab and select it.

7 On the Options Bar, select  .

8 In the Element Properties dialog, under Structural Analysis, select Top of Slab for Analytical Projection
Plane.

9 On the Modelling tab of the Design Bar, click Loads.

10 On the Options Bar, click  .

TIP Be sure to click the Area Load with Host option. Use the tooltips to be sure you click the correct option.

11 Click the garage sloped slab.
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The load is placed on the garage sloped slab. Notice the coordinate system indicates the load is perpendicular
to the host (ramp).

12 On the Design Bar, click Modify.

13 Select the load, and on the Options Bar, click  .

14 In the Element Properties dialog, under Structural Analysis, select Project for Orient to.

15 Click Ok.

The load coordinates are now parallel to the project.

Add a dead load at level 2 using slab as host

1 In the Project Browser, expand Views (all), expand Structural Plans, and double-click Level 2.

2 On the Modelling tab of the Design Bar, click Loads.

3 On the Options Bar, click  .
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TIP Be sure to click the Area Load with Host option. Use the Tooltips to be sure you click the correct option.

4 In the Type Selector, select Area Loads: Area Load 1 .

5 Select the Level 2 slab perimeter as shown.

6 On the Design Bar, click Modify to exit the Loads tool.

7 Right-click on the load you placed, and click Properties.

8 In the Element Properties dialog, enter -0.0300 ksf for the Fz 1 parameter, and click OK.

Add live load at Level 2

9 On the Modelling tab of the Design Bar, click Loads.

10 On the Options Bar, click  .

TIP Be sure to click the Area Load with Host option. Use the Tooltips to be sure you click the correct option.
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11 In the Type Selector, select Area Loads: Area Load 1 .

12 Select the Level 2 slab perimeter.

13 On the Design Bar, click Modify to exit the Loads tool.

You now have two loads that are hosted by the slab. To see them, open an elevation view.

14 In the Project Browser, under Elevations (Building Elevation), double-click South Elevation.

In the steps that follow, you change this live load, and specify other parameter values that allow you to
differentiate this load from others.

Change load properties

15 Right-click on the live load, and click Properties.

16 In the Element Properties dialog, click Edit/New.

17 In the Type Properties dialog, do the following:

■ Select Arrow 30 degree for Force arrowhead

■ Enter 1/3" for Distance between arrows, and click OK.

18 In the Element Properties dialog, do the following:

■ Enter -0.0700 ksf for Fz1

■ Select LL1(2) for Load Case, and click OK

Add wind load at Level 2

19 In the Project Browser, under Structural Plans, double-click Level 2.

20 On the Modelling tab of the Design Bar, click Loads.

21 On the Options Bar, click  .

TIP Be sure to click the Line Load option. Use the Tooltips to be sure you click the correct option.

22 Sketch a line load from one corner of the slab to the other, as shown.
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23 On the Design Bar, Click Modify.

24 Right-click on the Line Load 1, and click Properties.

TIP You may need to press TAB to highlight the line load. Watch the Status Bar to be sure you are highlighting
Line Load 1.

25 In the Element Properties dialog, click Edit/New.

26 In the Type Properties dialog, click Duplicate, enter Wind Load, and click OK.

27 In the Element Properties dialog, do the following:

■ Enter 0 kip/ft for Fz 1

■ Enter 0.0400 kip/ft for Fx 1

■ Select WIND1(3) for Load Case, and click OK.
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28 In the Project Browser, expand Views (all), expand 3D Views, and double-click View 1 - Analytical in order
to view the added loads.

29 On the View Control Bar, click the Model Graphics Style control, and click Hidden Line.

30 In the Project Browser, under Structural Plans, double-click Level 2 - Analytical.

31 Select  , draw a zoom box around the beams on the east side of the structure as shown.
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32 On the Basics tab of the Design Bar, click Grid.

33 Draw a temporary grid as shown.

This grid is drawn for reference only, and will be deleted in a later step.

34 On the View tab of the Design bar, click Framing Elevation.

35 Place the framing elevation symbol so that it will snap to the temporary grid approximately as shown.
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36 On the Design bar, click Modify.

37 Select the temporary grid, and press DELETE.

38 Double-click the new elevation bubble.

The elevation view opens.

39 Select  , draw a zoom box around the lower floors of the structure as shown.

40 On the Modelling tab of the Design Bar, click Loads.

41 On the Options Bar, click  .

TIP Be sure to click the Line Load option. Use the Tooltips to be sure you click the correct option.

42 On Level 2, select the edge of the flange as the starting point for the load.

43 Drawing the load from one corner of the flange to the other, as shown.

314 | Chapter 13   Structural Analytical Modelling



You will see the load is oriented to project orientation.

44 Select the load, and on the Options Bar, click  .

45 In the Element Properties dialog, under Structural Analysis, select Workplane for Orient to, and click OK.

The load projection plane is now oriented to the workplane of the temporary grid line plane to which the
framing elevation was pointing.

46 Click File menu ➤ Save As, and save the model to a location of your choice using the following filename:
i_RST_SAM3-in progress.rvt .

47 Proceed to the next exercise, “Load Combination” on page 315.

Load Combination

In this exercise, you add a load combination to your model for use by the analysis and design software.

You edit and add load combinations in the Structural Settings dialog.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saves at the end of that
exercise, i_RST_SAM3-in progress.rvt

Add a DL + LL combination

1 On the Settings menu, click Structural Settings.

2 In the Structural Settings dialog, click the Load Combinations tab.

3 Click Add in the Load Combination section.

4 Under Name, enter DL+LL.

5 Click on the Edit Selected Formula table, and click Add.

6 Under Factor, enter 1.4.

Notice that the Formula field under Load Combination changed automatically to show the new factor.

7 Under Case or Combination, select DL1.

8 Click Add.

9 Under Factor, enter 1.6.

10 Under Case or Combination, select LL1.
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Add a DL + LL + wind combination with a factor

11 Click on the Load Combination table, and click Add.

12 Under Name, enter DL+LL+WIND.

13 Click on the Edit Selected Formula table, and click Add.

14 Under Factor, and enter 1.2.

15 Under Case or Combination, select DL1.

Add a LL1 combination with a factor

16 Click Add.

17 Under Factor, enter 0.5.

18 Under Case or Combination, select LL1.
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Add a WIND1 combination with a factor

19 Click Add in the Edit Selected Formula table.

20 Under Factor, enter 1.3.

21 Under Case or Combination, select WIND1.

22 Click on the Load Combination table.

23 Select Row 2.

24 Under Type, select Envelope.

25 Under State, select Ultimate.

26 In the Structural Settings dialog, click OK.
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27 Click File menu ➤ Save.

28 Proceed to the next exercise, “Transfer Project Standards” on page 318.

Transfer Project Standards

In this exercise, you transfer the load combination table to a new or existing project.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saves at the end of that
exercise, i_RST_SAM3-in progress.rvt

Importing load types and combinations from a previous project

1 Open an existing Revit Structure project or create a new project.

2 Click File menu ➤ Transfer Project Standards.

3 In the Select Items to Copy dialog,

■ Under Copy from, select the file that contains the load table.

■ Click Check None.

■ Scroll down the list of items, and select Load Types.

■ Click OK.

4 In the Duplicate Types dialog, click Overwrite.

5 Click Settings menu ➤ Structural Settings.

6 On the Structural Settings dialog, click the Load Combinations tab.

7 The load combinations are displayed.
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8 Click File menu ➤ Save.

9 Proceed to the next exercise, “Documenting the Analytical Model” on page 319.

Documenting the Analytical Model

In this exercise, you document the analysis by adding an annotation, and creating an analytical schedule.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saves at the end of that
exercise, i_RST_SAM3-in progress.rvt

Add annotation

1 In the Project Browser, expand Views (all), expand Structural Plans, and double-click Level 2 - Analytical.

2 On the Drafting tab of the Design Bar, click Tag ➤ By Category.

3 Click the Wind Load to place the tag.

4 Click the Area Load to place the tag.
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5 On the Design Bar, click Modify.

6 Click on the drag control for the wind load tag and position approximately as shown.

Creating a load schedule

7 On the View tab of the Design Bar, click Schedule/Quantities.

TIP If the View tab of the Design Bar is not active, right-click on the Design Bar, and click View.

8 In the New Schedule dialog, under Category, select Line Loads and click OK.

Define the fields

9 In the Schedule Properties dialog, click the Fields tab.

10 Under Available fields, select Fx 1 and click Add.

The Fx 1 field is moved under Scheduled fields.

11 Using the same process, add the following fields to the schedule:

■ Fx 2
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■ Fy 1

■ Fy 2

■ Fz 1

■ Fz 2

■ Nature

12 Under Scheduled fields, order the fields as shown in the following illustration by selecting them and clicking
Move Up or Move Down.

13 Click OK.

A schedule is created that includes the analytical elements in the project.

14 Click File menu ➤ Save.

15 Proceed to the next exercise, “Examples of Analytical Adjustment and Reset in the Model” on page 321.

Examples of Analytical Adjustment and Reset in the Model

There are some structural configurations that are not suitable for direct integration with structural analysis and design
software. Manual adjustment is required before a structural model is input into the analysis and design software. For
this reason, the geometry of the analytical model may be adjusted in relation to those elements that it joins. In addition,
Revit Structure provides a reset tool to reset analytical models back to their original location relative to the corresponding
physical model.

NOTE This exercise requires the completion of the previous exercise. Use the project file that you saved at the end of that
exercise, i_RST_SAM3-in progress.rvt

Align the analytical beam

1 In the Project Browser, under Structural Plans, double-click Ground Level - Analytical.

2 Zoom into the column at grid line F - 3.

Examples of Analytical Adjustment and Reset in the Model | 321



3 Click Tools menu ➤ Analytical Model ➤ Adjust Analytical Model.

4 Press the TAB key and select the endpoint of the analytical line of the beam.

5 Press the TAB key and select the corner endpoint of the analytical plane of the slab.
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The analytical model lines and planes are now connected at the same location for analysis purposes.

6 Click File menu ➤ Close.

You can save the open file if you wish. In the next exercise, a new dataset is provided.

7 Proceed to the next exercise, “Examples of Automatic Adjustment in the Analytical Model” on page 323.

Examples of Automatic Adjustment in the Analytical Model

The analytical model that is generated in Revit Structure has discrepancies that are not suitable for direct integration
with structural analysis and design software. Revit Structure provides the capability to automatically adjust the analytical
model to reduce or eliminate these discrepancies for newly created elements as well as the ability to disassociate or
reassociate the auto-detect parameter for existing elements.

NOTE The auto-detect feature automatically adjusts the analytical model when creating the following structural elements
within a project.

■ Creating beams

The corresponding beam to slab projection planes are matched. For example, setting both planes to level 2 as
shown:

■ Creating columns

Places the analytical model of columns and walls in the same plane as shown:

■ Creating slabs and walls
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Aligns the vertical and horizontal analytical projection plane of walls, despite any variation in wall thicknesses or
projection plane location as shown:

If a wall and slab are joined, the top or bottom plane of the wall’s analytical model will coincide with the slab
analytical model as shown:

If a wall has a portion that extends beyond the roof (commonly known as parapets), it can be excluded in the
wall’s analytical model to exclude loads that extend above a level with framing members.
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If the analytical edge of slab coincides with the beam or wall analytical model, the exterior of the wall can be
defined as the analytical projection plane, or it can be trimmed back the analytical/physical model of the slab as
shown:

NOTE The following adjustments to the analytical model are applied to an existing project to better demonstrate the
auto-detect feature.

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_SAM_Auto_Detect.rvt located in the Imperial folder.

Auto-detect tolerances

1 Click Settings menu ➤ Structural Settings.

2 In the Structural Settings dialog, select the Analytical Model Settings tab.

This exercise applies the auto-detect feature within the tolerances specified in this dialog. They include
distances for the analytical-to-physical model and analytical adjustments, and the auto-detect tolerances
for both horizontal and vertical planes.

3 Click OK.
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Adjust the beam to slab vertical offset

1 In the Project Browser ➤ Structural Plans, double-click Level 2.

2 On the Toolbar, click  , and draw a zoom box around the lower-left corner of the structure as shown.

3 Double-click the section bubble to open the section view.

4 On the Toolbar, click  , and draw a zoom box around one of the beams.

5 Move the cursor over the top of the beam as shown.

326 | Chapter 13   Structural Analytical Modelling



The dot located at the top of the beam, represents the vertical projection plane of the beam analytical
model.

6 Click the beam, and on the Option Bar, click  .

NOTE The properties for all beams of the same type should be changed. For demo purposes, a single beam is
selected

7 In the Element Properties dialog, under Analytical Model, for Vertical Projection, select Auto-detect, and
then click OK.

The vertical projection plane of the analytical model automatically moves to the top of the slab.

8 Click the slab, and on the Option Bar, click  .

9 In the Element Properties dialog, under Analytical Model, for Vertical Projection, select Top of Slab, and
then click OK.
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The vertical projection plane of the analytical model automatically moves to the top of the slab.

The dot located at the top of the slab, represents the vertical projection plane of the analytical model.

Adjust the column to wall horizontal offset

10 In the Project Browser ➤ Structural Plans, double-click Level 2 - Analytical.

11 On the Toolbar, click  , and draw a zoom box around the column at grid location A3.

12 In an empty part of the drawing area, right-click, and click Zoom in Region.

13 Draw a zoom box around the column as shown.

Notice the green line representing the analytical model of the concrete wall is not aligned with the blue
dot representing the analytical model of the column.

14 Click the column, and on the Option Bar, click  .
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15 In the Element Properties dialog, under Analytical Model, for Horizontal Projection, select Auto-detect,
and then click OK.

The horizontal projection plane for the column, aligns with the horizontal projection plane of the wall.

16 On the Tools toolbar, click  , select the wall, and then select the column.

The geometry of the column and wall are now joined.

Adjust the vertical alignment of different wall types

17 In the Project Browser ➤ Structural Plans, double-click Level 2.

18 On the Toolbar, click  , and draw a zoom box around the elevator shaft located on the lower-right side
of the structure as shown.
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19 Double-click the section bubble to open the section view.
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Notice the solid green lines are not aligned. These lines represent the vertical projection plane of the upper
and lower wall analytical model. The dotted green line represents reference plane 1.

20 Move the cursor over the lower wall.

21 Press TAB, and select Chain of Walls or Lines.

Check the Status Bar to verify you are selecting the chain of walls and not a single wall.

22 On the Option Bar, click  .

23 In the Element Properties dialog, under Analytical Model, for Horizontal Projection, select Auto-detect,
and then click OK.
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The vertical projection plane for the lower wall is now aligned with the vertical projection plane of the
upper wall.

24 In an empty part of the drawing area, right-click, and click Zoom in Region.

25 Draw a zoom box around the center of the upper and lower walls as shown.

26 Click the upper wall, and on the Option Bar, click  .

27 In the Element Properties dialog, under Analytical Model, for Horizontal Projection, select Plane 1, and
then click OK.

The vertical projection plane for both the upper and lower walls are now aligned with vertical projection
plane 1.

Adjust the vertical alignment of a wall and slab

28 In the Project Browser ➤ Sections (Building Section), double-click Section 3.
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29 In an empty part of the drawing area, right-click, and click Zoom in Region.

30 Draw a zoom box around the intersection of the beam and column.

The brown line represents the analytical model of the slab, and the green line represents the analytical
model of the wall. Notice the green line extends to the top of the beam.

31 Click the lower wall, and on the Option Bar, click  .

32 In the Element Properties dialog, under Analytical Model, for Top Vertical Projection, select Auto-detect,
and then click OK.
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The vertical projection plane for the lower wall is now aligned with the horizontal projection plane of the
beam.

Adjust the horizontal alignment of the slab to wall

33 Click the slab, and on the Option Bar, click  .

34 In the Element Properties dialog, under Analytical Model, for Vertical Projection, select Bottom of Slab,
and then click OK.

The horizontal projection plane for the beam (brown line) is now aligned with the vertical projection plane
of the wall (green line). Notice the analytical line of the wall moves with the analytical line of the slab.

35 Click the slab, and on the Option Bar, click  .

36 In the Go to View dialog, select Structural Plan: Level 2 - Analytical, and then click Open View.

You are now in sketch mode and the slab perimeter appears in the drawing area.

37 Select the left sketch line of the slab as shown.
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38 On the Option Bar, click  .

39 In the Element Properties dialog, under Analytical Model, for Analytical Slab Edge, select Auto-detect, and
then click OK.

40 On the Design Bar, click Finish Sketch.

In the Revit dialog, click No.

41 In the Project Browser ➤ Sections (Building Section), double-click Section 3.

42 Click the lower wall, and on the Option Bar, click  .

43 In the Element Properties dialog, under Analytical Model, for Horizontal Projection, select Exterior Face,
and then click OK.

The horizontal projection plane of the slab is now aligned with the exterior face of the wall.

Adjust the column to the lower wall analytical projection

44 Click the column, and on the Option Bar, click  .

45 In the Element Properties dialog, under Analytical Model, select Auto-Detect Horizontal Projection, and
then click OK.
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46 Click the lower wall, and on the Option Bar, click  .

47 In the Element Properties dialog, under Analytical Model, for Top Vertical Projection, select Top of Wall,
and then click OK.

The vertical projection plane of the column (blue line) is now aligned with the exterior face of the wall
(green line).

Adjust the horizontal alignment of a beam

48 In the Project Browser ➤ Structural Plans, double-click Level 3 - Analytical.

49 Enter ZF (this is the keyboard shortcut for Zoom to Fit).

50 In the Project Browser ➤ Structural Plans, double-click Level 3.

51 Click Window menu ➤ Tile.

Both windows will be visible in the drawing area. Close any additional open windows.

52 On the Toolbar, click  , and draw a zoom box around the beam located in the upper-left corner of both
views as shown.
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53 Click the beam, and on the Option Bar, click 

Notice the beam is highlighted in both open views.

54 In the Element Properties dialog, under Analytical Model, for Horizontal Projection, select Auto-Detect,
and then click OK.

55 In the Level 3 window, do the following:

■ Move the cursor over the beam.

■ Press TAB, and select the beam shape handle.

Check the Status Bar to make sure you are selecting the shape handle and not the beam.

■ Extend each end of the beam as shown.
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Notice the beam in the analytical view remains unchanged.

56 Click File menu ➤ Save As, and save the model to a location of your choice using the following filename:
i_RST_SAM_Auto_Detect-in progress.rvt .

57 Proceed to the next exercise, “Boundary Conditions” on page 338.

Boundary Conditions

In this exercise, you add a boundary condition to your model for use by the analysis and design software.

NOTE The following modifications to the analytical model are applied to an existing project. Use the project file that you
saved at the end of the last exercise, i_RST_SAM_Auto_Detect-in progress.rvt .

Add a boundary condition to the base of a column

1 In the Project Browser ➤ 3D Views, double-click View 1 - Analytical.

Maximize the view so it fills the drawing area.

2 Click View menu ➤ Visibility/Graphics.

3 In the Visibility/Graphic dialog, under Visibility, clear Structural Foundation, click Apply, and then click
OK.
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4 In an empty part of the drawing area, right-click, and click Zoom in Region.

5 Draw a zoom box around the columns located on the lower-left side of the structure as shown.

6 On the Modelling tab of the Design Bar, click Boundary Conditions.

7 On the Options Bar, click  , and for State, select Fixed.

8 In an empty part of the drawing area, right-click, and click Zoom in Region.

9 Draw a zoom box around the base of one of the columns.

10 Click the end of the blue line (representing the analytical model of the beam) to place the fixed boundary
condition.

11 Repeat this technique to add a fixed boundary condition to the next closest beam as shown.
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12 Click one of the boundary condition symbols, press CTRL, and select the other symbol.

13 On the Option Bar, click  .

14 In the Element Properties dialog, under Structural Analysis, for State, select Pinned, and then click OK.

Notice the boundary condition now displays a pinned state symbol.

Add a boundary condition to the footing

15 Enter ZF (this is the keyboard shortcut for Zoom to Fit).

16 On the View Toolbar, click  , hold the SHIFT key, and click the model to rotate it until the foundation
wall is displayed as shown
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.

17 On the Toolbar, click  , and draw a zoom box around the foundation.

18 On the Modelling tab of the Design Bar, click Boundary Conditions.

19 On the Options Bar, click  , and for State, select Pinned.

20 Click the green line (representing the analytical model of the foundation) to place the boundary condition.

21 Click File menu ➤ Close.

You can save the open file if you wish. In the next exercise, a new dataset is provided.

22 Proceed to the next exercise, “Preparing the Analytical Model to be Calculated in 3rd Party Analysis Software”
on page 341.

Preparing the Analytical Model to be Calculated in 3rd Party Analysis Software

Revit Structure links to an analysis and design software, via an Application Programming Interface (API).

Size changes to your model and geometric modifications to your model involving member deletion, member relocation,
or member addition, that you confirm in the analysis software, are imported back into Revit Structure. All views,
including structural plans, elevations, sections, and detail sheets are updated according to changes that you import
into Revit Structure. In addition, some internal analysis software parameters are imported into Revit Structure.
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Export the model to analysis software

1 Click Tools menu ➤ External Tools ➤ Send Model.

NOTE The External Tools menu is only available once an approved 3rd party analysis software application has
been installed. Please refer to the following Autodesk web page for more information:
www.autodesk.com/revitstructure-partners.

The application programming interface (API) starts. You can open the analysis software or write to an
export file for later use. If you choose to have the API open the software and run your model, the API also
returns you to your Revit Structure model and updates it.
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Exporting Revit Structure Files

Your Autodesk® Revit® Structure 4 project can be exported into several different Autodesk AutoCAD®

formats. In this tutorial, you learn how to export your project into both 2D and 3D formats for improved

coordination with architects and engineers. You can export a 2D view (plan, elevation, section, etc.),

sheet, or schedule into AutoCAD, or you can export a 3D view directly into Autodesk Architectural

Desktop™ 2007. You can also export the project drawing sheets and import them as 2D images.
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Exporting CAD Formats
In this lesson, you begin by exporting a 3D view of the structural model as a DWG format and importing the file into
Architectural Desktop 2007. Revit Structure, maintains the properties of all structural elements as true Architectural
Desktop 2007 objects. You then select a 2D structural plan view and export the file as a DWG format, which is imported
into AutoCAD. Finally, you export sheets from the project and import them into AutoCAD or Architectural Desktop
2007 as 2D images.

Exporting the 3D Model to Architectural Desktop 2007

Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_Export.rvt located in the Imperial folder.

1 In the Project Browser, expand 3D Views, and double-click 3D - Atrium.

2 Click File menu ➤ Export ➤ CAD Formats.

NOTE You can only export the 3D model in a 3D view.

3 In the Export dialog, do the following:

■ Under Save in, select a folder on your local computer.

■ Under File naming, click Short.

The existing file name is automatically shortened.

■ Under Save as type, select AutoCAD 2007 DWG Files (*.dwg).

■ Click Options.

4 In the Export Options dialog, do the following:

■ Under Solids (3D views only), select Export as Architectural Desktop and Building Systems Options.
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■ Under Prefer, select Architectural Desktop Objects.

■ Click OK.

5 On the Export dialog, click Save.

Viewing the 3D file in Architectural Desktop 2007

6 Open Architectural Desktop 2007.

NOTE Revit Structure cannot export to earlier releases of Architectural Desktop.

7 Click File menu ➤ Open.

8 Navigate to the file location, and click Open.
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When the file is opened in Architectural Desktop 2007, the Revit Structure model appears as shown.

Revit Structure columns, beams, and braces are converted to the corresponding type of Architectural Desktop
structural member.

9 Select a beam as shown, and notice it is a true Architectural Desktop structural element.

10 Minimize the Architectural Desktop program.

11 In Revit Structure, click File menu ➤ Save As, and save the model to a location of your choice using the
following filename: i_RST_Export-in progress.rvt .

12 Proceed to the next exercise, “Exporting a 2D view to AutoCAD” on page 346

Exporting a 2D view to AutoCAD

Dataset

■ Continue to use the dataset i_RST_Export-in progress.rvt that was saved in the previous exercise.
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1 In the Project Browser, expand Structural Plans, and double-click Level 2.

2 Click File menu ➤ Export ➤ CAD Formats.

3 In the Export dialog, do the following:

■ Under Save in, select a folder on your local computer.

■ Under File naming, click Long (Specify prefix for all exports).

■ Under File name, clear the existing name and enter Framing Plan Level 2.

■ Under Save as type, select AutoCAD 2007 DWG Files (*.dwg).

■ Click Save.
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If the view was set to wireframe, a warning dialog appears. On the View’s export mode dialog, click Hidden
Line Removal.

Viewing the 2D file

4 Maximize the AutoCAD 2007 or Architectural Desktop 2007 program.

NOTE Revit Structure cannot export to earlier releases of Architectural Desktop.

5 Click File menu ➤ Open.

6 Navigate to the file location, and click Open.

When the file is opened in AutoCAD or Architectural Desktop 2007, the Revit Structure exported Level 3
Plan appears.

7 Minimize the AutoCAD or Architectural Desktop 2007 program.

8 In Revit Structure, click File menu ➤ Save.

9 Proceed to the next exercise, “Exporting Sheets” on page 348

Exporting Sheets

Dataset

■ Continue to use the dataset i_RST_Export-in progress.rvt that was saved in the previous exercise.

1 Click File menu ➤ Export ➤ CAD Formats.
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2 In the Export dialog, do the following:

■ Under Save in, select a folder on your local computer.

■ Under Export Range, click Selected views/sheets ➤ Select.

3 In the View/Sheet Set dialog, do the following:

■ Under Show, clear Views.

■ Select each sheet, and click OK.

Click No when asked if you want to save the settings for use in a future Revit session.

NOTE If you are exporting to a DWG file, you can flatten xrefs by exporting multiple views into a single file.
Select the Export each view or sheet as a single file option. This option is automatically selected for DXF files and
not available for DGN or sat files.

4 On the Export dialog, click Save.

If the view was set to wireframe, a warning dialog appears. On the View’s export mode dialog, click Hidden
Line Removal.
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5 Close the Revit Structure file. If you wish to save the changes, navigate to a folder of your preference and
rename the file.

Viewing the Revit Structure sheets in AutoCAD or Architectural Desktop 2007

6 Maximize the AutoCAD or Architectural Desktop 2007 program.

NOTE Revit Structure cannot export to earlier releases of Architectural Desktop.

7 Click File menu ➤ Open.

8 Navigate to the location of the files saved in the previous exercise, and click Open.

When the sheets are opened in AutoCAD or Architectural Desktop 2007, they appear as shown.
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About Families and the Family
Editor

All elements in Autodesk® Revit® Structure 4 are “family based.” The term family describes a powerful

concept used throughout Revit Structure to help you manage your data and make changes easily. Each

family element can have multiple types defined within it, each with a different size, shape, material set,

or other parameter variables as designed by the family creator. Even though various types within a family

can look completely different, they are still related and come from a single source, thus the term family.

Changes to a family type definition ripple through the project and are automatically reflected in every

instance of that family or type within the project. This keeps everything coordinated and saves you the

time and effort of manually keeping components and schedules up to date.

In this tutorial, you learn about the various types of families and the Family Editor.
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Using Families and the Family Editor
One of the many advantages of using Revit Structure is the ability to create your own families of components without
having to learn a complex programming language. Using the Family Editor, you create a family within predefined
templates that contain the intelligent objects needed to create the particular family type. You provide the information
necessary to uniquely describe the family geometry.

In this lesson, you learn about the three types of families and how they are used within a project and how they are
created. You also learn about the Family Editor, and when and how to use it.

Introduction to Families

Most families are created in the Family Editor and saved as separate files with an .rfa extension. All different types that
you create are stored with the master family file. For example, if you create a family called wide beams that includes
types with several sizes, the types would all be saved as one file which can then be loaded into any project. This makes
file management much easier, because there is only one file to track. There are, however, exceptions to this rule. Some
family types are pre-defined within Revit Structure and cannot be created or modified outside of the project environment.
Walls, and roofs are examples of these types of families. In addition, there is another type of family that allows you to
create any shape or form required for a particular project and have Revit Structure recognize it as a particular component
type, such as a curved beam.

Revit Structure has three types of families:

■ System

■ Standard Component

■ In-place

System Families

System families are pre-defined within Revit Structure and comprise principle building components such as walls,
floors, and roofs. The basic walls system family, for example, has wall types that define interior, exterior, foundation,
generic, and partition wall styles. You can duplicate and modify existing system families, but you cannot create new
system families.

NOTE You can use “Transfer Project Standards” to copy system families from one project to another.

The following illustration shows different types within the basic walls family.

Standard Component Families

Standard component families are loaded by default in project templates, while many more are stored in component
libraries. You work with the Family Editor to create and modify components. You can either duplicate and modify an
existing component family or create a new component family based on a variety of family templates.

The following dialog box shows how you can select a specific family template to start your family design project.
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Family templates are either host-based or standalone. Host-based families have components that require hosts. Standalone
families include columns, and beam. Family templates assist you in creating and manipulating component families.

Standard component families can exist outside of the project environment and have an .rfa extension. You can load
them into projects, transfer them from one project to another, and save them from a project file to your library if
needed.

The following illustration shows host-based openings in a wall, and also a standalone pile cap family component.

In-place Families

In-place families are either model or annotation components in a particular project. You create in-place families only
within the current project, so they are useful for objects unique to that project; for example, custom step footing. You
have a choice of categories when you create in-place families, and the category that you use determines the component’s
appearance and display control within the project.

The following illustration shows an in-place step footing.
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Adding a family to a project

1 Open or start a project.

To add a family to your project, you can drag it into the document window, or you can load it using the
Load From Library, Load Family command on the File menu. After the family has been loaded in the
project, it is saved with the project. Families are listed in the Project Browser under their respective
component category. You do not have to carry the original family file along with the project. However, if
you change the original family, you need to reload the family in the project to see the updated family.

2 On the File menu, click Load From Library ➤ Load Family.

3 Navigate to the library or location of the family.

4 Select the family file name and click Open.

In this section, you learned about the different types of Revit Structure families and when to use them. In the final
exercise, you learn about the Family Editor, how to access it, and when to use it.

Introduction to the Family Editor

You can use the Family Editor to create both real-life building components and graphical/annotation components.
Families store all of the necessary geometry to display the two-dimensional (2D) and three-dimensional (3D) versions
of particular objects. Family element visibility can be dependent of your viewing direction, such as plan, elevation, or
3D, as well as the level of detail associated with that view.

In this exercise, you learn when to use the Family Editor, how to access it, and the general procedure for creating a
standard component family.

When to use the Family Editor

During the design process, you will inevitably come to a point where you need a specific component for your design.
In this case, presume it is a bay window that you require. There is a logical thought process that you should follow:

1 Is there a component of this type already loaded into this project? If so, it should be available within the Type
Selector.

2 If there isn’t a component family loaded in the project, you can search the component library loaded on your local
hard drive. Also consider any internal family libraries that may exist on the network.

3 Next, consider checking the web library and other web resources, such as newsgroups.
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4 If you can’t find the component you require, you should then try to find the component that most closely resembles
it. It is far easier to modify an existing component within the Family Editor than to create it from scratch. If you
find a close match, open it in the Family Editor, modify it as needed, and then load it into the project.

5 Finally, if you have exhausted your external resources, you should create a new component family using one of
the family templates as a starting point.

How to use the Family Editor

You can access the Family Editor in several ways. With Revit Structure open, you can click File ➤ Open, navigate to a
family file, and click Open. When the family opens, it opens within the Family Editor. This will be apparent because
the only Design Bar tab available is Family.

Within the Windows® environment, you can double-click any file with an .rfa extension and it will open Revit Structure
in the Family Editor. You can have a project open and the Family Editor open simultaneously.

To start a new family, click File ➤ New ➤ Family, select the appropriate template, and click Open.

General procedure for creating a standard component family

1 Select the appropriate family template.

2 Define sub-categories for the family to aid in controlling visibility of the object.

3 Lay out reference planes to aid in drawing component geometry.

4 Add dimensions to specify parametric component geometry.

5 Add label dimensions to create type or instance parameters.

6 Flex the new model to verify correct component behavior.

7 Specify 2D and 3D geometry display characteristics with sub-category and entity visibility settings.

8 Define family type variations by specifying different parameters.

9 Save the newly-defined family, and then load it into a new project and see how it performs.
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Creating Components in the
Family Editor

In this tutorial, you learn how to create specific Autodesk® Revit® Structure 4 families. In each lesson,

you learn how to create a different type of component. Using the installed templates, you create a new

family, an in-place family, and you modify existing families. When you create an in-place family, you

create it within the project file, not within the Family template (.rft file). This allows you to create the

family in the context of the current project.

16
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Creating a New Family
In this lesson, you create a new family for a custom curved beam.

Drawing the Shape of the New Family

In this exercise, you draw a curved beam.

Create a new family based on the loaded profile (.rfa) family

1 On the File menu, click New ➤ Project.

2 In the New Project dialog, click OK.

3 On the Modelling tab of the Design Bar, click Create a component in place.

4 In the Family Category and Parameters dialog, select Structural Foundations for Family Category, and click
OK.

5 In the Name dialog, for Name, enter Curved beam, and click OK.

6 On the Design Bar, click Solid Form  ➤  Solid Sweep.

7 On the Design Bar, select Sketch 2D path.

8 On the Options Bar, click  .

9 Draw an arc approximately as shown.

10 On the Design Bar, click Modify.

11 On the View toolbar, click  .

Select a profile

12 On the Design Bar, click Finish Path.
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13 On the Options Bar, click Load profiles.

14 In the Open dialog, navigate to the location of the flange profile using the following path: Imperial
Library ➤ Profiles ➤ Structural ➤ Steel.

15 In the Open dialog, select W-Wide Flange-Profile.rfa .

16 In the Type table at the bottom of the Open dialog, select W44X335 , and click Open.

17 On the Options Bar, select W-Wide Flange-Profile: W44X335 .

The profile is placed on the arc as shown.

Finish the sweep

18 On the Options Bar, enter -1' 10" for Y.

19 On the Design Bar, click Finish Sweep.
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Add analytical lines to the curved beam

20 In the Project Browser, under Structural Plans, double-click Level 2.

21 Right-click the open area above the view, and click Zoom In Region.

22 On the View Control Bar, select Model Graphics Style: Wireframe.

23 Click View menu ➤ Visibility Graphics.

24 In the Visibility Graphics dialog, under Visibility, expand Structural Framing, and select Analytical Model.

25 Click Apply, and then OK.

26 Select the beam, and on the Options Bar, click  .

27 In the Element Properties dialog, do the following:

■ Under Other, select Trajectory Segmentation.

■ Enter 20 for Maximum Segment Angle.

■ Click OK.

28 On the Design Bar, select Model Lines.

29 In the Type Selector, select Analytical Model (projection).

30 On the Options Bar, select  , and enter 8" for offset.
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31 Click each segment of the sweep as shown.

32 After all segments have been selected, on the Design Bar, click Modify.

33 Select the beam, and on the Options Bar, click  .

34 In the Element Properties dialog, under Other, clear Trajectory Segmentation.

35 Click OK.

Add stick representation for curved beam

36 On the Design Bar, select Model Lines.

37 In the Type Selector, select Stick Symbols (projection).

38 On the Options Bar, select  , and enter 8" for offset.

39 Select the sweep reference line of the beam, and on the Design Bar, click Modify.

A stick representation is created at the center of the curved beam.

40 Select the physical geometry of the beam, and on the Options Bar, click Visibility.

41 In the Family Visibility dialog, under Detail Levels, clear Coarse.

The geometry will only be visible at the medium and fine detail levels.

42 Click OK.

43 Select the stick representation of the curved line.

44 On the Options Bar, click Visibility.

45 In the Family Visibility dialog, under Detail Levels, clear Medium and Fine.

The stick symbol will only be visible at the coarse detail level.

46 Click OK.

47 On the Design Bar, click Finish Family.
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48 On the View Control Bar, select Detail Level: Medium.

You will see the beam physical geometry and analytical lines.

49 Click View menu ➤ Visibility Graphics.

50 In the Visibility Graphics dialog, under Visibility, expand Structural Framing, and clear Analytical Model.

51 Click Apply, and then OK.

52 On the View Control Bar, select Detail Level: Coarse.

You will see the stick representation of the curved beam.

53 Proceed to the next lesson, “Creating Custom Families” on page 362.

Creating Custom Families
In this lesson, you customize 2 different families with the Revit Structure family editor. In the first exercise, you modify
the profile for a non-composite metal deck family by adding a dovetail rib. In the second exercise, you create a custom
opening in a castellated beam family. Modifications to the existing families are saved as a family (.rft) template for use
in other projects.

Creating a Custom Metal Deck Family

In this exercise, you create a custom, non-composite metal deck family by adding a dovetail rib to the deck profile.

Open the metal deck family

1 Click File menu ➤ Open.

2 In the left pane of the Open dialog, click the Imperial Library folder.

3 Click Profiles ➤ Structural folder, select Form Deck_non composite.rfa , and click Open.
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4 Click View menu ➤ Visibility Graphics.

5 On the Annotations Categories tab of the Visibility/Graphic Overrides dialog, do the following:

■ Under Visibility, click Dimensions and Reference Planes.

■ Click Apply, and then click OK.

6 In an empty part of the drawing area, right-click, and click Zoom to Fit.

7 On the View Control Bar, select 1 1/2" = 1' 0" for scale.

Delete vertical reference planes

8 Select parameter wr as shown, and press DELETE.

Delete the parameter on both sides of the profile.

9 Delete additional vertical reference planes until the view appears as shown.
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Modify the angular reference plane

10 On the Design Bar, click Dimension.

11 On the Options Bar, click  .

12 Place a dimension for the angle as follows:

■ Click the horizontal reference plane.

■ Click the angle.

■ Move the cursor inside the profile, and click to place the dimension as shown.

13 On the Design Bar, click Modify.

14 Select the angled reference plane, enter 66, and press ENTER.

15 Click the lock symbol next to the angular dimension to lock the angle to the horizontal reference plane.
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Repeat this technique to add a dimension for the angle on the opposite side of the profile.

16 In an empty part of the drawing area, right-click, and click Zoom to Fit.

17 On the View Control Bar, select 6" = 1' 0" for scale.

18 Click the top and bottom dimensions, and drag them approximately as shown.

19 Select the dimension that refers to the width of the profile base, and press DELETE.

Repeat for the dimension on the opposite side.

Place new dimensions

20 On the Design Bar, click Dimension, and add a dimension as shown.
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21 Add 2 dimensions from the center reference plane to the bottom of each side of the profile, place the
dimension under the lines as shown, and click the EQ symbol to apply equal constraints.

Sketch the dovetail reference planes

22 On the View Toolbar, click  , and draw a zoom box around the top of the profile.

23 On the Design Bar, click Ref Plane.

24 Draw 1 horizontal and 4 vertical reference planes approximately as shown.

25 Press ESC.

26 Highlight the reference planes and on the Options Bar, click  .

27 On the Element Properties dialog, under Other, for Is Reference, select Not a Reference, and then click OK.

Dimension and constrain the dovetail

28 On the Design Bar, click Dimension.
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29 Add a dimension from the top of the profile to the dovetail horizontal reference plane as shown.

The dimensions displayed in the following steps are provided for reference only and can be customized
based on your requirements.

30 Press ESC.

31 Select the horizontal reference plane, enter 0' 11/32" , and press ENTER.

32 Select the dimension, and click the lock symbol to lock the distance to the horizontal reference plane.

33 Repeat the previous technique to add the remaining dimensions for the dovetail as shown.

These dimensions refer to the positioning of the dovetail in relation to the profile center reference plane.

34 Click the EQ symbol to constrain the dimensions as shown.
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Sketch the dovetail

35 On the Design Bar, click Lines.

36 Sketch the dovetail by snapping to the intersections of the vertical and horizontal reference planes as
shown.

37 Click Modify.

38 On the Tools toolbar click  , and click Delete Inner Segment.

39 Using the split tool, trace the line between the dovetail and the existing element as shown.

40 Press ESC.

Create parameters a and b

41 Select the lower dovetail dimension as shown.
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42 On the Options Bar, click Label ➤ Add Parameter.

43 In the Parameters Properties dialog, under Parameter Data, enter a for Name, and then click OK.

44 Select the upper dovetail dimension as shown.

45 On the Options Bar, click Label ➤ Add Parameter.

46 In the Parameters Properties dialog, under Parameter Data, enter b for Name, and then click OK.
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Create parameter wr

47 On the Design Bar, click Family Types.

48 In the Family Types dialog, under Other, enter 0' 4 1/2" for wr.

49 Click Apply, and then click OK.

50 Select the dimension as shown.

51 On the Options Bar, click Label, and select wr.

Flex the new dovetail profile

52 On the Design Bar, click Family Types.

53 In the Family Types dialog, do the following.

■ Under Other, for a, enter 0' 2" .

■ Under Other, for b, enter 0' 2 1/2" .

■ Click Apply.

Notice the dovetail adjusts automatically to the new parameters.

Create new parameters

54 On the Design Bar, click Family Types.

55 In the Family Types dialog, do the following.

■ Under Family Types, select Rename, and enter 2" x 5" .

■ Under Other, for wr, enter 0' 4" .

■ Under Other, for a, enter 0' 2" .

■ Under Other, for b, enter 0' 2 1/2" .

■ Under Other, for Sr, enter 0' 5" .

■ Click Apply, and then click OK.
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Create a new project

56 On the File menu, click New ➤ Project.

57 In the New Project dialog, click Browse.

58 In the Choose Template dialog, in the Imperial Templates folder, select Structural Analysis-Default.rte ,
and click Open.

59 In the New Project dialog, click OK.

60 In the Project Browser, under Structural Plans, double-click Level 2.

61 On the Design Bar, click Slab.

You are now in sketch mode.

62 On the Design Bar, click Lines.

63 On the Options Bar, click  .

64 Draw a slab in the center of the drawing area.

The slab size should be approximately 55' 0"  long by 35' 0" wide.

65 On the Design Bar, click Finish Sketch.

The slab is created.

Create a section view of the slab

66 On the Design Bar, click Section.

67 Click above the slab and draw a section line through the slab approximately as shown.

68 In the Project Browser, under Sections (Building Sections), double-click Section 1.
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69 Select the slab, and in the Type Selector, select Floor: 3" LW Concrete on 2" Composite Metal Deck .

70 On the View Control toolbar, do the following:

■ For Scale, select 1/4" = 1' 0" .

■ For Detail Level, select Fine.

■ For Model Graphic Style, select Wireframe.

Apply the custom family to the metal deck

71 Click the Window menu, and click the new family file.

The file should still be open. If it is not, open the file from the saved folder location.

72 On the Families Design Bar, click Load into Project.

The new non-composite metal deck family is loaded into the slab project. If there are multiple files open,
select the slab project from the available files.

73 Select the metal deck, and on the Options Bar, click  .

74 In the Element Properties dialog, click Edit/New.

75 In the Type Properties dialog, under Construction, select Edit for Structure.

76 In the Edit Assembly dialog, do the following.

■ Under Layers, select Level 3.

■ Under Structural Deck Properties, for Deck profile, select the new metal deck profile file.

■ Click OK.

The new profile is applied to the slab.

77 Proceed to the next exercise, “Customizing a Castellated Beam” on page 372.

Customizing a Castellated Beam

In this exercise, you create a custom opening in a castellated beam.
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Dataset

■ Click File menu ➤ Open.

■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_Custom_Beam.rvt in the Imperial folder.

Modify the beam opening

1 On the Options Bar, click  , and draw a zoom box around one of the openings in the castellated beam.

2 Select the beam, and on the Options Bar, click  .

3 In the Element Properties dialog, click Edit/New.

4 Position both dialogs so the opening is visible in the drawing area as shown.

Refer to the following diagram to identify and define the parameters for the beam opening.

■ e1 = Tee length.

■ e2 = Space between voids (web post length).
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■ b = Length of sloped portion.

■ dt1 = Tee depth top beam.

■ dt2 = Tee depth bottom beam.

5 In the Type Properties dialog, under Construction, do the following:

■ For e1, enter 0' 6" .

■ For e2, enter 0' 5 1/2" .

■ For b, enter 0' 4" .

■ For dt1, enter 0' 3" .

■ For dt2, enter 0' 3" .

■ Click Apply, and then click OK.

6 In the Element Properties dialog, click OK.

Notice the opening in the beam changes based on the new parameters.

7 Proceed to the next lesson, “Creating In-Place Families” on page 374.

Creating In-Place Families
In this lesson, you start with an incomplete foundation wall. Because in-place families interact with the structural
model according to their assigned family category, you create an in-place family in your current project rather than in
the Family (.rft) template.

Creating a Step Footing In-Place Family

In this exercise, you create a step footing on an existing foundation wall. You sketch the footing cross-section with a
closed profile in an elevation view.

Dataset

■ Click File menu ➤ Open.
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■ In the left pane of the Open dialog, click the Training Files icon.

■ Open i_RST_In-Place-Footing.rvt in the Imperial folder.

Open the existing foundation project

1 On the Modelling tab of the Design Bar, click Create .

2 In the Family Category and Parameters dialog, select Structural Foundations for Family Category, and then
click OK.

3 In the Name dialog, enter Curved Stepped Footing for Name, and click OK.

4 On the Design Bar, click Solid Form ➤ Solid Sweep.

5 On the Design Bar, click Pick Path.

Select the foundation edge

6 Select the lines that represent the bottom edge of the foundation wall as shown.

Notice the path representing the short vertical wall needs to be adjusted.

7 Select the line representing the vertical wall.

8 Drag the line to complete the lower foundation wall paths as shown.

9 In the Project Browser, expand Structural Plans, and double-click Level 1 - Analytical.

Move the reference plane

10 Select the reference profile plane located in the center of the view, and drag it to the end of the foundation
wall as shown.
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11 On the Design Bar, click Finish Path.

12 In the Project Browser, expand Elevations (Building Elevation), and double-click Building Elevation.

Sketch the profile

13 On the Design Bar, click Sketch Profile.

14 On the Design Bar, click Lines.

15 Right-click the open area above the view, and click Zoom In Region.

16 Zoom in on the base of the elevation as shown.

17 On the Options Bar, click  .

18 Draw a rectangle approximately as shown.

19 Press ESC.

20 On the View toolbar, click  .
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Finish the sweep

21 On the Design Bar, click Finish Profile.

22 On the Design Bar, click Finish Sweep.

23 Select the footing, and on the Options Bar, click  .

24 In the Element Properties dialog, under Materials and Finish, click the value for Material.

25 In the Materials dialog, select Concrete - Cast-in-place concrete, and click OK.

26 In the Element Properties dialog, click OK.

27 On the Design Bar, click Finish Family.

28 On the View Control Bar, select Model Graphics Style: Shading with Edges.
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The in-place step footing is complete.

Creating a Titleblock Family
In this lesson, you create a custom titleblock sheet based on the D-size titleblock template.

The titleblock has linework, text, and labels. You customize the titleblock with a new text style, graphics, and your
project data.

Drawing Linework for a Titleblock Sheet

In this exercise, you draw all of the linework necessary to create a custom D-size sheet.

Create a new family based on the default titleblock template

1 On the File menu, click New ➤ Titleblock.

2 In the New dialog, navigate to the Titleblocks folder, select D - 36 x 24.rft, and click Open.

3 The default titleblock template consists of 4 border lines.
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Sketch the inside border

4 On the Design Bar, click Lines.

5 On the Options Bar, click  , and enter -1/2" for Offset.

6 Specify the upper-left corner of the sheet for the first rectangle corner, and then specify the lower-right
corner of the sheet for the second corner of the rectangle.

Add vertical and horizontal lines

7 On the Options Bar, click  , and enter 4 1/2" for Offset.

8 Move the cursor over the right inside border line, and click to draw a new vertical line.

9 On the Options Bar, click  , and click  .

10 Enter 0 for Offset.

11 Draw a horizontal line 4'' below the upper inside border as shown.

12 Draw a horizontal line 3'' below the last horizontal line as shown.
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13 Draw a horizontal line 3'' above the lower inside border as shown.

14 On the Design Bar, click Modify, press CTRL, and select the second and third horizontal lines.

15 In the Type Selector, select Wide Lines.

NOTE The wide line style is not visible until the titleblock is loaded into a new project.

16 Zoom in on the lower-right corner of the sheet.

17 On the Design Bar, click Lines.

18 In the Type Selector, select Title Blocks.

19 On the Options Bar, click  , and enter 0' 1/2" for Offset.

20 Move the cursor over the third horizontal line, and click to draw a new horizontal line 1/2'' below the
existing line.

21 Move the cursor over the fourth horizontal line, and click to draw a new horizontal line 1/2'' below the
existing line.

22 Move the cursor over the fifth horizontal line, and click to draw a new horizontal line 1/2'' below the
existing line.

23 On the Options Bar, enter 3/4" for Offset.

24 Move the cursor over the third horizontal line, and click to draw a new horizontal line 3/4'' above the
existing line.

25 Move the cursor over the seventh horizontal line, and click to draw a new horizontal line 3/4'' above the
existing line.

26 Move the cursor over the eighth horizontal line, and click to draw a new horizontal line 3/4'' above the
existing line.
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27 On the Design Bar, click Modify.

28 Zoom out to view the entire sheet.

The titleblock linework is now complete.

Adding Graphics and Text to a Titleblock

In this exercise, you add a company logo, text notes, and labels to your titleblock.

Add a company logo

1 On the File menu, click Import/Link ➤ Image.

2 In the Open dialog, navigate to Training/Common, select Company Logo.jpg, and click Open.

3 Place the image in the upper-right corner of the sheet as shown.

4 Zoom in on the logo.

Create a new 3/8'' text style

5 On the Design Bar, click Text.

6 On the Options Bar, click  .

7 In the Element Properties dialog, click Edit/New.
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8 In the Type Properties dialog, click Duplicate.

9 In the Name dialog, enter 3/8" Bold for Name, and click OK.

10 In the Type Properties dialog, under Text, enter 3/8" for Text Size, and select Bold.

11 Click OK twice.

Add company name text

12 Draw a text box under the first horizontal line as shown.

13 Enter Arch Design Inc. in the text box.

14 Click outside of the text box to complete the text.

Add company address and phone number text

15 In the Type Selector, select Text: Text Note 1.

16 Draw a text box below the initial text, and add an address and phone number as shown.

Press ENTER to add each new line of text, and click outside of the text box to complete the text.

17 On the Design Bar, click Modify, and select the last text note.

18 Select the drag handle, and drag the text note down as shown.
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19 Click outside the text box to complete the modification.

Add consultant name, address, and phone number text

20 On the Design Bar, click Text.

21 Draw a text box below the second horizontal line, and enter the following text:

■ Consultant:

■ Address:

■ Address:

■ Telephone:

22 On the Design Bar, click Modify, and select the consultant text note.

23 On the Edit toolbar, click  .

24 On the Options Bar, select Constrain and Multiple.

25 Click inside the Consultant text group.

26 Move the cursor down 4'', and click to specify the first copied text note position.

Adding Graphics and Text to a Titleblock | 383



27 Move the cursor down another 4'', and click to specify the second copied text note location.

Create a new 3/16'' text style

28 On the Design Bar, click Text.

29 On the Options Bar, click  .

30 In the Element Properties dialog, click Edit/New.

31 In the Type Properties dialog, click Duplicate.

32 In the Name dialog, enter 3/16" for Name, and click OK.

33 In the Type Properties dialog, under Text, enter 3/16" for Text Size.

34 Click OK twice.

Add drawing data text

35 In the Type Selector, select Text: 3/16".

36 Draw a text box in the lower-right space of the titleblock, and enter Sheet Number.

37 Draw a text box in the next space up, and enter Checked By.

38 Draw a text box in the next space up, and enter Drawn By.

39 Draw a text box in the next space up, and enter Date.
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Add drawing data labels

40 On the Design Bar, click Label.

41 On the Options Bar, select Right and Bottom for Text Alignment.

42 Place the cursor at the lower-right corner of the Date field, and click to specify the label location.

43 In the Select Parameter dialog, select Project Issue Date, and click OK.

The label displays a default value wrapped to 2 lines.

44 Select the left drag handle on the label, and drag to the left until the label displays on one line.

Adding Graphics and Text to a Titleblock | 385



NOTE Move the label if necessary to line up properly with the existing text.

45 Place the cursor at the lower-right corner of the Drawn By field, and click to specify the label location.

46 In the Select Parameter dialog, select Drawn By, and click OK.

47 Place the cursor at the lower-right corner of the Checked By field, and click to specify the label location.

48 In the Select Parameter dialog, select Checked By, and click OK.

Create a new 3/8'' label style

49 On the Design Bar, click Label.

50 On the Options Bar, click  .

51 In the Element Properties dialog, click Edit/New.

52 In the Type Properties dialog, click Duplicate.

53 In the Name dialog, enter 3/8" Label for Name, and click OK.

54 In the Type Properties dialog, under Text, enter 3/8" for Text Size.

55 Click OK twice.

Add sheet number and project data labels

56 In the Type Selector, select Label: 3/8'' Label.

57 Place the cursor at the lower-right corner of the Sheet Number field, and click to specify the label location.
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58 In the Select Parameter dialog, select Sheet Number, and click OK.

59 On the Options Bar, click Center and Middle.

60 Place the cursor near the center of the field above the Date field, and click to specify the label location.

61 In the Select Parameter dialog, select Project Number, and click OK.

62 Select the left drag handle on the label, and drag to the left until the label displays on one line.

63 Place the cursor near the center of the field above the Project Number field, and click to specify the label
location.

64 In the Select Parameter dialog, select Project Name, and click OK.

65 Place the cursor near the center of the field above the Project Name field, and click to specify the label
location.

66 In the Select Parameter dialog, select Client Name, and click OK.
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Click Modify, and select any labels that may need to be moved, so that they are all aligned.

Create a 1/16” label style

67 On the Design Bar, click Label.

68 On the Options Bar, click  .

69 In the Element Properties dialog, click Edit/New.

70 In the Type Properties dialog, click Duplicate.

71 In the Name dialog, enter 1/16" Label, and click OK.

72 In the Type Properties dialog, under Text, enter 1/16" for Text Size.

73 Click OK twice.

Add Project Path label

74 In the Type Selector, select 1/16” Label.

75 On the Options Bar, click Left and Middle.

76 Place the cursor in the border area below the left side of the Sheet Number field, and click to specify the
label location.

77 In the Select Parameter dialog, select File Path, and click OK.

78 On the Design Bar, click Modify, and then adjust the width of the File Path field so that it is approximately
equal to the width of the Sheet Number field.

79 Save the new titleblock family with the name Training D-Size Titleblock.rfa.

The titleblock graphics, text, and labels are now complete.
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Adding the Titleblock to a New Project

In this exercise, you add the titleblock that you created to a new project.

Load the new titleblock family into a new project

1 On the File menu, click New ➤ Project.

2 In the New Project dialog, verify that default.rte is the Template file and that Project is selected under Create
new, and then click OK.

3 On the View tab of the Design Bar, click Sheet.

4 In the Select a Titleblock dialog, click Load.

5 In the Open dialog, navigate to the location of Training D-Size Titleblock.rfa file, select it, and click Open.

6 In the Select a Titleblock dialog, select Training D-Size Titleblock.

7 Click OK.

Modify titleblock properties

8 On the Design Bar, click Modify, and select the titleblock.

9 On the Options Bar, click  .

10 In the Element Properties dialog, under Other, enter Name for Drawn By, and click OK.

11 Zoom in on the lower-right corner of the sheet.

12 On the Settings menu, click Project Information.

13 In the Type Properties dialog, do the following:

■ For Project Issue Date, enter January 1, 2005.

■ For Project Status, enter In Progress.

■ For Client Name, enter Jane Smith.

■ For Project Name, enter Office Building.
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■ For Project Number, enter 2005-01.

14 Click OK.

This completes the Creating a Titleblock Family lesson.
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Truss Building

In this tutorial, you create a custom steel truss using Autodesk® Revit® Structure 4. In the first exercise,

the truss is created manually using drafting tools provided with Revit Structure. In the second exercise,

the same truss is created automatically using the Autodesk TrussWizard application available through

the Revit Structure Application Program Interface (API).
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Creating a Steel Truss
In this first exercise, you open a new project and create the top and bottom chords using the beam tool, create column
grids, and a framing elevation. Finally, you add braces to form the steel truss.

Create a new project

1 Click File menu ➤ New ➤ Project.

2 In the New Project dialog, click Browse.

3 In the Choose Template dialog, in the Imperial Templates folder, select Structural Analysis-Default.rte ,
and click Open.

4 In the New Project dialog, click OK.

Create grids

5 In the Project Browser, under Structural Plans, double-click Level 2.

6 On the Drafting tab of the Design Bar, click Grid.

7 Draw 2 grid lines approximately as shown.

Add framing elevations

8 On the Basics tab of the Design Bar, click Framing Elevation.

9 Select each grid line, and place approximately as shown.

Place support columns

10 On the Design Bar, click Structural Column.

11 In the Type Selector, select W-Wide Flange Column: W10 x 49 .

12 Place 2 columns on each grid line spaced approximately 70' 0" apart as shown.
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(The dimensions are displayed for reference purposes only.)

13 Click the Framing Elevation symbol, and drag the blue handles beyond each column as shown

.

Sketch horizontal reference planes

14 In the Project Browser, under Elevations (Interior Elevation), double-click Elevation 1 - a.

15 On the Design Bar, click Ref Plane.

16 Place a horizontal reference plane above Level 2.

17 Click the dimension, enter 5' 0" , and press Enter.

The dimensions are displayed for reference purposes only.

18 Place a second horizontal reference plane above the first.

19 Click the dimension, and enter 15' 0" .

Place vertical reference planes

20 On the Design Bar, click Ref Plane.
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21 Snap to the center of the left column and draw a vertical reference plane that extends beyond the top
horizontal plane as shown.

22 Press ESC.

Place multiple reference planes using the array tool

23 Select the reference plane on the left column as shown.

24 On the Tools toolbar, click  .

25 Click the left vertical reference plane to identify the array start point.

26 Drag the array to the right, and snap to the center of the right column to identify the array length.

27 Enter 7 for array count, and press Enter.

394 | Chapter 17   Truss Building



The array is complete.

Place top and bottom chords

28 On the Design Bar, click Beam.

29 In the Type Selector, select W-Wide Flange: W12 x 26 .

30 On the Tools toolbar, select 3D Snapping.

31 Using reference planes as a guide, create the top and bottom chords of the truss by placing beams as shown.

When placing beams, make sure you snap to the intersections of the reference planes.

Place braces

32 On the Modelling tab of the Design Bar, click Brace.

33 In the Type Selector, select W-Wide Flange: W12 x 26 .

34 Using the vertical reference planes as a guide, create cross-braces by placing braces as shown.

When placing braces, make sure you snap to the intersections of the reference planes.
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Fix corner joint

35 On the View Toolbar, click  , and draw a zoom box around the upper-right corner of the truss as shown.

36 On the Design Bar, click Ref Plane.

37 Snap to the outer surface of the brace, and sketch a vertical ref plane as shown.

38 On the Tools toolbar, click  .

39 Select the vertical ref plane, then select the edge of the top chord as shown.
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40 The edge of the top chord will align with the vertical brace as shown.

View the truss

41 In the Project Browser, under 3D Views, double-click 3D.

The completed truss is displayed.

42 Click File menu ➤ Save As.

43 Navigate to a folder of your preference, and save the file as Truss_Builder-in progress.rvt.
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44 Proceed to the next exercise, “Creating a Steel Truss with the TrussWizard” on page 398.

Creating a Steel Truss with the TrussWizard
In this exercise, you use the Autodesk TrussWizard to automatically create a steel truss to the same specifications as the
truss created in the previous exercise.

NOTE The Autodesk Revit Structure 4 TrussWizard is an application offered to subscription customers to help model and
create trusses using industry-standard truss profiles as templates. The following exercise can only be performed after installing
the TrussWizard application.

Place the top chord of the truss

1 In the Project Browser, under Structural Plans, double-click Level 2.

2 On the Design Bar, click Beam.

3 In the Type Selector, select W-Wide Flange: W12 x 26 .

4 Draw a beam between the existing columns as shown.

Make sure the beam snaps to each column.

5 Select the beam on grid line 2.

6 Click Tools menu ➤ External Tools ➤ Create Truss from Beam.

The TrussWizard application is launched.

7 In the Select Truss Type dialog, do the following.

■ Under Select Truss Type, select Howe Truss.

■ Under Replaces Beam With, select Bottom Chord.

■ Click Next.
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Notice the truss length is set to the length of the beam you placed.

8 In the Input Truss Dimensions dialog, do the following.

■ Under Number of panels, enter 6.

■ Under Panel for peak, enter 4.

■ Under Peak Offset from Chord, enter 5' 0" .

■ Under Height at Left End, enter 0' 0" .

■ Under Height at Peak, enter 15' 0" .

■ Under Height at Right End, enter 20' 0" .

■ Click Next.

Notice the truss adjusts automatically as you change dimensions.
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9 In the Select Truss Property dialog, do the following.

■ Under Top Chord and Bottom Chord, select W-Wide Flange: W12 x 26 .

■ Under Diagonals and Verticals, select W-Wide Flange: W12 x 26 .

■ Click Finish.

The existing beam is deleted and replaced with the new truss.

10 In the Project Browser, under 3D Views, double-click 3D.

The completed truss is displayed.
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Creating Multiple Design Options

When working with a building model, it is common to explore multiple design schemes as the project

develops. These schemes can be conceptual or can be detailed engineering designs. Using design options,

you create multiple design schemes within a single project file. Because all design options coexist in the

project with the main model (the main model consists of elements not specifically assigned to a design

option), you can study and modify each design option and present the options to the client.

In this tutorial, you learn how to create and manage multiple design sets and options within a single

building model.
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Creating Multiple Design Options in a Project
You can use design options to explore multiple design schemes as the project develops. At any time in the design
process, you can have multiple sets of design options, and each option set can have multiple schemes. For example,
you can have an option set called roofing with multiple subordinate roofing schemes. In addition, you can have an
option set for the roof structure with multiple subordinate structural design schemes. After you and the client agree
on the final design, you can designate a primary design scheme for each option set.

In this particular case, the task is to develop two roof schemes for an addition to an existing house. The client is
interested in a pergola and sunshade for the roof terrace but is not sure of the specific layout or materials. The client
has asked you to create various options.

In the first exercise in this lesson, you set up the design option names and add the modeling elements to the structural
design option set. In the second exercise, you create two roof system design options that work with the structural
options. In the final exercise of this lesson, you learn how to manage and organize the design options, make your final
design decision, and delete the unwanted options from the project. These three exercises are designed to be completed
sequentially with the second and third exercises dependent on the completion of the previous exercise.

Creating the Structural Design Options

In this exercise, you set up multiple design option sets, each with multiple design options. After setting up the design
option sets and their subordinate options, you design each of the structural options. The first option is a simple
combination of columns and beams. With the second option, you create a unique in-place family as the structural
system.

Dataset

■ On the File menu, click Open.

■ In the left pane of the Open dialog box, click the Training Files icon.

■ Open the i_Urban_House.rvt file located in the Imperial folder.

Create first design option

1 On the Tools menu, click Design Options ➤ Design Options.

The first time you open the Design Options dialog box within a project, the only available command is to
create a new option set. There is no limit to the number of option sets you can create. Each option set
represents a portion of the building model wherein design alternatives are being considered. After you
create a design option, you can edit it. Any new elements introduced at that time become part of that
option.

2 In the Design Options dialog box, under Option Set, click New.

Notice Option Set 1 has been created with a design option: Option 1 (primary). This option will be the
first structural scheme consisting of 3" round columns and 2" round bars.
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TIP In this exercise, the roof and structure systems must work together; therefore, each is constructed for
interchangeability.

3 Select Option 1 (primary), click Edit Selected, and click Close.

Any new elements introduced to the building model are added to this option.

4 In the Project Browser, expand Views (all), expand Floor Plans, and double-click ROOF TERRACE.

5 On the View menu, click Zoom ➤ Zoom in Region, and zoom in on the upper half of the building model.

6 On the Architectural tab of the Design Bar, click Column.

7 In the Type Selector, select Round Column: 03" Diameter.

8 Using the following illustration as a guide, add three columns. Arrows and the dimension lines have been
added for training purposes only. The left column should be centered at the intersection of the notch and
the wall, the second column directly across from it at the intersection of the two walls, and the third
column centered between the two.

TIP To center the middle column, either add a centered reference plane and snap the column to it, or add a
dimension string between the columns, and click the EQ symbol to equalize the segments. You should delete
the dimension and unconstrain after adding the column.

9 On the Design Bar, click Modify.

10 Select the three columns either by dragging a pick box around them or by selecting them individually
while holding CTRL.

11 On the Edit toolbar, click  .

12 On the Options Bar, select:

■ Constrain

■ Copy

■ Multiple

The Copy command is a two-click process. The first click specifies the reference point on the element to
be copied, and the second click specifies the point on the building model the reference point is copied to.
In this case, the three columns need to be copied three times to create a 3 x 4 grid of 12 columns. By
selecting Multiple, you can continue adding new copies without reselecting the reference point (the first
click). Selecting Constrain limits the movement and helps ensure the post-copy alignment of the columns.

13 Zoom in around the left column that is embedded in the notch.

14 Click at an identifiable part of the notch construction. Because it is important that you select the same
location on the notches you copy to, make sure you select a point that is easily recognizable. In the following
illustration, the midpoint of the lower notch line is selected.
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TIP You can zoom in and out easily during this process using the wheel on your wheel mouse.

15 Zoom out and move downward to the notch just below this one.

16 Zoom in around the notch construction, and click in the same location as you did for the previous notch.

A copy of the three selected columns is added.

17 Zoom out and, using the same technique, add a copy of the columns to the next two notches below this
one. When you are finished, click Modify on the Design Bar to end the copy process.

Because of the size of the columns, they are difficult to see in this view.

18 On the View toolbar, click  .
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Notice the 12 columns that you added.

Next, you add the beams that span the columns.

19 In the Project Browser, under Floor Plans, double-click TOP OF CORE.

20 On the Basicstab of the Design Bar, click Beam.

Adding a beam is a two-click process. The first click specifies the beam start point. The second click specifies
the end of the beam.

21 In the Type Selector, select Round Bar : 2" .

22 Add the first beam between the upper left and right columns by using the following steps:

■ Zoom in on the upper-left column, and click at its center to set the beam start point.

■ Zoom out and move the cursor over the upper right column.

■ Zoom in on the upper right column, and click on the center to set the beam endpoint.

Use the following illustration as a guide. In it, two callouts with thin lines have been added to clarify the
location of the start and end points of the beam.

23 On the Design Bar, click Modify.

24 Select the Beam you added previously.

The beam needs to be added between the remaining columns. You can do this manually or use the Copy
command.

25 On the Edit toolbar, click  .

Creating the Structural Design Options | 405



26 On the Options Bar, select:

■ Constrain

■ Copy

■ Multiple

27 Zoom in around the upper left column that is embedded in the notch, and click the center point.

This is the reference point for the subsequent copies.

28 Zoom out, move down to the next set of columns, zoom into the left column, and select the center of the
column to add a copy.

29 Repeat this step twice more until a beam is added to each set of columns.

30 On the View toolbar, click  .
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Notice that the beams complete the bracket structure for the proposed roof.

Organize design option sets and subordinate options

31 On the Tools menu, click Design Options ➤ Design Options.

32 In the Design Options dialog box, notice that you are still editing Option Set 1: Option 1 (primary).

33 Click Finish Editing.

34 In the Design Options dialog box, under Option, click New.

NOTE Be sure you are creating a new option, not a new option set.

35 Select Option 1 (primary) and, under Option, click Rename.

36 In the Rename dialog box, enter Brackets for New, and click OK.

37 Select Option 2 and, under Option, click Rename.

38 In the Rename dialog box, enter Beam for New, and click OK.

39 Select Option Set 1 and, under Option Set, click Rename.

40 In the Rename dialog box, enter Structure for New, and click OK.

Logically naming the option sets and relative options allows you to more easily manage them.

41 Under Option Set, click New.

42 Select Option Set 1 and, under Option Set, click Rename.

43 In the Rename dialog box, enter Roofing for New, and click OK.

44 Select the option set Roofing and, under Option, click New.

There should now be two roofing design options.

45 Under Roofing, select Option 1 (primary).

46 Under Option, click Rename, name the option Louvers, and click OK.
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47 Under Roofing, select Option 2.

48 Under Option, click Rename, name the option Sunscreen, and click OK.

You have completed the initial setup of the design option sets and their subordinate design option names.
This allows you to more easily manage the project.

Design the second structural design option

49 In this section of the exercise, you create the second design option. When finished, it will resemble the
following illustration.

50 In the Design Options dialog box, under Structure, select Beam.

51 Under Edit, select Edit Selected.

Under Now Editing, notice that Structure: Beam is displayed.

52 Click Close.

Notice that the columns added to the Brackets design option do not display.

53 In the Project Browser, under Floor Plans, double-click ROOF TERRACE.

54 Zoom in toward the top of the roof terrace near the stairs.
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55 On the Basics tab of the Design Bar, click Component.

56 In the Type Selector, select Roof Beam .

57 Place a roof beam into the drawing area as shown.

58 On the Tools menu, click Align.

Using the Align tool requires two clicks. The first click sets the plane that the object will be aligned to. The
second click represents the plane that is moved.

59 Align the roof beam by clicking the lower edge of the adjacent horizontal wall and then clicking the lower
edge of the roof beam. Refer to the following illustration.

60 After aligning the beam, click the padlock that displays to lock the alignment.

61 On the Design Bar, click Modify.
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62 Select the beam and, on the Edit toolbar, click  .

63 On the Options Bar:

■ Clear Group and Associate

■ Enter 4 for number

■ Select 2nd for Move To:

■ Select Constrain

Using the Array tool requires two clicks. The first click sets the move start point. The second click represents
the move end point.

64 Click the start point at the alignment of the beam and wall as shown.

65 Move the cursor down to the next intersection of the lower edge of the horizontal wall and the beam. Click
to indicate the end point of the move.
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Three more roof beams are placed at the same intersection as the first beam.

66 On the View toolbar, click  .

Notice the new design option for the structural elements supporting the roof system.

67 On the Tools menu, click Design Options ➤ Design Options.

68 In the Design Options dialog box, click Finish Editing.

Notice that even before you close the dialog box, the 3D view has reverted back to the brackets rather than
the structural beams you just created.

That is because the brackets option is set to primary, which is visible by default. Design option visibility
is covered in more detail later in the tutorial.

69 Click Close.

70 On the File menu, click Save As.

71 Navigate to your preferred directory, name the file, i_Urban_House-in progress.rvt , and click Save.

NOTE If you intend to continue with the next exercise, you need this file in its current state. You can leave it
open and proceed immediately to the next exercise.

In this exercise, you set up multiple design option sets, each with multiple design options to pick from. After setting
up the design option sets and their subordinate options, you designed each of the structural options: one for brackets,
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the other for beams. The first option is a simple combination of columns and beams. With the second option, you
created a unique in-place family as the structural system.

In the next exercise, you create the roof systems that compliment these structural design options.

Creating the Roof System Design Options

In this exercise, you design each of the roofing options. The first option, a Louver system, is constructed of 2" x 10"
rafters and 2" x 6" louvers. The second roofing system, Sunscreen, is a simple fabric roof created using an extrusion.
Both of these options are designed to work in conjunction with each of the structural design options.

This exercise is designed to work in conjunction with the other exercises in this tutorial. All are sequential and dependent
on the previous exercise. If you have not completed the first exercise in this tutorial, do so now.

Create the first roofing design option

1 If you do not have the project file that you saved at the end of the previous exercise open, open it now.
You should have named it i_Urban_House-in progress.rvt .

2 On the Tools menu, click Design Options ➤ Design Options.

3 In the Design Options dialog box, under Roofing, select Louvers (primary).

4 Under Edit, click Edit Selected.

Under Now Editing, Roofing: Louvers (primary) should display.

5 Click Close.

6 In the Project Browser, expand Views (all), expand Floor Plans, and double-click TOP OF CORE.

7 On the Basics tab of the Design Bar, click Component.

8 In the Type Selector, select Rafter 2 x 10 .

9 Zoom in on the lower half of the building model until you can see the bottom set of columns and the
beam traversing the span.

10 Referring to the following illustration, place the rafter 3' 0" inside the wall shown and overlap the horizontal
beam 3' .

The dimensions shown are for training purposes. If you need to add dimensions, delete them after the
rafter is in place.
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11 On the Basics tab of the Design Bar, click Modify.

12 Select the rafter you added previously.

13 On the Options Bar, click  .

14 In the Element Properties dialog box, under Other, enter 38' 6" for Length, and click OK.

The rafter should now span the entire vertical length of the proposed roof system.

15 On the Edit menu, click Array.

16 On the Options Bar, specify the following:

■ Clear Group and Associate.

■ Enter 5 for Number.

■ Select 2nd for Move To.

■ Select Constrain.

You are creating an array of five rafters that are 3' 3"  apart.

17 Zoom in on the intersection of the lower end of the rafter and the intersecting beam; click in the center
of the intersection to specify the array start point.
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18 Move the cursor horizontally to the right and, when the listening dimension displays, enter 3' 3" , and
press ENTER.

TIP When entering a dimension value, you do not need to type the foot and inch markers. For example, rather
than entering 3' 3", you can enter 3 3. The space separates feet and inches.

Zoom out to see that the rafter array is created.

Add the louvers to the design option

19 On the Basics tab of the Design Bar, click Component.
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20 In the Type Selector, select Louver 2 x 6 .

21 Place the first horizontal louver in the upper left corner according to the following illustration.

22 On the Design Bar, click Modify, and select the louver you just placed.

23 On the Options Bar, click  .

24 In the Element Properties dialog box, under Other, enter 17' 6 1/2" for Length, and click OK.

The louver now spans the horizontal plane of the roof system.

25 With the louver still selected, click the Edit menu, and click Array.

26 On the Options Bar, specify the following:

■ Clear Group and Associate.

■ Enter 34 for Number.

■ Select 2nd for Move To.

■ Select Constrain.

27 For the array starting point, click in the center of any intersection between the louver and the beam.

28 Move the cursor vertically downward, and, when the listening dimension displays, enter 1' , and press
Enter.
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Zoom out to see that the 34 louvers array 1' 0" apart.

29 On the View toolbar, click  .

The louver roof system is complete.

30 On the Tools menu, click Design Options ➤ Design Options.

31 In the Design Options dialog box, under Edit, click Finish Editing.

The louver roof system still displays in the 3D view because it is the primary option.

Create sunscreen roof system

32 In the Design Options dialog box, under Roofing, select Sunscreen.

33 Under Editing, click Edit Selected, and then click Close.

Notice that the louver roof system no longer displays.

34 In the Project Browser, expand Elevations, and double-click West.

35 Zoom in on the upper level where the roof design is taking place.
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36 On the Architectural tab of the Design Bar, click Roof ➤ Roof by Extrusion.

37 In the Work Plane dialog box, select Reference Plane : Roof Extrusion for Name, and click OK.

The roof extrusion reference plane has been added to the dataset specifically for this purpose and is hidden
in all views.

38 You are prompted to verify the roof level and offset. Click OK.

Because an extruded roof has a roof type associated with it, you only need to sketch a single line or a string
of lines to define the shape of the extruded roof. In this case, you must create a draped canvas sunscreen.
Therefore, the sketch should be a series of arcs connected at the ends where they connect to the columns.

39 On the Design Bar, click Lines.

40 On the Options Bar, click  .

This tool allows you to sketch an arc line using three points. The first two points define the ends of the
line, and the third point defines the arc.

41 Select the top of the left column, the top of the next column on the right, and then adjust the dip of the
arc until it is 60 degrees. You can adjust the degrees by clicking the blue temporary dimension value
immediately after you create the line.

42 Repeat the previous step and create two more arcs between the columns.

NOTE As you sketch the arcs, try to get the angle value as close to 60 degrees as possible, then you can modify
it through the dimension. Do not be too concerned if your sketch lines do not exactly connect. You will fix this
in a later step.

43 On the Design Bar, click Properties.

44 In the Element Properties dialog box, specify the following:

■ Select Sunscreen Fabric for Type.

■ Under Constraints, enter 1' 0" for Extrusion Start.

■ Under Constraints, enter -19' 0" for Extrusion End.

45 Click OK.

The roof sketch must be a continuous line. You must make sure the arcs are connected where they connect
to the columns. The easiest way to accomplish this is to use the Trim tool.

46 On the Tools menu, click Trim/Extend.

47 Select the left arc and then the center arc. Select the right arc, then the center arc.
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The arcs should connect.

48 On the Design Bar, click Finish Sketch.

49 On the View toolbar, click  .

The louver roof system is complete.

You have completed the sunscreen roof system.

50 On the Tools menu, click Design Options ➤ Design Options.

51 In the Design Options dialog box, under Edit, click Finish Editing, and then click Close.

52 On the File menu, click Save.

NOTE If you intend to continue with the final exercise, you need this file in its current state. You can leave it
open and proceed immediately to the next exercise.

In this exercise, you designed each of the roofing options. The first option, a Louver system, was constructed of 2" x
10" rafters and 2" x 6" louvers. The second roofing system, Sunscreen, was a simple fabric roof created using an extrusion.
Both of these options are designed to work in conjunction with each of the structural design options.

Managing Design Options

In this exercise, you explore how to present each of the design options by creating multiple views to display the various
combinations. After exploring the combinations, you select a design, make it part of the building model, and delete
the discarded design options.

This exercise is designed to work in conjunction with the other exercises in this tutorial. All are sequential and dependent
on the previous exercise. If you have not completed the previous exercises in this tutorial, do so now.

Create new views for each design option

1 In the Project Browser, under Views (all), expand 3D Views.

Because the client wants to see 3D building models of each of the designs, you must create a named 3D
view for the primary, secondary, tertiary, and last options.

2 In the Project Browser, under Views (all), under 3D Views, right-click {3D}, and click Rename.
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3 In the Rename View dialog box, enter Primary Option, and click OK.

4 In the Project Browser, right-click the 3D View Primary Option, and click Duplicate. Repeat this step two
more times until you have three copies of the view.

5 Right-click each of the copies, and click Rename. Rename the three copies as follows:

■ Secondary Option

■ Tertiary Option

■ Last Option

6 In the Project Browser, under Views (all), under 3D Views, double-click Primary Option.

7 On the View menu, click Visibility/Graphics.

8 In the Visibility/Graphics dialog box, click the Design Options tab.

Notice that both option sets are set to automatic. This ensures that the primaries (currently bracket and
louver) are visible.

9 Click OK.

10 In the Project Browser, under Views (all), under 3D Views, double-click Secondary Option.

11 On the View menu, click Visibility/Graphics.

12 In the Visibility/Graphics dialog box, click the Design Options tab.

13 Specify Beam for the Structure design option, and click OK.
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14 In the Project Browser, under Views (all), under 3D Views, double-click Tertiary Option.

15 On the View menu, click Visibility/Graphics.

16 In the Visibility/Graphics dialog box, click the Design Options tab.

17 Specify Brackets for the Structure design option, specify Sunscreen for the Roofing design option, and click
OK.

18 In the Project Browser, under Views (all), under 3D Views, double-click Last Option.

19 On the View menu, click Visibility/Graphics.

20 In the Visibility/Graphics dialog box, click the Design Options tab.

21 Specify Beam for the Structure design option, specify Sunscreen for the Roofing design option, and click
OK.
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At this point, all isometric views are ready to be placed on a titleblock or exported and e-mailed to the
client.

In this case, the client has reviewed the design options and has decided that the beam system coupled with
the louver roofing system is the preferred design. In your design options, the beam and the louver roofing
should be selected as primary.

22 On the Tools menu, click Design Options ➤ Design Options.

23 In the Design Options dialog box, under Structure, select Beam.

24 Under Option, select Make Primary. This was the client choice for structural.

Because the client has selected the design option, the current primaries are no longer options; but should
be accepted as part of the building model.

25 Select Structure.

26 Under Option Set, click Accept Primary.

An alert is displayed, asking if you are sure you want to delete all elements of secondary options in this
option set and remove the option set.

27 In the alert dialog box, click Yes.

The set is deleted, the beam option becomes part of the model, and you get a dialog asking if you want to
delete dedicated option views.

28 In the Delete Dedicated Option Views dialog box, click Delete to remove the views that used options, since
you no longer need them.

29 Select Roofing.

30 Under Option Set, click Accept Primary to take the louvers into the model, delete the other design option
geometry and any dedicated option views.

31 In the alert dialog box, click Yes.

32 In the Delete Dedicated Option Views dialog box, click Delete.

33 In the Design Options dialog box, click Close.

34 In the Project Browser under 3D Views, double-click Primary Option. The other options were removed
along with any dedicated option views.
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The beam and louver systems are now part of the building model.

35 On the File menu, click Save.

In this exercise, you learned how to present each of the design options by creating multiple views to display the various
combinations. After exploring the combinations, you selected a design, made it part of the building model, and deleted
the discarded design options.
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Linking Building Models and
Sharing Coordinates

Many projects consist of disparate buildings in an overall campus, or of a group of related but

semi-independent sub-projects. In these situations, you can use model linking and shared coordinates

to create the campus within one project file while allowing work to proceed on the individual building

models in other project files. This maximizes efficiency, performance, and productivity by working in a

smaller project file while retaining the ability to place that building model into a larger context.

Specific examples when you may want to use model linking and shared coordinates:

■ A campus plan that contains links to several structures.

■ A residential development in which a few different prototypes are configured differently in an area.

■ Comparison of alternatives on a site.

In this tutorial, you link several building models within a single project file in which only a site plan has

been developed. You position the building models on the site plan, modify their visibility, and manage

the links throughout the project. In the final lesson, you share the coordinates so that the linked files

remember their location within the host project.

19
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Linking Building Models
In this lesson, you work within a project in which only the site components have been developed. You link multiple
instances of one building model and a single instance of another. You position the building models on the site, modify
their visibility, and manage their locations in coordination with their originating project files.

NOTE You must complete the exercises in this lesson in sequence.

Linking Building Models from Different Project Files

In this exercise, you open a project in which only site components have been developed. You link two building models
to the project. One building model is a condominium, and the other is a townhouse.

Placement options when linking building models

1 When you link a building model in a project, you have the option to manually place the linked building
model or allow Autodesk Revit Structure 4 to automatically place it.

Automatic placement options:

■ Center-to-Center: Revit Structure places the center of the imported geometry at the center of the model.

NOTE The center of a Revit Structure model is the center of the model geometry. This center changes as
the footprint of your model changes.

■ Origin-to-Origin: The origin of the imported geometry is placed at the invisible origin of the Revit
Structure model.

■ By shared coordinates: When using Model Linking in conjunction with Shared Coordinates, this option
will place the link at a predefined location.
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RELATED See the lesson, “Sharing Coordinates Between Building Models” on page 440.

Manual placement options:

■ Cursor at origin: The origin of the linked document is centered on the cursor.

NOTE Revit Structure projects are based on a coordinate system; however, this system is not exposed to
the user.

■ Cursor at base point: Not applicable for linked Revit Structure Files. This option is grayed out.

■ Cursor at center: The center of the linked document is at the cursor location.

This tutorial requires write permission to all the training files used. Because training files are used in multiple
tutorials and are normally installed as read-only, you need to copy the three training files to a different
directory and make them writable. If you are comfortable doing this using Windows Explorer, you can do
so. The required files can be found in the Common folder of the Training files: c_Site, c_Townhouse,
c_Condo_Complex. Otherwise, use the following steps to copy the training files to a new location.

Save training files to different folder

2 Create a new folder on your hard drive called Model Linking.

3 On the File menu, click Open.

■ In the left pane of the Open dialog box, click the Training Files icon.

■ Open the c_Site file located in the Common folder.

4 On the File menu, click Save As, navigate to the Model Linking folder you created in the first step, and save
the file there.

5 On the File menu, click Close.

6 Repeat the previous four steps for the following files:

■ c_Townhouse

■ c_Condo_Complex

7 Open the Model Linking folder, select the three files, right-click, and click Properties.

8 Clear Read-only, and click OK.

All three files now reside, with write permission, in the Model Linking folder that you created.

Link condo complex into site project

9 On the File menu, click Open.

■ Navigate to the Model Linking folder.

■ Select c_Site.
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■ Click Open.

10 In the Project Browser, expand Views (all), expand Floor Plans, and double-click Level 1.

Notice the blue detail lines. These represent the footprint outlines of the three building model sites.

11 On the File menu, click Import/Link ➤ Revit.

12 In the Add Link dialog box:

■ Navigate to the Model Linking folder and select c_Condo_Complex.

■ Under Positioning, select Automatically place.

■ Under Automatically place, select Origin to origin.

13 Click Open.

The condo complex building model is placed approximately at the center of the site model.

Move the condo complex building model

14 Select the linked building model.
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After you select it, Linked Autodesk Revit Model: c_Condo_Complex.rvt is displayed in the Type Selector.

Standard move commands work with linked building models. The linked model moves as one object,
similar to the behavior of imported DWG objects.

15 On the Edit toolbar, click  .

The Move command requires two clicks. The first click specifies the move start point. The second click
specifies the move endpoint.

16 For the move start point, click the upper-left corner of the linked condo complex building model.

17 For the move endpoint, click the upper-left corner of the matching blue detail lines above it.
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After you specify the location to move to, the linked file is displayed within the confines of the blue detail
lines.

18 On the View menu, click Zoom ➤ Zoom To Fit.

Link the townhouse building model

19 On the File menu, click Import/Link ➤ Revit.

20 In the Add Link dialog box:

■ Navigate to the Model Linking folder, and select c_Townhouse.

■ Under Positioning, select Automatically place.

■ Under Automatically place, select Origin to origin.

21 Click Open.

The townhouse building model is displayed above the site model.

Rotate the townhouse

22 Zoom in around the townhouse model and select it.
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23 On the Edit toolbar, click  .

To rotate an object, you first specify the rotation start point, and then click to specify the end of the rotation.
In this case, the townhouse must be rotated 90 degrees clockwise.

24 Place the cursor just north of the townhouse and, when the vertical line displays, click to specify the
rotation start point.

25 Move the cursor 90 degrees clockwise, and click to specify the end of the rotation.
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The rotated townhouse should resemble the following illustration.

Move the townhouse

26 On the Edit toolbar, click  .

This townhouse building model needs to be moved inside the blue detail lines in the lower-left corner of
the site model. Do not be concerned if the detail lines do not match the exact footprint of the townhouse.

27 Click the lower-left corner of the townhouse building model as the move start point.

28 Select the lower-left corner of the lower-left set of blue detail lines as the move endpoint.
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The townhouse is located within its required footprint.

Copy the townhouse

29 On the Edit toolbar, click  .

The Copy command works much like the Move command. The first click specifies the start point, and the
second click specifies the copy-to point.

30 For the starting point, select the upper-right corner of the townhouse.

31 Select the upper-right corner of the blue detail lines on the right to specify the copy-to point.

A copy of the townhouse is displayed on the right side of the site project.

32 On the Edit menu, click Rotate, and rotate the townhouse 180 degrees.

432 | Chapter 19   Linking Building Models and Sharing Coordinates



NOTE After you rotate the townhouse, if it does not fit reasonably well within the detail lines, use the Move
command to make any adjustments.

33 Click the first instance of the townhouse on the left.

34 On the Options Bar, click  .

35 In the Element Properties dialog box, under Identity data, for Name, enter Townhouse A, and click OK.

36 Use the same technique to name the instance of the Townhouse on the right to Townhouse B.

37 On the View toolbar, click  .

38 On the File menu, click Save.

NOTE If you intend to complete the next exercise of this tutorial, you need this project file open and in this
view.

In this exercise, you linked two separate Autodesk Revit Structure 4 models into a site model. After linking the files,
you rotated and moved the building models to fit them into their designated positions within the site development.

In the next exercise, you modify the elevation of the townhouses.

Repositioning Linked Building Models

In this exercise, you reposition the townhouses in respect to their elevation. When you originally linked the files, they
were placed too low within the site topography. In this exercise, you modify their vertical position so that the townhouses
sit correctly on the site.

NOTE This exercise requires the completion of the previous exercise in this tutorial and the resulting project files. If you have
not completed the previous exercise, do so before continuing.

Modify the vertical position of the townhouses

1 On the View toolbar, click  .

2 Using the Dynamic View tool, hold the Shift key down and spin the model until it resembles the following
illustration.
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Notice that the townhouse is not at the proper elevation in relationship to the site toposurface. This is
apparent because there is a planter below ground level that was designed to sit on top of the site surface.

3 In the Project Browser, under Views (all), expand Elevations, and double-click South.

4 Zoom in around the townhouse on the left.

5 Place the cursor over the townhouse and notice that, when it highlights, the tooltip and status bar display
the name of the linked file.

6 Zoom in closer on the lower half of the townhouse and notice the ground floor level of the townhouse is
11 feet below Level 1 of the site project.

In the steps that follow, you use the Align command to reposition the linked model within this project.
When using the Align command, you first select the plane you want to align to, and then select the plane
that you want to align. In this case, you align the Ground Floor level to Level 1 of the site plan.

7 On the Tools toolbar, click  .
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8 Select the Level 1 line of the Site project, move the cursor over the Ground Floor level of the Townhouse
project, and click to select it.

Notice that the townhouse is now at the proper height within this project. Also notice the option displays
for you to lock the alignment. Do not lock the alignment of the linked file. This would over-constrain the
model.

9 In the Project Browser, under Elevations, double-click North.

10 Using the same technique learned in the previous steps, align the Ground Floor level of the remaining
townhouse to Level 1 of the Site project.

11 Return to the South elevation view.

Both townhouses should be at the proper level.

12 On the View toolbar, click  .

13 On the View toolbar, click  .

14 Using the Dynamic View tool, hold the Shift key down and spin the model until it resembles the following
illustration.

15 On the File menu, click Save.

NOTE If you intend to complete the next exercise of this tutorial, you need this project file open and in this
view.
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In this exercise, you changed the elevation of the townhouses relative to the host project. As you can see, each linked
file can have a separate set of levels and relative heights and you can accommodate those differences within the host
project.

In the next exercise, you modify how the linked files display within the host project.

Controlling Linked Building Model Visibility

In this exercise, you modify the visibility settings of the linked files within the site project. After you link an Autodesk
Revit Structure 4 project file within another project, you can control the visibility settings, detail level, display settings,
and the halftone settings.

NOTE This exercise requires the completion of the previous exercises in this tutorial and the resulting project files. If you have
not completed the previous exercise, do so before continuing.

Modify visibility settings

1 On the Project Browser, under Elevations, double-click South.

2 On the View menu, click Visibility/Graphics.

3 In the Visibility/Graphics dialog box, click the Revit Links tab.

4 Under Visibility, expand c_Townhouse.rvt.

Notice that you can change visibility settings of an entire linked file or selected instances of a linked file.

NOTE You have three options for controlling visibility settings of a linked file. By host view matches the display
to the settings of the current active project view. By linked view matches the display to the settings of the
linked project view. Custom allows you to override specific visibility settings for a linked project or an instance
of the linked project. When you link a file, the defaults are set to By host view for all options.

5 Under Display Settings for c_Townhouse.rvt, click By Host View.

6 On the Basics tab of the RVT Link Display Settings dialog box, click Custom.

If the Basics page is set to Custom, then the other pages on the RVT Link Display Settings dialog may be
set to By host View, By linked view, or Custom.

7 Click the Annotations Categories tab.

8 Under Annotation Categories, select Custom.

9 Under Visibility, scroll down and clear Levels.

10 Click OK.

11 In the Visibility/Graphics dialog box, click OK.

Notice the Level lines for both townhouses are no longer displayed.

NOTE Changes to Visibility/Graphics are per view only. The townhouse level lines still are displayed in the
remaining elevation views.

Apply halftone

12 On the Project Browser, under Floor Plans, double-click Level 1.

13 On the View menu, click Visibility/Graphics.
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14 In the Visibility/Graphics dialog box, click the Revit Links tab.

15 Under Visibility, expand c_Townhouse.rvt.

Notice the option to halftone individual instances of the townhouse model.

16 Select Halftone for the Townhouse project, and click OK.

Halftone displays objects with half their normal darkness. With linked files, you can apply halftone to the
entire linked project or individual instances of the model. Using the Custom option, you can also apply
halftone to individual categories. Notice both townhouses are displayed in halftone.

Detail levels of a linked file

17 On the View menu, click Visibility/Graphics.

18 In the Visibility/Graphics dialog box, click the Revit Links tab.

19 Click the Model Categories tab.

By default, the detail level for the linked townhouse project is set to By Host View. This means that the
detail level of the linked file is matched to the detail level of the current active project view. By selecting
custom under Model Categories, you can independently set the detail level for each model category for
each link on a per view basis. You can click the value for Detail Level, and then set the detail level to coarse,
medium, or fine.

In this case, no detail level changes are required.

20 Click Cancel.

Modify display settings of linked files

21 You can use display settings to control the view range, phase, and phase filter of a specific link.

On the Revit Links tab, under Visibility, select c_Townhouse.rvt.

Notice that the Custom button displays under Display Settings.

22 Under Display Settings, click Custom for the Townhouse link.

23 In the RVT Link Display Settings dialog box, select Floor Plan: Ground Floor for Linked view.
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By default, the view range of a linked project uses the current view of the host project to define its view
range. In most cases, this is preferable. However, there are situations, on a sloped site for instance, where
you need to specify a different view range so that all the building model plan views cut at the same height.
In this case, the townhouse view range now uses the same view range defined within the Floor Plan: Ground
Floor of the original linked file.

24 Select By linked view for View range.

Notice the Phase and Phase filter specfied are By host view. In this case, the host view specifies New
Construction for the Phase and Show All for the phase filter.

This means that the phase named New Construction for the linked building model is displayed, with Show
All as the phase filter applied to the link. With the Show All filter applied, all new, existing, demolished,
and temporary components in that particular phase (New Construction) are displayed. All other components
are grayed out.

25 Click OK.

26 In the Visibility/Graphics dialog box, click OK.

27 On the File menu, click Save.

NOTE If you intend to complete the next exercise of this tutorial, you need this project file open and in this
view.

In this exercise, you modified the visibility settings of the townhouse link by turning off the visibility of the level lines
and applying halftone in a plan view. You also changed the view range of the townhouse so it would cut through the
building model at the same height as the other linked building model.

In the next exercise, you manage the linked files.

Managing Linked Building Models

In this exercise, you manage the links within the host project by unloading and reloading the linked projects. After
you link an Autodesk Revit Structure 4 project into another project, a connection to the original linked project continues
to exist. If the host file is closed and one of the linked files is modified, those modifications are reloaded into the host
project when it is reopened.

NOTE This exercise requires the completion of the previous exercises in this tutorial and the resulting project files. If you have
not completed the previous exercise, do so before continuing.

Unload and reload links

1 On the File menu, click Manage Links.

2 In the Manage Links dialog box, click the Revit tab.

Notice the Loaded, Locations Not Saved, and Saved Path fields are read only. They supply information
regarding the links.

NOTE The Locations Not Saved field is only relevant for links with shared coordinates. In a shared coordinate
environment, any changes made to the locations of a linked file are saved within the linked file rather than the
host project. As links are moved to new locations in the host project, you can use the Save Locations command
to save the new locations to the linked project. You learn more about this in the next lesson, Sharing Coordinates
Between Building Models.

3 Under Path Type, notice that you have a choice between Relative and Absolute.

The default path type is Relative. In general, you should use a relative path rather than an absolute. If you
use a relative path and move the project and linked file together to a new directory, the link is maintained.
If you use an absolute path and move the project and linked file to a new location, the link is broken
because the host project continues to look for the link in the absolute path specified. The most common
scenario for using Absolute is when the linked file is on a network where multiple users need access to it.
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4 Under Linked File, select c_Condo_Complex.rvt.

The buttons at the bottom of the dialog box are now active.

5 Click Unload.

The Loaded option for that linked file is now clear.

6 Click OK.

Notice that the condo complex link is no longer displayed in the host project.

7 On the File menu, click Manage Links.

8 In the Manage Links dialog box, click the Revit tab.

9 Under Linked File, select c_Condo_Complex.rvt.

10 Click Reload.

11 Click OK.

Notice the condo complex building model has been reloaded into its previous location.

TIP In the Manage Links dialog box, you can also remove a link completely or reload the link from a different
location.

Linking building models with Worksharing enabled

In some cases, you may need to link projects that have Worksharing enabled. In these cases, you should
consider the following:

■ Selective open of worksets: When linking a Worksharing-enabled building model, you can specify
which worksets to open after the link is made. In the Add Link dialog box, under Open Worksets, select
Specify. This enhances performance by reducing the quantity of components that must be opened
and drawn.
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■ Changing the linked worksets: While working in a host file with Worksharing-enabled linked
files, you may decide that you need to see additional worksets of one of those linked files. To do this,
go to the Manage Links dialog box and use the Reload From command. You can then specify the
additional worksets you need opened.

■ Linking a building model into multiple host projects: Although the same Worksharing-enabled
building model can be linked within multiple host projects, the specific worksets opened in each host
project must be identical. The user who creates the first link determines the status for all other linked
files.

■ Host files with Worksharing enabled: When the host file has Worksharing activated, you must
keep in mind which workset the link is placed in. Links consist of two parts: the link symbol and the
link instance. When you initially place the link, both the link symbol and the link instance are placed
in the active workset. However, link instances can be reassigned to different worksets. In general, you
should try to keep all instances of a link on the same workset.

TIP When opening a Worksharing-enabled host file, it is possible to specify which links are loaded when the
host file opens. A link is only loaded if the workset that the link instance is assigned to opens. If you choose not
to open that workset, the link is not loaded.

12 On the File menu, click Save As.

13 In the Save As dialog box, navigate to the Model Linking folder you created in the first exercise, name the
file Site_Project, and save it as an RVT file.

NOTE If you intend to complete the next lesson, Sharing Coordinates Between Building Models, it is important
that this file exist in the same directory as the condo complex and townhouse projects.

In this exercise, you managed the linked files by unloading and reloading the townhouse project. In the next lesson,
you learn how to share the coordinates between the host and linked projects.

If you intend to complete the next lesson now, leave the project file open in its current view.

Sharing Coordinates Between Building Models
In this lesson, you learn how to share coordinates between project files so that you can correctly locate building models
with respect to each other. When used in conjunction with model linking, you can keep track of the multiple locations
in which a linked building model may reside.

When you share coordinates between projects, you are deciding which coordinate system will be used by the two files.
In essence, you are establishing a shared origin point.

NOTE This lesson requires the completion of the lesson “Linking Building Models” on page 425, and the resulting project
files. If you have not completed the previous lesson, do so before continuing.
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Acquiring and Publishing Coordinates

In this exercise, you publish the coordinates from a host project file to two different buildings that are linked to that
project. The host file consists primarily of site components.

When you link an Autodesk Revit Structure 4 project into another project (the host project), you can choose to use the
coordinates of either the host project or the linked project. In most cases where the host project consists primarily of
site components and the linked projects contain the building models, the host project coordinates are used. This ensures
all the linked building models define their position with respect to the site data.

When you are working in the host project, you can publish the coordinates of the linked files. This sends the coordinate
information to the linked project so that its internal coordinate system matches the host project.

You can also acquire coordinates when working in the host project. In this case, the host file acquires the coordinates
of a specified linked file. You may want to do this in a case when the link refers to a DWG that has an established
coordinate system that you want the host project to adopt.

NOTE This exercise requires the completion of the previous lesson, “Linking Building Models” on page 425, and the resulting
project files. If you have not completed the lesson, do so before continuing. If you have closed the project, open it before
continuing.

Dataset

■ On the File menu, click Open.

■ Navigate to the Model Linking folder you created in the first exercise of this tutorial.

■ Select Site_Project.rvt and click Open.

Publish coordinates

1 Verify that the floor plan Level 1 is the active view.
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2 On the Tools menu, click Shared Coordinates ➤ Publish Coordinates.

As indicated in the Status Bar, you must now select a linked project to publish coordinates to.

3 In the drawing area, click the Condo Complex. It is the building model in the upper center of the host
project.

4 In the Manage Place and Locations dialog box, select Location 1, and click OK.

On the Status Bar, notice you are still in Publish Coordinates mode and Revit Structure is waiting for you
to select another link.

5 On the Design Bar, click Modify to end the Publish Coordinates process.

NOTE If you intend to complete the next exercise of this lesson, you need this project file open and in this view.

You have published the coordinates of the host project to the linked project. Both projects now share the same coordinate
system.

Relocating a Project with Shared Coordinates

When an Autodesk Revit Structure 4 model is linked into a host project, it is placed at a specific location. Until coordinates
are shared between the link and the host, this location is not saved outside of the host model. However, if coordinates
are published from the host to the linked file, then the location becomes saved in the linked file. This location is defined
as being a specified location with respect to the origin of the Host.

Linked files using shared coordinates must have at least one defined location, but can have multiple additional locations.
An example of a linked file with many locations is a prototype model of a house that is placed on 3 different lots. These
three locations can be named Lot A, Lot B, and Lot C. Each of these lots is simply a different position for the same
house design. Each of the locations can then be saved within the linked file for reference. This makes it possible to use
the same building file to represent identical buildings on a site.
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In this exercise, you specify and save the two townhouse locations, even though both models originate from one linked
file. You also relocate the shared origin of the project.

NOTE This exercise requires the completion of the previous exercise within this lesson and the resulting project files. If you
have not completed the exercise, do so before continuing.

Specify a townhouse location

1 In the drawing area of the floor plan Level 1, move the cursor over the left townhouse and, when the edges
highlight, click to select it.

2 On the Options Bar, click  .

3 In the Element Properties dialog box, under Instance Parameters, notice the Shared Location value is Not
Shared.

4 Under Value, click Not Shared for Shared Location.

Because this is the first time you are setting up the shared coordinates between the host and the linked
models, a dialog box is displayed telling you to reconcile the coordinates. This means that you need to
choose which coordinate system will be shared by both files. This is a one-time operation.

5 In the Share Coordinates dialog box:

■ Select Publish the shared coordinate system.

■ Under Record selected instance as being positioned at location, click Change.

6 In the Manage Place and Locations dialog box, click Rename.

7 In the Rename dialog box, enter Lot A for New, and click OK.

8 In the Manage Place and Locations dialog box, click OK.

9 In the Select Location dialog box, click Reconcile.

10 In the Element Properties dialog box, notice the Shared Location value is now Lot A, and click OK.

Constrain a link to a specific location

11 Select the townhouse building model on the right side of the host project.

After a link instance is assigned a shared location, changing the position of that instance can affect the
definition of the location that is saved with the linked file. When constraining a link to a location, you
have only two choices:

■ Move the instance to an existing location that is not already in use.

■ Record the current position as a location.

12 On the Options Bar, click  .
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13 In the Element Properties dialog box, under Instance Parameters, click Not Shared for Shared Location.

In the Choose Location dialog box, notice that you do not have an option to acquire or publish coordinates.
This is because the coordinates for this linked file have already been shared. It is only necessary to reconcile
coordinates once.

14 In the Choose Location dialog box, select Move instance to.

Notice the OK button is not active. This is because you cannot choose a location where an instance link
already exists. You created the Lot A location in previous steps, and the left townhouse resides at that
location.

15 In the Choose Location dialog box, select the second option, Record current position as.

Notice the OK button is still not active. Because Lot A is currently in use, you cannot redefine its location.

16 Click Change.

17 In the Manage Place and Locations dialog box, click Duplicate, enter Lot B for Name, and click OK.

18 In the Manage Place and Locations dialog box, make sure Lot B is selected, and click OK.

19 In the Select Location dialog box, click OK.

20 In the Element Properties dialog box, click OK.

You now have two different locations for the townhouse building model: Lot A and Lot B.

Save locations

21 On the File menu, click Manage Links.

22 In the Manage Links dialog box, click the RVT tab, and then select the townhouse project.

23 Click Save Locations.

24 In the Save Modified Linked Model dialog box, select Save, and click OK.

When you create a location, it is not automatically saved within the linked file. To explicitly save a location,
you must go to the Manage Links dialog box and save the locations there.

NOTE If you attempt to close a host file without saving location changes made to linked files, you are prompted
to save the locations to the linked files.

25 In the Manage Links dialog box, notice the Locations Not Saved checkbox for the townhouse project is no
longer checked.

26 Click OK.

27 Select the townhouse on the right in Lot B and drag it a short distance in any direction. When you release
the mouse button, a warning is displayed.

You are informed that you have attempted to move a linked file that has been saved to a specific location.
You are given the opportunity to save the new location, ignore the warning, or cancel the action.

28 Click Cancel to return the townhouse to Lot B.

You can relocate an entire project with respect to all the linked files that are shared with it. When you
relocate a project, the active location position is moved, although it may appear that the linked files are
moving. By relocating a project, you essentially move the origin of the shared coordinates.

Relocate a project

29 On the View menu, click Zoom ➤ Zoom to Fit.

30 On the Tools menu, click Project Position/Orientation ➤ Relocate this Project.

This is a two-click process. The first click specifies the move start point. The second click specifies the move
endpoint.

31 Click just north of the site topography and just below the North elevation symbol.
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32 Move the cursor horizontally to the left approximately 40' and click to relocate the shared origin.

Notice the site topography and the linked building models no longer line up, and the linked projects are
offset the distance that you moved the origin.

33 On the Edit menu, click Undo to return the origin to its original position.

34 On the File menu, click Save.

35 In the Save Modified Linked Model dialog box, select Save, and click OK.

NOTE If you intend to complete the next exercise of this lesson, you need this project file open and in this view.

In this exercise, you created and saved the locations of each townhouse. You have also learned how to relocate the
host project with respect to the linked projects.

Scheduling Components of Linked Files

In this exercise, you schedule components of the host file and of all linked files.
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NOTE This exercise requires the completion of the previous exercise within this lesson and the resulting project files. If you
have not completed the exercise, do so before continuing.

Create a door schedule

1 Verify that the floor plan Level 1 is the active view.

2 On the View tab of the Design Bar, click Schedule/Quantities.

3 In the New Schedule dialog box, under Category, select Doors, and click OK.

Select the fields to display in the door schedule

4 In the Schedule Properties dialog box, click the Fields tab.

5 Under Available fields, select Count, and click Add.

6 Add the remaining fields in the following order:

■ Family and Type

■ Comments

■ Cost
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7 Select Include elements in linked files, and click OK.

In order to see a concise listing of all the doors in the campus project, you can sort the schedule data and
display a single table entry per door type.

Sort schedule data

8 In the Project Browser, expand Schedules/Quantities, right-click Door Schedule, and click Properties.

9 In the Element Properties dialog box, under Other, click Edit for Sorting/Grouping.

10 In the Schedule Properties box, select Family and Type for Sort by.

11 Select Grand totals, clear Itemize every instance, and then click OK twice.

Because you did not itemize every instance of each door type, the schedule lists the total count for each
door type, and a grand total for the number of doors in the project buildings.

12 On the File menu, click Save.

13 On the File menu, click Close.

NOTE In the following exercise, you work in one of the linked projects. You cannot work on a host file and one
of its linked files simultaneously in the same session of Revit Structure.

In this exercise, you created a schedule of doors in the host file and all linked files of a project. You also sorted the
schedule data to produce a consolidated listing of the components.

Working with a Linked Building Model

After a file has been linked into a host and its coordinates are shared, the linked file contains information about its
location with respect to the host. When opening the linked file, you can select which of the defined locations is the
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active location that you would like to work on. Also, if other models were linked into the same host, you could link
them in and have them retain their correct position.

In this exercise, you work on the townhouse building model and modify its location.

NOTE This exercise requires the completion of the previous exercises within this lesson and the resulting project files. If you
have not completed the exercises, do so before continuing.

Dataset

■ On the File menu, click Open.

■ Navigate to the Model Linking folder you created in the first exercise of this tutorial.

■ Select c_Townhouse and click Open.

Link a project

1 In the Project Browser, under Floor Plans, double-click 1st Floor.

This project is currently linked to the Site_Project.rvt file. It is located in Lot A and Lot B within that project
file. In addition, the condo complex is linked within the Site_Project.rvt file.

2 On the File menu, click Import/Link ➤ RVT.

3 In the Add Link dialog box:

■ Navigate to the Model Linking folder you created in the first exercise of this tutorial.

■ Select c_Condo_Complex.

■ Under Positioning, select By shared coordinates.

■ Click Open.

Because this building model only has one named location, it is placed automatically within the host project.

4 Zoom out to see the condo complex building model.

The condo complex is positioned relative to the active location of the townhouse building model. The
current active location is Lot A.

Change the active location

5 On the Settings menu, click Manage Place and Locations.

Notice that Lot A is the current active location.

6 Select Lot B, and click Make Current.

7 Click OK.
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Notice that the condo complex link has repositioned itself as though the townhouse was on Lot B.

NOTE If you intend to complete the next exercise of this lesson, you need this project file open and in this view.

In this exercise, you worked within a project that is linked within another project. You loaded a linked file into the
townhouse project and then changed the active location to see how the project reacts to the changes.

In the final exercise of this tutorial, you manage the shared locations.

Managing Shared Locations

The Manage Place and Locations command allows you to quickly create new location names or rename existing ones.
These new locations can be assigned later within a host file. In this exercise, you create a new location, orient a view
to true north, and use the Report Shared Coordinates tool.

NOTE This exercise requires the completion of the previous exercises within this lesson and the resulting project files. If you
have not completed the exercises, do so before continuing.

Manage locations

1 On the Settings menu, click Manage Place and Locations.

2 In the Manage Place and Locations dialog box, click Duplicate.

3 In the Name dialog box, enter Lot C, and click OK.

4 In the Manage Place and Locations dialog box, click OK.

Lot C now exists as a location although it has not been specified as an instance. In the host file, you can
select Lot C if necessary.

Orient a view to true north

5 On the View menu, click View Properties.

6 In the Element Properties dialog box, under Graphics, select True North for Orientation, and click OK.

7 Zoom to Fit.

Notice that the orientation of the model resembles the site project.
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Report shared coordinates

8 On the Tools menu, click Shared Coordinates ➤ Report Shared Coordinates.

This command allows you to determine the location of elements and points in the model with respect to
the shared coordinate origin.

9 Click any component or in any location on the drawing area.

On the Options Bar, notice the coordinates display in regards to the direction and distance to the origin.

10 On the File menu, click Close. You can save the file if you wish.

In this exercise, you created a new location using the Manage Place and Locations tool. You rotated a view to true north
and used the Report Shared Coordinates tool to locate components in regards to the origin.

You have completed this tutorial.
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Using Phasing
In this lesson, you renovate a building to convert it to a shopping mall. You create and manage three project phases,
assigning building elements to the appropriate phase:

■ Existing: Includes the original brick-clad building with structural walls and non load-bearing internal partitions.

■ Phase 1 (south): Includes new steelwork and footings for the existing building, as well as a covered walkway,
the galleria. Also includes demolition of all internal walls for the existing building.

■ Phase 2 (north): Includes new steelwork, footings, a floor slab, and a non load-bearing brick panel wall for a
new building to be constructed north of the galleria.

Existing phase

Phase 1 (south)
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Phase 2 (north)

After you add phases to the project, you create structural schedules for a specific phase of the project. You create a new
sheet on which you place the schedules and two views of the building model.

The finished sheet

Phasing Your Model

In this exercise, you begin with all the building elements drawn as new construction. The default structural project
template has two phases: Existing and New Construction. You create new phases for the project timeline, use phase
filters to control what displays in each phase, and modify graphic overrides to highlight demolition work. After you
assign building elements to phases, you create new phase-specific views.

Dataset

■ On the File menu, click Open.

■ In the left pane of the Open dialog box, click the Training Files icon.

■ Open the c_STR_Project_Phasing.rvt file located in the Common folder.
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Verify the current phase is New Construction

1 In the Project Browser, expand Views (all), expand Floor Plans, and double-click Floor.

When you create a new structural project, two phases exist by default: Existing and New Construction. As
you add new elements to the building model, they are assigned to the New Construction phase by default.
This phase assignment is controlled by a Phase setting within the view properties. For example, if a view
is assigned to a Phase 1 setting, then new building elements are assigned to Phase 1. Every building element
has a Phase Created and a Phase Demolished value so you can assign a creation and a demolition phase to
new work.

TIP Available phases and view phase settings can be changed in a project template so they are available for each
new project. They can also be added or edited in an existing project at any time.

2 On the View menu, click View Properties.

3 In the Element Properties dialog box, under Phasing, notice that Show All is selected for Phase Filter and
New Construction is selected for Phase.

Any new elements that you add to this view are assigned the New Construction phase value. The Show All
filter means that all building model elements (new, existing, demo, or temporary) are visible in this phase.
A phase view can show work in the current phase and work from previous phases in the project timeline.
By default, the current phase linework is displayed as black, while previous phase linework is displayed as
gray. Demolition work is represented by a black dashed line.

4 Click Cancel.

5 Select any of the exterior walls.

6 On the Options Bar, click  .

In the Element Properties dialog box, notice that the Phase Created value is New Construction, and the
Phase Demolished value is None. These values let you assign creation and demolition phases in a timeline.

You can also use the Demolition tool  to select building elements for demolition.

7 Click Cancel.

8 On the Basics tab of the Design Bar, click Modify to clear the command.

Add and edit phases

9 On the Settings menu, click Phases.

10 In the Phasing dialog box, on the Project Phases tab, click the New Construction field.
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11 Enter Phase 1 (south).

All building objects that were assigned to New Construction are now assigned to Phase 1 (south) because
you changed the phase name.

12 Under Insert, click After, and enter Phase 2 (north) under Name.

The phases are on a timeline with later phases lower on the list, so Phase 1 and Phase 2 occur after the
Existing phase.

13 Click in the Description fields for each phase, and enter the following text:

■ Existing: Existing building

■ Phase 1 (south): Existing building with new steelwork and demolished walls

■ Phase 2 (north): New building with steelwork and exterior panel wall

14 Click OK.

There are now three phases in your project: Existing, Phase 1 (south), and Phase 2 (north). All of the building
elements in the project are currently assigned to Phase 1 (south).

Assign selected building elements to the Existing phase

15 In the Project Browser, expand 3D Views, and double-click 3D.

16 On the View menu, click View Properties.

17 In the Element Properties dialog box, scroll down the list of Instance Parameters until you see the Phasing
heading.

The Phase value is Phase 1 (south) and the Phase filter is Show All, which means that work assigned to
Phase 1 (south), existing earlier phases, demo, or temporary work (created and demolished in same phase),
is visible in this view.

18 Select Show New for Phase Filter, and click OK.

Now you are seeing only work that is new to Phase 1 (south) of the project. You do not see a change in
the graphics because all the building elements are new to Phase 1 (south). With the phase Filter set to Show
New, as you change selected building elements to the existing phase, you will see a visual confirmation of
the change as the building elements disappear from the view.

19 Click  and click Spin to adjust your view as shown.

20 In the drawing area, right-click one of the rectangular footings, and click Select All Instances.

21 On the View Control Bar, click Hide/Isolate, and click Hide Object.
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The footings are hidden and cannot be selected.

22 On the View menu, click Orient ➤ Top.

23 Use a crossing window to select the existing building, as shown.

24 On the Options Bar, click  .

25 In the Filter dialog box, clear Structural Columns and Structural Framing, and click OK.

This filters out the steelwork, and previously you hid the rectangular footings to make sure they couldn’t
be selected. The continuous footing foundations, walls, and openings, which are the building elements
that comprise the existing building, are selected and are displayed in red.

26 On the Options Bar, click  .

27 In the Element Properties dialog box, under Phasing, select Existing for Phase Created, and click OK.

28 On the View menu, click Orient ➤ Southeast.
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29 On the View Control Bar, click Hide/Isolate, and click Reset Temporary Hide/Isolate.

The building elements that you assigned to the Existing phase are no longer displayed in the drawing.
Only elements new to Phase 1 (south) are displayed.

30 On the View menu, click View Properties.

31 In the Element Properties dialog box, under Phasing, select Show All for Phase Filter.

32 Click OK.

Now you can see the Existing phase displayed with gray linework in the view. All of the structural elements
are still assigned to Phase 1 (south).

33 On the View menu, click Orient ➤ Top.

34 Use a selection window to select the structural elements, the walls, the slab, and the footings north of the
galleria.

35 On the Options Bar, click  .

36 In the Element Properties dialog box, under Phasing, select Phase 2 (north) for Phase Created, and click
OK.

37 On the View menu, click Orient ➤ Northeast.
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Because the active phase is Phase 1 (south) and the phase filter is set to Show All, the building is displayed
as shown. You see work for Phase 1 (south) and the existing phases. You do not see future phases such as
Phase 2 (north).

You have reassigned building elements to three phases. Because this is a renovation project, it requires
separate plan views for the Existing, Phase 1 (south) with demolition, and Phase 2 (north) project phases.
After you create the views, you modify phase and phase filter properties to determine which phase is shown
and which building elements (existing, new, demo, and temporary) are shown in the same timeline. In a
phase such as Phase 1, it might be desirable to show previous phases or demolition.

Create phase-specific plan views

38 In the Project Browser, under Floor Plans, right-click Floor, and click Rename.

39 In the Rename View dialog box, enter Existing, and click OK.

You are asked if you want to rename corresponding level and views. This refers to the ceiling plan and the
level line visible in any of the elevation views. Because this is a phase-specific view, you do not want to
rename the corresponding views and level.

40 Click No.

41 In the Project Browser, under Floor Plans, right-click Existing, and click Duplicate.

42 In the Project Browser, under Floor Plans, right-click Copy of Existing, and click Rename.

43 In the Rename View dialog box, enter Phase 1 (south), and click OK.

You now have a separate floor plan for the existing building model and for Phase 1, which will include
planned demolition.

44 Repeat the process to create a view named Phase 2 (north)

Manage the phases for a view

45 In the Project Browser, under Floor Plans, double-click Existing.

46 On the View menu, click View Properties.

47 In the Element Properties dialog box, under Phasing, select Existing for Phase, and click OK.

The line style of the walls and openings are displayed as black.

48 In the Project Browser, under Floor Plans, double click Phase 1 (south).

49 On the View menu, click View Properties.

50 In the View Properties dialog box, under Phasing, select Phase 1 (south) for the Phase value, and click OK.

The line style of the new work, in phase 1, shows as black. Phase 1 (south) occurs after existing construction,
Because of this time relationship, a graphic override is used to make “older” existing elements use the gray
line style. You can see the earlier existing phase because the phase filter is set to Show All.
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Demolish the interior walls

51 On the Tools toolbar, click  .

The cursor is displayed as a hammer.

52 Referring to the walls displayed as dashed lines in the following illustration, select the interior walls one
at a time.

As you click each wall, it is displayed as a dashed line.

Notice that the openings display as demolished even though you did not specifically demolish them. That
is because the openings are wall-hosted elements. When you demolish the host, you demolish all elements
hosted by it. Because the Phase value is Phase 1 (south) the walls are demolished in this phase.

53 In the Project Browser, under Floor Plans, double-click Phase 2 (north).

54 On the View menu, click View Properties.

55 In the Element Properties dialog box, under Phasing, select Phase 2 (north) for the Phase value, and select
Show All for Phase Filter.

56 Click OK.

The line style of the current phase is displayed as black and previous phases are displayed as gray.

Create a custom phase filter

57 On the Settings menu, click Phases.

58 In the Phasing dialog box, click the Phase Filters tab.

The default phase filters are displayed. In this case, however, you need a filter that takes all of the phases
into account with a particular graphic override to highlight the demolished walls in red.

59 In the Phasing dialog box, click New.

A new phase filter is displayed at the bottom of the Filter Name list.

60 Under Filter Name, click Filter 1, and enter Demo Red.

61 For the Filter Name, Demo Red, under Demolished, select Overridden.

This new filter uses graphic overrides to set the display of all building model elements, New, Existing,
Demolished, and Temporary.

View graphic overrides

62 Click the Graphic Overrides tab.

Graphic overrides define the appearance of building model elements according to their phase status:
existing, demo, new or temporary.

63 Click on the Demolished line color and change it from black to red.
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64 Click OK twice.

Apply the Demo Red graphic overrides to a view

65 Under Floor Plans, double-click Phase 1 (south).

Because you changed the override, and the Show All phase filter includes the override for demolition, the
demolished walls are displayed as red.

66 To assign as specific phase filter to a view, on the View menu, click View Properties.

67 In the Element Properties dialog box, under Phasing, select Demo Red for Phase Filter to show work that
is demolished with the red line color from the graphic overrides.

The override settings for Show All and Demo Red are the same.

68 Click OK.

Create phase-specific 3D views

69 In the Project Browser, under 3D Views, right-click 3D and click Duplicate. Do this three times so you have
three copies.

70 Right-click on each of the copies, and click Rename.

71 Name the views Existing, Phase 1 (south), Phase 2 (north).

Manage the phases for the 3D views

72 In the Project Browser, under 3D Views, double-click Existing.

73 On the View menu, click View Properties.

74 In the Element Properties dialog box, under Phasing, select Existing for the Phase value, and click OK.

The line style of the walls and openings are displayed as black.

75 On the View menu, click View Properties.

76 Under Graphics, select Shading for Model Graphics Style.

77 Select Coordination for Discipline, which will show both architectural and structural building elements.

78 Click OK.

79 In the Project Browser, under 3D Views, double-click Phase 1 (south).

80 On the View menu, click View Properties.

81 In the Element Properties dialog box, under Phasing, select Phase 1 (south) for Phase, and Show All for
Phase Filter.

The line style of the new work, in phase 1, shows as black. Phase 1 (south) occurs after existing construction.
Because of this time relationship, a graphic override is used to make “older” existing elements use the gray
line style. You can see the earlier existing phase because the phase filter is set to Show All.

82 In the Element Properties dialog box, under Graphics, select Shading for Model Graphics Style.

83 Select Coordination for Discipline.

This displays both architectural and structural building elements.

460 | Chapter 20   Project Phasing



84 Click OK.

85 Repeat steps 81 - 84 for the Phase 2 (north) view, assigning Phase 2 (north) as the Phase.

86 If you wish to save this file, you can do so at this time or you can continue in this file for the next exercise.

In this exercise, you created a building model with three distinct phases and created three plan views with appropriate
phase filters to display each phase. You created a custom phase filter with graphic overrides to show demolition work
in red. You finished the exercise by creating 3d phased views suitable for a client presentation.

Creating Phase-Specific Structural Schedules

In this exercise, you create column, framing, and footing schedules for a single phase of a project. You create a new
sheet on which you place the schedules, as well as two views of the building model.

The finished sheet

Dataset

■ On the File menu, click Open.

■ In the left pane of the Open dialog box, click the Training Files icon.

■ Open the i_STR_Project_Phasing_Schedules file located in the Imperial folder.
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Create a structural column schedule for Phase 1 (south)

1 On the View tab of the Design bar, click Schedule/Quantities.

2 In the New Schedule dialog box, do the following:

■ Under Category, select Structural Columns.

■ Enter Columns - Phase 1 for Name.

■ Select Phase 1 (south) for Phase.

■ Click OK.

3 In the Schedule Properties dialog box, click the Fields tab.

4 Under Available Fields, select the following fields, and click Add to add them to the schedule in order:

■ Count

■ Family and Type

■ Length

TIP Press and hold CTRL to make multiple selections under Available Fields.

5 Click the Sorting/Grouping tab, and do the following:

■ Select Family and Type for Sort By.

■ Select Length for Then by.

■ Select Grand totals.

■ Clear Itemize every instance.

■ Click OK.

You can drag a column grid line to adjust the width of a column.

Create a structural framing schedule for Phase 1 (south)

6 On the Design Bar, click Schedule/Quantities.

7 In the New Schedule dialog box, do the following:

■ Under Category, select Structural Framing.

■ Enter Framing - Phase 1 for Name.

■ Select Phase 1 (south) for Phase.

■ Click OK.

8 In the Schedule Properties dialog box, click the Fields tab.

9 Under Available Fields, select the following fields, and click Add to add them to the schedule in order:

■ Count

■ Family and Type

10 Click the Sorting/Grouping tab, and do the following:

■ Select Family and Type for Sort By.
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■ Select Grand totals.

■ Clear Itemize every instance.

■ Click OK.

Create a footings schedule for Phase 1 (south)

11 On the Design bar, click Schedule/Quantities

12 In the New Schedule dialog box, do the following:

■ Under Category, select Structural Foundations.

■ Enter Footings - Phase 1 for Name.

■ Select Phase 1 (south) for Phase.

■ Click OK.

13 In the Schedule Properties dialog box, click the Fields tab.

14 Under Available Fields, select the following fields, and click Add to add them to the schedule in order:

■ Count

■ Family and Type

15 Click the Sorting/Grouping tab, and do the following:

■ Select Family and Type for Sort By.

■ Select Grand totals.

■ Clear Itemize every instance.

■ Click OK.

Create a sheet and then add views and schedules

16 In the Project Browser, right-click Sheets (all), and click New Sheet.

17 In the Select a Titleblock dialog box, click OK.

18 In the Project Browser, expand Sheets (all), right-click the new sheet, and click Rename.

19 In the Sheet Title dialog box, enter Phase 1 - Structural for Name.

Next, you drag the schedules and project views onto the sheet. Use the following illustration as a guide as
you complete the steps to create your sheet.
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20 In the Project Browser, expand Floor Plans, and drag Phase 1 (south) onto the sheet, and click to place it.

21 Under 3D views, drag Phase 1 (south) onto the sheet, and click to place it.

22 Expand Schedules, drag each of the three schedules onto the sheet, and click to place them.

23 On the sheet, select each schedule one at a time, and move the column controls to adjust column width.

In this exercise, you created three custom structural schedules for a specific project phase and placed them on a sheet.
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Viewing

In this tutorial, you learn to create and customize views of building information models. You learn how

to access and create building model views and how to change the visibility of building components and

annotation within views.

More specifically, you learn how to change the visibility of detail components, how to control fill pattern

colors, and how to use plan regions within floor plans and reflected ceiling plans.

21
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Viewing a Building Model
In this lesson, you learn to create and customize user-defined views of a building information model.

You create elevations, sections, and three-dimensional (3D) views, and learn how to control the visibility of building
components and annotation within them.

Exploring the Building Model

In this exercise, you learn how to access different views of the building model, including elevation and three-dimensional
views. You also learn how to control the visibility of different building components and annotation within building
model views.

Dataset

■ On the File menu, click Open.

■ In the left pane of the Open dialog box, scroll down and click the Training Files icon.

■ Open i_Viewing_Exercise.rvt located in the Imperial folder.

Open an elevation view of the building model

1 On the left side of the drawing area, locate the Project Browser.

The Project Browser is displayed by default between the Design Bar and the drawing area. The current file
name is displayed in the Project Browser title bar.

TIP If the Project Browser does not display, on the Standard toolbar, click  .

2 In the Project Browser, expand Views (all), expand Elevations, and double-click East.

A new view displays a wireframe view of the east elevation view of the building model. Both hidden lines
and window tags display in the east elevation view.
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Display the elevation view with hidden lines

3 On the View Control Bar, click Model Graphics Style, and click Hidden Line.

This hides the lines that show through to the exterior of the elevation view. The east elevation view displays
with hidden lines. This change is applied only to the active view, the east elevation. Notice that window
tags continue to display in the view.

Turn off the display of window tags in the elevation view

4 On the View menu, click Visibility/Graphics.

5 In the Visibility/Graphic Overrides for Elevation: East dialog box, click the Annotation Categories tab.

6 Under Visibility, scroll down and clear Window Tags.

7 Click OK.

The window tags are no longer displayed in this view. This change is applied only in this elevation view.

Create a 3D view of the building model

8 On the View toolbar, click  .

The 3D view is displayed in a new viewing window. The default name of the view is {3D}.
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9 On the View toolbar, click  to reorient the view.

10 Move the cursor to the drawing window and notice that it now displays as a hand  .

This means you are in pan mode.

11 Pan the view by clicking and dragging the cursor in the drawing area.

The view follows the movement of the cursor.

NOTE If you have a pointing device with a middle wheel, you can enable pan mode by pressing and holding
the middle wheel button down. Move the mouse to pan the view.

12 Press and hold CTRL, and notice that the cursor displays as a magnifying glass  .

This indicates that you are in zoom mode.

NOTE If you have a pointing device with a middle wheel, you can enable zoom mode by rolling the middle
wheel.

13 View the Dynamic View dialog box in the lower left corner of the screen.

You can pan, zoom, and spin the building model by clicking the appropriate button in this dialog box.

Save the current 3D view

14 In the Project Browser, expand Views (all), and expand 3D Views.

15 In the Project Browser under 3D Views, right-click {3D}, and click Rename.

16 In the Rename View dialog box, enter My 3D View, and click OK.

Notice that the view name is updated in the title bar of the viewing window and in the Project Browser.

17 In the upper right corner of the viewing window, click X to close the view.

18 In the Project Browser, under 3D Views, double-click My 3D View.

Notice that the view continues to display with hidden lines and no window tags.
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19 Proceed to the next exercise, “Creating a Perspective View with a Camera” on page 469.

Creating a Perspective View with a Camera

In this exercise, you create a perspective view of the building model with a camera. Cameras define the eye point, eye
height, and distance from the target.

Dataset
Continue to use the dataset you used in the previous exercise, i_Viewing_Exercise.rvt .

Create the perspective view

1 In the Project Browser, expand Views (all), expand Floor Plans, and double-click Level 1.

2 On the View tab of the Design Bar, click Camera.

TIP If the View tab of the Design Bar is not active, right-click in the Design Bar, and click View.

3 Add the camera to the view by specifying two points: one for the camera position and the other for the
camera target point:

■ Specify the first point in the top right corner of the drawing, outside of the dimension lines.

■ Specify the second point in one of the rooms in the building, as shown in the following illustration.

After you specify the second point (the view target), the new view named 3D View 1 is displayed by default
in a perspective view.
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4 To resize the view to see the entire floor model, select the blue control grips on the sides of the crop region
and move them out.

5 On the View menu, click Zoom ➤ Zoom All To Fit.

Change the camera projection settings

6 On the View menu, click Dynamically Modify View.

7 In the Dynamic View dialog box, click the Walkthrough tab located at the bottom of the dialog box.

You can use the walkthrough controls in this dialog box to move the camera position and change the view.

8 To move the camera eye position higher or lower:

■ Click Dolly and move the cursor into the perspective view.

■ Press and hold the left mouse button.

■ Move the cursor up, down, and sideways to see how the view changes.

9 To move the camera forward and backward in the view:

■ Click Forward/Back and move the cursor into the perspective view.

■ Press and hold the left mouse button.

■ Move the cursor up and down in the view to move the cursor forward and backward.

470 | Chapter 21   Viewing



10 To rotate the camera around the target:

■ Click Turn and move the cursor into the perspective view.

■ Press and hold the left mouse button.

■ Move the cursor side to side in the view to rotate the view. You may need to reposition the view with
the other controls.

11 Adjust the view as shown in the following illustration.

Change the camera position, height, and target

12 On the Window menu, click Tile.

Four views of the model display in the drawing area.

13 On the View menu, click Zoom ➤ Zoom All To Fit.
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14 In the Project Browser under Floor Plans, double-click Level 1.

The border of the window that contains the Level 1 view highlights.

15 In the Project Browser under 3D Views, click 3D View 1.

16 Right-click 3D View 1, and click Show Camera.

The camera and the view direction of the camera are displayed in the appropriate views.
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17 In My 3D View, select the camera target point (the magenta grip), and move it to another location.

3D View 1 should update immediately after you move the target point of the camera.

18 Change the target and eye elevation of the camera by modifying its properties:

■ Select the camera in My 3D View, right-click, and click Properties.

■ In the Element Properties dialog box, under Camera, enter 50' 0" for Eye Elevation and 5' 6" for Target
Elevation.

■ Click OK.

3D View 1 immediately updates to show the change.

TIP The updated view depends on the location of the camera before you change the elevation values.

Use a section box to clip the model

19 On the View toolbar, click  to create a new 3D view.
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20 On the View Control Bar, click Model Graphics Style, and click Shading.

21 Rotate the view as shown in the following illustration.

22 On the View menu, click View Properties.

23 In the Element Properties dialog box, under Extents, select Section Box, and click OK.

A section box is displayed around the model.

24 Click the section box.
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The section box highlights and grips are displayed on its faces. A rotation tool is also displayed.

25 Select and move the lower right grip on the section box closer to the model, as shown in the following
illustration.

26 Click and hold the rotation tool, and rotate the section box around the model.

27 Proceed to the next exercise, “Creating a Section View” on page 475.

Creating a Section View

In this exercise, you create a section view by sketching a section line in a plan view.

Dataset
Continue to use the dataset you used in the previous exercise, i_Viewing_Exercise.rvt .

Sketch a section line in a plan view

1 In the Project Browser, expand Floor Plans, double-click Level 1, and maximize this view.
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2 On the Basics tab of the Design Bar, click Section.

3 Click to the left of the left wall of the building model, and then click to the right of the lower right wall
to sketch the horizontal section line shown in the following illustration.

Notice a dashed green box with blue grips is displayed on the section line. The box represents the extents
of the section view as well as the viewing direction of the section.

4 On the Design Bar, click Modify.

View the section

5 To view the section, double-click the section head, or in the Project Browser, expand Sections, and
double-click Section 1.
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NOTE Fill pattern is dependent on the zoom ratio. You may need to zoom closer to the walls in order to see the
fill pattern.

6 Select the section view, right-click, and click Find Referring Views.

7 In the Go To View dialog box, select Floor Plan: Level 1, and click Open View.

8 Select the section line, and drag the section depth grip below the middle horizontal wall as shown in the
following illustration.

9 On the Design Bar, click Modify.

10 Double-click the section head to display the section view.

Notice the change in section depth.

Change the view direction of the section

11 In the Project Browser under Floor Plans, double-click Level 1.

12 Select the section line.

Control arrows are displayed near the section tag.

13 Click the control arrows to flip the section view, and select and move the section depth grip under the
lower wall.

14 On the Design Bar, click Modify.

15 Double-click the section head to display the section view.

Notice the change in the view direction.
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16 Proceed to the next exercise, “Creating Elevation Views” on page 478.

Creating Elevation Views

In this exercise, you learn to create an elevation view in a project by adding an elevation symbol to a plan view.

Dataset
Continue to use the dataset you used in the previous exercise, i_Viewing_Exercise.rvt .

Add an elevation symbol

1 In the Project Browser, under Floor Plans, double-click Level 1.

2 On the View tab of the Design Bar, click Elevation.

An elevation symbol displays at the end of the cursor.

3 Without clicking in the drawing area, move the cursor around the building model.

Notice that the elevation symbol arrow points to the nearest wall as you move through the building model.
You may need to adjust your zoom settings to see the elevation symbol.

4 To create an elevation view of the building lobby, place the cursor inside the building facing the lobby
entrance, and click.

Make sure the elevation symbol is pointing towards the lobby doors.

5 On the Design Bar, click Modify.

View the elevation

6 To view the new elevation, zoom in, and double-click the elevation symbol arrow.

The elevation is named Elevation 1 - a by default.
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7 In the Project Browser under Floor Plans, double-click Level 1.

8 Select the center of the elevation symbol. Do not select the arrow.

The elevation symbol is displayed with four check boxes, indicating the possible elevation views that you
can create. The check mark in the right box indicates the current elevation view, Elevation 1 - a.

9 Select the box shown in the following illustration to add a new elevation view, Elevation 1 - b.

10 In the Project Browser, under Elevations, double-click Elevation 1 - b.

11 If you want to save your changes, on the File menu, click Save As, and save the exercise file with a unique
name.

12 Close the exercise file without saving your changes.

Creating a View Plan Region
In this lesson, you work with a split-level building model that requires a different view range than the rest of the view.
Plan regions are closed sketches that you can create in floor plan and reflected ceiling plan (RCP) views only. If you
create more than one plan region in a file, the plan regions cannot overlap each other, although they may have
coincident edges. Plan regions do not work with linked Revit Structure files, and you cannot control their visibility,
line type, line color, or pattern.
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If you are not familiar with view ranges in Revit Structure, refer to the online Help for more information.

Creating a Plan Region in a Floor Plan

In this exercise, you create a plan region in the Level 1 floor plan of the following building model.

Because the stepped portion of the walls in the building model is above the cut plane height in the Level 1 floor plan
view, it does not display in the Level 1 floor plan.

By creating a plan region in the view with a different cut plane height, you can display the stepped portion of the walls
in the Level 1 floor plan.

Dataset

■ On the File menu, click Open.

■ In the left pane of the Open dialog box, scroll down and click the Training Files icon.

■ Open i_Plan_Region.rvt located in the Imperial folder.

View the Level 1 floor plan

1 In the Project Browser, expand Views (all), expand Floor Plans, and double-click Level 1.

The cut plane height of the view range for this view is 4' 0" . The stepped portion of the project walls and
windows are not displayed because the cut plane does not intersect any of the model geometry above this
height.

In the following illustration, the south elevation is also displayed, so you can view the height of the walls
and windows.
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Add a plan region to view the stepped portion of the model

2 On the View tab of the Design Bar, click Plan Region.

TIP If the View tab of the Design Bar is not active, right-click in the Design Bar, and click View.

Plan regions have a single property, view range, that is similar to the view range for plan views. You use
the view range property to control cut plane, the top and bottom clip planes, and the view depth plane.

3 In the Level 1 view, sketch the plan region using the blue tick marks for guidance:

■ On the Design Bar, click Lines.

■ On the Options Bar, click  .

■ Specify a point at the intersection of the two dashed blue lines on the top left.

■ Specify a point at the intersection of the two dashed blue lines on the bottom right.

■ On the Design Bar, click Finish Sketch.

■ Press ESC to end the command.

The plan region is no longer visible, as it is displayed with hidden lines in this view.

4 Move the cursor across the area where you sketched the plan region.
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As the cursor moves across it, the plan region is displayed as a red dashed rectangle.

5 Select the red dashed line, right-click, and click Properties.

6 In the Element Properties dialog box, under Extents, click Edit for View Range.

7 In the View Range dialog box, select Parent View’s Level (Level 1) for Cut Plane, and enter 9' 0" for the cut
plane Offset.

By selecting Parent View’s Level, you specify that the level used to define each plane (cut plane, top and
bottom clip planes, and view depth) in the view range is the same as the level used to define the
corresponding plane in the parent view. This means that the plan region view is going to cut all geometry
at 9 feet above Level 1.

8 Because the top clip plane value cannot be set lower than the cut plane, enter 12' 6" for the Top Offset.

9 Click Apply, and then click OK twice.

10 On the Design Bar, click Modify.

The Level 1 floor plan should display as shown in the following illustration.

The following illustration demonstrates how the level 1 floor plan view is being viewed with the plan
region.
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11 If you want to save your changes, on the File menu, click Save As, and save the exercise file with a unique
name.

12 Close the exercise file without saving your changes.
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Rendering Views and Creating
Walkthroughs

In this tutorial, you learn to use the AccuRender® Radiosity and Raytrace features in Autodesk Revit

Structure 4 to create rendered interior and exterior views of your building information model; to place

and render decals to create signs, billboards, and posters; and to create walkthroughs of your building

information model. AccuRender is the rendering engine incorporated into Revit Structure that is used

to produce rendered views.

22
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Rendering an Exterior View
In this lesson, you learn how to create an exterior perspective view of a building model and render it with the AccuRender
Raytrace feature.

You learn to create and apply materials to a building model, add realistic three-dimensional trees to the building site,
and create the perspective view that you want to render. After you create the perspective view, you select a scene that
defines the model environment, and then raytrace the view to produce the final rendered exterior view.

Applying Materials and Textures to the Building Model

In this exercise, you learn how to view and modify the material that is applied to a building component in a building
model. You also learn to create a new material and apply it to a building component. You work with a building model
that already has material applied to it.

In this exercise, you:

■ change the texture of the brick material applied to the exterior walls of the building.

■ change the material of the front terrace of the building from the default material to asphalt.

■ define a new polished aluminum material and apply it to the curtain wall mullions on the front curtain wall.

When you complete these changes, you raytrace a region of the building that includes the exterior wall, the floor, and
the curtain wall to view and verify the material and texture changes.
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Dataset

■ On the File menu, click Open.

■ In the left pane of the Open dialog box, click the Training Files icon.

■ Open i_Cohouse.rvt located in the Imperial folder.

View the finish material of the exterior walls

1 Verify that the 3D view of the townhouse building model is displayed.

2 On the Architectural tab of the Design Bar, click Wall.

TIP If the tab that you need does not display in the Design Bar, right-click in the Design Bar, and click the tab
in the context menu.

3 On the Options Bar, click  .

4 In the Element Properties dialog box, select System Family: Basic Wall for Family, verify that Co-house -
Exterior - Brick on CMU is displayed for Type, and click Edit/New.

5 In the Type Properties dialog box, under Construction, click Edit for Structure. Verify that the material
defined for the exterior finish layer (Layer 1) of the building model is Masonry - Brick.

6 Click Cancel three times to return to the 3D view of the building model without making any changes to
the exterior finish at this time.

Change the brick texture of the exterior wall finish material

7 On the Settings menu, click Materials.

8 In the Materials dialog box, under Name, select Masonry - Brick.
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9 Under AccuRender, click  next to Texture to display the Material Library.

A preview of the brick texture that is currently assigned to the walls is displayed in the right pane of the
Material Library.

10 In the left pane of the Material Library dialog box, under _accurender, expand Masonry and click Brick.

11 Under Name, select Carib,_12",Running .

12 Click OK twice.

You can view the new brick texture when you raytrace a region of the building in a later step.

Change the material of the terrace from the default material to asphalt

13 On the Design Bar, click Modify and select the terrace in front of the building.

14 On the Options Bar, verify that Floor : Floor 3 displays in the Type Selector, and click  .

15 In the Element Properties dialog box, click Edit/New.

16 In the Type Properties dialog box, under Construction, click Edit for Structure.

17 In the Edit Assembly dialog box, for Layer 2, click in the Material field that contains Default Floor, and

click  .

18 In the Materials dialog box, under Name, select Site - Asphalt.

19 Click OK four times.

Define a new polished aluminum material and apply it to the curtain wall mullions

20 On the Settings menu, click Materials.

21 In the Materials dialog box, under Name, click Duplicate.

22 In the New Material dialog box, enter Aluminum, Polished and click OK.

23 Under AccuRender, click  next to Texture to display the Material Library.

24 In the Material Library, under _accurender, expand Metals, and click Aluminum.

25 Under Name, select Polished,Plain.

26 Click OK twice.

27 On the Design Bar, click Modify.

28 Select one of the curtain wall mullions on the exterior face of the building.
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TIP If you do not select the curtain wall mullion on the first selection, press TAB to cycle your selection through
different building model components. When Curtain Wall Mullions: Rectangular Mullion displays in the Status
Bar at the bottom of the screen, select the curtain wall mullion again.

29 On the Options Bar, click  .

30 In the Element Properties dialog box, click Edit/New.

31 In the Type Properties dialog box, under Materials and Finishes, click in the Material field, and then click

 .

32 In the Materials dialog box, under Name, select Aluminum, Polished.

33 Click OK three times.

This completes the changes in materials and textures that you make for the building model.

Raytrace a region of the building to view the material changes that you made

34 On the Rendering tab of the Design Bar, click Region Raytrace.

35 Move the cursor over the building model, and draw the rectangular region shown in the following
illustration.

Make sure the region includes the exterior walls, floor, and curtain wall mullions to which you made
material changes.

36 In the Scene Selection dialog box, verify that New is selected, select Exterior under Type, and click OK.

37 If you are prompted to turn off the lights in the scene, click No.
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The portion of the building that you selected is raytraced and the materials that you changed and applied
to the exterior walls, floor, and curtain wall mullions are rendered (this takes a few moments), producing
a photorealistic effect.

38 On the Design Bar, click Display Model to end the Region Raytrace command and redisplay the building
model in hidden line wireframe.

39 Proceed to the next exercise, “Adding Trees to the Site” on page 490.

Adding Trees to the Site

In this exercise, you place two different types of trees on the building site.

In a later exercise, when you render an exterior view of the model, the leaves of the trees display as indicated by the
season and location specified in the render scene settings.

Dataset
Continue to use the dataset you used in the previous exercise, i_Cohouse.rvt .

Add red maple trees to the site

1 In the Project Browser, expand Views (all), expand Floor Plans, and double-click 1st Flr. Cnst.
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2 Zoom out so you can easily view the area surrounding the building model.

3 On the Site tab of the Design Bar, click Site Component.

TIP If the Site tab is not displayed, right-click in the Design Bar, and click Site.

4 In the Type Selector, select Tree - Deciduous : Acer Rubrum 30' .

Available tree types are listed in the Type Selector by their Latin names. The tree that you selected in this
step is a red maple.

5 Move the cursor to a location on the building site, and click to place a tree.

Continue to place trees until you have added several red maples to the building site as shown in the
following illustration.

Create a new type of tree, and add it to the site

6 On the Design Bar, click Modify, and click Site Component.

7 In the Type Selector, select any of the deciduous trees, and click  .
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8 In the Element Properties dialog box, click Edit/New.

9 In the Type Properties dialog box, click Duplicate.

10 In the Name dialog box, enter Black Oak, and click OK.

11 In the Type Properties dialog box, under Other, click in the Value field for Plant Name, and then click 
to display the Plant Library.

12 In the Plant Library, under accurender, expand Trees and Shrubs, and click Deciduous.

13 Under Name, select Oak, Black, and click OK.

14 In the Type Properties dialog box, under Identity Data, select Black Oak for Type Comments.

15 Under Other, enter 22' 0" for Plant Height, and click OK twice.

The black oak is shorter than the red maple trees that you added to the site.

16 Move the cursor to the building site, and place two black oak trees, as shown in the following illustration.

17 Press ESC to end tree placement.

18 Proceed to the next exercise, “Creating a Perspective View” on page 492.

Creating a Perspective View

In this exercise, you define the exterior perspective view of the building model that you want to render.

Dataset
Continue to use the dataset you used in the previous exercise, i_Cohouse.rvt .
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Place a camera in the first floor view

1 With the 1st Flr. Cnst. view open, on the View tab of the Design Bar, click Camera.

2 Add the camera to the view by specifying points for the camera position and the camera target point:

■ Specify the first point on the site facing the building to position the camera.

■ Specify the second point in front of the building facade to define the target point of the camera.

The new perspective view is displayed.

3 Select and move the crop boundary grips until the perspective view displays as in the following illustration.
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Modify the camera position and back clipping plane in the perspective view

4 In the Project Browser under Views (all), expand 3D Views, right-click 3D View 1 (the default perspective
view name), and click Show Camera.

5 In the Project Browser under Floor Plans, double-click 1st Flr. Cnst.

The camera position is displayed in the 1st Flr. Cnst. view. The red triangle represents the FOV (field of
vision) angle and the back clipping plane of the view.

6 Select and move the FOV boundary grip to adjust the field of vision and back clipping plane as shown in
the following illustration.
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7 In the Project Browser, under 3D Views, right-click 3D View 1, and click Rename.

8 In the Rename View dialog box, enter Exterior, and click OK.

9 Proceed to the next exercise, “Selecting a Scene and Rendering the View” on page 495.

Selecting a Scene and Rendering the View

In this exercise, you select a scene and specify time, date, place, lighting, and environment settings that you use to
render the view.

Dataset
Continue to use the dataset you used in the previous exercise, i_Cohouse.rvt .

Display the perspective view

1 In the Project Browser under 3D Views, double-click Exterior.
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You must define a scene because this is the first time settings are being applied to this view.

Select the render scene settings

2 On the Rendering tab of the Design Bar, click Settings.

3 In the Scene Selection dialog box, click OK to accept the existing scene (Scene 1).

4 In the Render Scene Settings dialog box, under Scene Settings, clear Use Sun and Shadow Settings from
view, and click Sun.

5 In the Sun and Sky Settings dialog box, click the Solar Angles tab.

6 Select By Date, Time, and Place from the Specify Solar Angles list.

Notice that the name of the tab changes to Date and Time.

7 Under Date, enter 10 (October) for Month and 5 for Day.

8 Under Time, verify that Daylight Savings Time is selected, and drag the slider to set the time to 2:30 PM.

TIP Use the left and right arrow keys to adjust the minutes precisely.
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9 Click the Place tab.

10 Click in the Cities list, and enter bo.

11 Scroll down, and select Boston, MA, USA.

12 Click the Settings Tab.

13 Enter .20 for Cloudiness.

This setting produces a level of cloudiness in the sky that ranges from 0 (no clouds) to 1.00 (many clouds.)

14 Click OK.

15 In the Render Scene Settings dialog box, under Scene Settings, click Environment.

16 In the Environment dialog box, under Background Color, verify that Automatic Sky is selected.

17 Under Advanced, select Ground Plane.

The Ground Plane tab displays.

18 Click Material.

19 In the Material Library, under _accurender, click Site.

20 In the Name list, select Grass, Rye, Dark.

21 Click OK twice.

22 In the Render Scene Settings dialog box, under Scene Settings, select Autumn for Plant Season.

23 Under Raytrace Settings, select Good for Quality, and click OK.

Render the perspective view

24 On the Design Bar, click Image Size.

25 Enter 150 for Resolution, and click OK.

26 On the Design Bar, click Raytrace.

27 On the Options Bar, click  .

28 If you are prompted to turn off the lights in the scene, click No.

The rendered exterior perspective view is displayed.

Save the rendered view

29 On the Design Bar, click Capture Rendering.

The rendered view is saved in the project and can be accessed from the Project Browser.
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30 On the Design Bar, click Display Model to end rendering and redisplay the wireframe perspective view of
the building model.

Redisplay the rendered view

31 In the Project Browser under Views (all), expand Renderings, and double-click Exterior to display the
rendered view of the townhouse that you saved.

32 If you want to save this exercise, on the File menu, click Save As, and save the exercise file with a unique
name.

33 Proceed to the next lesson, “Rendering an Interior View” on page 498.

Rendering an Interior View
In this lesson, you render an interior view of the building model that you worked with in the previous lesson.

To create the rendered scene, you add ArchVision realpeople (RPC people) to the floor plan of the second floor, define
the view and render scene settings, and finally, use both Radiosity and Raytracing to render the view.

Adding RPC People

In this exercise, you add two RPC people to the interior view that you render in a later exercise. RPC people are
represented by a circle in plan view and resemble real people only when rendered in a 3D view.

Dataset
Continue to use the dataset you used in the previous exercise, i_Cohouse.rvt .

Open second floor plan to display the interior scene that you will render

1 In the Project Browser under Views (all), expand Floor Plans, and double-click 2nd Flr. Cnst.
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2 Zoom in on the left side of the living room as shown.

3 On the Rendering tab of the Design Bar, click Component.

4 In the Type Selector, select RPC Female : Cathy .

5 On the Options Bar, select Rotate after placement.

6 Click to place Cathy to the right of the sofa and below the table, and then move the cursor to rotate her
so she is facing up and to the right (northeast).

7 Repeat steps 4 - 6 to select and place RPC Male : Alex to the right of Cathy and facing up and to the left
(northwest).
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8 Proceed to the next exercise, “Creating the Interior Perspective View” on page 500.

Creating the Interior Perspective View

In this exercise, you create the interior perspective view that you will render in the final exercise in this lesson.

Dataset
Continue to use the dataset you used in the previous exercise, i_Cohouse.rvt .

Add a camera

1 On the View tab of the Design Bar, click Camera.

2 Add the camera to the view by specifying points for the camera position and target point:

■ Specify the first point on the floor plan facing the table and RPC people to place the camera.
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■ Specify the target point of the camera in front of the corner of the table.

The interior perspective is displayed, but you must adjust the field of vision and far clipping plane to display
more of the view.

3 In the Project Browser under Floor Plans, double-click 2nd Flr. Cnst.
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4 Select and move the FOV boundary grip to adjust field of vision and back clipping plane as shown in the
following illustration.

5 In the Project Browser under 3D Views, double-click 3D View 1 to redisplay the interior perspective view.

Resize the perspective view

6 On the Options Bar, click the dimensions for Size.

7 In the Crop Region Size dialog box, under Size, enter 9" for Width, enter 7" for Height, and click OK.

8 In the Project Browser under 3D Views, right-click 3D View 1, and click Rename.

9 In the Rename View dialog box, enter Interior, and click OK.

502 | Chapter 22   Rendering Views and Creating Walkthroughs



Add a section box to limit the extents of the rendered view

10 On the View toolbar, click  to display the 3D view of the building model.

11 On the View menu, click Shading to view the effects of the section box when you add it.

12 On the View menu, click View Properties.

13 In the Element Properties dialog box, under Extents, select Section Box, and click OK.

A section box is displayed around the building model.

14 On the Design Bar, click Modify, and select the section box.

Grips are displayed on the section box.

15 Select and move the section box grips until only the room that you added RPC people to and that you
want to render is visible.
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This process allows you to limit the geometry that will be rendered when you create a rendering of your
interior view. By limiting the geometry, you reduce the rendering time.

16 Proceed to the next exercise, “Creating a New Render Scene” on page 504.

Creating a New Render Scene

In this exercise, you create a render scene to specify the time, date, place, and environment settings used to render the
view.

Dataset
Continue to use the dataset you used in the previous exercise, i_Cohouse.rvt .

Display the interior perspective view

1 In the Project Browser, under 3D Views, double-click Interior to display the interior perspective view.

Select the render scene settings

2 On the Rendering tab of the Design Bar, click Settings.

3 In the Scene Selection dialog box, select New, and enter Interior Scene for Name.

4 Under Type, select Interior, and click OK.

5 In the Render Scene Settings dialog box, under Scene Settings, clear Use Sun and Shadow Settings from
view, and click Sun.

6 In the Sun and Sky Settings dialog box, click the Solar Angles tab.

7 Select By Date, Time, and Place from the Specify Solar Angles list.

Notice that the name of the tab changes to Date and Time.

8 Under Date, enter 6 (June) for Month and 6 for Day.

9 Under Time, verify that Daylight Savings Time is selected, and drag the slider to set the time to 8:30 PM.

TIP Use the left and right arrow keys to precisely adjust the minutes.

10 Click the Place tab.

11 Click in the Cities list, and enter bo.

12 Scroll down, and select Boston, MA, USA.

13 Click the Settings tab.

14 Click Save, specify a file location and name for the scene settings, and click Save.

15 In the Sun and Sky Settings dialog box, click OK.

16 In the Render Scene Settings dialog box, under Scene Settings, click Environment.
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17 In the Environment dialog box, on the Main tab, under Background Color, verify that Automatic Sky is
selected.

18 Under Advanced, select Ground Plane.

The Ground Plane tab displays.

19 Click Material.

20 In the Material Library, under accurender, click Site.

21 In the Name list, select Grass, Rye, Dark.

22 Click OK twice.

23 In the Render Scene Settings dialog box, under Use View’s Section Box, select {3D}.

24 Under Scene Settings, select Summer for Plant Season, and click OK.

25 Proceed to the next exercise, “Defining Daylights and Rendering the View” on page 505.

Defining Daylights and Rendering the View

In this exercise, you define daylights for the glazed panels of the curtain wall and render the view. When you define
daylights for the curtain wall panels, you allow sunlight to pass through the panels when you render the view. You
can select families with transparent materials, such as windows and doors, as daylight sources.

Dataset
Continue to use the dataset you used in the previous exercise, i_Cohouse.rvt .

Define daylights for the glazed panels of the curtain wall

1 In the Project Browser, under 3D Views, double-click {3D}.

The 3D view of the building model with the section box is displayed.

2 On the Rendering tab of the Design Bar, click Daylights.

3 Select the curtain wall on the second floor (Walls: Curtain Wall; Curtain Wall 1).

Render the perspective view

4 In the Project Browser under 3D Views, double-click Interior.
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5 On the Design Bar, click Radiate.

6 In the Radiosity Information dialog box, click OK.

The radiosity process, which can take several minutes, begins. Light bounce is calculated for each individual
light. When radiate completes, the following rendered view is displayed. The RPC people do not display
in the view until you raytrace them in the next steps.

7 On the Design Bar, click Raytrace.

8 On the Options Bar, select Medium (150 dpi) for Resolution, and click  .

The raytraced perspective view is displayed and now includes the RPC people.

9 If you want to save your changes, on the File menu, click Save As, and save the exercise file with a unique
name.

10 Close the exercise file.

By completing the two rendering lessons included in this tutorial, you rendered an exterior and an interior view. You
learned to use both the Radiosity and Raytracing features included in the AccuRender render engine.
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Creating and Recording Walkthroughs
In this lesson, you learn how to create and record animated walkthroughs of your building model in Autodesk Revit
Structure 4. A walkthrough is created in a 3D perspective view by default, but you can also create it in a 3D orthographic
view.

Creating and Editing a Walkthrough

The first step in creating a walkthrough is to define the walkthrough path, which is the path that a camera will follow
through your building model. Usually you define the walkthrough path in a plan view, but you can also define it in a
3D, elevation, or section view. The walkthrough path is a spline, and you create it by specifying points that create the
spline. Each point becomes a key frame in the walkthrough. Additional frames that comprise the walkthrough are
created between the key frames. You can edit the walkthrough path by selecting and moving the key frames. In a plan
view, you can also specify the height of the camera along the walkthrough path.

Recording a Walkthrough

After you create a walkthrough, you can record the walkthrough by exporting it to an AVI file that you can play with
any available video player independent of your Revit Structure software. When you export your walkthrough to an
AVI, you can select one of the following display options for the building model in your walkthrough:

■ Wireframe

■ Hidden Line (wireframe view with hidden lines)

■ Shaded or Shaded with Edges

■ AccuRender (Raytrace)

IMPORTANT If you record your walkthrough AVI with the AccuRender display option, you must select or define a scene.

Creating a Walkthrough

In this exercise, you learn how to create and edit a walkthrough of the first floor of a townhouse.

You create a walkthrough that begins in the breakfast room of the townhouse, proceeds through the dining room, and
ends in the far corner of the living room.

Dataset

■ On the File menu, click Open.

■ In the left pane of the Open dialog box, click the Training Files icon.

■ Open c_Townhouse.rvt located in the Common folder.
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NOTE Some Imperial values are used by default in this exercise. If you prefer to use Metric values, click Settings ➤ Project
Units, and change unit formats as desired.

Create a walkthrough of the first floor of the building model

1 In the Project Browser, expand Views (all), expand Floor Plans, and double-click 1st Floor.

The floor plan of the first floor of the townhouse is displayed.

2 On the View tab of the Design Bar, click Walkthrough.

TIP If the tab that you need does not display in the Design Bar, right-click in the Design Bar, and click the tab
in the context menu.

3 On the Options Bar, verify that Perspective is selected to create the walkthrough in a 3D perspective view.

4 Move the cursor under the text label in the Breakfast room, and click to specify the start point, or the first
key frame, of the walkthrough.

5 Specify four additional points to define key frame positions on the walkthrough path as shown in the
following illustration.

6 After you specify the final point of the walkthrough path in the Living room, on the Options Bar, click

 .

Edit and play the walkthrough

7 In the Project Browser under Views (all), expand Walkthroughs, and double-click Walkthrough 1.
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The last frame of the walkthrough is displayed, surrounded by a crop boundary with grips as shown in the
following illustration. Your frame may look a bit different from the frame in the illustration because the
walkthrough path is not precisely the same.

8 Verify that the crop boundary of the walkthrough frame is selected and is displayed as red with blue grips.
If it is not, select the crop boundary.

Two options are displayed on the Options Bar: Edit Walkthrough and Size.

9 On the Options Bar, click the dimensions for Size to change the size of the walkthrough frame crop region.

10 In the Crop Region Size dialog box, enter 16" for Width and 9" for Height.

11 Under Change, verify Field of view is selected, and click OK.

12 On the View menu, click Zoom ➤ Zoom Out (2x), and select the crop boundary.

13 On the Options Bar, click Edit Walkthrough.

The walkthrough controls are displayed on the Options Bar. The frame that is displayed is frame 300 of
300 frames in the walkthrough.

14 Click  .
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15 In the Walkthrough Frames dialog box, enter 60 to reduce the total number of frames in the walkthrough
from 300 to 60, and click OK.

16 On the Options Bar, enter 1 for Frame, and press ENTER to set the walkthrough to play from the beginning
(the key frame).

17 Click  .

The walkthrough plays. The current display is wireframe with hidden lines.

NOTE To stop playing the walkthrough at any time, press ESC.

18 When the walkthrough stops playing, proceed to the next exercise, “Changing the Walkthrough Path and
Camera Position” on page 510.

Changing the Walkthrough Path and Camera Position

In this exercise, you learn how to edit the walkthrough path and change the camera position in the walkthrough that
you created in the previous exercise.

Dataset
Continue to use the dataset you used in the previous exercise, c_Townhouse.rvt.

Change the properties of the camera

1 In the Project Browser under Floor Plans, double-click 1st Floor.

The walkthrough path is displayed in the floor plan of the first floor.

2 On the Options Bar, click  .

3 In the Element Properties dialog box, under Extents, clear Far Clip Active, and click OK.

Clearing this option disables the far clipping plane of the camera.

Edit the walkthrough path

4 On the Options Bar, click Edit Walkthrough.
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The camera is displayed at the first key frame position on the walkthrough path in the breakfast room.

5 Select the target point of the camera (the magenta grip), and adjust it to view the kitchen as shown in the
following illustration.

Your walkthrough path may vary from the one in the illustration so do not be concerned if the camera
displays at a slightly different location.

6 On the Options Bar, select Path for Controls.

Blue grips are displayed at each key frame. You can move any camera target or key frame position.
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7 Click the third key frame position, and drag it to the location shown in the following illustration.

Play the walkthrough to view the changes that you made

8 In the Project Browser, under Walkthroughs, double-click Walkthrough 1.

9 On the Options Bar, click Edit Walkthrough, and then click  to play the walkthrough.

10 Proceed to the next exercise, “Recording the Walkthrough” on page 512.

Recording the Walkthrough

In this exercise, you record the walkthrough that you created in the previous exercise by exporting it to an AVI. When
you export the walkthrough, you can select to display the walkthrough in wireframe, hidden line, shaded, shaded with
edges, or with AccuRender raytracing.

Dataset
Continue to use the dataset you used in the previous exercise, c_Townhouse.rvt.

1 On the File menu, click Export ➤ Walkthrough.

2 In the Save As dialog box, specify a path and a file name for the AVI.

3 Under Output Length, specify 10 for Frames per Second.

4 Under Format, select <Shading> for Display mode, and click Save.

5 In the Video Compression dialog box, select any codec (compression/decompression) that is available on
your system for Compressor, and click OK.

NOTE The available Compressor options are specific to your current computer system. If you are unsure of what
option to use, the Full Frames (Uncompressed) option is available to all users. It produces files that are larger
than compressed files, but that do not suffer loss due to compression quality.

The AVI is recorded.

6 Double-click the AVI file to play the walk-through from the location that you specified in step 3, without
opening Autodesk Revit Structure 4.
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7 Try creating other walkthroughs, specifying the number of frames, reducing the size of the image, perhaps
to 6” wide x 4” height, and with a frame rate of from 15-30 frames per second. If you had 150 frames and
a frame rate of 15 seconds, then you are moving from the breakfast area to the living room window in 10
seconds. Reducing the size of the output images and managing the frame rate lets you create realistic and
smooth movement.

8 If you want to save this exercise, on the File menu, click Save As, and save the exercise file with a unique
name.

9 Close the exercise file without saving your changes.
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Roofs

In this tutorial, you learn how to create different types of roofs in Autodesk Revit Structure 4. In addition,

you learn how to add fascia, gutters, and soffits to the roofs that you create.
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Creating Roofs
In this lesson, you learn to create several different types of roofs, including hip, gable, shed, and mansard roofs. You
create roofs from footprints and by extrusion: the two roof creation methods in Revit Structure.

Creating an Extruded Roof

In this exercise, you create an extruded roof over a breezeway between a house and a garage.

You create the roof by sketching the top roof profile and extruding it over the length of the breezeway. Before you can
sketch the roof profile, you need to select a work plane to use as a sketching guide. You do not need to create the work
plane; a work plane named Breezeway exists for the purpose of this exercise.

Dataset

■ On the File menu, click Open.

■ In the left pane of the Open dialog box, click the Training Files icon.

■ Open i_Roofs.rvt located in the Imperial folder.

1 In the Project Browser, expand Views (all), expand Floor Plans, and double-click Level 1.

2 On the Architectural tab of the Design Bar, click Roof ➤ Roof by Extrusion.

3 In the Work Plane dialog box, select Name, and then select Reference Plane : Breezeway.

4 Click OK.

5 In the Go To View dialog box, verify that Section: Section1 is selected, and then click Open View to select
a section view parallel to the work plane in which to sketch the roof.

6 In the Roof Reference Level and Offset dialog box, verify Level 3 is selected for Level, and click OK.
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The section view is automatically cropped around the area where you want to sketch the roof.

Before you can sketch the profile of the roof, you need to define four reference planes to help determine
key points on the profile sketch.

7 On the Sketch tab of the Design Bar, click Ref Plane.

8 Sketch the first reference plane 1'6'' to the left of the left exterior breezeway wall face.

TIP Instead of trying to place the reference plane in its exact location initially, you can place it in the general
location and then zoom in and use temporary dimensions. This helps ensure that the plane is measured from
the face of the wall rather than from the wall centerline.

9 Sketch a similar reference plane 1' 6" to the right of the right exterior breezeway wall face.

10 Sketch a vertical reference plane centered between the two vertical walls.
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11 Sketch a horizontal reference plane 1'6" below Level 2.

Next, sketch the roof profile.

12 On the Sketch tab of the Design Bar, click Lines.

13 On the Options Bar, select Chain.

14 Sketch two sloped lines to create the roof profile.

Begin the sketch at the intersection of the left vertical reference plane and the horizontal plane. Use
automatic snaps to link the chain to the reference plane intersections.

15 On the Sketch tab of the Design Bar, click Finish Sketch to complete the roof.
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The roof is automatically extruded from the Breezeway work plane in one direction.

16 On the View toolbar, click  to display the model.

Notice that the breezeway roof penetrates the house walls inappropriately.

Next, use the Join Roofs command to adjust the length of the roof and join the roof edges to the exterior
walls.

17 On the Tools toolbar, click  .

18 Select the edge of the roof, and then select the exterior wall face of the garage to join the roof to the garage
wall.

Use the Join Roof command again to join the opposite end of the breezeway roof to the exterior wall of
the house that joins the breezeway.

19 On the Tools toolbar, click  .

20 Select the breezeway roof edge, press TAB, and then select the exterior face of the wall.

The roof should resemble the following illustration.

Creating an Extruded Roof | 519



The breezeway walls still penetrate the roof, so you next attach the breezeway walls to the breezeway roof.

21 In the Project Browser, expand Views (all), expand Sections (Type 1), and double-click Section 1.

22 On the Modelling tab of the Design Bar, click Modify.

23 Select one of the breezeway walls, press CTRL, and select the second wall.

24 On the Options Bar, click Attach for Top/Base, and then verify that Attach Wall: Top is selected.

25 Select the roof to join the wall tops to the roof.

26 On the View toolbar, click  to view the completed breezeway roof in the model.

27 Proceed to the next exercise, “Creating a Roof with a Vertical Penetration from a Footprint” on page 520 .

Creating a Roof with a Vertical Penetration from a Footprint

In this exercise, you add a main gable roof to a house from a footprint. The roof requires an opening to accommodate
a chimney.

You begin by sketching the perimeter of the roof in plan view to create the roof footprint. After you define the roof
slope lines and complete the footprint, you sketch a closed rectangular opening around the chimney. When you
complete the roof, the opening that you sketched becomes a void in the roof.
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Dataset
Continue to use the dataset you used in the previous exercise, i_Roofs.rvt .

1 In the Project Browser, expand Views (all), expand Floor Plans, and double-click Level 3.

2 On the Architectural tab of the Design Bar, click Roof ➤ Roof by Footprint.

3 On the Options Bar, clear Defines slope, and enter 1' 0" for Overhang.

NOTE You add the slope defining lines in a later step.

4 On the Sketch tab of the Design Bar, click Pick Walls.

5 Place the cursor over one of the exterior walls, press TAB, and then verify that a dashed green line displays
to the exterior side of the walls.

6 Click to select all the walls.

Next, sketch the chimney opening.

7 On the Sketch tab of the Design Bar, click Lines.

8 On the Options Bar, click  .

9 Using automatic snaps, sketch a rectangle from the upper left corner of the exterior chimney face to the
lower right corner of the exterior chimney face.

10 On the View menu, click Zoom ➤ Zoom To Fit to view the entire floor plan.
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Next, add new slope lines to the roof.

11 On the Sketch tab of the Design Bar, click Modify.

12 Select the uppermost horizontal line.

13 On the Options Bar, select Defines Slope.

14 Select one of the shorter line segments shown in the following illustration.

15 On the Options bar, select Defines Slope.

16 On the Sketch tab of the Design Bar, click Finish Roof.

17 When you see the informational dialog box, click Yes to attach the walls to the roof.

18 On the View toolbar, click  to view the new roof in the model.

19 Proceed to the next exercise, “Creating a Hip Roof from a Footprint” on page 522.

Creating a Hip Roof from a Footprint

In this exercise, you create a hip roof over the rear of a house from a footprint.

Dataset
Continue to use the dataset you used in the previous exercise, i_Roofs.rvt .

1 In the Project Browser, expand Views (all), expand Floor Plans, and double-click Level 2.
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2 On the Architectural tab of the Design Bar, click Roof ➤ Roof by Footprint.

3 On the Options Bar, select Defines slope, and enter 2' 0" for Overhang.

4 On the Sketch tab of the Design Bar, click Pick Walls.

5 Select the exterior edges of the three walls that create the rear addition to the house. Verify that a dashed
green line displays on the exterior side of the wall from the edge of the roof as you select the walls.

Next, close the roof sketch. Roof sketches must create a closed loop before you can create the roof. The
sketched lines cannot overlap or intersect each other.

6 On the Sketch tab of the Design Bar, click Lines.

7 On the Options Bar, clear Defines Slope, and click  .

8 Select the exterior edge of the uppermost horizontal wall of the main building, using the following
illustration for guidance.

Next, trim the extra line segments that result from the intersection of the sketch lines. You must trim these
lines to create a valid sketch.

9 On the Tools toolbar, click  .

10 On the Options Bar, verify that the Trim/Extend to Corner option is selected.

11 To trim the first line segment, select the left vertical slope definition line, and then specify a point near
the midpoint of the line that you sketched along the wall of the main building.
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Make sure you select the segment on the side that you want to keep.

12 Repeat the trim procedure on the adjacent corner to create a closed loop without intersections.

Next, raise the roof 2' 0" above the current level.

13 On the Sketch tab of the Design Bar, click Roof Properties.

The Element Properties dialog box is displayed.

14 Under Constraints, enter 2' 0" for Base Offset From Level, and click OK.

15 On the Sketch tab of the Design Bar, click Finish Roof.

16 On the View toolbar, click  to display the model.

17 Click  to use the Dynamic View tool to view the back of the house.

Notice that the walls do not join to the roof. Use the Attach Top/Base command to join the walls to the
roof.

18 On the Design Bar, click Modify.

19 Select one of the walls under the hip roof, click Attach for Top/Base on the Options Bar, and then verify
that Attach Wall: Top is selected.

20 Select the roof to join the wall top to the roof.
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21 Click  to use the Dynamic View tool to view the remaining walls that support the hip roof.

22 Using the same method that you used previously, join the two remaining walls to the roof. Press and hold
CTRL to select and join the two remaining walls at the same time.

Notice that the new hip roof does not properly join to the back of the house. Next, use the Join Roof
command to fix the roof.

23 On the Tools toolbar, click  .

24 Select the edge of the hip roof, and then select the edge of the main roof to join the roofs.

The properly joined roof should resemble the following illustration.

25 Proceed to the next exercise, “Creating a Shed Roof from a Footprint” on page 525.

Creating a Shed Roof from a Footprint

In this exercise, you create a shed roof over the entrance to a house from a footprint.

Dataset
Continue to use the dataset you used in the previous exercise, i_Roofs.rvt .

1 In the Project Browser, expand Views (all), expand Floor Plans, and double-click Level 2.
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2 On the Architectural tab of the Design Bar, click Roof ➤ Roof by Footprint.

3 On the Sketch tab of the Design Bar, click Pick Walls.

4 On the Options Bar, clear Defines Slope, and enter 1' 0" for Overhang.

5 Place the cursor over one of the exterior walls that defines the entry way, press TAB, and then click to select
all three of the entry way walls.

Verify that a green dashed line displays around the exterior side of the walls before clicking to select the
walls.

6 On the Options Bar, enter 0' 0" for Overhang.

7 Select the exterior face of the main wall to close the sketch.

Next, trim the extra line segments that result from the intersection of the sketch lines. You must trim these
lines to create a valid sketch.

8 On the Tools toolbar, click  .

9 On the Options Bar, verify that the Trim/Extend to Corner option is selected.

10 To trim the first line segment, select the left vertical roof line, and then select a point near the midpoint
of the upper horizontal line you sketched earlier. Make sure you select the segment on the side that you
want to keep.

11 Repeat the trim procedure on the adjacent corner to create a closed loop without intersections.

Next, you add a slope-defining line.

12 On the Sketch tab of the Design Bar, click Modify, and select the lower horizontal line at the front of the
roof.

13 On the Options Bar, select Defines slope.
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Notice the rise value is displayed next to the slope marker.

14 Enter 6" for the rise value to change the roof slope, and press ENTER.

15 On the Sketch tab of the Design Bar, click Roof Properties.

16 Under Constraints, enter -2' 0" for Base Offset From Level, and click OK.

17 On the Sketch tab of the Design Bar, click Finish Roof to complete the roof.

18 Click Yes to attach the walls to the roof.

19 Click  on the View toolbar to display the model.

20 Click  to use the Dynamic View tool to rotate the model.

21 Proceed to the next exercise, “Adding Slope Arrows to a Shed Roof” on page 527.

Adding Slope Arrows to a Shed Roof

In this exercise, you add slope arrows to the shed roof.

Dataset
Continue to use the dataset you used in the previous exercise, i_Roofs.rvt .

1 In the Project Browser, expand Views (all), expand 3D Views, and double-click 3D.

2 Select the shed roof over the entrance of the house.

3 On the Options Bar, click  to activate the roof footprint sketch.

4 In the Project Browser, expand Views (all), expand Floor Plans, and double-click Level 2.

5 On the View menu, click Zoom ➤ Zoom in Region, and zoom in around the shed roof footprint.

Before you can add slope arrows, you need to split the slope defining line into three segments. To help
locate the position of each split, you need to add two reference planes.

6 On the Sketch tab of the Design Bar, click Ref Plane.

7 On the Options Bar, click  , and enter 2' 0" for Offset.
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8 Select the two vertical sketch lines. Verify that the reference planes are located inside the shed roof sketch.

9 On the Tools menu, click Split Walls and Lines.

10 Split the slope defining line where the reference planes intersect as shown in the following illustration.

Next, change the longest slope line segment (the middle segment) so that it no longer defines slope.

11 On the Design Bar, click Modify, and select the middle segment of the slope defining line.

12 On the Options Bar, clear Defines Slope.

Next, add two new slope arrows.

13 On the Sketch tab of the Design Bar, click Slope Arrow.

14 On the Options Bar, verify  is selected.

15 Sketch a slope arrow from the reference plane to the midpoint of the lower horizontal roof line:

■ Select the intersection of the left vertical reference plane and the roof line to specify the location of
the slope arrow tail.

■ Move the cursor along the roof line until the midpoint displays, and then select it to specify the location
of the slope arrow head.

16 Repeat steps 13 - 15 to add the second slope arrow.

Begin the tail at the right reference plane, and move the cursor to rotate the arrow. The head should snap
to the midpoint of the line as in the previous steps.

17 On the Sketch tab of the Design Bar, click Modify.

18 Press CTRL, select both slope arrows, and click  .

19 Under Constraints, select Slope for Specify.

20 Under Dimensions, enter 6" for Rise/12" , and then click OK.
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21 On the Sketch tab of the Design Bar, click Finish Roof to complete the roof.

22 Click  on the View toolbar to display the model.

NOTE If the front wall is separated from the roof, use the Attach Top/Base command to join the wall to the roof.

23 Proceed to the next exercise, “Creating a Mansard Roof” on page 529 .

Creating a Mansard Roof

In this exercise, you create a mansard roof by cutting off a hip roof at a specific level and adding another roof on top
of it.

Dataset

■ On the File menu, click Open.

■ In the left pane of the Open dialog box, click the Training Files icon.

■ Open i_Mansard_Roof.rvt located in the Imperial folder.

1 In the Project Browser, expand Views (all), expand Elevations, and double-click North.

Notice the model has four defined levels:

In the next steps, you constrain the current roof so it does not rise above Level 3.

2 On the Basics tab of the Design Bar, click Modify.

3 Select the roof and, on the Options Bar, click  .

4 In the Element Properties dialog box, under Constraints, select Level 3 for Cutoff Level.

5 Click OK to cut the top of the roof off at level 3.
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6 On the View toolbar, click  to display the model.

Next, create a new roof that starts at level 3 and completes the mansard roof.

7 In the Project Browser, expand Views (all), expand Floor Plans, and double-click Level 3.

8 On the Architectural tab of the Design Bar, click Roof ➤ Roof by Footprint.

9 On the Sketch tab of the Design Bar, click Lines.

10 On the Options Bar, click  , and then select Defines slope.

11 Select the four edges of the roof cutoff.

12 On the Sketch tab of the Design Bar, click Modify.

13 Select one of the roof cutoff lines, press TAB, and select the remaining three lines.

14 On the Options Bar, click  .

15 In the Element Properties dialog box, under Dimensions, enter 3" for Rise/12" , and click OK.

16 On the Sketch tab of the Design Bar, click Finish Roof.

17 On the View toolbar, click  to display the model with the complete mansard roof.

530 | Chapter 23   Roofs



18 If you want to save your changes, on the File menu, click Save As, and save the exercise file with a unique
name.

19 Close the exercise file without saving your changes.
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Grouping

Using the grouping functionality in Autodesk Revit Structure 4, you can create reusable entities that

represent layouts common to many building projects. By grouping objects, you not only simplify their

placement, you also simplify the modification process. For example, when you make changes to a single

instance of a model group, all instances in the building model are updated, and all new instances that

you place contain the modifications.

You can also nest groups within other groups. In this tutorial, you create a model group for a typical

hotel guest room, and then you create a group for a typical toilet room that is nested within the guest

room group. Modifications to the nested group are automatically included in the host group.

Saving a group to a library gives you the ability to share the group with other team members working

on the same project, or with those working on a different project. This functionality ensures consistency

within and across projects. It also gives all those with access to the library the ability to load any group

from the library into their project drawing. Because existing groups can be duplicated and then customized

for another purpose, creating a library of groups for your office can reduce the amount of work needed

to create, place, and modify repetitive units.
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Creating Groups
In this lesson, you learn how to use model groups to collect related elements to simplify placement of repetitive units.
Examples of the types of units for which groups are intended include hotel rooms, classrooms, and typical office layouts.

After you create a model group, you can place instances of the group in the building model using various methods.
You can also update all instances of a group in the building model by editing a single instance of the group and saving
the changes.

Creating a Group

In this exercise, you create a model group for a typical hotel room. You create the group by selecting drawing objects
and grouping them as a single entity.

Dataset

■ On the File menu, click Open.

■ In the left pane of the Open dialog box, click the Training Files icon.

■ Open the i_Grouping.rvt file located in the Imperial folder.

Specify a view

1 In the Project Browser, expand Views (all), expand Floor Plans, and double-click Level 2.

2 Enter ZR to zoom to a specific region.

3 Draw a rectangle around the populated room.

The view is zoomed in to the selected room. You zoom in so that you can select objects in the room
accurately.

Create a group from drawing objects

4 Press and hold CTRL, and select the bed, chair, desk, and two nightstands.

5 On the Edit toolbar, click  .

6 In the Project Browser, expand Groups, and expand Model.

7 Right-click Group 1, and click Rename.

8 Enter Typical guest room, and press ENTER.

The objects are now grouped and can be placed in the drawing as a single entity.

9 On the File menu, click Save As.

10 Navigate to your preferred directory, name the file Grouping-in progress.rvt, and click Save.

11 Proceed to the next exercise, “Placing a Group” on page 535.
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Placing a Group

In this exercise, you use drag and drop functionality to place a new instance of a group in the floor plan. You also
mirror an existing instance of a group, using an adjacent wall as the axis of reflection.

Dataset
Continue using the dataset saved at the end of the previous exercise, Grouping-in progress.rvt.

Modify the origin of a group

1 In the drawing area, select the group.

2 Drag the group origin to the wall intersection directly below the entry door, as shown.

Drag a group into position

3 In the Project Browser, select Typical guest room and drag it to the room below the original instance of
the group.

4 Snap the origin to the wall intersection below the entry door.

A second instance of the group is added to the drawing.

5 On the Options Bar, click Finish.

Mirror a group

6 In the drawing area, select the original instance of the group.

7 On the Edit toolbar, click  .

8 Select the wall abutted by the desk and tub of the original instance as the axis of reflection.
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You should now have three instances of the Typical guest room group in your model: two with the original
orientation and one mirrored, as shown.

9 On the File menu, click Save.

10 Proceed to the next exercise, “Modifying a Group” on page 536.

Modifying a Group

In this exercise, you make changes to a single instance of a group. When you finish the editing routine, all instances
of the same group in the drawing are updated.

Dataset
Continue using the dataset saved at the end of the previous exercise, Grouping-in progress.rvt.

1 In the drawing area, select the mirrored instance of the Typical guest room group.

2 On the Options Bar, click Edit Group.

The elements in this instance of the group remain displayed in their object style. All other elements in the
model are grayed out.

3 Press and hold CTRL, and select the desk and chair.

4 On the Edit toolbar, click  .
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5 Click near the left edge of the desk as the move start point.

6 Click the exterior wall as the move end point.

The edge of the desk is aligned with the exterior wall.

7 On the Design Bar, click Finish Group.

All instances of the Typical guest room are updated to reflect the change.

8 On the File menu, click Save.

9 Proceed to the next lesson, “Creating Nested Groups” on page 537.

Creating Nested Groups
In this lesson, you create a group that you add to a previously created group. The new group is considered nested within
the host group, and is contained in every new instance of the host group that you place in the building model.

When you make changes to a nested group, the host group is also updated. This ensures that the modifications are
propagated when each new instance of the host group is added to the building model and also when each stand-alone
instance of the nested group is added.

Creating a Nested Group

In this exercise, you create a group for a toilet room that you add to the guest room group. The new group is then
nested within the original group, which acts as the host. When you nest the toilet room in the guest room, all instances
of the host group are updated to contain the nested group.

Dataset
Continue using the dataset saved at the end of the previous lesson, Grouping-in progress.rvt.
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Create a group

1 In the original instance of the Typical guest room group, select all the elements that make up the toilet
room and closet. In the selection, make sure you also include both doors and their host walls, and the wall
separating the bathroom and closet.

2 On the Edit toolbar, click  .

3 In the Project Browser, expand Groups, expand Model, right-click Group 1, and click Rename.

4 Enter Typical toilet room, and press ENTER.

Change the origin of a group

5 Select the original instance of Typical guest room.

6 Drag the origin of the group to the intersection of the corridor wall and the guest room wall nearest the
tub.

Create a nested group

7 On the Options Bar, click Edit Group.

8 On the Design Bar, click Add To Group.

The elements of the group are grayed out in every instance; everything else is available for selection.

9 On the Options Bar, verify that Multiple is clear.

10 In the drawing area, select the Typical toilet room group.

11 On the Design Bar, click Finish Group.
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The Typical toilet room group is nested in the Typical guest room group, and all instances are updated to
include the nested group.

12 On the File menu, click Save.

13 Proceed to the next exercise, “Modifying a Nested Group” on page 539.

Modifying a Nested Group

In this exercise, you add a component to a single instance of the nested toilet room group. When you edit the group
to add the component, all instances of the nested group are updated in the building model. Because the modified group
is nested, the host group is also updated so that new instances of either group contain the new component.

Dataset
Continue using the dataset saved at the end of the previous exercise, Grouping-in progress.rvt.

Add a component to the model

1 On the Basics tab of the Design Bar, click Component.

2 In the Type Selector, select i_Pedestal Sink-3D .

3 In the drawing area, place the cursor over one of the toilet rooms and press the spacebar three times to
rotate the sink to the orientation shown.

4 Place the sink on the wall with the toilet in any instance of the Typical toilet room.
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5 On the Design Bar, click Modify.

Edit a nested group

6 Move the cursor over the same instance of the toilet room group in which you placed the sink.

7 Press TAB, and select the nested toilet room group.

8 On the Options Bar, click Edit Group.

9 On the Design Bar, click Add To Group.

10 In the drawing area, select the sink.

11 On the Design Bar, click Finish Group.

All instances of the nested group are updated with the change.

12 On the File menu, click Save.

13 Proceed to the next lesson, “Working with Groups” on page 540.

Working with Groups
In this lesson, you work with groups in order to use them in the most efficient manner within and across projects. You
create a group based on an existing group by using the Duplicate command. You then customize the new group for
use in the current building model. You also create a detail group in the level 2 floor plan that you add to the building
model in a different floor plan view.
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In subsequent exercises, you add door tags to a group, and then save the tags as an attached detail group. You work
with the attached detail group in a different way than you had previously worked with host and nested groups, because
attached detail groups require more manual manipulation.

Lastly, having created a group that represents a typical layout, you save it to a library where it can be accessed by other
team members for use in other projects. When you load the group from the library into a new project, you can then
work with it in the context of the new project. You use functionality that allows you to not only fix inconsistencies
among instances of a group, but automatically create a new group as part of the process to fix the group.

Duplicating a Group

In this exercise, you use the Duplicate command to create a group based on an existing group. You then place the new
group in the building model, and customize it so that it fits in the available space and has the correct group nested
within it. After you finish the modified group, you draw an axis of reflection at the midpoint of the building model so
that the group is mirrored from its location at the top of the building model to a location at the bottom.

Dataset
Continue using the dataset saved at the end of the previous lesson, Grouping-in progress.rvt.

Use Project Browser to duplicate a group

1 In the Project Browser, under Groups, right-click Typical guest room, and click Duplicate.

A new group definition (Typical guest room 2) is displayed in the Project Browser.

2 Right-click Typical guest room 2, and click Rename.

3 Enter Corner guest room, and press ENTER.

Place a duplicated group

4 Drag Corner guest room from the Project Browser to the vacant room in the northwest corner of the
building.

5 Click at the upper-right corner of the room, where the corridor wall and the exterior wall intersect, to
specify the group origin.

6 On the Options Bar, click Finish.

7 After a warning message displays, click OK.

Notice that the desk overlaps the exterior wall. This is because the corner room is smaller than the interior
rooms.

Edit a duplicated group

8 In the drawing area, select the Corner guest room group.

9 On the Options Bar, click Edit Group.

10 Press and hold CTRL, and select the desk and chair.

11 On the Edit toolbar, click  .
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12 Move the desk and chair so that they are within the room.

13 On the Design Bar, click Remove From Group.

14 Select the toilet room.

15 On the Design Bar, click Finish Group.

16 Select the same toilet room group, and press DELETE.

Nest a group

17 In the Project Browser, select Corner toilet room, and drag it into the corner guest room.

Use the inside corner of the exterior wall and the corridor wall as the origin of the group.

18 On the Options Bar, click Finish to finish placing the group.

19 In the drawing area, select the Corner guest room group.

20 On the Options Bar, click Edit Group.

21 On the Design Bar, click Add To Group.

22 In the drawing area, select the Corner toilet room group.

23 On the Design Bar, click Finish Group.

TIP If a warning appears indicating that there are errors that cannot be ignored, click Unjoin Elements to resolve
the errors.

Mirror along a drawn axis of reflection

24 In the drawing area, select the Corner guest room group.

25 On the Edit toolbar, click  .

26 On the Options Bar, click  for Axis.

27 Click the midpoint of the corridor wall as the start point of the axis of reflection as shown.

TIP To help find the midpoint of the wall, enter SM on your keyboard to limit snaps to midpoints.
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28 Drag the cursor to the left, past the exterior wall, staying perpendicular to the corridor wall, and click to
specify the end point.

A new instance of the Corner guest room group is added to the southwest corner of the building model.

29 On the File menu, click Save.

30 Proceed to the next exercise, “Creating a Detail Group” on page 543.

Creating a Detail Group

In this exercise, you sketch and annotate a rectangular filled region that represents an area of tiled flooring in front of
the elevators in the building model. You then save the region and the text note as a detail group. You can add the
detail group to other views of the building model.

Dataset
Continue using the dataset saved at the end of the previous exercise, Grouping-in progress.rvt.

Draw a filled region

1 On the Drafting tab of the Design Bar, click Filled Region.

2 On the Options Bar, click  to draw a rectangular region.

3 Click the lower-left endpoint below the elevators as the start point of the rectangle.

4 Move the cursor down and to the right, and select a point on the interior of the vertical wall.

5 On the Design Bar, click Finish Sketch.
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A rectangular region with a diagonal cross hatch pattern is added in front of the elevator doors.

Add a text note

6 On the Drafting tab of the Design Bar, click Text.

7 On the Options Bar, click  to add an arc leader.

8 Click in the filled region to specify the leader start point.

9 Click below the filled region to end the leader and specify the text start point.

10 Enter Tile, and click Modify on the Design Bar.

The text note with arc leader is added to the building model.

Create a detail group

11 Press and hold CTRL, and select the note and the filled region.

12 On the Edit toolbar, click  .

13 In the Project Browser, expand Groups, and expand Detail.

14 Right-click Group 1, and click Rename.

15 Enter Elevator lobby tile, and press ENTER.

Modify a group origin

16 In the drawing area, select the instance of the Elevator lobby tile group.

17 Move the origin of the group to the corner of the elevator shaft, as shown.

Add a group instance to a different drawing view

18 In the Project Browser, under Floor Plans, double-click Level 3.

19 Drag an instance of the Elevator lobby tile group from the Project Browser into the level 3 view.
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20 On the File menu, click Save.

21 Proceed to the next exercise, “Using Attached Detail Groups” on page 545.

Using Attached Detail Groups

In this exercise, you add door tags to the Typical toilet room group, and then use the door tags to create an attached
detail group. Because the detail group contains variables, it cannot be added to a group in the same manner that a
drawing component can be added; you must manually attach it to each instance of the Typical toilet room group.

Dataset
Continue using the dataset saved at the end of the previous lesson, Grouping-in progress.rvt.

Place door tags

1 In the Project Browser, under Floor Plans, double-click Level 2.

2 On the Drafting tab of the Design Bar, click Tag ➤ By Catgeory.

3 On the Options Bar, clear Leader.

4 Place two door tags in the original instance of the Typical toilet room, as shown.

5 On the Design Bar, click Modify.

Create an attached detail group

6 In the drawing area, press and hold CTRL, and select the two door tags.

7 On the Edit toolbar, click  .

A warning dialog box is displayed, informing you that an attached detail group has been created for the
Typical toilet room group.

8 In the Project Browser, expand Groups, expand Attached Detail, and expand Typical toilet room.

9 Right-click Group 1, and click Rename.

10 Enter Door tags, and press ENTER.

Place a detail group in another group instance

11 Move the cursor over the Typical toilet room group, (this group is just below the original instance of the
Typical guest room group), press TAB, and select the nested Typical toilet room group.

12 On the Options Bar, click Place Detail.

13 In the Attached Detail Group Placement dialog box, select Door tags, and click OK.
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The new instance of the attached detail group is added at the same relative position and orientation as in
the original instance of the model group.

NOTE Component instance numbering is sequential; therefore, the doors are numbered based upon the order
in which you placed each group.

14 On the File menu, click Save.

15 Proceed to the next exercise, “Saving and Loading Groups” on page 546.

Saving and Loading Groups

In this exercise, you save a group to a library so that you can use the group in a new project. This enables you to create
a library of groups that can be shared with other team members and used on multiple projects. Using groups from a
library ensures consistency and increases productivity for projects that reuse similar typical layouts for repetitive units.

Dataset
Continue using the dataset saved at the end of the previous lesson, Grouping-in progress.rvt.

Save a group to a library

1 On the File menu, click Save to Library ➤ Save Group.

2 In the Save Group dialog box, select Typical toilet room for Group To Save.

NOTE Groups containing nested groups cannot be saved.

3 Click Save.

Load the group in a new project

4 On the File menu, click New ➤ Project.

■ In the New Project dialog box, under Template file, click Browse.

■ In the left pane of the Choose Template dialog box, click the Training Files icon.

■ Select the i_Tutorial_Default.rte file located in the Imperial folder, and click Open.

5 In the New Project dialog box, click OK.

6 On the File menu, click Load from Library ➤ Load Group.

7 In the Load Group dialog box, navigate to the directory where you saved the group, select Typical toilet
room.rvg, and click Open.

8 In the Duplicate Types dialog box, click OK.

A warning dialog box is displayed, explaining that duplicate types were renamed to avoid conflicts in the
project. Close the warning dialog box.
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Sketch walls

9 On the Architectural tab of the Design Bar, click Wall.

10 On the Options Bar, click  to draw a square.

11 In the drawing area, click to specify the start point of the square, and then drag the cursor so that all the
walls in the square are 20' long.

Place an instance of the loaded group

12 In the Project Browser, expand Groups, and expand Model.

13 Select Typical toilet room, drag it into the drawing area, and place it in the upper-right corner of the square,
as shown.

IMPORTANT Be sure to line up the outline of the group with the exterior surface of the walls. The toilet and
the tub are wall-hosted components whose hosts are not part of the group, so it is important to place the group
accurately in order to use the walls you sketched.

14 On the Options Bar, click Finish.

The Typical toilet room model group is added to the new project.

15 On the File menu, click Save.

16 Enter Loaded_Group for File name, and click Save.

17 Proceed to the next exercise, “Automatically Creating a Group” on page 547.

Automatically Creating a Group

In this exercise, you mirror the instance of the Typical toilet room group you added to the new project in the previous
exercise. Because one of the wall-hosted components in the group does not have a wall in the mirrored group, the
software gives you the option of fixing the inconsistency by creating a new group. The new group is created automatically
and contains the same components as the existing group, except for the wall-hosted component for which there is no
wall.

Dataset
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Continue using the dataset saved at the end of the previous exercise, Loaded_Group.

1 In the drawing area, select the instance of Typical toilet room.

2 On the Edit toolbar, click  .

3 Select the wall shared by the toilet and the sink as the axis of reflection.

Because there is no wall to host the tub in the mirrored instance, a warning dialog box is displayed.

4 In the warning dialog box, click Fix Groups.

5 In the Fix Inconsistent Groups dialog box, click Create new group types, and click OK.

6 On the Design Bar, click Modify.

The Typical toilet room model group is mirrored, and a new group (Typical toilet room 2) is created. The
tub component is not included in the new group because there is no wall to host it.

7 On the File menu, click Close. Click Yes when prompted to save the drawing.
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